• RELEVANCY SCORE 5.39

    DB:5.39:Dbi Perl Mod d7







    A client could need that DBI perl mod be installed on our server, would this be any problem ?

    I havnt heard of this mod before, have any of you heard of it, and if so will it cause any problems on plesk ?

    Thanks,
    Glenn

    DB:5.39:Dbi Perl Mod d7




    I have 3 servers with RH7.2 and psa 5.0.2 rpm running that module and I have not had any problems.(just thought I would let you know that)......Briman

  • RELEVANCY SCORE 3.99

    DB:3.99:Perl Module Dbi For Mysql 77







    some of our clients needed the Perl module DBI for Mysql.
    Is it possible to install this modul on server, without damaging the PSA?

    more details about the Perl module DBI can be find here
    http://www.lynxafrica.demon.co.uk/dbi/index.html

    DB:3.99:Perl Module Dbi For Mysql 77




    Re: Newbie needs help



    Originally posted by avimagic
    I need to install DBI module. I downloaded the files provided here, but Im new at this and dont want to screw anything up on my server.

    Does anyone have a step-by-step guide to installing a perl module on my server?

    Thanks

  • RELEVANCY SCORE 3.86

    DB:3.86:Dbi Module Version For Active Perl 5.6.1 f7




    Hi
    I have installed Active PERL 5.6.1
    I have installed oracle 10g.
    But when I am running perl scripts with the line "use DBI",
    This is giving an error "Can't locate loadable object for module DBI in @INC (@INC contains: C:\oracle\pr
    oduct\10.1.0\db_4\perl\lib\5.6.1\MSWin32-x86 C:\oracle\product\10.1.0\db_4\perl\
    lib\5.6.1 C:\oracle\product\10.1.0\db_4\perl\5.6.1\lib\MSWin32-x86 C:\oracle\pro
    duct\10.1.0\db_4\perl\site\5.6.1 C:\oracle\product\10.1.0\db_4\perl\site\5.6.1\l
    ib C:\oracle\product\10.1.0\db_4\sysman\admin\scripts C:/Perl/lib C:/Perl/site/l
    ib .) at C:\oracle\product\10.1.0\db_4\perl\site\5.6.1\lib/DBI.pm line 189
    BEGIN failed--compilation aborted at C:\oracle\product\10.1.0\db_4\perl\site\5.6
    .1\lib/DBI.pm line 189.
    Compilation failed in require at select1.pl line 3.
    BEGIN failed--compilation aborted at select1.pl line 3."

    The perl code is :-
    #!/usr/local/bin/perl

    use DBI;

    ...............

    The error clearly says that DBI module needs to be installed.
    I want to know the DBI module version for Active PERL 5.6.1,and the path from where I can downloaded.
    I also want the path for the DBD::Oracle module

    Thanks in Advance,
    Bannu

    DB:3.86:Dbi Module Version For Active Perl 5.6.1 f7

    Check your environment variables... I'm pretty sure Oracle 10g adds a reference to it's own version of perl. You might have to rearrange a few things. I can check tomorrow when I get to work and log on to my Windows box.

    ~Jer

  • RELEVANCY SCORE 3.86

    DB:3.86:Error When Using Perl Dbd::Maxdb 8f



    Hello ,

    i get an error when selecting data from MaxDB with perl dbi , DBD::MaxDB

    Whats wrong in the following field description '' AS no_data_returned

    The statement is correct when i tried it in Database Studio.

    The script runs on SLES

    Linux hostname 3.0.101-0.15-default #1 SMP Wed Jan 22 15:49:03 UTC 2014 (5c01f4e) x86_64 x86_64 x86_64 GNU/Linux

    This is perl, v5.10.0 built for x86_64-linux-thread-multi

    perl-DBI-1.607-1.16

    perl-DBD-MaxDB-7.7.05.00-1

    # -- error in DBD::MaxDB, because of Null Pointer exception

    $sth = $dbh-prepare( "SELECT '' as no_data_returned from dual" ) or die "Can't prepare statement $DBI::err $DBI::errstrn";

    $res = $sth-execute() or die "Can't execute statement $DBI::err $DBI::errstrn";

    while ( my @row = $sth-fetchrow_array )

    {

    print "Data:[" .join( ", ", @row) ."]\n" if $dbg ;

    }

    # -- part of dbitrace

    ...!! ERROR: -10305 'Parameter (1) contains null pointer' (err#0)

    !! ERROR: -10305 CLEARED by call to prepare method

    ...

    Best regards

    Arnd

    DB:3.86:Error When Using Perl Dbd::Maxdb 8f


    Hello ,

    i get an error when selecting data from MaxDB with perl dbi , DBD::MaxDB

    Whats wrong in the following field description '' AS no_data_returned

    The statement is correct when i tried it in Database Studio.

    The script runs on SLES

    Linux hostname 3.0.101-0.15-default #1 SMP Wed Jan 22 15:49:03 UTC 2014 (5c01f4e) x86_64 x86_64 x86_64 GNU/Linux

    This is perl, v5.10.0 built for x86_64-linux-thread-multi

    perl-DBI-1.607-1.16

    perl-DBD-MaxDB-7.7.05.00-1

    # -- error in DBD::MaxDB, because of Null Pointer exception

    $sth = $dbh-prepare( "SELECT '' as no_data_returned from dual" ) or die "Can't prepare statement $DBI::err $DBI::errstrn";

    $res = $sth-execute() or die "Can't execute statement $DBI::err $DBI::errstrn";

    while ( my @row = $sth-fetchrow_array )

    {

    print "Data:[" .join( ", ", @row) ."]\n" if $dbg ;

    }

    # -- part of dbitrace

    ...!! ERROR: -10305 'Parameter (1) contains null pointer' (err#0)

    !! ERROR: -10305 CLEARED by call to prepare method

    ...

    Best regards

    Arnd

  • RELEVANCY SCORE 3.65

    DB:3.65:Need Help With Perl &Amp; Dbd-Oracle On Redhat 1f


    Hi,

    I have Oracle 8.1.5, Redhat 6.1, and Perl 5.005_3. I have DBI 1.13, and DBD-Oracle 1.03.

    I want to install as LITTLE of Oracle as possible on my web server to get it so that Perl can see an Oracle DB which is running on a second computer.

    When trying to compile DBD-Oracle 1.03 I get the error that it can't find oratypes.h, ocidfn.h and ociapr.h.

    What must I do to get it to work? I am quite stuck.

    Thanks

    From
    Paul

    DB:3.65:Need Help With Perl &Amp; Dbd-Oracle On Redhat 1f

    Hi ,

    I am trying to install Oracle DBD driver 1.12 on red hat
    linux 6.2, to connect to oracel database through perl.

    I had DBI 1.18, on which I installed DBI 1.20.
    while creating Makefile( i.e. perl Makefile.PL) , It ask for
    oracle.mk and proc.mk which are not available in my clients.

    Where will I get these files and how do I proceed for the
    installation?

    reply awaiting ....

    Bharat

  • RELEVANCY SCORE 3.62

    DB:3.62:Oci Memory Leak dd


    Hello,

    I use Oracle with perl 5.8.0, DBI 1.35 and DBD::Oracle
    1.14 to run a script that fill my database with external
    data
    Everything was running fine with Oracle 8.1.7

    With 9.2.0.1, and the same perl, DBI and DBD::Oracle
    version, the perl process memory is growing until an "out
    of memory" error.
    so I made a little test where I only open a connection,
    enter a loop that make a commit without any transaction,
    end the loop and close the connection. And the perl
    process memory continue to furiously grow !

    I tested the same script with 8.1.7, but there were no
    memory increase

    Could someone give me a clue that could allow me to use
    9.2.0.1?

    thanks

    Pierre

    DB:3.62:Oci Memory Leak dd

    Problem solved
    updgrade to 9.2.0.3

    thanks for your non answer

  • RELEVANCY SCORE 3.59

    DB:3.59:Intermittent Ora-12154 Using Perl Dbi m9


    Hey,

    I'm trying to debug an app we have that uses Perl to connect to
    an 8.1.7 database.

    Works fine 95% of the time, but every so often we get an
    ORA-12154 error. This just started a few weeks ago, and no-one
    seems to know of any changes to the systems.

    Anyone run into something similar? Here's the error we get.

    DBI-connect(PDIQ) failed: ORA-12154: TNS:could not resolve
    service name (DBD ERROR: OCIServerAttach)

    DB:3.59:Intermittent Ora-12154 Using Perl Dbi m9

    is the database running MTS or dedicated servers.

  • RELEVANCY SCORE 3.59

    DB:3.59:Mysql Perl Dbi z1


    Dear Wise Powerful Masters of OS X,

    I had written a large number of perl scripts that passed information back forth to MySQL. Then my disk drive wore out broke down`;'^(

    What is the best way to restore the DBI(Data Base Interface)between MySQL perl? So far I get:

    $perl new.pl
    install_driver(mysql) failed: Can't find 'bootDBD_mysql' symbol in /opt/local/lib/perl5/site_perl/5.8.8/darwin-2level/auto/DBD/mysql/mysql.bundle
    at (eval 4) line 3
    Compilation failed in require at (eval 4) line 3.

    at new.pl line 143
    $

    Thank you for your kind wisdom.

    Your humble unix geek,

    Kurt

    DB:3.59:Mysql Perl Dbi z1

    Dear Wise Powerful Masters of OS X,

    I had written a large number of perl scripts that passed information back forth to MySQL. Then my disk drive wore out broke down`;'^(

    What is the best way to restore the DBI(Data Base Interface)between MySQL perl? So far I get:

    $perl new.pl
    install_driver(mysql) failed: Can't find 'bootDBD_mysql' symbol in /opt/local/lib/perl5/site_perl/5.8.8/darwin-2level/auto/DBD/mysql/mysql.bundle
    at (eval 4) line 3
    Compilation failed in require at (eval 4) line 3.

    at new.pl line 143
    $

    Thank you for your kind wisdom.

    Your humble unix geek,

    Kurt

  • RELEVANCY SCORE 3.59

    DB:3.59:Dbi And Apache Powered By Oracle z3


    I have created some programs in Perl to connect to database and they work fine on the Apache server installed from rpm, but if I have moved this code under Oracle-Apache server the script fails. Has somebody looked it that problem or know where I can found info how to configure DBI under Apache from Oracle package.

    DB:3.59:Dbi And Apache Powered By Oracle z3

    I seem to be having the same problem using perl DBI. Short of obtaining cl (compiler) and compiling DBI from it's module source, is there anything that can be done to make DBI and DBD::Oracle available to perl?

    Thanks for the assistance.

    -Mike

  • RELEVANCY SCORE 3.48

    DB:3.48:Dbi Connect Error fa


    I get the following err msg when I try to connect to
    Oracle 9.2.0 using perl 5.6.1 / DBI 1.21.
    Iam using Oracle client 8.1.5 (ORACLE_HOME is pointing to 8.1.5) and the platform is SunOS 5.5.1.

    ORA-03113: end-of-file on communication channel (DBD: login failed)

    Appreciate your help.

    DB:3.48:Dbi Connect Error fa

    Hi Prabakar,

    It's normal, u have tio put ORACLE_HOME to 9i for the 9i server and ORACLE_HOME to 8i to the 8i server.

    If u put ORACLE_HOME to 8i with the 9i server, it will use the 8i binary files to connect to a 9i database and it cant work...

    Fred

  • RELEVANCY SCORE 3.40

    DB:3.40:Re:Installing Perl Dbi kj


    Hi Atul,
    I already had the DYLD path setup - although that's exactly what I'd expect to cure the problem under other unixes, it doens't appear to work the same way with Darwin.
    I used the CPAN::shell to build/install the modules.
    d.

    su-2.05a$ id; echo $DYLD_LIBRARY_PATH; echo $ORACLE_HOME; perl -e 'use DBI; $dbh = DBI-connect ("dbi:Oracle:O0006", "denty", "xxxxxx");'
    uid=502(oracle) gid=20(staff) groups=20(staff), 100(dba)
    /opt/u01/oracle/app/product/9.0.2.0.1/lib:/opt/u01/oracle/app/product/9.0.2.0.1/rdbms/lib:
    /opt/u01/oracle/app/product/9.0.2.0.1
    dyld: perl Undefined symbols:
    _OCIAttrGet
    _OCIAttrSet
    ...

    DB:3.40:Re:Installing Perl Dbi kj

    Tom Mornini posted in perl.dbi.users the way to do this successfull with perl 5.8. if you search the newsgroup using deja news you can find it. i found it at:

    http://groups.google.com/groups?hl=enlr=ie=UTF-8selm=400FBBA7-FE88-11D6-A100-00306546AE4A%40infomania.com

    works well for me.

    jim

  • RELEVANCY SCORE 3.40

    DB:3.40:Perl/Cgi Problem sp





    My web server doesnt run perl codes and only returns source code as a text file.
    I have enables the cgi support for all domains and even mod-perl support.
    Any idea? my php files are running without problem or settings.please help.
    thanks
    -Reza

    DB:3.40:Perl/Cgi Problem sp




    addhanler cgi

    found the solution here and thank you myself!
    http://www.sw-soft.com/ru/products/psa/faq/cgi/
    -Reza

  • RELEVANCY SCORE 3.40

    DB:3.40:Perl, Dbi Or Mod_Perl 1x





    We have a web applictation that runs with DBI and Mysql. I have got the correct perl modules installed and the perl file are working great.

    But.

    If if I use our system it works for a bit then our scripts start bombing out with the foolowing error msg: Cant call method prepare on an undefined value.

    now the weird thing is that the prepare statment is used on all the pages and now why does it suddely bomb out.

    If anyone has any answers or sugestions would be helpful.

    thanking u in advance.

    Ryan

    DB:3.40:Perl, Dbi Or Mod_Perl 1x




    We have a web applictation that runs with DBI and Mysql. I have got the correct perl modules installed and the perl file are working great.

    But.

    If if I use our system it works for a bit then our scripts start bombing out with the foolowing error msg: Cant call method prepare on an undefined value.

    now the weird thing is that the prepare statment is used on all the pages and now why does it suddely bomb out.

    If anyone has any answers or sugestions would be helpful.

    thanking u in advance.

    Ryan

  • RELEVANCY SCORE 3.39

    DB:3.39:Dbi Connect('Ar System Odbc Data Source', 'Username','Password'...) Failed 1s



    #!C:\Perl\bin\perl

    use DBI;

    use strict;

    use DBI;

    my @dsns = DBI-data_sources('ODBC');

    my $dbh = DBI-connect("dbi:ODBC:AR System ODBC Data Source", "username", "password",{RaiseError=1}) or die "Could not connect to the Remedy database, please contact the server admisitrator if the problem persists";

    ------------------------------------------------------

    When execute above code, following error is reported:

    "DBI connect('AR System ODBC Data Source', 'username','password'...) failed: Unable to fetch information about the at line 7.."

    This Perl code tries to make a connection to ARS database server directly through ODBC driver. I have created a DSN in ODBC data source with AR Server set as the hostname of AR Server, which can be pinged successfully. However, above code never works. Any help?

    DB:3.39:Dbi Connect('Ar System Odbc Data Source', 'Username','Password'...) Failed 1s


    #!C:\Perl\bin\perl

    use DBI;

    use strict;

    use DBI;

    my @dsns = DBI-data_sources('ODBC');

    my $dbh = DBI-connect("dbi:ODBC:AR System ODBC Data Source", "username", "password",{RaiseError=1}) or die "Could not connect to the Remedy database, please contact the server admisitrator if the problem persists";

    ------------------------------------------------------

    When execute above code, following error is reported:

    "DBI connect('AR System ODBC Data Source', 'username','password'...) failed: Unable to fetch information about the at line 7.."

    This Perl code tries to make a connection to ARS database server directly through ODBC driver. I have created a DSN in ODBC data source with AR Server set as the hostname of AR Server, which can be pinged successfully. However, above code never works. Any help?

  • RELEVANCY SCORE 3.37

    DB:3.37:How To Install Perl Lib Without Make? j7


    Hi, I know that to install perl libs, php, mysql I need install first Developer tool to have a make. But my preview experience was not good. The system become runs slowly, even if I uninstall Developer tool after compiling the sources.

    Now, I reinstall system and found already compiled php, mysql and they works prefect by only 2 more things left, DB and DBI libs for perl and ImageMagick.

    Is it possible to install them without installing Developer tool?

    eMAc Mac OS X (10.4.9)

    DB:3.37:How To Install Perl Lib Without Make? j7

    Hi, I know that to install perl libs, php, mysql I need install first Developer tool to have a make. But my preview experience was not good. The system become runs slowly, even if I uninstall Developer tool after compiling the sources.

    Now, I reinstall system and found already compiled php, mysql and they works prefect by only 2 more things left, DB and DBI libs for perl and ImageMagick.

    Is it possible to install them without installing Developer tool?

    eMAc Mac OS X (10.4.9)

  • RELEVANCY SCORE 3.36

    DB:3.36:Any Issues Installing Following Perl Modules? a3





    perl-DBI-1.14-10 perl-DBD-MySQL-1.2215-1

    I am running redhat 7.1 and plesk 5.04.
    A client has asked me to install the rpms and I want to make sure the installation of these modules wont affect MySQL or the Plesk admin in any way.
    Can someone please provide some feedback?
    Thanks

    DB:3.36:Any Issues Installing Following Perl Modules? a3




    RPMs from rpmfind often dont install quite the same way that RPMs from Red Hat do - paths are often different which is very likely why you had to create the symlinks. I installed from Red Hat RPMs and didnt have to do that. But now that thats done, you shouldn;t have any problems using the modules.

  • RELEVANCY SCORE 3.34

    DB:3.34:Mod Perl Dbd::Oracle Driver f8


    Hi.

    I have installed Oracle 8i client on a linux machine running red hat 6.2. It is also running Mod Perl 5.00513 and the latest version of apache.

    I have installed DBI from cpan and I am trying to install the DBD::Oracle driver for DBI to connect to an Oracle server on the my network.

    The problem I am having is that I cannot install DBD::Oracle. I keep getting an error message when I do a make test informing me that there are some Oracle libraries missing. I have installed everything and I keep getting this error.

    The files that are missing are:

    /Oracle-Home/rdbms/lib/libskgxpd..a
    /Oracle-Home/rdbms/lib/libskgxpu..a
    /Oracle-Home/rdbms/lib/libskgxpt..a

    Has anyone had any similar problems and got a fix for it? Or does anyone know where I can get the missing libs from?

    Any help would be greatly appreciated

    Thanks

    ifrawley@acquist.co.uk
    null

    DB:3.34:Mod Perl Dbd::Oracle Driver f8

    Not quite the same as your problem.
    I coudn't get DBD-Oracle 1.05 or 1.06 to work (1.03 was OK!) without adding $ORACLE_HOME/lib to the file /etc/ld.so.conf and the running ldconfig.
    Note that errors from ldconfig are caused if old libs i.e. pre are left over from Oracle upgrades.

    Worth a try as this worked for me.

  • RELEVANCY SCORE 3.28

    DB:3.28:Dbd::Oracle "Make Test" Failed On Linux Suse 5.3 m3


    --
    Hi,

    I Can't build the DBD::Oracle on Linux Suse 5.3.
    Sqlplus work fine, i can connect to a remote Oracle db.

    I use :

    DBD-Oracle-0.59
    DBI-1.06
    perl5.005_02
    Oracle 8.0.5 (patch1,patch2)
    Suse 5.3 (opatch.rpm)

    My env. for Oracle 8 for "make test"

    LD_RUN_PATH= /opt/oracle/8.0.5/lib
    ORACLE_BASE = /opt/oracle
    ORACLE_HOME = /opt/oracle/8.0.5
    ORACLE_SID = orcl
    ORACLE_TERM = vt100
    ORACLE_USERID = scott/tiger

    I describe all (DBI and DBD) install sequence :

    1. DBI 1.06 "make test" OK and installed
    /usr/lib/perl5/site_perl/i586-linux/auto/DBI

    2. DBD Oracle 0.59

    - /root/install/perl/module/DBD-Oracle-0.59/perl Makefile.pl
    -- cut perlMakefile.pl.log ---

    ???? Note (probably harmless): No library found for -lnsl ???
    Using DBI 1.06 installed in
    /usr/lib/perl5/site_perl/i586-linux/auto/DBI

    Configuring DBD::Oracle ...
    [...]
    Checking if your kit is complete...
    Looks good
    [...]
    Using DBD::Oracle 0.59.
    Using DBI 1.06 installed in
    /usr/lib/perl5/site_perl/i586-linux/auto/DBI

    Writing Makefile for DBD::Oracle
    -- end cut --------------

    - make
    -- cut make.log ---
    mkdir ./blib
    [...]
    LD_RUN_PATH="/opt/oracle/8.0.5/lib:/lib" cc -o
    blib/arch/auto/DBD/Oracle/Oracle.so (OK)
    [...]
    "MY-fixin(shift)" ./blib/script/ora_explain
    -- end cut -------

    - /root/install/perl/module/DBD-Oracle-0.59/make test
    -- cut of maketest.log -----
    PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
    -I/usr/lib/perl5/5.00502/i586-linux -I/usr/lib/perl5/5.00502 -e
    'use
    Test::Harness qw(runtests $verbose); $verbose=1; runtests
    @ARGV;' t/*.t

    t/base..............dubious
    Test returned status 0 (wstat 11, 0xb)
    t/general...........dubious
    Test returned status 0 (wstat 11, 0xb)
    t/plsql.............dubious
    Test returned status 0 (wstat 11, 0xb)
    FAILED--3 test scripts could be run, alas--no output ever seen
    make: *** [test_dynamic] Error 2
    ---end cut -------

    -/root/install/perl/module/DBD-Oracle-0.59/ make test
    TEST_VERBOSE=1
    idem. "make test"

    Thanks for all the help.

    Georges.
    null

    DB:3.28:Dbd::Oracle "Make Test" Failed On Linux Suse 5.3 m3

    --
    My install failed make test, but worked on make all. In other
    words, the fact that it failed did not prevent me from
    installing and running the DBI modules.

    Georges Dewez (guest) wrote:
    : Hi,
    : I Can't build the DBD::Oracle on Linux Suse 5.3.
    : Sqlplus work fine, i can connect to a remote Oracle db.
    : I use :
    : DBD-Oracle-0.59
    : DBI-1.06
    : perl5.005_02
    : Oracle 8.0.5 (patch1,patch2)
    : Suse 5.3 (opatch.rpm)
    : My env. for Oracle 8 for "make test"
    : LD_RUN_PATH= /opt/oracle/8.0.5/lib
    : ORACLE_BASE = /opt/oracle
    : ORACLE_HOME = /opt/oracle/8.0.5
    : ORACLE_SID = orcl
    : ORACLE_TERM = vt100
    : ORACLE_USERID = scott/tiger
    : I describe all (DBI and DBD) install sequence :
    : 1. DBI 1.06 "make test" OK and installed
    : /usr/lib/perl5/site_perl/i586-linux/auto/DBI
    : 2. DBD Oracle 0.59
    : - /root/install/perl/module/DBD-Oracle-0.59/perl Makefile.pl
    : -- cut perlMakefile.pl.log ---
    : ???? Note (probably harmless): No library found for -lnsl ???
    : Using DBI 1.06 installed in
    : /usr/lib/perl5/site_perl/i586-linux/auto/DBI
    : Configuring DBD::Oracle ...
    : [...]
    : Checking if your kit is complete...
    : Looks good
    : [...]
    : Using DBD::Oracle 0.59.
    : Using DBI 1.06 installed in
    : /usr/lib/perl5/site_perl/i586-linux/auto/DBI
    : Writing Makefile for DBD::Oracle
    : -- end cut --------------
    : - make
    : -- cut make.log ---
    : mkdir ./blib
    : [...]
    : LD_RUN_PATH="/opt/oracle/8.0.5/lib:/lib" cc -o
    : blib/arch/auto/DBD/Oracle/Oracle.so (OK)
    : [...]
    : "MY-fixin(shift)" ./blib/script/ora_explain
    : -- end cut -------
    : - /root/install/perl/module/DBD-Oracle-0.59/make test
    : -- cut of maketest.log -----
    : PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
    : -I/usr/lib/perl5/5.00502/i586-linux -I/usr/lib/perl5/5.00502 -e
    : 'use
    : Test::Harness qw(runtests $verbose); $verbose=1; runtests
    : @ARGV;' t/*.t
    : t/base..............dubious
    : Test returned status 0 (wstat 11, 0xb)
    : t/general...........dubious
    : Test returned status 0 (wstat 11, 0xb)
    : t/plsql.............dubious
    : Test returned status 0 (wstat 11, 0xb)
    : FAILED--3 test scripts could be run, alas--no output ever seen
    : make: *** [test_dynamic] Error 2
    : ---end cut -------
    : -/root/install/perl/module/DBD-Oracle-0.59/ make test
    : TEST_VERBOSE=1
    : idem. "make test"
    : Thanks for all the help.
    : Georges.
    null

  • RELEVANCY SCORE 3.28

    DB:3.28:Personal Oracle For Web Backend? 1d


    I'm thinking of using personal oracle for a website's backend much as you would MySQL.

    Is personal oracle threaded so that multiple users can use it?

    Can you attach personal oracle to a remote oracle database via ODBC?

    Can you use perl DBI?

    Is it fast enough?

    TIA,

    - Jim
    null

    DB:3.28:Personal Oracle For Web Backend? 1d

    I'm thinking of using personal oracle for a website's backend much as you would MySQL.

    Is personal oracle threaded so that multiple users can use it?

    Can you attach personal oracle to a remote oracle database via ODBC?

    Can you use perl DBI?

    Is it fast enough?

    TIA,

    - Jim
    null

  • RELEVANCY SCORE 3.28

    DB:3.28:Perl Dbi Module pf


    All,

    I have a strange behaviour of my perl program.
    The perl program communicates through TCP/IP to another server.
    A text based protocol has been established to communicate with the other server.
    But after a while it seems that the other party is sending me the entire Oracle Errors making my program to crash.

    The processing is done by types and type body members, this creates some objects and after each processing I do a DBMS_SESSION.FREE_UNUSED_USER_MEMORY to clear up some memory.
    I do this because I think it is a memory leak in the type body usage.

    Since the perl program is multithreaded, for each thread a connection is being made (DBI module does not support the connection to be passed to several threads).

    My questions:
    - has anyone encountered this issue?
    - how come the entire oracle error collection is being displayed in my log file instead of a single message.

    DB:3.28:Perl Dbi Module pf

    All,

    I have a strange behaviour of my perl program.
    The perl program communicates through TCP/IP to another server.
    A text based protocol has been established to communicate with the other server.
    But after a while it seems that the other party is sending me the entire Oracle Errors making my program to crash.

    The processing is done by types and type body members, this creates some objects and after each processing I do a DBMS_SESSION.FREE_UNUSED_USER_MEMORY to clear up some memory.
    I do this because I think it is a memory leak in the type body usage.

    Since the perl program is multithreaded, for each thread a connection is being made (DBI module does not support the connection to be passed to several threads).

    My questions:
    - has anyone encountered this issue?
    - how come the entire oracle error collection is being displayed in my log file instead of a single message.

  • RELEVANCY SCORE 3.28

    DB:3.28:Perl ≪-≫ Xmldb Sample Code? k3


    Where can I get information on accessing XML DB with Perl? I can issue SQL through DBI, but am new to XML DB so I was hoping there'd be at least some sample code, if not an XMLDB-specific module.

    - Mark.

    DB:3.28:Perl ≪-≫ Xmldb Sample Code? k3

    That's a new one on me I'm afraid.. Hopefully someone else out there has some ideas on how this might work.

    Are you wanting to store and retieve XML from pearl, in which case you may be able to use HTTP or FTP to access documents in the repository. I've no idea how DBI works, but in general if you can execute a SQL statement from Pearl you should be able to execture a SQL statement that queries XML. I'm not sure how you would 'bind' an XML into pearl, or even if that is an issue, but if it is an issue you can always call .getClobVal() on the XML to get a CLOB

  • RELEVANCY SCORE 3.28

    DB:3.28:Oracle 8 + Perl Dbi 8c


    Has anybody successfully used Oracle 8 with the perl DBI over the web?

    I'm interested in finding out what sort of performance you get compared with running OAS?

    What problems (if any) were encountered along the way?

    DB:3.28:Oracle 8 + Perl Dbi 8c

    For an example of Perl / DBI over the web,
    visit http://www.oracletool.com

  • RELEVANCY SCORE 3.27

    DB:3.27:[Solved] Cpan: Segmentation Fault m7



    HiCpan seems to be broken since the last update. It gives Segmentation fault.It also happens when I use the DBI package in perl.

    Last edited by TheChosenOne (2014-06-30 17:34:14)

    DB:3.27:[Solved] Cpan: Segmentation Fault m7


    Thanks! I had to delete everything under /usr/lib/perl5/site_perl.

  • RELEVANCY SCORE 3.25

    DB:3.25:Perl Dbi And Dbd For Oracle 8i ax


    Trying (and failing) to find downloads for Perl DBI abd DBD for Linux Redhat on Oracle 8i. Nothing on Redhat.com, Perl.com or Oracle.com. Any ideas ? Thanks in Advance.

  • RELEVANCY SCORE 3.22

    DB:3.22:Perl Dbi For Oracle s8


    Hi all,
    I want to create and manipulate databases and tables in Oracle 10g XE R2 with perl DBI-1.607
    Can someone help me please with some documentation, I really need it
    I already red the DBI perl documentation but it was not sufficient

    thank you in advance

    DB:3.22:Perl Dbi For Oracle s8

    Hi,

    I will do my best to send you all what I have about Perl-DBI during the week-end.

    Regards

  • RELEVANCY SCORE 3.18

    DB:3.18:Reading Long Raw Using Perl fj


    I am reading long raw (document .doc) usig DBI (perl) from Oracle db 8.1.7
    How do I retrieve the document using perl so I can display them on the web?
    Thank you
    Dario

    DB:3.18:Reading Long Raw Using Perl fj

    Hi,
    I am faceing the same problem,
    that I need to save the long raw containing file to unix file folder.
    Have you done it?
    I would be grateful if you can share your with me.

    -Jasper

  • RELEVANCY SCORE 3.17

    DB:3.17:Connecting Form Perl To Mysql 88


    Hy,
    I've installed a MySQL Database on my Mac and want to connect from Perl to MySQL, but always when I try this, there comes an error message, that the DBI-Module is missing. Where can I find it and how do I install it? Do I need a DBD-Module also? Do I have to use the Terminal? scary

    Thanks a lot,
    Mo

    DB:3.17:Connecting Form Perl To Mysql 88

    Hy,
    I've installed a MySQL Database on my Mac and want to connect from Perl to MySQL, but always when I try this, there comes an error message, that the DBI-Module is missing. Where can I find it and how do I install it? Do I need a DBD-Module also? Do I have to use the Terminal? scary

    Thanks a lot,
    Mo

  • RELEVANCY SCORE 3.17

    DB:3.17:Perl Dbd::Oracle Nclob Problem: Ora-24806 zk


    Hello,

    my Perl script uses uses the DBI interface to connect to Oracle and runs a select statement. But if one column is of type NCLOB it fails with:

    DBD::Oracle::st fetchrow_hashref failed: ORA-24806: LOB form mismatch (DBD ERROR: OCILobRead) [for Statement "SELECT * FROM ttt WHERE ROWNUM=1"]

    I googled a lot and didn't found any solution for it. According to the used versions of Perl, DBI and Oracle and the NLS settings it should work.

    Any idea how to get it working?

    Here are my used versions:

    DBI::VERSION = "1.41"
    perl, v5.8.0

    SQL desc ttt
    Name Null? Type
    ----------------------------------------- -------- ----------------------------
    T1 NCLOB
    UMSISDN VARCHAR2(200 CHAR)
    SPARTID NUMBER(2)

    bash-3.00$ env | grep -i nls
    NLS_LANG=AMERICAN_AMERICA.UTF8
    NLSPATH=:/export/home/omni/locale/%L/%N.cat:/export/home/omni/locale/%L/%N

    Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bit Production

    much thanks,
    yoyo

    DB:3.17:Perl Dbd::Oracle Nclob Problem: Ora-24806 zk

    Hello,

    my Perl script uses uses the DBI interface to connect to Oracle and runs a select statement. But if one column is of type NCLOB it fails with:

    DBD::Oracle::st fetchrow_hashref failed: ORA-24806: LOB form mismatch (DBD ERROR: OCILobRead) [for Statement "SELECT * FROM ttt WHERE ROWNUM=1"]

    I googled a lot and didn't found any solution for it. According to the used versions of Perl, DBI and Oracle and the NLS settings it should work.

    Any idea how to get it working?

    Here are my used versions:

    DBI::VERSION = "1.41"
    perl, v5.8.0

    SQL desc ttt
    Name Null? Type
    ----------------------------------------- -------- ----------------------------
    T1 NCLOB
    UMSISDN VARCHAR2(200 CHAR)
    SPARTID NUMBER(2)

    bash-3.00$ env | grep -i nls
    NLS_LANG=AMERICAN_AMERICA.UTF8
    NLSPATH=:/export/home/omni/locale/%L/%N.cat:/export/home/omni/locale/%L/%N

    Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bit Production

    much thanks,
    yoyo

  • RELEVANCY SCORE 3.17

    DB:3.17:Problem In Running Perl Script Through Oracle pm


    Hi,
    I am facing one problem in perl script.

    " I have one perl script which is interact with sybase database.We have migrated the sybase database to oracle successfully.Now i wanna to change the perl script to interact with oracle database.
    I am using the code like that for interacting the oracle database

    Old Code with sybase database : use DBI::Sybase::GFAS;
    New code with oracle database : Use DBI::oracle::GFAS;

    When i am running the perl script,Its showing the below mentioned error:

    Can't locate DBI/oracle.pm in @INC (@INC contains: C:\oracle\product\10.2.0\db_1
    \perl\5.8.3\lib\MSWin32-x86 C:\oracle\product\10.2.0\db_1\perl\5.8.3\lib/MSWin32
    -x86-multi-thread C:\oracle\product\10.2.0\db_1\perl\5.8.3\lib C:\oracle\product
    \10.2.0\db_1\perl\5.8.3\lib\MSWin32-x86 C:\oracle\product\10.2.0\db_1\perl\site\
    5.8.3 C:\oracle\product\10.2.0\db_1\perl\site\5.8.3\lib/MSWin32-x86-multi-thread
    C:\oracle\product\10.2.0\db_1\perl\site\5.8.3\lib C:\oracle\product\10.2.0\db_1
    \sysman\admin\scripts C:/Perl/lib C:/Perl/site/lib .) at hello.pl line 4.
    BEGIN failed--compilation aborted at hello.pl line 4.

    Anyone have any idea about this error.

    Thx in advance.

    DB:3.17:Problem In Running Perl Script Through Oracle pm

    Hi DBA_in_Scotland,

    Using the DBI and DBD from ORACLE_HOME is possible when the Perl script is running on the same machine as DB installation.
    If that is not the case and perl client is running on different machine than Oracle DB, what is the best way to go about?

    Thanks in advance

  • RELEVANCY SCORE 3.16

    DB:3.16:Fetching Japanese Characters From Oracle Database kf


    Hi,

    my developer trying to fetch Japanese characters in a perl script from an oracle database using DBI-Connect()
    Without setting any environment varaibles, I am getting ???????????? instead of Japanese font.

    When he set env variables NLS_LANG, ORA_NLS, ORA_NLS33, ORA_NLS32, the script errors out saying :
    DBI-connect failed: ORA-12705: Cannot access NLS data files or invalid environment specified (DBD: login failed)

    Can someone suggest how to proceed in this?

    DB:3.16:Fetching Japanese Characters From Oracle Database kf

    Hi,

    I suppose for perl, you need to set a variable "charset" or by using ora_csid durring connect time.
    Am not too much well versed with perl scripting. But you can get help from Oracle perl forum.

    Regards
    Anurag

  • RELEVANCY SCORE 3.16

    DB:3.16:Perl And Mysql Using Dbi j3





    Does anyone know if the problem dicussed in this thread:

    http://forum.plesk.com/showthread.php?s=threadid=4957

    is resolved after upgrading to 6.0? It is the problem of 5.0.3 connecting Perl to Mysql using DBI.

    Thanks,

    Den

    DB:3.16:Perl And Mysql Using Dbi j3







    Originally posted by dennism220

    I dont want to apply the fixes that are described in the forums if upgrading to Plesk 6 (which changes the install from Standard to RPM) is going to take care of the issue.

  • RELEVANCY SCORE 3.14

    DB:3.14:Installed 2.5.1 Rpm And Php Does Not Seem To Work? p7





    I formatted the HD
    Installed RH7.2 (No Extras)
    Installed all the required RPMs
    Installed the reccomended
    frontpage and Perl RPMs
    Installed the PSA 2.5.1 RPMs.

    After doing that I checked to make sure I could bring up the PSA admin interface, and I could.
    Then I copied an info.php which simply contains one line ?
    phpinfo(); ? to /home/httpd/vhosts/default/htdocs and tried to view that page. The page loads totally blank and does not generate errors to either
    error_log or to the screen.

    I have the correct (default) entries in my httpd.conf for PHP in the AddType section.

    Heres my configuration:

    Apache/1.3.22 (Unix) (Red-Hat/Linux) FrontPage/5.0.2.2623 mod_ssl/2.8.4
    OpenSSL/0.9.6b DAV/1.0.2 PHP/4.0.6 mod_perl/1.2

    Linux version 2.4.7-10 (gcc version2.96 20000731 (Red Hat Linux 7.1 2.96-98))

    # rpm -qa | grep php
    php-imap-4.0.6-7
    php-mysql-4.0.6-7
    asp2php-0.75.17-1
    php-4.0.6-7
    php-ldap-4.0.6-7

    # rpm -qa | grep perl
    perl-DBI-1.18-1
    mod_perl-1.24_01-3
    perl-Digest-MD5-2.13-1
    perl-HTML-Parser-3.25-2
    perl-FreezeThaw-0.41-2psa
    perl-HTML-Tree-3.11-2psa
    perl-MLDBM-Sync-0.25-1psa
    perl-MIME-Base64-2.12-6
    perl-libwww-perl-5.53-3
    perl-5.6.0-17
    perl-libnet-1.0703-6
    perl-DBD-MySQL-1.2216-4
    perl-HTML-Tagset-3.03-3
    perl-Font-AFM-1.18-2psa
    perl-HTML-Format-1.23-2psa
    perl-MLDBM-2.00-2psa
    perl-URI-1.12-5
    perl-Storable-0.6.11-6
    perl-Apache-ASP-2.29-3psa

    Since almost everyone is running PSA 2.5.1 without a hitch I have to wonder why Im having problems or if phpinfo() even works as its supposed to anymore. Doesnt the Admin interface use PHP? Whouldnt that be broken?

    So confused..

    DB:3.14:Installed 2.5.1 Rpm And Php Does Not Seem To Work? p7




    Wow.. Such a simple problem!

    Plesk support was busy and the support request form on the main Plesk site was crashing my X session. So I decided to probe the problem on my own and eventually I realized that because of the way PHP is parsed, you cannot stick a PHP page into an area that is not flagged for PHP Support. So sticking PHP commands into pages located under ../vhosts/default/htdocs wont work.

    Sooooo frustrating.. What a waste of many hours..

  • RELEVANCY SCORE 3.12

    DB:3.12:Anyone Know About Lwp::Simple Perl Module fd





    Does anyone know if plesk come with

    DBI Perl module (this is used to access the MySQL database from Perl)
    LWP::Simple Perl Module (this is used to grab external search listings)

    I need those two programs in order to run this program i have... But i have been having some problems getting the script to run... Do anyone know how to install those LWP and DBI... Or is it alreayd installed when i installed plesk?

    DB:3.12:Anyone Know About Lwp::Simple Perl Module fd




    Download the modules from CPAN

    perl -MCPAN -e shell

    and follow the instructions

  • RELEVANCY SCORE 3.12

    DB:3.12:Integrating Pl/Sql With Perl 1a


    Hello All,

    I have just started learning PL/SQL and this my first RD stuff with PL/SQL :)

    I have a very basic beginner question.

    Suppose I want to insert 1 lakh rows in a table through Perl. One and easiest way to do is to prepare and execute insert queries using Perl module - 'DBI' module in a loop

    But I guess this will send lot of traffic over the LAN. What I rather feel is that if I execute these 1 lakh SQL queries using PL/SQL it will be comparatively more network efficient and fast.

    So I have following questions:

    1. Is it possible to integrate PL/SQL with Perl using 'DBI' module
    2. Is there a way in PL/SQL that it will return status of all the 1 Lakh SQL queries after execution that will let me know which SQL queries were successfully executed and which failed.

    DB:3.12:Integrating Pl/Sql With Perl 1a

    1. Is it possible to integrate PL/SQL with Perl using 'DBI' moduleyes, just use a PL/SQL statement instead of a sql one

    2. Is there a way in PL/SQL that it will return status of all the 1 Lakh SQL queries after execution that will let me know which SQL queries were successfully executed and which failed.yes, you have to manage an exception block for each row and store the single row result in a cumulative variable:

    The following code is an incomplete and not testet example:

    my $STM = "
    declare
    ret varchar2(10);
    begin
    begin
    insert into mytab values(1);
    ret := ret||'0';
    exception
    when others then
    ret:=ret||'1';
    end;
    begin
    insert into mytab values(2);
    ret := ret||'0';
    exception
    when others then
    ret:=ret||'1';
    end;
    ... and so on ...
    select ret into :OUTRES from dual;
    end;";

    my $outres;
    my $hnd = $db-prepare($STM);

    $hnd-bind_param_inout( ":OUTRES", \$outres, 10); -- 10 is the variable length, e.g. the number of inserts
    $hnd-execute();
    print "inserts output: $outres\n";At the end of the script you should hava a string of bits. A 0 for each successful insert an 1 for each unsuccessful...

    Max
    [My Italian Oracle blog|http://oracleitalia.wordpress.com/2010/01/10/crittografia-in-plsql-utilizzando-dbms_crypto/]

  • RELEVANCY SCORE 3.11

    DB:3.11:Dbi Moduiles -Perl - Mysql Installation xx





    Anybody get the DBI modules to install properly for perl so that it interacts with mysql. Ikonboard utilizes this module and when i install it, it seems as if it is not recognized...

    any ideas?

    Or has anybody successfully installed ikonboard v3.0 using mysql?

    DB:3.11:Dbi Moduiles -Perl - Mysql Installation xx




    perfect, i did a search and didnt find that but thanks!

  • RELEVANCY SCORE 3.11

    DB:3.11:Dbi.Pm 3m





    Hello

    Does Plesk 2.0 support the DBI.pm perl modules? I need them for my Ikonboard forums.

    DB:3.11:Dbi.Pm 3m




    ?

    Hello

    Thanks for the reply. How can I convince my host that this is correct and how do they install the modules?

    Regards

  • RELEVANCY SCORE 3.11

    DB:3.11:Perl Cgi-Bin Tnsnames Error mj


    I am using Oracle9iAS perl script sample hotelInfo and getting following error. Some of the other samples in perl work OK. Indicates that there is no problem setting up perl. The perlModule sample work OK, indicated DBI is working fine and getting to database tnsnames. TNSNAMES for all other applications work fine and setup right. However, hotelInfo gives me this error about TNSNAMES. I wonder where is it looking at and why it's not able to resolve TNSNAME. Can anybody please help? Thanks..

    Error : Couldn't connect to database:
    ORA-12154: TNS:could not resolve service name (DBD ERROR: OCIServerAttach)

    Prashant

    DB:3.11:Perl Cgi-Bin Tnsnames Error mj

    It works, if I bypass TNSNAMES at the connection string as:
    $dbh = DBI-connect("dbi:Oracle:host=myhost;sid=mysid",$user,$password)

    As for TNSNAMES, it could be the environment variables not set properly. Will look into that.

  • RELEVANCY SCORE 3.10

    DB:3.10:Using Perl To Access Oracle p7


    I am trying to run the guestbook sample perl application from technet on the apache that came with my 9iDB R2 install, and the documentation says that I need to get the DBI and DBD modules and install them.

    "perl Makefile.pl" for DBI works file, but the "make" commands from the instructions are not recognized. The "perl Makefile.pl" command for the DBD says "Can't locate DBI.pm in @INC..."

    Oracle Support does not support the use of DBI/DBD, so I must turn to OTN.

    Am I missing something in my path variables? What am I doing wrong?

    Thanks in advance for any help you can provide.

    DB:3.10:Using Perl To Access Oracle p7

    Gregory,

    You should use ppm (perl package manager) look at doc for this. Once you get it loaded you will have the doc available thru your web browser for perl doc locally.

    HTH
    Frank

  • RELEVANCY SCORE 3.10

    DB:3.10:Oracles Perl Samples? Where Are They? cd


    otn has a bunch of html pages w/ instructions for running perl-dbi-oracle samples (hotel res. , guest book, hello, ect).
    these pages have links to get mod_perl, dbi, dbd , but nowhere can
    I find the perl sample code itself. help please, oracle. Miked

    DB:3.10:Oracles Perl Samples? Where Are They? cd

    Hi,

    You can find the perl samples developed by otn at http://otn.oracle.com/sample_code/products/ias/content.html

    Thanks,
    Sujatha
    OTN Team

  • RELEVANCY SCORE 3.08

    DB:3.08:Exact Configuration Of Perl, Dbd::Mysql,Dbi,Gcc Which Will Work xs


    Hi,
    I am trying to install all these modules on solaris 10 and there were lot of compilation problems.Nothing got well as also may be I am very new to this solaris world.
    Can you just tell me exact versions of DBD,DBI,perl and any gcc required on solaris 10(x86) so that i can reinstall it. I am ready to start from scratch. But this is very annoying.
    I would be very thankful if you help me out.

    DB:3.08:Exact Configuration Of Perl, Dbd::Mysql,Dbi,Gcc Which Will Work xs

    Hi,
    I am trying to install all these modules on solaris 10 and there were lot of compilation problems.Nothing got well as also may be I am very new to this solaris world.
    Can you just tell me exact versions of DBD,DBI,perl and any gcc required on solaris 10(x86) so that i can reinstall it. I am ready to start from scratch. But this is very annoying.
    I would be very thankful if you help me out.

  • RELEVANCY SCORE 3.08

    DB:3.08:Mysql And Perl 8z


    I'm trying to add 2 modules to MySQl using Perl. Instructions say to use
    perl -MCPAN -e 'install DBI' and perl -MCPAN -e 'install DBD::mysql'.

    I'm using an XServe G5 running 10.4.2. When executing the first command I get the following result

    Writing Makefile for DBI
    -- NOT OK
    Running make test
    Can't test without successful make
    Running make install
    make had returned bad status, install seems impossible

    I also ran a mysql -v and received the following

    insidedns2:/etc root# mysql -v
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/mysql/mysql.sock' (2)
    insidedns2:/etc root#

    Are they related, and does someone know the workaround.

    Thanks

    DB:3.08:Mysql And Perl 8z

    Hi Bart,
    Also, to install the Perl DBI module, you'll need to have your MySQL server up and running first. I'd also recommend installing the DBI module first, then the DBD module. When you type perl Makefile , make note of any missing dependencies and resolve them first before moving on and running make , make test , and make install .

    As for the second error message, it's indicating that the permissions on the MySQL socket file are probably not correct. I'd go thru the MySQL README post-installation check list and ensure everything checks out and that you can bring up the server ok. Then install the DBI and DBD perl modules.

    Ed

  • RELEVANCY SCORE 3.05

    DB:3.05:Solution For Viewing Installed Dbi Modules fm





    I have seen here some ppl was looking for a way to see the DBI modules installed in the system. Here is a simple script, do that job.

    There are many scripts avilable, but this is a simple one and it is working...

    make a file called dbi_test.pl with following line.

    #!/usr/bin/perl -w

    use strict;
    use DBI;

    print Heres a list of DBI drivers:\n;

    my @available_drivers = DBI-available_drivers(quiet);
    my $driver;

    foreach $driver (@available_drivers)
    {
    print DBI::,$driver\n;
    }

    log in to your server run the file using
    # perl dbi_test.pl in command prompt.

    You will see a list of DBI modules installed in your server.

    if BDI is not installed then it will say

    Cant locate DBI.pm in @INC bla bla bla...

    I never tried to run this from the browser but it may also possible, may be need some modification.

    DB:3.05:Solution For Viewing Installed Dbi Modules fm




    Try Perl Diver

    http://www.scriptsolutions.com/programs/free/perldiver/index.html

    Just upload it to your cgi-bin, chmod - 755 and call from the browser. Gives other usefull system info.

  • RELEVANCY SCORE 3.04

    DB:3.04:Additional Perl Modules Installation c8


    Hi,I use the perl DBI module that comes with the oracle installation.Can I and how can I install additional modules on that perl installation?thx pod

  • RELEVANCY SCORE 3.04

    DB:3.04:@Inc p9





    Hi,

    Our cgi scripts use DBI
    But the location has changed since we installed Plesk.

    How do I change the location of DBI.

    One possibility is maybe in every script the following line:
    BEGIN {@INC=(@INC, /usr/local/psa/apache/lib/perl/site_perl/5.005/i385-freebsd);}

    but that doesnt work (and also is much work to change in al scripts)

    How can I change this to work ?

    Kind reagrds,

    Paul

    DB:3.04:@Inc p9




    I think where youd put that is in the httpd.conf as something like this (this is right from 1.3.1):

    PerlSetEnv PERL5LIB /usr/local/plesk/apache/lib/perl/5.00503/:/usr/local/plesk/apache/lib/perl/site_perl/5.005/

  • RELEVANCY SCORE 3.04

    DB:3.04:Samp Perl Dbi Mysql cx


    I have Solaris 10 0606 running with Apache2 mysql and php - all standard. I can access data on mysql thru a simple php script via Apache2. I would like to run a Perl cgi script to access the mysql database, but am having problems. It appears DBI.pm is not available. Does Solaris 10's 0606 full install support the ability to access mysql data via Perl DBI or other mechanism? If so, does anyone have a simple example of how this was done? If it is not supported, and additional Perl modules or other configurations are needed, does any one have a listing of steps to get this working? Thanks!

    DB:3.04:Samp Perl Dbi Mysql cx

    I ended up downloading the free Studio 11 and installing the necessary
    modules from CPAN. It was very easy. Thanks Sun for providing this for
    free. Install requirements are here :
    http://docs.sun.com/source/819-3052/introduction.html
    which is a bit much for just getting Perl to talk to Mysql.
    Makes me wonder why Sun does not provide the necessary componants to
    install Perl modules in the Solaris distribution.

  • RELEVANCY SCORE 3.04

    DB:3.04:Ora-12545 d8


    I'm running oracle 8.1.6.0 on a redhat 6.1 server, with two databases, the first orcl1 connects acroos the network no problem, the second orcl2 throws the above 12545 error every time, local connections are ok, connecting through the perl dbi on the local machine is ok. tnsping orcl2 from remote machines is ok. any clues ?

    DB:3.04:Ora-12545 d8

    I'm running oracle 8.1.6.0 on a redhat 6.1 server, with two databases, the first orcl1 connects acroos the network no problem, the second orcl2 throws the above 12545 error every time, local connections are ok, connecting through the perl dbi on the local machine is ok. tnsping orcl2 from remote machines is ok. any clues ?

  • RELEVANCY SCORE 3.04

    DB:3.04:Perl Dbi Module Question 7a


    --
    when I use perl DBI module to connect oacle, there is an error of
    "DBI-connect failed: ORA-12224: TNS:no listener (DBD ERROR:
    OCIServerAttach)", how can I do?
    null

    DB:3.04:Perl Dbi Module Question 7a

    --
    when I use perl DBI module to connect oacle, there is an error of
    "DBI-connect failed: ORA-12224: TNS:no listener (DBD ERROR:
    OCIServerAttach)", how can I do?
    null

  • RELEVANCY SCORE 3.03

    DB:3.03:Reason For Oci-21500 3a


    Hi,

    I have started getting this error in some of my Perl/DBI code ...

    OCI-21500: internal error code, arguments: [kghssgai5], [4080], [180326480], [24], [], [], [], []I can't find any reference to this (kghssgai5) internal error number that might help me track the problem down.

    Can anyone help me?

    Thanks,

    Steve

    DB:3.03:Reason For Oci-21500 3a

    Please post some sample code, queries used, conditions at which the error is seen etc.
    Include the version numbers of Oracle client and server and information on OS too.

  • RELEVANCY SCORE 3.03

    DB:3.03:Manipulate Databases In Oracle 10g Xe R2 zm


    Hi all,
    I need to create and manipulate databases in Oracle 10g XE R2 using perl DBI:1.607
    please can someone help me with some documentation
    thank you in advance

    DB:3.03:Manipulate Databases In Oracle 10g Xe R2 zm

    user10984468 wrote:
    Hi all,
    I need to create and manipulate databases in Oracle 10g XE R2 using perl DBI:1.607
    please can someone help me with some documentation
    thank you in advanceThis does not appear to be an issue with documentation. (Note the title of the forum.)

    It does appear to be a request for documentation. Your question is best asked in the Database category - go to http://forums.oracle.com, scroll down to Databases, expand that category (click on More...), look for Express Edition.

    The XE docs are at http://www.oracle.com/pls/xe102/homepage

    Much more info about XE is at http://www.oracle.com/technology/products/database/xe/index.html

  • RELEVANCY SCORE 3.02

    DB:3.02:Identity Insert With Sqloledb From Perl kc


    I have a simple code sample here which throws an error on the SQL INSERT statement. It creates a table with a single integer identity column and then tries to force a value into it. My real world problem is more complex, but this distills the error I'm getting.
    I can run the SQL statements from SQL Server Management Studio into the same database using the same credentials without issue.
    use DBI;
    use strict;
    use warnings;

    my $SQL_dbh;
    my $SQL_sth;

    my $tb = testtb;
    my $cnstr = DBI:ADO:Provider=SQLOLEDB.1;
    Persist Security Info=False;
    User ID=user id;
    PWD=password;
    Initial Catalog=database;
    Data Source=instance;;

    $SQL_dbh = DBI-connect($cnstr) || die $DBI::errstr;

    $SQL_sth = $SQL_dbh-prepare(create table $tb (col1 int identity(1,1))) || die $DBI::errstr;
    $SQL_sth-execute() || die $DBI::errstr;

    $SQL_sth = $SQL_dbh-prepare(set identity_insert $tb ON) || die $DBI::errstr;
    $SQL_sth-execute() || die $DBI::errstr;

    $SQL_sth = $SQL_dbh-prepare(insert into $tb (col1) values (4)) || die $DBI::errstr;
    $SQL_sth-execute() || die $DBI::errstr;

    $SQL_sth-finish || die $DBI::errstr;

    The error I get is:
    DBD::ADO::st execute failed: Can't Execute Command 'insert into testtb (col1) values (4)'

    Package : DBD::ADO::st
    Filename : C:/Perl64/site/lib/DBD/ADO.pm
    Line : 1244
    Last error : -2147217900

    OLE exception from Microsoft OLE DB Provider for SQL Server:

    Cannot insert explicit value for identity column in table 'testtb' when
    IDENTITY_INSERT is set to OFF.

    Win32::OLE(0.1709) error 0x80040e14
    in METHOD/PROPERTYGET Execute

    Description : Cannot insert explicit value for identity column in table 'testtb' when IDENTITY_INSERT is set to
    OFF.
    HelpContext :
    HelpFile :
    NativeError : 544
    Number : -2147217900
    Source : Microsoft OLE DB Provider for SQL Server
    SQLState : 42000
    at ./t3.pl line 30.

    This is being run on a trial version of Windows Server 2012, Standard Edition with a trial version of SQL Server 2012. Both are fully patched. Perl is ActivePerl, version 5.16.3.1603.
    Anyone any suggestions?
    Thanks,
    KTP

    DB:3.02:Identity Insert With Sqloledb From Perl kc

    Often when moving data with incompatible types, you can use a source-side query that converts the data to interoperable types and enable a simple load.

    DavidDavid http://blogs.msdn.com/b/dbrowne/

  • RELEVANCY SCORE 3.02

    DB:3.02:/Usr/Bin/Perl Cpan Building Dbi, Macro Recursion Errors? ka


    Solaris 10 Sparc
    Sun supplied perl (/usr/bin/perl) and with the blastwave Perl (/opt/csw/bin/perl) the same behaviour occurs. When installing DBI from CPAN (perl -MCPAN -e 'install DBI' ) DBI always fails with PERLIO macro recursion errors.
    I'm seeing this behavious using Studio 10 and with gcc. I've built Perl from source and DBI installed clean. I'll be happy to put any output needed into this thread. Curious.
    Doug

    DB:3.02:/Usr/Bin/Perl Cpan Building Dbi, Macro Recursion Errors? ka

    Alternatively, you can modify your PATH
    PATH=/opt/SUNWspro/bin:$PATH
    as suggested here (http://sunsolve.sun.com/search/document.do?assetkey=1-25-11339-1searchclause=language%2420optional%2420software%2420package%2420not%2420installed).
    BTW, at the bottom of that page there is a note about Perl.

  • RELEVANCY SCORE 3.02

    DB:3.02:Oracle Client On Linux 7d


    Is Client version on Linux free?? I need to connect a linux box to an oracle server running on dec alpha.
    Can i install a linux client and use it in for connecting to oracle production use. I intend to use apache and perl dbi to connect to oracle..

    THanks
    null

    DB:3.02:Oracle Client On Linux 7d

    Is Client version on Linux free?? I need to connect a linux box to an oracle server running on dec alpha.
    Can i install a linux client and use it in for connecting to oracle production use. I intend to use apache and perl dbi to connect to oracle..

    THanks
    null

  • RELEVANCY SCORE 3.02

    DB:3.02:Access Oracle 10g Xe With Perl z1


    I'm using ubuntu lucid as OS, oracle 10g xe as db and want to access the oracle db via perl.
    Installed software:
    libdbd-oracle-perl 1.21-2
    libdbi-perl 1.609-1build1
    perl, v5.10.1 (*) built for i486-linux-gnu-thread-multi
    oracle-xe-universal 10.2.0.1-1.0
    oracle-instantclient-basic 10.2.0.3-2

    after using
    #!/usr/bin/perl

    my $ORACLE_HOME = "/usr/lib/oracle/xe/app/oracle/product/10.2.0/server";
    my $ORACLE_SID="XE";

    $ENV{ORACLE_HOME}=$ORACLE_HOME;
    $ENV{ORACLE_SID}=$ORACLE_SID;
    $ENV{PATH}="$ORACLE_HOME/bin";
    # $ENV{LD_LIBRARY_PATH}="$ORACLE_HOME/lib";

    use strict;
    use DBI;
    my $dbh = DBI-connect( 'dbi:Oracle:XE@localhost','scott','tiger',{ RaiseError = 1, AutoCommit = 0 }
    ) || die "Database connection not made: $DBI::errstr";

    $dbh-disconnect;I get the error:
    wucis@dell6400:~/perlora$ perl zugriff1.pl
    DBI connect('XE@localhost','scott',...) failed: ORA-12154: TNS:could not resolve the connect identifier specified (DBD ERROR: OCIServerAttach) at zugriff1.pl line 13although sqlplus scott/tiger works properly

    DB:3.02:Access Oracle 10g Xe With Perl z1

    Appears to be off-topic for APEX forum.

    +{forum:id=61}+ ?

    +{forum:id=251}+ ?

  • RELEVANCY SCORE 3.02

    DB:3.02:Perl Ocienvinit Error On Connect Across Different Environments 17


    Hi,

    I'm running in an 11.03 Oracle Appls environment. Which means my database is 8.1.6 and my concurrent managers run under 8.0.6.

    Usign DBI as the database account I'm able to connect successfully. As the concurrent manager account I get
    DBI-connect() failed: ERROR OCIEnvInit at ./dbtest.pl line 4
    Can't connect to Oracle database: ERROR OCIEnvInit

    I've been working my way through the environmental variables:

    TWO_TASK
    ORACLE_HOME
    PATH
    LD_LIBRARY_PATH

    With no luck so far.

    I've found some posts on the net indicating that DBI appears to have issues crossing environments; but not very specific.

    Thanks in advance
    Ken

    DB:3.02:Perl Ocienvinit Error On Connect Across Different Environments 17

    Hi,

    I'm running in an 11.03 Oracle Appls environment. Which means my database is 8.1.6 and my concurrent managers run under 8.0.6.

    Usign DBI as the database account I'm able to connect successfully. As the concurrent manager account I get
    DBI-connect() failed: ERROR OCIEnvInit at ./dbtest.pl line 4
    Can't connect to Oracle database: ERROR OCIEnvInit

    I've been working my way through the environmental variables:

    TWO_TASK
    ORACLE_HOME
    PATH
    LD_LIBRARY_PATH

    With no luck so far.

    I've found some posts on the net indicating that DBI appears to have issues crossing environments; but not very specific.

    Thanks in advance
    Ken

  • RELEVANCY SCORE 3.01

    DB:3.01:Small Remark Regarding 3.0.9 Full Installation s1





    It appears that the configuration/installation routine of 3.0.9 requires DBI to be installed. If I install perl-DBI, this gets installed through confixx once again during the process, which leads to having 2 versions of DBI installed on the system.

    if I remember correctly, no previous version had perl-DBI required in configure.pl, would it be possible to remove the requirement for DBI from configure.pl, as it installs DBI again nevertheless?

    or am I seeing things...

    regards

    DB:3.01:Small Remark Regarding 3.0.9 Full Installation s1




    it seems that version of DBI module you installed is lower than Confixxs one.
    Thus it is offered to be installed.

  • RELEVANCY SCORE 3.01

    DB:3.01:Perl Dbd::Oracle Nclob Problem: Ora-24806 zf


    Hello,

    my Perl script uses uses the DBI interface to connect to Oracle and runs a select statement. But if one column is of type NCLOB it fails with:

    DBD::Oracle::st fetchrow_hashref failed: ORA-24806: LOB form mismatch (DBD ERROR: OCILobRead) [for Statement "SELECT * FROM ttt WHERE ROWNUM=1"]

    I googled a lot and didn't found any solution for it. According to the used versions of Perl, DBI and Oracle and the NLS settings it should work.

    Any idea how to get it working?

    Here are my used versions:

    DBI::VERSION = "1.41"
    perl, v5.8.0

    SQL desc ttt
    Name Null? Type
    -------- T1 NCLOB
    UMSISDN VARCHAR2(200 CHAR)
    SPARTID NUMBER(2)

    bash-3.00$ env | grep -i nls
    NLS_LANG=AMERICAN_AMERICA.UTF8
    NLSPATH=:/export/home/omni/locale/%L/%N.cat:/export/home/omni/locale/%L/%N

    Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bit Production

    much thanks,
    yoyo

    DB:3.01:Perl Dbd::Oracle Nclob Problem: Ora-24806 zf

    Thanks for the answer. I know already the error text and cause.
    But I do not provide the buffer into Oracle copies the NCLOB content. This is somewhere inside of Perl DBI/DBD. So can't provide a proper buffer. At least I do not know how.
    yoyo

  • RELEVANCY SCORE 3.00

    DB:3.00:Please Advise. 7a


    --
    hello,

    Can anyone share their experiences with CGI on Sun's Solaris
    OS. I am looking for problems with compiling, DBI DBD modules,
    accessing problems, etc.

    For example, one of mine problems with AIX based systems, was
    that DBI and DBD had to be compiled using xlc_r compiler !!! not
    cc or gcc, and then also maybe the whole perl module. Otherwise
    i am getting coredumps on -connect command.
    So anything will do.

    Alex
    null

    DB:3.00:Please Advise. 7a

    --
    Well acctually,

    that was an idea to begin with. The problem is, I am developing
    a software for a huge company, and it is their server, and they
    are not willing/cannot allocate space. Plus they are moving to a
    new OS anyways, Sun OS, so it does not matter, and also now they
    want us to go with Java. But i want to know more about Perl,
    since i might run into the same problems with other companies.

    But let me ask you this, do you know where would i look on
    how-to set up a java-bin directory?

    Alex
    Rx (guest) wrote:
    : You don't need to "mess" with the system and the existing Perl.
    : Just build a new perl in your own home dir and have your
    program
    : reference YOUR perl (i.e put "#!/YOUR_HOME_DIR/NEW_PERL/perl"
    in
    : the first line of your perl script, change YOUR_HOME and
    NEW_PERL
    : to the actual locations accordingly).
    : Rx
    : Alex Korneyev (guest) wrote:
    : : I believe it was cc compiler. I know that i would need to
    : : recompile perl with xcl_r compiler. But that is not possible,
    : it
    : : is a very big production server, and i dont want to mess
    with,
    : : plus we are moving to SunOS.
    : : Alex
    : : Rx (guest) wrote:
    : : : Which compiler was used to build Perl on your system?
    DBI/DBD
    : : may
    : : : require the same compiler. You can try recompile a new Perl
    : : using
    : : : gcc (or cc), and then build DBI/DBD with the same compiler,
    : gcc
    : : : (or cc).
    : : : Robert XU
    : : : Alex Korneyev (guest) wrote:
    : : : : hello,
    : : : : Can anyone share their experiences with CGI on Sun's
    : : Solaris
    : : : : OS. I am looking for problems with compiling, DBI DBD
    : : modules,
    : : : : accessing problems, etc.
    : : : : For example, one of mine problems with AIX based
    systems,
    : : was
    : : : : that DBI and DBD had to be compiled using xlc_r compiler
    : !!!
    : : : not
    : : : : cc or gcc, and then also maybe the whole perl module.
    : : Otherwise
    : : : : i am getting coredumps on -connect command.
    : : : : So anything will do.
    : : : : Alex
    null

  • RELEVANCY SCORE 3.00

    DB:3.00:Installing Plesk Panel On Centos6 X86_X64 x7





    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    parallels Plesk latest version, Centos6.2 x86_64

    PROBLEM DESCRIPTION
    installation problems

    STEPS TO REPRODUCE
    installed centos with minimal configuration. used artikle http://kb.parallels.com/article_17_819_en.html to create the disks. then i used the document plesk-10-installation-upgrade-guide.pdf to install plesk. first i created .autoinstallerrc and added the line USE_YUM=yes to it as descibed in the manual on page 11(Centos only)
    then i used One-Click installer procedure to install plesk panel as descibed on page 17.
    my host is behind a NAT. the installer begins installing/downloading some components. then after few minutes it fails. see any additional information for the log. how can i fix this?

    ACTUAL RESULT
    plesk not installed

    EXPECTED RESULT
    plesk installed

    ANY ADDITIONAL INFORMATION
    + php
    + lsof
    + plesk-skins
    + perl
    + php-imap
    + php-cli
    + php-gd
    + cronie-anacron
    + psa-logrotate
    + perl-libs
    + xmlrpc-c-c++
    + plesk-base
    + php-common
    + rsync
    + perl-BSD-Resource
    + psa-drweb-configurator
    + sw-milter
    + postfix
    + php-xml
    + mailman
    + perl-ExtUtils-ParseXS
    + php-mysql
    + psa-awstats-configurator
    + psa-mail-driver-common
    + perl-Pod-Escapes
    + sw-engine
    + perl-Module-Pluggable
    + rdbmspp
    + psa-proftpd
    + psa-libxml-proxy
    + psa-locale-base-en-US
    + unixODBC
    + mysql-libs
    + php-pdo
    + plesk-core
    + perl-Digest-SHA1
    + cyrus-sasl-plain
    + httpd-tools
    + sw-cp-server
    + glibc
    + psa-turba
    + perl-libwww-perl
    + pp-sitebuilder-skins
    + perl-Compress-Raw-Zlib
    + glibc
    + plesk-l10n
    + libxml2-python
    + drweb-updater
    + psa-backup-manager
    + pp-sitebuilder-default-templates
    + mysql
    + psa-kronolith
    + mod_ssl
    + psa-mod_fcgid
    + webalizer
    + psa-triggers
    + perl-HTML-Tagset
    + mod_python
    + perl-DBI
    + perl-Text-Iconv
    + psa-selinux
    + libarchive
    + psa-mailman-configurator
    + perl-IO-Compress-Zlib
    + psa-vhost
    + tokyocabinet
    + pp-sitebuilder
    + xinetd
    + psa-autoinstaller
    + unzip
    + perl-version
    + perl-DBD-MySQL
    + bind-utils
    + drweb-bases
    + psa-imp
    + perl-Time-HiRes
    + perl-Test-Harness
    + psa-courier-imap
    + cronie
    + perl-ExtUtils-MakeMaker
    + zip
    + platform-runtime
    + psa
    + perl-IO-Compress-Base
    + perl-Pod-Simple
    + crontabs
    + drweb-common
    + libaps
    + cyrus-sasl-sqlite3
    + nss-softokn-freebl
    + drweb-base
    + psa-ingo
    + libc-client
    + psa-spf2
    + gd
    + sw-doctrine
    + libmcrypt
    + psa-pear
    + awstats
    + mod_perl
    + bind
    + psa-pylibplesk
    + perl-TimeDate
    + mysql-server
    + psa-php5-configurator
    + mysql-connector-odbc
    + psa-libpam-plesk
    + perl-HTML-Parser
    + bind-libs
    + psa-mimp
    + php-mbstring
    + psa-mod-fcgid-configurator
    + mailx
    + httpd
    + plesk-mail-pc-driver
    + perl-Compress-Zlib
    + cyrus-sasl-md5
    + psa-mnemo
    + pp10.13.4-bootstrapper
    + php5-ioncube-loader
    + psa-ftputil
    + sharutils
    + perl-devel
    + psa-updates
    + psa-horde
    + sw-libsqlite3-0
    + perl-URI
    + file
    + glibc-common
    + log4cpp-plesk
    + postgresql-libs
    + drweb-daemon

    Following amount of diskpace required in directories:
    /usr/local: 900.00 Mb.
    Total required: 900.00 Mb, available 18128.00 Mb.

    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
    * base: ftp.tudelft.nl
    * extras: ftp.tudelft.nl
    * updates: ftp.tudelft.nl
    137 packages excluded due to repository priority protections
    Running rpm_check_debug
    Installing: mysql-libs-5.1.61-1.el6_2.1.x86_64 [1/22]
    Installing: platform-runtime-1.0-38.rhel6.x86_64 [2/22]
    Installing: 1erl-Pod-Escapes-1.04-119.el6_1.1.x86_64 [3/22]
    Installing: 4erl-libs-5.10.1-119.el6_1.1.x86_64 [4/22]
    Installing: 1erl-Pod-Simple-3.13-119.el6_1.1.x86_64 [5/22]
    Installing: 1erl-Module-Pluggable-3.90-119.el6_1.1.x86_64 [6/22]
    Installing: 3erl-version-0.77-119.el6_1.1.x86_64 [7/22]
    Installing: 4erl-5.10.1-119.el6_1.1.x86_64 [8/22]
    Installing: perl-DBI-1.609-4.el6.x86_64 [9/22]
    Installing: perl-DBD-MySQL-4.013-3.el6.x86_64 [10/22]
    Installing: mysql-5.1.61-1.el6_2.1.x86_64 [11/22]
    Installing: mysql-server-5.1.61-1.el6_2.1.x86_64 [12/22]
    Installing: unixODBC-2.2.14-11.el6.x86_64 [13/22]
    Installing: rdbmspp-2.0-650086.11082613.x86_64 [14/22]
    Installing: postgresql-libs-8.4.9-1.el6_1.1.x86_64 [15/22]
    Installing: libarchive-2.8.3-4.el6_2.x86_64 [16/22]
    Installing: libaps-1.0.2-669424.11082613.x86_64 [17/22]
    Installing: libmcrypt-2.5.8-9.el6.x86_64 [18/22]
    Installing: xmlrpc-c-c++-1.16.24-1200.1840.el6_1.4.x86_64 [19/22]
    Installing: libc-client-2007e-11.el6.x86_64 [20/22]
    Installing: sw-engine-2.3-201111031522.centos6.x86_64 [21/22]
    Installing: pp10.13.4-bootstrapper-10.13.4-cos6.build1013111102.18.x86_64 [22/22]
    hostname: Unknown host
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
    * base: ftp.tudelft.nl
    * extras: ftp.tudelft.nl
    * updates: ftp.tudelft.nl
    137 packages excluded due to repository priority protections
    Package mysql-server-5.1.61-1.el6_2.1.x86_64 already installed and latest version
    Package pp10.13.4-bootstrapper-10.13.4-cos6.build1013111102.18.x86_64 already installed and latest version
    YumDownloadError: [uErrors were encountered while downloading packages., plesk-core-10.13.4-cos6.build1013111102.18.x86_64: failure: base/plesk-core-10.13.4-cos6.build1013111102.18.x86_64.rpm from PSA_10_4_4-dist: [Errno 256] No more mirrors to try.]

    ERROR: Failed to run the Yum utility.
    The Yum utility failed to install the required packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
    [root@mer plesk]#

    DB:3.00:Installing Plesk Panel On Centos6 X86_X64 x7




    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    parallels Plesk latest version, Centos6.2 x86_64

    PROBLEM DESCRIPTION
    installation problems

    STEPS TO REPRODUCE
    installed centos with minimal configuration. used artikle http://kb.parallels.com/article_17_819_en.html to create the disks. then i used the document plesk-10-installation-upgrade-guide.pdf to install plesk. first i created .autoinstallerrc and added the line USE_YUM=yes to it as descibed in the manual on page 11(Centos only)
    then i used One-Click installer procedure to install plesk panel as descibed on page 17.
    my host is behind a NAT. the installer begins installing/downloading some components. then after few minutes it fails. see any additional information for the log. how can i fix this?

    ACTUAL RESULT
    plesk not installed

    EXPECTED RESULT
    plesk installed

    ANY ADDITIONAL INFORMATION
    + php
    + lsof
    + plesk-skins
    + perl
    + php-imap
    + php-cli
    + php-gd
    + cronie-anacron
    + psa-logrotate
    + perl-libs
    + xmlrpc-c-c++
    + plesk-base
    + php-common
    + rsync
    + perl-BSD-Resource
    + psa-drweb-configurator
    + sw-milter
    + postfix
    + php-xml
    + mailman
    + perl-ExtUtils-ParseXS
    + php-mysql
    + psa-awstats-configurator
    + psa-mail-driver-common
    + perl-Pod-Escapes
    + sw-engine
    + perl-Module-Pluggable
    + rdbmspp
    + psa-proftpd
    + psa-libxml-proxy
    + psa-locale-base-en-US
    + unixODBC
    + mysql-libs
    + php-pdo
    + plesk-core
    + perl-Digest-SHA1
    + cyrus-sasl-plain
    + httpd-tools
    + sw-cp-server
    + glibc
    + psa-turba
    + perl-libwww-perl
    + pp-sitebuilder-skins
    + perl-Compress-Raw-Zlib
    + glibc
    + plesk-l10n
    + libxml2-python
    + drweb-updater
    + psa-backup-manager
    + pp-sitebuilder-default-templates
    + mysql
    + psa-kronolith
    + mod_ssl
    + psa-mod_fcgid
    + webalizer
    + psa-triggers
    + perl-HTML-Tagset
    + mod_python
    + perl-DBI
    + perl-Text-Iconv
    + psa-selinux
    + libarchive
    + psa-mailman-configurator
    + perl-IO-Compress-Zlib
    + psa-vhost
    + tokyocabinet
    + pp-sitebuilder
    + xinetd
    + psa-autoinstaller
    + unzip
    + perl-version
    + perl-DBD-MySQL
    + bind-utils
    + drweb-bases
    + psa-imp
    + perl-Time-HiRes
    + perl-Test-Harness
    + psa-courier-imap
    + cronie
    + perl-ExtUtils-MakeMaker
    + zip
    + platform-runtime
    + psa
    + perl-IO-Compress-Base
    + perl-Pod-Simple
    + crontabs
    + drweb-common
    + libaps
    + cyrus-sasl-sqlite3
    + nss-softokn-freebl
    + drweb-base
    + psa-ingo
    + libc-client
    + psa-spf2
    + gd
    + sw-doctrine
    + libmcrypt
    + psa-pear
    + awstats
    + mod_perl
    + bind
    + psa-pylibplesk
    + perl-TimeDate
    + mysql-server
    + psa-php5-configurator
    + mysql-connector-odbc
    + psa-libpam-plesk
    + perl-HTML-Parser
    + bind-libs
    + psa-mimp
    + php-mbstring
    + psa-mod-fcgid-configurator
    + mailx
    + httpd
    + plesk-mail-pc-driver
    + perl-Compress-Zlib
    + cyrus-sasl-md5
    + psa-mnemo
    + pp10.13.4-bootstrapper
    + php5-ioncube-loader
    + psa-ftputil
    + sharutils
    + perl-devel
    + psa-updates
    + psa-horde
    + sw-libsqlite3-0
    + perl-URI
    + file
    + glibc-common
    + log4cpp-plesk
    + postgresql-libs
    + drweb-daemon

    Following amount of diskpace required in directories:
    /usr/local: 900.00 Mb.
    Total required: 900.00 Mb, available 18128.00 Mb.

    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
    * base: ftp.tudelft.nl
    * extras: ftp.tudelft.nl
    * updates: ftp.tudelft.nl
    137 packages excluded due to repository priority protections
    Running rpm_check_debug
    Installing: mysql-libs-5.1.61-1.el6_2.1.x86_64 [1/22]
    Installing: platform-runtime-1.0-38.rhel6.x86_64 [2/22]
    Installing: 1erl-Pod-Escapes-1.04-119.el6_1.1.x86_64 [3/22]
    Installing: 4erl-libs-5.10.1-119.el6_1.1.x86_64 [4/22]
    Installing: 1erl-Pod-Simple-3.13-119.el6_1.1.x86_64 [5/22]
    Installing: 1erl-Module-Pluggable-3.90-119.el6_1.1.x86_64 [6/22]
    Installing: 3erl-version-0.77-119.el6_1.1.x86_64 [7/22]
    Installing: 4erl-5.10.1-119.el6_1.1.x86_64 [8/22]
    Installing: perl-DBI-1.609-4.el6.x86_64 [9/22]
    Installing: perl-DBD-MySQL-4.013-3.el6.x86_64 [10/22]
    Installing: mysql-5.1.61-1.el6_2.1.x86_64 [11/22]
    Installing: mysql-server-5.1.61-1.el6_2.1.x86_64 [12/22]
    Installing: unixODBC-2.2.14-11.el6.x86_64 [13/22]
    Installing: rdbmspp-2.0-650086.11082613.x86_64 [14/22]
    Installing: postgresql-libs-8.4.9-1.el6_1.1.x86_64 [15/22]
    Installing: libarchive-2.8.3-4.el6_2.x86_64 [16/22]
    Installing: libaps-1.0.2-669424.11082613.x86_64 [17/22]
    Installing: libmcrypt-2.5.8-9.el6.x86_64 [18/22]
    Installing: xmlrpc-c-c++-1.16.24-1200.1840.el6_1.4.x86_64 [19/22]
    Installing: libc-client-2007e-11.el6.x86_64 [20/22]
    Installing: sw-engine-2.3-201111031522.centos6.x86_64 [21/22]
    Installing: pp10.13.4-bootstrapper-10.13.4-cos6.build1013111102.18.x86_64 [22/22]
    hostname: Unknown host
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
    * base: ftp.tudelft.nl
    * extras: ftp.tudelft.nl
    * updates: ftp.tudelft.nl
    137 packages excluded due to repository priority protections
    Package mysql-server-5.1.61-1.el6_2.1.x86_64 already installed and latest version
    Package pp10.13.4-bootstrapper-10.13.4-cos6.build1013111102.18.x86_64 already installed and latest version
    YumDownloadError: [uErrors were encountered while downloading packages., plesk-core-10.13.4-cos6.build1013111102.18.x86_64: failure: base/plesk-core-10.13.4-cos6.build1013111102.18.x86_64.rpm from PSA_10_4_4-dist: [Errno 256] No more mirrors to try.]

    ERROR: Failed to run the Yum utility.
    The Yum utility failed to install the required packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
    [root@mer plesk]#

  • RELEVANCY SCORE 2.97

    DB:2.97:Manipulate Databases In Oracle 10g Xe R2 js


    Hi all,
    I need to create and manipulate databases in Oracle 10g XE R2 using perl DBI:1.607
    please can someone help me with some documentation
    thank you in advance

    DB:2.97:Manipulate Databases In Oracle 10g Xe R2 js

    Hi all,
    I need to create and manipulate databases in Oracle 10g XE R2 using perl DBI:1.607
    please can someone help me with some documentation
    thank you in advance

  • RELEVANCY SCORE 2.97

    DB:2.97:Perl Version Issue, Apache::Dbi, ... sc


    I fear I have mucked up my environment...I have an old install of Perl 5.10 on my machine; recently while installing various components through macports, the default Perl was changed (by macports) from 5.10 to 5.8.9 (which I believe ships with Mac OS).

    I am trying to get a web app up and running with mod_perl, and startup.pl cannot find Apache::DBI. There are several issues: 1) Apache::DBI is not installed, 2) when I try to use CPAN to install Bundle::Apache, CPAN asks me for the path to my apache source (which I'm not sure I even have), and 3) when I look at my perl @INC, my @INC still refers to 5.10.0 directories. (I realize that this is unrelated, largely: there is simply no DBI.pm in a directory named Apache on my system. But it's clearly wrong anyway).

    Suggestions?

    DB:2.97:Perl Version Issue, Apache::Dbi, ... sc

    rm50 wrote:
    Yeah, I actually meant my whole machine, not just MacPorts...

    That's even easier. Put in your install disk (or your install drive), select Disk Utility and re-partition your boot drive, then reinstall. That will give you a pristine system.

  • RELEVANCY SCORE 2.97

    DB:2.97:Dbd::Oracle Installtion To Access A Remote Oracle Db With Perl Script 38


    I want to know how to install the DBI Oracle module on Linux for perl so as to be able to access a remote Oracle database with perl script:

    the remote Oracle database (Oracle 10g) is on a windows server

    the server on witch i want to install DBD::Oracle has an Ubuntu 10.04 LTS OS

    Hope I can find an answer, Regards!

    DB:2.97:Dbd::Oracle Installtion To Access A Remote Oracle Db With Perl Script 38

    869570 wrote:
    The link provide in the previous answer is usfull but not answer my question:
    cause the link just give me some script axemple in perl on how to make the connection but it's not my concern. I want to know if i should install an oracle client. if yes, how should I install it. And for the DBD::Oracle module, how should I install it.http://www.lmgtfy.com/?q=perl+install+dbd

  • RELEVANCY SCORE 2.97

    DB:2.97:Perl Dbi And Dbd::Oracle xk


    Has anyone had any exerience with using Perl, DBI and DBD::Oracle to access Oracle databases on NT? I'll be starting a project that requires this kind of configuration and I was wondering if anyone has pointers.

    TIA!

    DB:2.97:Perl Dbi And Dbd::Oracle xk

    Has anyone had any exerience with using Perl, DBI and DBD::Oracle to access Oracle databases on NT? I'll be starting a project that requires this kind of configuration and I was wondering if anyone has pointers.

    TIA!

  • RELEVANCY SCORE 2.96

    DB:2.96:Perl Dbd/Dbi 8z


    I have a few scripts that run on an Oracle 8 database client using the Perl DBD/DBI's to access the database servers. The company is looking to upgrade these database servers to 9.2.0.6 and I'm wondering what the impact of that might be.

    When they went to 9.2.0.5 on some of the databases, the perl scripts stopped working due to an incompatibility issue between the Oracle 8 client, Perl DBD/DBI and the Oracle 9 database.

    Thanks for any feedback you may have.

    DB:2.96:Perl Dbd/Dbi 8z

    Oracle 8 client, Perl DBD/DBI and the Oracle 9 database.And the teaching is: it's usually a good idea to upgrade the client at the same time as the server.

    Cheers, APC

  • RELEVANCY SCORE 2.96

    DB:2.96:Connecting W/O Listener With Dbi/Dbd 9m


    --
    I read somewhere that perl can connect (VIA DBD::Oracle/DBI)
    without using the listener. However, they suggest using
    ORAPIPES, which from what I can find is an Oracle 7 thing.

    Does anyone know how to connect to DBI without the listener?

    I'm asking because every once in a while I get no listener errors
    on my connects, but when I try it again, everything is ok
    (without recycling the listeners, that is).

    thanks

    --Geoff
    younggs@acwilm.com
    null

    DB:2.96:Connecting W/O Listener With Dbi/Dbd 9m

    --
    I read somewhere that perl can connect (VIA DBD::Oracle/DBI)
    without using the listener. However, they suggest using
    ORAPIPES, which from what I can find is an Oracle 7 thing.

    Does anyone know how to connect to DBI without the listener?

    I'm asking because every once in a while I get no listener errors
    on my connects, but when I try it again, everything is ok
    (without recycling the listeners, that is).

    thanks

    --Geoff
    younggs@acwilm.com
    null

  • RELEVANCY SCORE 2.96

    DB:2.96:Perl On Oracle 8x


    Hallo,

    For perl scripting over an Oracle Database , it is required to install DBI, usually shipped with perl, and DBD:Oracle, usually installed on an Oracle Client.

    Is it safe to install DBD:Oracle on an Oracle Server with a live instance running? Does it imply a relinking of binaries?

    TIA

  • RELEVANCY SCORE 2.96

    DB:2.96:Problems Installing Dbd And Dbi Modules mz





    Hi

    I am trying to install DBD Module and get the following error.

    Error: No valid respositories:
    Error: 500 Cant connect to ppm.ActiveState.com:80 (conection: Unknown error) at c:/Program Files/SWsoft/Plesk/Perl/site/lib/PPM/Repository.pm line84

    I go to Run – PPM – and type install DBD or DBI and get the above message.

    Do you have any idea why?

    It was suggested to me at the serverbeach forum to reinstall perl. Is this something I can do through Plesk or something seperate?

    Stewart

    DB:2.96:Problems Installing Dbd And Dbi Modules mz




    Hi

    I am trying to install DBD Module and get the following error.

    Error: No valid respositories:
    Error: 500 Cant connect to ppm.ActiveState.com:80 (conection: Unknown error) at c:/Program Files/SWsoft/Plesk/Perl/site/lib/PPM/Repository.pm line84

    I go to Run – PPM – and type install DBD or DBI and get the above message.

    Do you have any idea why?

    It was suggested to me at the serverbeach forum to reinstall perl. Is this something I can do through Plesk or something seperate?

    Stewart

  • RELEVANCY SCORE 2.96

    DB:2.96:Creation Utilities / Missing Perl Modules 8a





    Hello!

    Finally I wanted to give those creation utilities from Plesk a shot ... but the README file says that the following Perl modules are needed:
    ftp://cpan.perl.org/pub/CPAN/modules/by-module/DBI/DBI-1.20.tar.gz
    ftp://cpan.perl.org/pub/CPAN/modules/by-module/Data/Data-ShowTable-3.3.tar.gz
    ftp://cpan.perl.org/pub/CPAN/modules/by-module/DBD/Msql-Mysql-modules-1.2216.tar.gz

    Neither the Data-ShowTable nor the Msql-Mysql-modules link work for me. Using CPAN doesnt find them either. .... Any suggestions?

    John

    DB:2.96:Creation Utilities / Missing Perl Modules 8a




    Do I need to install anything though????
    Seeing as how perldiver already shows DBI as being installed...
    Should the mySql modules be listed as MySql::Modules if they are installed... how can I tell?

  • RELEVANCY SCORE 2.95

    DB:2.95:Return Number Of Rows Selected In Perl 1f


    Hi all, i am doing a perl script to read from a db. I am able to retrieve the rows, but i am unable to return the number of rows selected. i tried $selectedrows = $sth-numrows; i got the error msg:
    Can't locate object method "numrows" via package "DBI::st"

    i changed it to $selectedrows = $sth-rows;i get 0, when i have results returned.

    Any advise, thanks.

    DB:2.95:Return Number Of Rows Selected In Perl 1f

    Hi all, thanks for the suggestions.

    i used

    while @content = $stat -fetch_rowarray() {
    $selected +=1;
    }

  • RELEVANCY SCORE 2.94

    DB:2.94:Perl Dbi Driver Installation On Linux 7.3 kx


    when ever i am ruuning perl srcipt to access oracle

    i am getting following message " can't locate object method "USE" via package "strict " ( perhaps you may forget to load "strict") "

    it appreciated if some one help to get rid of this

    DB:2.94:Perl Dbi Driver Installation On Linux 7.3 kx

    when ever i am ruuning perl srcipt to access oracle

    i am getting following message " can't locate object method "USE" via package "strict " ( perhaps you may forget to load "strict") "

    it appreciated if some one help to get rid of this

  • RELEVANCY SCORE 2.94

    DB:2.94:Cpan Other Perl Modules mx





    Hi,

    I was trying to install PerlDesk. It requires DBI and MIME::Tools installed. Its module check utility showed me that, these modules are not installed on my machine. So, I installed the CPAN. It asked me a lot of questions, and I pressed the default for all. After installing CPAN, I also installed DBI and MIME::Tools using:-

    cpan install Bundle:: DBI

    and

    cpan install MIME::Tools

    Now, cpan says these modules are uptodate, but the module check utility of the software is still saying these modules are missing.

    Also, I downloaded and installed perldiver.cgi from scriptsolutions.com, but it also does not display these modules listed.

    Please let me whats wrong. Have I installed everything somewhere else? How do correct?

    Thanks
    ukagg

    DB:2.94:Cpan Other Perl Modules mx




    I got the plesk beta version working without too much trouble. It seems that mod_perl causes some problems. Turn it off for the domain you are installing perldesk on. In your httpd.conf, add .pl to the AddHandler for cgi. I would wait another couple weeks, John is releasing a real plesk version, that should be a bit more straight forward.

  • RELEVANCY SCORE 2.94

    DB:2.94:Perl Dbi Module Question dx


    --
    when I use perl DBI module to connect oacle, there is an error of
    "DBI-connect failed: ORA-12224: TNS:no listener (DBD ERROR:
    OCIServerAttach)", how can I do?
    null

    DB:2.94:Perl Dbi Module Question dx

    --
    when I use perl DBI module to connect oacle, there is an error of
    "DBI-connect failed: ORA-12224: TNS:no listener (DBD ERROR:
    OCIServerAttach)", how can I do?
    null

  • RELEVANCY SCORE 2.94

    DB:2.94:Does The Ms Sql Odbc Driver For Linux Work With The Perl Dbi? ad



    Hi,
    I'm trying to connect to MS SQL Server 2008 from a Linux box. I wanted to know if the

    Microsoft SQL Server ODBC Driver 1.0 for Linux will work with the Perl DBI? The overview of the driver says that it will work with C and C but I wanted to know if someone used it with Perl DBI. Any instructions or links to documentation will
    be greatly appreciated.
    Kind regards,
    Dudenyc

    DB:2.94:Does The Ms Sql Odbc Driver For Linux Work With The Perl Dbi? ad

    Hi Peja,
    Thanks for the answer. I've installed the DBD::Sybase module and FreeTDS driver and everything seems to work fine except the function $sth-bind_param_inout. I get a segmentation
    fault in my implementation. I was wondering if anybody else came into this problem. I have an excerpt of the code below.
    my $sth = $DB-{DBC}-prepare('EXECUTE OURDB.dbo.OURSTOREDPROC ?,? OUTPUT');
    $sth-bind_param(1, 'AM%');
    $sth-bind_param_inout(2, \$recCount, 4, DBI::SQL_INTEGER);
    $sth-execute();
    #Existence of bind_param_inout call causes segmentation fault on execute…

    while (my $rec = $sth-fetchrow_hashref() )
    {
    print $rec-{COMPANY_NAME} . \n;
    }

    print $recCount;

    Thanks,

    dude

  • RELEVANCY SCORE 2.93

    DB:2.93:Reason For Oci-21500 c8


    (Also posted to C++ Forum)

    Hi,

    I have started getting this error in some of my Perl/DBI code ...

    OCI-21500: internal error code, arguments: [kghssgai5], [4080], [180326480], [24], [], [], [], []I can't find any reference to this (kghssgai5) internal error number that might help me track the problem down.

    Can anyone help me?

    Thanks,

    Steve

    DB:2.93:Reason For Oci-21500 c8

    Seems like a bug. Could you please furnish some more details like what your application tries to do. If the problem can be reproduced with a simple test case, please provide that as well.

    Thanks,
    Sumit

  • RELEVANCY SCORE 2.92

    DB:2.92:Get Sql*Net To Use Perl Module (Dbi And Dbd::Oracle) c8


    Hi,

    I'm doing a perl script which tests oracle database availability

    Now to install it on a Unix computer i need some Oracle files to use the DBI and DBD::Oracle module

    I saw in differents forums that i need to install SQL*NET to have those files but i know few things about Oracle products and then i don't know which package i have to download to have it.

    If someone have the answer please mail me !!(menant.nicolas@wanadoo.fr)

    Thanks a lot

    Nicolas Minant

    DB:2.92:Get Sql*Net To Use Perl Module (Dbi And Dbd::Oracle) c8

    Hi,

    I'm doing a perl script which tests oracle database availability

    Now to install it on a Unix computer i need some Oracle files to use the DBI and DBD::Oracle module

    I saw in differents forums that i need to install SQL*NET to have those files but i know few things about Oracle products and then i don't know which package i have to download to have it.

    If someone have the answer please mail me !!(menant.nicolas@wanadoo.fr)

    Thanks a lot

    Nicolas Minant

  • RELEVANCY SCORE 2.91

    DB:2.91:Oracle 8i Equivalent Of $Sth-≫{Mysql_Insertid} W/Perl Dbi? z7


    What is the easiest way to obtain the value of an auto-incrementing column following an insert using Perl DBI with Oracle 8i? I've done it for years under MySQL using my($lastInsertID)=$sth-{mysql_insertid}, but that's obviously MySQL-specific (if only because of the name).

    DB:2.91:Oracle 8i Equivalent Of $Sth-≫{Mysql_Insertid} W/Perl Dbi? z7

    What is the easiest way to obtain the value of an auto-incrementing column following an insert using Perl DBI with Oracle 8i? I've done it for years under MySQL using my($lastInsertID)=$sth-{mysql_insertid}, but that's obviously MySQL-specific (if only because of the name).

  • RELEVANCY SCORE 2.91

    DB:2.91:Logging Into Ops$ Account From Perl Script ss


    Hi,

    I am new to Perl and know very little about it.

    I need to login into the OPS$ account from a perl script. Can this be done?
    It is a version 7.3 database.

    I have read up about DBI and I can log into other accounts using
    $dbh = DBI-connect("dbi:Oracle:", "$ENV{ECIREAD_UNPW}",undef);
    where ECIREAD_UNPW is an environment variable containing the username/password.

    I have tried the following to log into OPS$ account
    dbh = DBI-connect("dbi:Oracle:host=hostname;sid=oracle_sid", "/",undef);
    but I get the message
    ORA-01004: default username feature not supported; logon denied
    ORA-01988: remote os logon is not allowed (DBD ERROR: OCISessionBegin)

    Any help would be greatly appreciated.

    Thanks,
    John

  • RELEVANCY SCORE 2.91

    DB:2.91:Whatis Wrong With My sa


    We just installed 3.2.1 APEX on solaris 10 x86 . When we try to using its DBI/DBD modules, got following error
    BEGIN failed--compilation aborted at /apex/app/oracle/product/10.2.0/HTTPServer/perl/lib/site_perl/5.6.1/i86pc-solaris/DBI.pm line 152.

    Here is my env setup

    APEX_HOME=/apex/app/oracle/product/10.2.0/HTTPServer
    ORACLE_HOME=/apex/app/oracle/product/10.2.0/HTTPServer
    PERL5LIB=/apex/app/oracle/product/10.2.0/HTTPServer/perl/lib/5.6.1:/apex/app/oracle/product/10.2.0/HTTPServer/perl/lib/site_perl/5.6.1/i86pc-solaris
    LD_LIBRARY_PATH=/apex/app/oracle/product/10.2.0/HTTPServer/lib32:/apex/app/oracle/product/10.2.0/HTTPServer/lib:/usr/lib:/usr/local/lib:.

    Could somebody help me understand What I am missing to use perl DBI/DBD modules in our script?

    DB:2.91:Whatis Wrong With My sa

    This sounds like more of a database issue than APEX, you might want to post this in the general database forum..

    Thank you,

    Tony Miller
    Webster, TX

  • RELEVANCY SCORE 2.91

    DB:2.91:Perl_Gthr_Key_Ptr a9





    I am trying to run a psadump but keep getting the following error.. Any suggestion?

    [root@plesk /]# /usr/local/psa/bin/psadump -F -f - | split -b1000m - dump

    get the following error:
    /usr/bin/perl: relocation error: /usr/local/psa/lib/perl5/site_perl/5.8.0/i386-linux/auto/DBI/DBI.so: undefined symbol: Perl_Gthr_key_ptr

  • RELEVANCY SCORE 2.91

    DB:2.91:Dbd::Mysql 1k





    Has anyone been able to install the DBD drivers for mysql? I am running RH Linux 7.1. I downloaded the DBI module from cpan and they installed fine. I then downloaded the DBD module and tried to run perl Makefile.PL but got an error:

    Cant locate DBI/DBD.pm in @INC (@INC contains: /usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at Makefile.PL line 5.

    Is there a way to solve this without adding the path to DBI in Makefile.PL?

    DB:2.91:Dbd::Mysql 1k




    ports

    The Freebsd ports are my best friends.

    Live was made very simple because of these ports.
    You can also use Cpan.

  • RELEVANCY SCORE 2.91

    DB:2.91:Installation Problem Rpm 5.05 Rh.73 8m





    [root@info base]# rpm -Uvh psa-5.0.5-rh7.3.build030207.16.i586.rpm
    Preparing... ########################################### [100%]
    package psa-5.0.5-rh7.3.build030207.16 is already installed
    [root@info base]# rpm -Uvh psa-courier-imap-add-5.0.5-rh7.3.build030207.16.i586.
    rpm
    Preparing... ########################################### [100%]
    package psa-courier-imap-add-5.0.5-rh7.3.build030207.16 is already installed
    [root@info base]# rpm -Uvh psa-locale-5.0.5-rh7.3.build030207.16.noarch.rpm
    Preparing... ########################################### [100%]
    package psa-locale-5.0.5-rh7.3.build030207.16 is already installed
    [root@info base]# rpm -Uvh psa-proftpd-1.2.5rel-rh7.3.build030207.16.i586.rpm
    Preparing... ########################################### [100%]
    package psa-proftpd-1.2.5rel-rh7.3.build030207.16 is already installed
    [root@info base]# rpm -Uvh psa-proftpd-xinetd-1.2.5rel-rh7.3.build030207.16.i586
    .rpm
    Preparing... ########################################### [100%]
    package psa-proftpd-xinetd-1.2.5rel-rh7.3.build030207.16 is already installed
    [root@info base]# rpm -Uvh psa-qmail-1.03-rh7.3.build030207.16.i586.rpm
    Preparing... ########################################### [100%]
    package psa-qmail-1.03-rh7.3.build030207.16 is already installed
    [root@info base]# rpm -Uvh psa-qmail-rblsmtpd-0.70-rh7.3.build030207.16.i586.rpm

    Preparing... ########################################### [100%]
    1sa-qmail-rblsmtpd ########################################### [100%]

    [root@info rpm_RedHat7.3]# sh query_rpm_for_prod.sh -vvv
    Red Hat Linux release 7.3 (Valhalla)
    package @@PRODNAME@@ is not installed
    package @@PRODNAME@@-locale is not installed
    package @@PRODNAME@@-proftpd is not installed
    package @@PRODNAME@@-proftpd-xinetd is not installed
    package @@PRODNAME@@-qmail is not installed
    courier-imap-1.4.6-16psa.rh7.3
    package @@PRODNAME@@-courier-imap-add is not installed
    webalizer-2.01_10-1
    package mod_frontpage is not installed
    package frontpage is not installed
    bind-9.2.1-1.7x.2
    bind-utils-9.2.1-1.7x.2
    ntp-4.1.1-1
    xinetd-2.3.7-4.7x
    stunnel-3.22-1
    apache-1.3.27-2
    mod_perl-1.26-5
    mod_ssl-2.8.12-2
    php-4.1.2-7.3.6
    php-imap-4.1.2-7.3.6
    php-mysql-4.1.2-7.3.6
    mysql-3.23.49-3
    mysql-server-3.23.49-3
    perl-5.6.1-34.99.6
    perl-CGI-2.752-34.99.6
    perl-CPAN-1.59_54-34.99.6
    perl-DateManip-5.40-15
    perl-DBD-MySQL-1.2219-6
    perl-DBD-Pg-1.01-8
    perl-DB_File-1.75-34.99.6
    perl-DBI-1.21-1
    perl-Digest-MD5-2.20-1
    perl-HTML-Parser-3.26-2
    perl-HTML-Tagset-3.03-14
    perl-libnet-1.0901-17
    perl-libwww-perl-5.63-9
    perl-libxml-enno-1.02-15
    perl-libxml-perl-0.07-14
    perl-MIME-Base64-2.12-14
    perl-NDBM_File-1.75-34.99.6
    perl-Parse-Yapp-1.05-15
    perl-SGMLSpm-1.03ii-4
    perl-Storable-1.0.14-15
    perl-URI-1.17-16
    perl-XML-Dumper-0.4-12
    perl-XML-Encoding-1.01-9
    perl-XML-Grove-0.46alpha-11
    perl-XML-Parser-2.30-15
    perl-XML-Twig-2.02-9
    openssl-0.9.6b-32.7
    binutils-2.11.93.0.2-11
    textutils-2.0.21-1
    shadow-utils-20000902-9.7
    perl-5.6.1-34.99.6
    sed-3.02-11
    [root@info rpm_RedHat7.3]#

    how i install psa ? pls help me

    DB:2.91:Installation Problem Rpm 5.05 Rh.73 8m




    I had to rpm -Uvh --force (rpm here) most of my RPMs. When I didnt it never seemed to work.
    If you get any errors do the Force. Even if it tells you its already installed.

  • RELEVANCY SCORE 2.91

    DB:2.91:Retereiving Rows From The Result Set m3


    Perl DBI has a function fetchrow_hashref, which returns a hash reference where names of columns are keys while the values are well values. This makes it somewhat easier to retreive data, without having too much prior knowledge of the data. Is there anythign similar in Java?

    DB:2.91:Retereiving Rows From The Result Set m3

    But for display purposes only couldn't I just
    retereive everything as a String?For most fields yes but not all.

    For some fields (like dates) you may not like the output formatting which could be easily modified if you had a Date object.

    Then for Blobs and Clobs goodness knows what you'll get. Probably something untoward.

  • RELEVANCY SCORE 2.90

    DB:2.90:[Solved]Cannot Install Mysql Correctly 77



    HiIf i try install mysql I get this errror:
    chown: invalid user: mysql
    Cannot change ownership of the database directories to the mysql
    user. Check that you have the necessary permissions and try again.
    error: command failed to execute correctly
    Optional dependencies for mysql
    perl-dbi
    perl-dbd-mysql

    DB:2.90:[Solved]Cannot Install Mysql Correctly 77


    Gcool - thanks for temporarily fixing, it works. But I need permanently fix

    This topic is solved, I moved discuss here

  • RELEVANCY SCORE 2.90

    DB:2.90:Ispcp Omega px



    I found this great new project called IspCP at http://www.isp-control.net/Its a fork of VHCS if anyone is familiar with that. In short terms, its a Multi Server Control and Administration Panel.

    Heres a list of current supported distributions: http://www.isp-control.net/ispcp/wiki/u … ll/distros

    My plan is to have archlinux on that list, here are a list of the deps: http://www.isp-control.net/component/op … view/id,3/

    Now, there are some of those packages which I havent found yet, i will post my list of archpackages when i get home tonight.

    Does anyone like to collaborate with me on this? just pm/email me.

    ---

    Ok, heres the packagelist, those that im uncertain of has a ?mark or a note behind them, the name of those packages are taken from the list further up in my post, the packages without ?mark or a note are package that Ive managed to find, I havent tested to see if all deps are contained within the packages already installed, me thinks not, so if anyone got a clue, let me know.

    Ive also switched to xtermins repo for perl stuff: http://xtermin.us/archperl/
    01. mysql
    01. perl-berkeleydb
    02. libc
    03. perl-crypt-blowfish
    04. perl-crypt-cbc
    05. perl-passwd-md5
    06. perl-date-calc
    07. perl-date-manip
    08. perl-dbd-mysql
    09. perl-dbi
    10. perl-io-stringy
    11. perl-mail-sendmail
    12. perl-mailtools
    13. libmime-base32-perl ?
    14. libmime-perl ?
    15. perl-net-dns
    16. libnet-netmask-perl ?
    17. libnet-perl ?
    18. libnet-smtp-server-perl (Could be smtpprox)
    19. libperl5.8 (Could be perl-libwww)
    20. libsnmp-session-perl (Could be perl-net-snmp)
    21. perl-term-readkey
    22. perl-timedate
    23. perl
    24. perl-base
    25. perl-modules ?
    26. perl-term-read-password
    27. apache
    28. php
    29. gcc
    30. nfs-utils
    31. libc6 ?
    32. procmail
    33. postfix
    34. courier-authlib
    35. courier-imap
    36. courier-maildrop
    37. courier-mta
    38. libsasl
    39. make
    40. bind
    41. proftpd (Might need to be rebuilt with tls)
    42. pam_mysql

    DB:2.90:Ispcp Omega px


    I have created a Arch Linux PKGBUILD and submitted it into the AUR(Arch User Repositry),https://wiki.archlinux.org/index.php/IspCP.A related wiki page was also created to explain the post-setup work need to be done,https://wiki.archlinux.org/index.php/IspCP.

  • RELEVANCY SCORE 2.90

    DB:2.90:Perl Dbi/Dbd::Mysql - Mysql Libraries And Header Files jm





    To my surprise, the new Plesk-based box does not come with Perl DBI DBD::mysql installed.

    After trying to install them via:

    perl -MCPAN -e shell
    force install DBI (fails some test and requires force)
    install DBD::mysql

    DBD::mysql fails because it cant find mysql.h

    rpm -qa does not show that the required mysql Libraries and header files Client programs are installed (per the mysql book para 2.7.1).

    These are available at: http://www.mysql.com/downloads/mysql-3.23.html

    However, these are version 3.23.56 and my new server is 3.23.54a. They wont install and complain that the files are in conflict with the installed version.

    SO, the QUESTION IS: where do I go from here? Are the proper versions of the RPM files available somewhere or do I have to upgrade the database to v3.23.56. If I have to upgrade, what is the procedure for a Plesk box? Any risks of something else going up in smoke in the process?

    thanks in advance.

    DB:2.90:Perl Dbi/Dbd::Mysql - Mysql Libraries And Header Files jm




    There are command line options that you can use in order to point the DBD::MySQL install to the correct location. However I had to do this without using the MCPAN utility.

    This is the command line I used after downloading the .tar.gz file and unpacking it:

    perl Makefile.PL --cflags=-I/usr/local/psa/mysql/include/mysql --libs=-L/usr/local/psa/mysql/lib/mysql -lmysqlclient -lz -lcrypt -lnsl -lm

    Once I did this I could run:

    make test

    or

    make install

    without any problems.

    NOTE - I run the standard install. RPM install of PSA may have different directory structure.

    Hope this helps!

    Rob

  • RELEVANCY SCORE 2.89

    DB:2.89:Error In Dbi-≫Connect 7k


    Hi,
    I am trying to connect to the database froma perl script with the following command and i got the error below:
    DBI-connect( "dbi:Oracle:service_name", "$username", "$password", {AutoCommit = 0 , RaiseError = 1} ) or die "Can't connect to Oracle database: $DBI::errstr\n";

    and the error message is
    nstall_driver(Oracle) failed: Can't load '/appl/oracle/10.2.0/perl/lib/site_perl/5.8.3/aix-thread-multi/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: Could not load module /appl/oracle/10.2.0/perl/lib/site_perl/5.8.3/aix-thread-multi/auto/DBD/Oracle/Oracle.so.
    Dependent module /appl/oracle/10.2.0/lib/libclntsh.a(shr.o) could not be loaded.
    The module has an invalid magic number.
    Could not load module /appl/oracle/10.2.0/perl/lib/site_perl/5.8.3/aix-thread-multi/auto/DBD/Oracle/Oracle.so.
    Dependent module /appl/oracle/10.2.0/perl/lib/site_perl/5.8.3/aix-thread-multi/auto/DBD/Oracle/Oracle.so could not be loaded. at /appl/oracle/10.2.0/perl/lib/5.8.3/aix-thread-multi/DynaLoader.pm line 229.
    at (eval 2) line 3
    Compilation failed in require at (eval 2) line 3.
    Perhaps a required shared library or dll isn't installed where expected

    Any idea?
    I am on Oracle server on AIX 5.3 64bit
    Regards,
    Badri.

    DB:2.89:Error In Dbi-≫Connect 7k

    If you installed another perl in 64 bit on your system then make sure you installed the DBD and DBI modules alson on 64 bit perl. Check the first line of you perl script which starts with #! it should refer to your 64 bit perl. And also try:

    export PERL5LIB=/appl/oracle/10.2.0/perl/lib/site_perl/5.8.3

    Daljit Singh

  • RELEVANCY SCORE 2.88

    DB:2.88:Errors Connecting To Oracle Via Perl Dbi 7m


    Hi List.

    I've installed Oracle on my linux box (SuSE 10) and I've installed
    DBD::Oracle.

    I can run sqlplus as the oracle user however when I try and connect via
    DBD::Oracle in a perl script I always get errors as follows:

    connect string =
    my $dbh = DBI-connect("dbi:Oracle:ORCL", 'oracle', 'oracle' );

    error =
    DBI connect('ORCL','oracle',...) failed: ORA-12541: TNS:no listener (DBD
    ERROR: OCIServerAttach) at ora1.pl line 7
    Connection Failed...

    connect string =
    my $dbh = DBI-connect("dbi:Oracle:HOST=linux.site;SID=ORCL;PORT=1522",
    'oracle', 'oracle' );

    error =
    DBI connect('HOST=linux.site;SID=ORCL;PORT=1522','oracle',...) failed:
    ORA-12541: TNS:no listener (DBD ERROR: OCIServerAttach) at ora1.pl line 7
    Connection Failed...

    Maybe I have the connect string wrong?

    Below is a listing of my code, and my tnsnames.ora:
    Thanks in advance for your help.

    ############ code listing ################ #!/usr/bin/perl

    use DBI;

    print "Started\n";

    my $dbh = DBI-connect("dbi:Oracle:HOST=linux.site;SID=ORCL;PORT=1522",
    'oracle', 'oracle' );

    if ($dbh) {
    print "Connected...\n";
    }
    else {
    print "Connection Failed...\n";
    exit;
    }

    my $qry = $dbh-prepare("select count(*) from dba_tables");
    $qry-execute();

    my @data = $qry-fetchrow_array();

    print "[$data[0]] [$data[1]] [$data[2]]\n";

    exit;

    ######### tnsnames.ora listing #####################
    # Generated by Oracle configuration tools.

    LISTENER_ORCL =
    (ADDRESS = (PROTOCOL = TCP)(HOST = linux.site)(PORT = 1522))

    ORCL =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = linux.site)(PORT = 1522))
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = orcl)
    )
    )

    EXTPROC_CONNECTION_DATA =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC2))
    )
    (CONNECT_DATA =
    (SID = PLSExtProc)
    (PRESENTATION = RO)
    )
    )

    DB:2.88:Errors Connecting To Oracle Via Perl Dbi 7m

    'TNS: no listener' usually means that your listener hasn't been started. Try a lsnrctl status to find out whether your Listener is actually running.

  • RELEVANCY SCORE 2.88

    DB:2.88:Unable To Connect Oracle Dbd Error kk


    Hi all,

    I am using Perl to connect Oracle database. OS is Linux and I use to connect two different database depends upon the TWO_TASK environment variable. TWO_TASK values may be 'saph_db1' or 'saph_db2', and both the databases are Oracle9i Enterprise Edition Release 9.2.0.5.0. Both database are residing in two different machins.
    Linux version is 2.4.21-15.ELsmp on an i686,
    Perl version is 5.8.4 built for i686-linux,

    The perl code is as below

    #!/usr/bin/perl
    use DBI;
    $user = "a_user";
    $pass = "a_pass";
    my $dbh = DBI-connect("DBI:Oracle:", $user, $pass,{ PrintError = 0,
    AutoCommit = 0 } ) || die "Error = ".$DBI::errstr."\n";
    ---------------------------------------------------------------------------------------------
    This code works fine with saph_db1 database but when I am running with 2nd TWO_TASK value (as saph_db2) the error message is -
    Error = ORA-01017: invalid username/password; logon denied (DBD ERROR: OCISessionBegin)

    I hope some body could help me in this regards? Thanks in advance.

    Thanks
    Ravi

    DB:2.88:Unable To Connect Oracle Dbd Error kk

    Just thinking did you have the same user on saph_db2 also ?

  • RELEVANCY SCORE 2.88

    DB:2.88:How To Install Perl Dbi &Amp; Dbd Modules Correctly? 7k


    PLEASE HELP!

    I'm running OS X Snow Leopard 10.6.3 on a MacBook Pro.

    Using MacPorts I've installed the following items:
    mysql5 @5.1.45_0 (active)
    mysql5-server @5.1.45_0 (active)
    p5-dbd-mysql @4.013_0+mysql5 (active)
    p5-dbi @1.609_0 (active)
    perl5.10 @5.10.1_1+darwin (active)

    Everything seems to be working, with the exception ofthe Perl DBI module, and the DBD module. Whenever I try to run a Perl program using DBI, I get the following error:

    Sun Apr 18 03:18:42 EDT 2010
    ~/Perl1 -
    peterv@MBP17.local520$: db.pl
    install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: /Library/Perl/Updates/5.10.0 /System/Library/Perl/5.10.0/darwin-thread-multi-2level /System/Library/Perl/5.10.0 /Library/Perl/5.10.0/darwin-thread-multi-2level /Library/Perl/5.10.0 /Network/Library/Perl/5.10.0/darwin-thread-multi-2level /Network/Library/Perl/5.10.0 /Network/Library/Perl /System/Library/Perl/Extras/5.10.0/darwin-thread-multi-2level /System/Library/Perl/Extras/5.10.0 .) at (eval 3) line 3.
    Perhaps the DBD::mysql perl module hasn't been fully installed,
    or perhaps the capitalisation of 'mysql' isn't right.
    Available drivers: DBM, ExampleP, File, Gofer, Proxy, SQLite, Sponge.
    at /Users/peterv/Perl1/db.pl line 8

    Sun Apr 18 03:18:42 EDT 2010

    If anyone can also explain what @INC is (I'm assuming it's some kind of path), how to display its value, and how to set it correctly, I'd appreciate that too! I've been working on this for days, so I'd really be grateful for some help!
    Thanks,
    Peter V.

    DB:2.88:How To Install Perl Dbi &Amp; Dbd Modules Correctly? 7k

    I found out the cause of the problem. It seems that I have conflicting versions of Perl MySQL. Perl is 64 bit and MySQL is 32 bit. Once that's been resolved, these errors will be fixed.

  • RELEVANCY SCORE 2.88

    DB:2.88:Please Help, Perl Error, Urgent!!! xs





    Hello to all,

    After I use RHs up2date to update my box. All my Perl scripts is no longer functioning. I did use Skip Package List to skip Perl*. My current vesion of Perl is as below:

    perl-5.6.0-12
    perl-SGMLSpm-1.03ii-4
    mod_perl-1.24_01-2
    perl-DBD-MySQL-1.2215-1
    perl-FreezeThaw-0.41-4psa
    perl-HTML-Parser-3.25-4psa
    perl-HTML-Tree-3.11-4psa
    perl-MLDBM-2.00-4psa
    perl-Storable-1.0.13-4psa
    perl-libwww-perl-5.53-4psa
    groff-perl-1.17.2-7.0.2
    perl-libnet-1.0703-5
    perl-DBI-1.14-10
    perl-Font-AFM-1.18-4psa
    perl-HTML-Format-1.23-4psa
    perl-HTML-Tagset-3.03-4psa
    perl-MIME-Base64-2.12-4psa
    perl-MLDBM-Sync-0.25-3psa
    perl-URI-1.17-4psa
    perl-Apache-ASP-2.29-5psa

    Anyone experience this before? Below are my system info:

    RH Linux 7.1
    PSA 2.5.5 RPM version

    Please help, this is very urgent. Help really appreciate. Thank you.

    Warm regards,
    Dummy

    DB:2.88:Please Help, Perl Error, Urgent!!! xs




    Hi everyone,

    Ive found the error and Ill post the answer here.

    Just copy the suexec file as below:

    cp /usr/sbin/psa-suexec /usr/sbin/suexec

    This will fix my error. Thank you.

    Warm regards,
    Dummy

  • RELEVANCY SCORE 2.88

    DB:2.88:Where Is Mysql? 9s





    I am trying to install the DBI module for PERL, and when installing the MySQL module, it asks:

    Code:

    DB:2.88:Where Is Mysql? 9s




    Havent you already installed perl-DBI-1.14-10.i386.rpm as part of Plesk RPM installation?

  • RELEVANCY SCORE 2.88

    DB:2.88:Unable To Transfer Files Using Asmcmd In Oracle 11g Rel 2 pk


    Gettin the followin error when using ASMCMD to transfer file to remote ASM instance in a different diskgroup.

    ASMCMD cp -ifr data/dbase/spfiledbase.ora sys@dbase_dr.1521.ASM:+DATA2/dbase
    Enter password: *********
    ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)
    ASMCMD-08202: internal error: [asmcmdvol_error_msg_05] [8201]

    Also tried to trace the error using export DBI_TRACE=1 getting the following messages

    [grid@rac1 admin]$ asmcmd
    DBI 1.602-ithread default trace level set to 0x0/1 (pid 17884) at DBI.pm line 273 via asmcmdshare.pm line 180
    - DBI-connect(dbi:Oracle:, , ****, HASH(0x8d51278))
    - DBI-install_driver(Oracle) for linux perl=5.010000 pid=17884 ruid=1100 euid=1100
    install_driver: DBD::Oracle version 1.20 loaded from /u01/app/11.2.0/grid/perl/lib/site_perl/5.10.0/i686-linux-thread-multi/DBD/Oracle.pm
    - STORE('ShowErrorStatement', 1)= 1 at Oracle.pm line 62
    - install_driver= DBI::dr=HASH(0x90513d0)
    - DESTROY(DBI::st=HASH(9058b88))= undef at Oracle.pm line 234
    - connect('', '', ...)= DBI::db=HASH(0x9058ac8) at DBI.pm line 637
    - STORE('PrintError', 0)= 1 at DBI.pm line 689
    - STORE('AutoCommit', 1)= 1 at DBI.pm line 689
    - STORE('Username', '')= 1 at DBI.pm line 692
    FETCH('Username')= '' ('Username' from cache) at DBI.pm line 692
    $h-{'ora_session_mode'}=32768 ignored for invalid driver-specific attribute
    - STORE('ora_session_mode', 32768)= '' at DBI.pm line 692
    - FETCH('ora_session_mode')= undef at DBI.pm line 692
    - connected('dbi:Oracle:', '', ...)= undef at DBI.pm line 698
    - connect= DBI::db=HASH(0x9058ac8)
    - STORE('dbi_connect_closure', CODE(0x90585a8))= 1 at DBI.pm line 707
    - prepare('/* ASMCMD */ select version from v$instance')= DBI::st=HASH(0x88b46e0) at asmcmdshare.pm line 2438
    - execute= '0E0' at asmcmdshare.pm line 2462
    - fetchrow_hashref= HASH(0x87f1300)1keys row1 at asmcmdshare.pm line 2488
    - finish= 1 at asmcmdshare.pm line 2509
    - DESTROY(DBI::st=HASH(9058ae8))= undef at asmcmdcore line 388
    ASMCMD cp -ifr data/dbase/spfiledbase.ora sys@dbase_dr.1521.ASM:+DATA2/dbase/
    Enter password: *********
    - DBI-connect(dbi:Oracle:host=dbase_dr;port=1521;sid=+ASM, sys, ****, HASH(0x9058ca8))
    connect using '(DESCRIPTION=(ADDRESS=(HOST=dbase_dr)(PROTOCOL=tcp)(PORT=1521))(CONNECT_DATA=(SID=+ASM)))' !! ERROR: '12545' 'ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)' (err#0)
    - connect('host=dbase_dr;port=1521;sid=+ASM', 'sys', ...)= undef at DBI.pm line 637
    DBI connect('host=dbase_dr;port=1521;sid=+ASM','sys',...) failed: ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)
    ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)
    ASMCMD-08202: internal error: [asmcmdvol_error_msg_05] [8201]
    - DESTROY(DBI::db=HASH(9058a38))= undef at asmcmdshare.pm line 410
    !! ERROR: '12545' CLEARED by call to disconnect_all method
    - disconnect_all= (not implemented) at DBI.pm line 716
    ! - DESTROY(DBI::dr=HASH(9058238))= undef during global destruction

    Please help resolve this

    DB:2.88:Unable To Transfer Files Using Asmcmd In Oracle 11g Rel 2 pk

    Gettin the followin error when using ASMCMD to transfer file to remote ASM instance in a different diskgroup.

    ASMCMD cp -ifr data/dbase/spfiledbase.ora sys@dbase_dr.1521.ASM:+DATA2/dbase
    Enter password: *********
    ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)
    ASMCMD-08202: internal error: [asmcmdvol_error_msg_05] [8201]

    Also tried to trace the error using export DBI_TRACE=1 getting the following messages

    [grid@rac1 admin]$ asmcmd
    DBI 1.602-ithread default trace level set to 0x0/1 (pid 17884) at DBI.pm line 273 via asmcmdshare.pm line 180
    - DBI-connect(dbi:Oracle:, , ****, HASH(0x8d51278))
    - DBI-install_driver(Oracle) for linux perl=5.010000 pid=17884 ruid=1100 euid=1100
    install_driver: DBD::Oracle version 1.20 loaded from /u01/app/11.2.0/grid/perl/lib/site_perl/5.10.0/i686-linux-thread-multi/DBD/Oracle.pm
    - STORE('ShowErrorStatement', 1)= 1 at Oracle.pm line 62
    - install_driver= DBI::dr=HASH(0x90513d0)
    - DESTROY(DBI::st=HASH(9058b88))= undef at Oracle.pm line 234
    - connect('', '', ...)= DBI::db=HASH(0x9058ac8) at DBI.pm line 637
    - STORE('PrintError', 0)= 1 at DBI.pm line 689
    - STORE('AutoCommit', 1)= 1 at DBI.pm line 689
    - STORE('Username', '')= 1 at DBI.pm line 692
    FETCH('Username')= '' ('Username' from cache) at DBI.pm line 692
    $h-{'ora_session_mode'}=32768 ignored for invalid driver-specific attribute
    - STORE('ora_session_mode', 32768)= '' at DBI.pm line 692
    - FETCH('ora_session_mode')= undef at DBI.pm line 692
    - connected('dbi:Oracle:', '', ...)= undef at DBI.pm line 698
    - connect= DBI::db=HASH(0x9058ac8)
    - STORE('dbi_connect_closure', CODE(0x90585a8))= 1 at DBI.pm line 707
    - prepare('/* ASMCMD */ select version from v$instance')= DBI::st=HASH(0x88b46e0) at asmcmdshare.pm line 2438
    - execute= '0E0' at asmcmdshare.pm line 2462
    - fetchrow_hashref= HASH(0x87f1300)1keys row1 at asmcmdshare.pm line 2488
    - finish= 1 at asmcmdshare.pm line 2509
    - DESTROY(DBI::st=HASH(9058ae8))= undef at asmcmdcore line 388
    ASMCMD cp -ifr data/dbase/spfiledbase.ora sys@dbase_dr.1521.ASM:+DATA2/dbase/
    Enter password: *********
    - DBI-connect(dbi:Oracle:host=dbase_dr;port=1521;sid=+ASM, sys, ****, HASH(0x9058ca8))
    connect using '(DESCRIPTION=(ADDRESS=(HOST=dbase_dr)(PROTOCOL=tcp)(PORT=1521))(CONNECT_DATA=(SID=+ASM)))' !! ERROR: '12545' 'ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)' (err#0)
    - connect('host=dbase_dr;port=1521;sid=+ASM', 'sys', ...)= undef at DBI.pm line 637
    DBI connect('host=dbase_dr;port=1521;sid=+ASM','sys',...) failed: ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)
    ORA-12545: Connect failed because target host or object does not exist (DBD ERROR: OCIServerAttach)
    ASMCMD-08202: internal error: [asmcmdvol_error_msg_05] [8201]
    - DESTROY(DBI::db=HASH(9058a38))= undef at asmcmdshare.pm line 410
    !! ERROR: '12545' CLEARED by call to disconnect_all method
    - disconnect_all= (not implemented) at DBI.pm line 716
    ! - DESTROY(DBI::dr=HASH(9058238))= undef during global destruction

    Please help resolve this

  • RELEVANCY SCORE 2.88

    DB:2.88:Filemaker To Oracle Migration Script 1m


    Members of this forum may be interested in the following Perl DBI script which migrates FileMaker text and image data to Oracle: http://www.dotcomsolutionsinc.net/products/fmpro_migrator/oracle_files/fmpro_migrator_oracle_xfer_odbc1.html

    David Simpson
    http://www.dotcomsolutionsinc.net

    DB:2.88:Filemaker To Oracle Migration Script 1m

    Members of this forum may be interested in the following Perl DBI script which migrates FileMaker text and image data to Oracle: http://www.dotcomsolutionsinc.net/products/fmpro_migrator/oracle_files/fmpro_migrator_oracle_xfer_odbc1.html

    David Simpson
    http://www.dotcomsolutionsinc.net

  • RELEVANCY SCORE 2.88

    DB:2.88:Problem With Pl/Sql Script In Perl Module 99


    I keep getting this error:
    DBD::Oracle::st execute failed: ORA-06550: line 6, column 23:
    PLS-00201: identifier 'BLAH' must be declared
    ORA-06550: line 6, column 4:
    PL/SQL: Statement ignored (DBD ERROR: OCIStmtExecute) [for Statement "
    declare

    ret integer;
    BEGIN
    ret:= SIMPLE.func2(blah);

    ? :=ret;
    END;
    " with ParamValues: :p1=undef] at simple.pm line 35.

    ------------------------------------------------------------------------------------------

    Bellow is the actuall perl script and the pl/sql package body.
    please help

    #!/usr/local/bin/perl

    use DBI;

    my $dbh = DBI-connect( secret
    ) || die "Database connection not made: $DBI::errstr";

    my $moo = 'blah';

    my $sth = $dbh-prepare ( qq
    (
    declare

    ret integer;
    BEGIN
    ret:= SIMPLE.func2($moo);

    ? :=ret;
    END;
    ));
    my $ret;
    $sth-bind_param_inout ( 1, \$ret, 10 );
    $sth-execute();
    print $ret;

    #package in DB compiles fine
    #PACKAGE BODY SIMPLE
    #IS

    # FUNCTION func2
    # (
    # param2 IN VARCHAR2)
    # RETURN INTEGER
    # is
    # BEGIN
    # RETURN 12;
    # END;

    #END;

    DB:2.88:Problem With Pl/Sql Script In Perl Module 99

    Good stuff.

    And stick to bind variables like a bikini to a supermodel's body. Using bind variables will have a significant performance increase for your Perl-DBI code - and what's more, it will not trash Oracle's Shared Pool.

    Using a small little Perl programming (reading UDP data, unpacking it, and stuffing the results into Oracle), we are managing 100's of inserts into an Oracle table per second. Correctly used, Oracle is very very fast.

  • RELEVANCY SCORE 2.88

    DB:2.88:Access Oracle 10g Xe With Perl sa


    I'm using ubuntu lucid as OS, oracle 10g xe as db and want to access the oracle db via perl.
    Installed software:
    libdbd-oracle-perl 1.21-2
    libdbi-perl 1.609-1build1
    perl, v5.10.1 (*) built for i486-linux-gnu-thread-multi
    oracle-xe-universal 10.2.0.1-1.0
    oracle-instantclient-basic 10.2.0.3-2

    after using
    #!/usr/bin/perl

    my $ORACLE_HOME = "/usr/lib/oracle/xe/app/oracle/product/10.2.0/server";
    my $ORACLE_SID="XE";

    $ENV{ORACLE_HOME}=$ORACLE_HOME;
    $ENV{ORACLE_SID}=$ORACLE_SID;
    $ENV{PATH}="$ORACLE_HOME/bin";
    # $ENV{LD_LIBRARY_PATH}="$ORACLE_HOME/lib";

    use strict;
    use DBI;
    my $dbh = DBI-connect( 'dbi:Oracle:XE@localhost','scott','tiger',{ RaiseError = 1, AutoCommit = 0 }
    ) || die "Database connection not made: $DBI::errstr";

    $dbh-disconnect;I get the error:

    wucis@dell6400:~/perlora$ perl zugriff1.pl
    DBI connect('XE@localhost','scott',...) failed: ORA-12154: TNS:could not resolve the connect identifier specified (DBD ERROR: OCIServerAttach) at zugriff1.pl line 13

    although sqlplus scott/tiger works properly

    DB:2.88:Access Oracle 10g Xe With Perl sa

    I use this script:
    pre class="jive-pre"
    #!/usr/bin/perl

    use DBI;

    $SRVDBHost = "localhost";
    $dbuser = "db_user_name";
    $dbpass = "password";
    $sid = "SID_Database";
    $SRVDBPort="1521"; #!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    #Connect to DB
    $ora = DBI-connect("DBI:Oracle:host=$SRVDBHost;sid=$sid;port=$SRVDBPort", $dbuser, $dbpass,
    { RaiseError = 1, AutoCommit = 1 } )|| die "Database connection not made: $DBI::errstr";
    /pre

    Edited by: 884600 on 12.09.2011 3:50

  • RELEVANCY SCORE 2.88

    DB:2.88:Rman Script In Perl 37


    Hi, I want to ask if there is a way to write the rman commands in PERL such that I won't have to redirect the commands to an external file? Is there a module that can be used similar to DBI for sql statements?

    Thanks!

    DB:2.88:Rman Script In Perl 37

    Not that I know!

    When you use RMAN you must be very careful: you must know what are you doing. You have easy procedures as others that require much attention. For these reason it is suitable to use RMAN directly.

    This example creates a command file and then runs it from the operating system command line:

    echo "BACKUP DATABASE;" backup_db.rman
    rman TARGET / @backup_db.rmanAron

  • RELEVANCY SCORE 2.88

    DB:2.88:Help!! Rhel With Mysql Installation Issue p8



    Hi,

    I am having trouble to install MySQL to my RHEL Virtual Machine.

    I have tested the installation on a physical machine, it is installed with no problem, however when I install it to my RHEL vm, it returns the following error:

    error: Failed dependencies: perl(DBI) is needed by MySQL-server-enterprise-gpl-5.0.56sp1-0.rhel5.x86_64

    I was trying to install MySQL server into my RHEL 5.1 and 5.4 (64bit) vm, and they both returned the above error.

    Evnthough I have installed the DBI with perl, the error still exist.Please could you provide support in this matter?

    Here are some info for your reference:

    [root@localhost ~]# rpm -i MySQL-server-enterprise-gpl-5.0.56sp1-0.rhel5.x86_64.rpmerror: Failed dependencies: perl(DBI) is needed by MySQL-server-enterprise-gpl-5.0.56sp1-0.rhel5.x86_64[root@localhost ~]# perl -MDBI -e1[root@localhost ~]# perl -M'DBI 999' -e1 DBI version 999 required--this is only version 1.52.

    Please, are there any VM experts or Redhat experts can help me on this issue?

    Many thanks

    Kind Regards

    Juewei

    DB:2.88:Help!! Rhel With Mysql Installation Issue p8


    Hi,

    I am having trouble to install MySQL to my RHEL Virtual Machine.

    I have tested the installation on a physical machine, it is installed with no problem, however when I install it to my RHEL vm, it returns the following error:

    error: Failed dependencies: perl(DBI) is needed by MySQL-server-enterprise-gpl-5.0.56sp1-0.rhel5.x86_64

    I was trying to install MySQL server into my RHEL 5.1 and 5.4 (64bit) vm, and they both returned the above error.

    Evnthough I have installed the DBI with perl, the error still exist.Please could you provide support in this matter?

    Here are some info for your reference:

    [root@localhost ~]# rpm -i MySQL-server-enterprise-gpl-5.0.56sp1-0.rhel5.x86_64.rpmerror: Failed dependencies: perl(DBI) is needed by MySQL-server-enterprise-gpl-5.0.56sp1-0.rhel5.x86_64[root@localhost ~]# perl -MDBI -e1[root@localhost ~]# perl -M'DBI 999' -e1 DBI version 999 required--this is only version 1.52.

    Please, are there any VM experts or Redhat experts can help me on this issue?

    Many thanks

    Kind Regards

    Juewei

  • RELEVANCY SCORE 2.88

    DB:2.88:Perl Script And Unix Users 7k


    Hi, I have a perl script that connects to a regular users account, using DBI/DBD::Oracle. It works fine is the UNIX user is in the oinstall group, but if its in oracle, dba or neither it gives me the following error:

    DBI connect('orcl','xxxxxxx',...) failed: ORA-24327: need explicit attach before authenticating a user (DBD ERROR: OCISessionBegin) at /terida/opt/smarthost/updatedatabases.pl line 15

    I'm guessing here that Perl DBD::Oracle needs access to a specific file in the oracle installation perhaps ? I'm also gonna wager that letting it live in the oinstall group is not recommended..

    Tips?

    Thanks

    DB:2.88:Perl Script And Unix Users 7k

    Silly error message, your workaround worked a treat for me!

    Cheers!

  • RELEVANCY SCORE 2.88

    DB:2.88:Dbi 9m


    Anyone know where to download the DBI Module for Perl?

    I went to the Perl website and all i get is this 0.5MB zip file that has nothing in it to extract.

    I need this to write some Perl scripts to hit some of mt Oracle Databases.

    DB:2.88:Dbi 9m

    change the file name from

    DBI-1.58.tar.tar
    to
    DBI-1.58.tar.gz

    Shud work now

  • RELEVANCY SCORE 2.88

    DB:2.88:Re: Sqlplus Fails To Start, Halting Ora10g Install On Winxp mk


    I solved this. In my case the problem was related to a Perl installation I had. It was using a oci.dll version that doesn't work with sqlplus. Once I removed the DBI-DBD perl package sqlplus worked again.

    Regards
    Galo

    DB:2.88:Re: Sqlplus Fails To Start, Halting Ora10g Install On Winxp mk

    Hi,

    U need to reinstall Oracle because if some component of oracle crashed, It is very hard to recover that one. Nothing with SP.
    So u need to do the following steps.

    1. Uninstall ur oracle from Oracle Universal Installer and reboot ur machine.
    2. Check oracle services should not exist in services.
    3. Go to Run and write regedit (Registery Editor) will open and find here word ORACLE and remove all.
    4. Reboot the machine and install again oracle.
    5. After Installation u need to add ORACLE_HOME environment variable.

    Hopefully it will helpful.

    Regards,

    Rizi

  • RELEVANCY SCORE 2.85

    DB:2.85:Perl Samples? Where Are They? 8k


    otn has a bunch of html pages w/ instructions for running perl-dbi-oracle samples (hotel res. , guest book, hello, ect).
    these pages have links to get mod_perl, dbi, dbd , but nowhere can
    I find the perl sample code itself. help please, oracle. Miked

    DB:2.85:Perl Samples? Where Are They? 8k

    thanks abhijeet. since this is the suggestions/feedback page, i would suggest links to the zip from the tutorial/examples html pages.
    thanks again. md

  • RELEVANCY SCORE 2.85

    DB:2.85:Unable To Get Cpan Module Dbi To Work With Apache And Mod_Perl 1a


    I was able to dig around and finally found the mod_perl lib, added that to the apache config and was able to start apache successfully.

    I then updated my cpan modules for Perl 5.8.8 (ended up removing the 5.8.6 library as I had warnings of possible conflicts... putting it back didn't seem to make any difference in this issue).

    So I started putting together my config for my web applications and I cannot for the life of me get it booted with using DBI successfully.

    I keep getting this error:
    [Mon Oct 29 12:04:39 2007] [error] Can't load '/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DBI/DBI.bundle' for module DBI: dlopen(/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DBI/DBI.bundle, 1): no suitable image found. Did find:\n\t/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DBI/DBI.bundle: no matching architecture in universal wrapper at /System/Library/Perl/5.8.8/darwin-thread-multi-2level/DynaLoader.pm line 230.\n at /Library/Perl/5.8.8/darwin-thread-multi-2level/DBI.pm line 266\nBEGIN failed--compilation aborted at /Library/Perl/5.8.8/darwin-thread-multi-2level/DBI.pm line 266.\nCompilation failed in require at /Library/WebServer/Documents/timewarneracm/lib/ACMhandler.pm line 7.\nBEGIN failed--compilation aborted at /Library/WebServer/Documents/timewarneracm/lib/ACMhandler.pm line 7.\nCompilation failed in require at (eval 3) line 3.\n

    To note:
    1. I have successfully loaded and used the DBI module with a regular perl script
    2. I have installed, uninstalled, made by hand, etc, etc the DBI module with no errors.

    Any ideas? I've used previous versions of Mac OS X successfully for my web development, but I cannot get around this. Any ideas? Thoughts?

    DB:2.85:Unable To Get Cpan Module Dbi To Work With Apache And Mod_Perl 1a

    I know I'm late to this thread, but I just recently discovered the same problem and have not been able to get CPAN to compile universal binaries with the ARCHFLAGS variable set.

    It appears the problem is that while Apache2 was compiled as a universal binary supporting 64 bit architectures, perl itself was built for 32 bit only (perhaps with good reason), and so there is this basic incompatibility between the two.

    I gave up and rebuilt Apache from scratch with mod_perl statically compiled inside. My request is just that in a future update, Apple make some effort to see that the two provided binaries work together. Would be appreciated.