• RELEVANCY SCORE 4.69

    DB:4.69:Plesk 11 And Php 5.3.29 Plesk Panel V11.0.9 f3







    Is that possible to update to PHP 5.3.29 ?
    By default it uses 5.3.10
    Version Plesk Panel v11.0.9_build110120608.16
    OS Ubuntu 12.04.5 LTS

    Regards,
    Rob

    DB:4.69:Plesk 11 And Php 5.3.29 Plesk Panel V11.0.9 f3




    So can you help in this case how to update .10 to .29 ?

  • RELEVANCY SCORE 3.78

    DB:3.78:Is It Possible To Have Both Php Versions (5.2 And 5.3) After Update To Plesk 11? ad







    Hello,

    I am using Plesk 10 on a Windows dedicated server.

    I read on Parallels website that version 11 will upgrade PHP to 5.3.

    Is it possible to keep PHP 5.2 together with PHP 5.3?

    Thank you for your help.

    DB:3.78:Is It Possible To Have Both Php Versions (5.2 And 5.3) After Update To Plesk 11? ad




    Hello,

    Yes you can have multiple phps,for that you will need to go to upgrades and updates section hosting features and select the versions that you want to install on your server.

  • RELEVANCY SCORE 3.75

    DB:3.75:Php 5.3 / Mysql 5.5 pc







    Hi,

    how can I install PHP 5.3 and MySQL 5.5 on an Windows Server 2008 R2 with Plesk 10.4.4 ???

    DB:3.75:Php 5.3 / Mysql 5.5 pc




    ok ... and what about MySQL 5.5 ???

    on Plesk 10.4.4 it is only MySQL 5.1.56 installes :-/

  • RELEVANCY SCORE 3.71

    DB:3.71:Plesk 11.5 Easy Install Script For Multiple Php Centos 6.4 X64 sx





    This project is no longer maintained
    I recommend switching to PHP Panda http://forum.parallels.com/showthread.php?293750-PHP-Panda!-Multi-PHP-installer-for-Plesk

    The following script I made will automate these tasks:

    - Install needed dependencies
    - Download and extract sources
    - Configure and make sources
    - Install and register new PHP
    - You will then be able to find the new PHP version in Plesk - Domain - Websites Domains - Web Hosting Access - PHP - FastCGI

    Code:

    DB:3.71:Plesk 11.5 Easy Install Script For Multiple Php Centos 6.4 X64 sx




    Hello fellas,

    our manager install php 5.2 and 5.4 into CGI mode, but when when we change for anyone of this two version we lost access to mysql.
    when i run info.php, appear that mysql is not installed.

    a) how to have mysql in all of them?

    b) Is better to add into fastCGI than just CGI?

    thanks!

  • RELEVANCY SCORE 3.68

    DB:3.68:Fcgi Problem While Setting Up Two Versions Of Php ax





    Hi,

    I am developing a crawler which require PCRE v7+ in PHP. The Plesk version of PHP has PCRE version 6.6 which is not enough. So, I decided to install a second version of PHP. I used this guide (http://kb.parallels.com/114753) as the source and tried to install PHP 5.4.7. Everything looks good in configuration (wrapper, vhost, permissions) But I am getting 500 Internal server Error on my domain. Server error log says



    [Thu Oct 11 15:04:29 2012] [warn] [client 74.208.205.191] (104)Connection reset by peer:
    mod_fcgid: error reading data from FastCGI server
    [Thu Oct 11 15:04:29 2012] [error] [client 74.208.205.191] Premature end of script headers: index.php

  • RELEVANCY SCORE 3.58

    DB:3.58:Upgrading Php 5.2 To 5.3 Plesk 9.5.4 xs





    Hi guys,

    Anyone knows how i can upgrade my PHP 5.2 to 5.3 on Plesk 9.5.4?

    Please its a little urgent.

    Thanks

  • RELEVANCY SCORE 3.55

    DB:3.55:Multiple Php Version Plesk 11.5.30 1j





    We have plesk panel 11.5.30 with php 5.4 version. The problem is some of the my sites works only in php 5.3. How can I downgrade php version or how can run multiple php in single server.

    Referred KB article not helped
    http://kb.parallels.com/en/111711

    http://kb.parallels.com/en/118378

    Thanks

  • RELEVANCY SCORE 3.51

    DB:3.51:Plesk 8.1 Php Upgrade xs





    Hello

    I have waited for a while to see if Plesk would upgrade my version of PHP from 4.3.9 to any version above 5. Now I am beginning to think the Plesk updater is not capable of updating PHP.

    Is there a way to install a version of PHP 5 that will replace my current version and play nice with Plesk and its other components?

    My server OS is CentOS 3.x and I am more or less a complete linux no0b!

    Any help would be deeply appreciated.

    Thank you
    Dav

    DB:3.51:Plesk 8.1 Php Upgrade xs




    Update: The atomic support have fixed the installer and I have successfully installed PHP 5.2.3

    Thank you guys!

  • RELEVANCY SCORE 3.47

    DB:3.47:Php-Fpm.Sock Failed (13: Permission Denied) While Connecting To Upstream k3





    I recently acquired a brand-new CentOS 6.3 VPS with Plesk 11.0 pre-installed. After getting everything up and running and installing some additional PHP versions I noticed that Nginx worked but Nginx with PHP-FPM enabled caused 502 Bad Gateway errors.

    Today I took the time to completely reinstall following these steps:
    1. Reinstall CentOS6.3 / Plesk Image.
    2. Activate Plesk panel 11.0
    3. Yum Update all system and package files.
    4. Update to Plesk 11.5.30 Update #8
    5. Enable RoundCube through Add or Remove Components
    6. Check if all components are up to date through the panel
    7. Check yum update once more
    8. Install Remi and EPEL repos and give them low priorities to prevent them updating all sorts of files.
    9. Install PHP-FPM through Add or Remove Components
    10. Create new service plan
    11. Create test domain inspyred.nl
    12. Enable Serve static files directly by nginx and Process PHP by nginx
    13. Create info.php (?php phpinfo(); ?) inside the default test folder.
    14. Navigate to inspyred.nl/test/info.php

    The results remains the same: 502 bad gateway.

    I then checked /var/log/php-fpm/error.log for errors:

    Code:

  • RELEVANCY SCORE 3.44

    DB:3.44:Debian 3.1 Plesk 8.2 Php 5 ad





    here a other question
    ive plesk 8.2 running on my system and how can i now upgrade my php4 to php5
    without crashing my plesk ?

    DB:3.44:Debian 3.1 Plesk 8.2 Php 5 ad




    here a other question
    ive plesk 8.2 running on my system and how can i now upgrade my php4 to php5
    without crashing my plesk ?

  • RELEVANCY SCORE 3.38

    DB:3.38:The Newest Pleask 11 With Php 5.3.3 ?? zm





    I cannot understand, why?! :

    The newest Plesk 11 has PHP 5.3.3 on the board.... why it cannot comes with 5.3.24 for example?

    DB:3.38:The Newest Pleask 11 With Php 5.3.3 ?? zm




    Plesk doesn’t ship client’s PHP, it only downloads it from original OS vendor repo and it is quite likely it may be outdated there (especially for older OS). If your OS comes with PHP 5.3.24, then Plesk would run PHP 5.3.24 for clients.

  • RELEVANCY SCORE 3.37

    DB:3.37:Plesk 9.2.2 Php 5.3.8 Fastcgi Session Problem 1k





    Plesk 9.2.2 php 5.3.8 CentOS release 5.6 (Final) using fastcgi

    My webhost recently upgraded php on my dedicated server from 5.1.8 to 5.3.8

    Now I cannot use php sessions.

    ... Self edit: Now solved.

    DB:3.37:Plesk 9.2.2 Php 5.3.8 Fastcgi Session Problem 1k




    Plesk 9.2.2 php 5.3.8 CentOS release 5.6 (Final) using fastcgi

    My webhost recently upgraded php on my dedicated server from 5.1.8 to 5.3.8

    Now I cannot use php sessions.

    ... Self edit: Now solved.

  • RELEVANCY SCORE 3.37

    DB:3.37:Plesk 11.5 Wrongly Detects Php 5.2.17 As Just Php 5 mk





    Custom versions for 5.3, 5.4 and 5.5 all get detected with correct subversion.
    But for 5.2.17 it just says PHP 5.

    This is the version output of the fresh compiled PHP 5.2.17:

    /usr/local/php5.2.17-cgi/bin/php-cgi -q -c /usr/local/php5.2.17-cgi/etc/php.ini ?php print phpversion(); ?
    5.2.17

    But Plesk shows PHP 5 as version when using this handler.

    I can fix this using:

    mysql -uadmin -p$(cat /etc/psa/.psa.shadow) -D psa -Nse UPDATE ServiceNodeEnvironment SET value = REPLACE(value, version5/version, version5.2/version) WHERE section = phphandlers AND name = fastcgi-5.2.17;

    But value gets overwritten each time Plesk does a reread of PHP handlers.

    My bet is that there is a hardcoded table in Plesk that links major versions to specific versions.
    Can this table be made more accurate?

    DB:3.37:Plesk 11.5 Wrongly Detects Php 5.2.17 As Just Php 5 mk




    Custom versions for 5.3, 5.4 and 5.5 all get detected with correct subversion.
    But for 5.2.17 it just says PHP 5.

    This is the version output of the fresh compiled PHP 5.2.17:

    /usr/local/php5.2.17-cgi/bin/php-cgi -q -c /usr/local/php5.2.17-cgi/etc/php.ini ?php print phpversion(); ?
    5.2.17

    But Plesk shows PHP 5 as version when using this handler.

    I can fix this using:

    mysql -uadmin -p$(cat /etc/psa/.psa.shadow) -D psa -Nse UPDATE ServiceNodeEnvironment SET value = REPLACE(value, version5/version, version5.2/version) WHERE section = phphandlers AND name = fastcgi-5.2.17;

    But value gets overwritten each time Plesk does a reread of PHP handlers.

    My bet is that there is a hardcoded table in Plesk that links major versions to specific versions.
    Can this table be made more accurate?

  • RELEVANCY SCORE 3.34

    DB:3.34:Different Version Of Php Between Iis And Plesk Panel 11.5.30 z1





    Dear support,

    On service plan I configure php 5.3 and ASP.NET 4.0. When I create subscription (using API without the php version ), main domain created correct (php 5.3 and ASP.NET 4.0), but additional domains created incorrect (I see php 5.2 ASP.NET 2.0 on IIS 8.0/ I see php 5.3 ASP.NET 4.0 on Plesk Panel).

    P.S. When I used Plesk Panel 11.0.9 didnt reproduce this problem.

    DB:3.34:Different Version Of Php Between Iis And Plesk Panel 11.5.30 z1




    Dear support,

    On service plan I configure php 5.3 and ASP.NET 4.0. When I create subscription (using API without the php version ), main domain created correct (php 5.3 and ASP.NET 4.0), but additional domains created incorrect (I see php 5.2 ASP.NET 2.0 on IIS 8.0/ I see php 5.3 ASP.NET 4.0 on Plesk Panel).

    P.S. When I used Plesk Panel 11.0.9 didnt reproduce this problem.

  • RELEVANCY SCORE 3.34

    DB:3.34:How To Upgrade Php From 4.3 To 5.2 On Plesk 1j





    I am running Plesk version 8.2 all current and am trying to upgrade my php to version 5.2. I have had a friend attemp it once and it somehow uninstalled Plesk and really killed me as my system was down for two days trying to reinstall everything.

    Anything that can help would be greatly appreciated.

    I must get this right this time.

    Thanks,

    Nick G

    DB:3.34:How To Upgrade Php From 4.3 To 5.2 On Plesk 1j




    ANY idea if that is what is causing the php5 upgrade error message posted earlier?

  • RELEVANCY SCORE 3.33

    DB:3.33:Cronjob Problems With Plesk 11.5.30#44 s1





    Hi Guys,
    im running in some troubles with Plesk 11.5.3 cronjobs. I have several machines running with plesk and cronjobs (Scheduled Tasks in Plesk) with no hickups or errors.
    This time however i dont get a simple cronjob php script working. I also googled for the problem and we get several answers back. Thats why we try all answers, but all with no result.

    Hope some can help me? Kind regards,
    Peter
    ---------------------------------------------------------------
    PRODUCT, VERSION, MICROUPDATE, OPERATING SYSTEM, ARCHITECTURE
    Parallels Plesk, Plesk 11.5,30 MU#44, Uubntu 12.04.4 LTS x64

    PROBLEM DESCRIPTION
    The cronjob with phpcode: Hello World will not execute from the cronjob defined in Parallels Plesk

    STEPS TO REPRODUCE
    1) in a domain create a cronjob
    2) define the cronjob in scheduled tasks with:
    - php /var/www/vhosts/domain.tld/httpdocs/testcron.php
    -/usr/bin/php /var/www/vhosts/domain.tld/httpdocs/testcron.php
    ACTUAL RESULT
    A result mail with: error php not found, and error /usr/bin/php not found (this seems a common problem after we are googlet it.
    3) define the cronjob in scheduled task with:
    - wget http://www.domain.tld/testcron.php
    -curl domain.tld/testcron.php
    of course with some variations in the syntax.

    ACTUAL RESULT
    A result mail with: a blank error for wget and curl gives a resolving error: could not resolve domain.tld
    EXPECTED RESULT
    Hello world in the e-mail

    ANY ADDITIONAL INFORMATION
    --------------------------------------------------------------
    how testcron.php is made:
    ?php
    echo hello world;
    echo br/;
    echo PHP_BINDIR;
    echo **;
    ?

    DB:3.33:Cronjob Problems With Plesk 11.5.30#44 s1




    http://forum.parallels.com/showthread.php?301521

  • RELEVANCY SCORE 3.33

    DB:3.33:Plesk Errors After Upgrading To 11.5.3 Php Version/Handlers 9f





    Hello,

    After upgrading to Plesk 11.5.3 Im getting errors when trying to access Websites section of a particular Customer:
    Unable to create or update the subscription: The PHP handler fastcgi is not registered.
    or
    Unable to create or update the subscription: The PHP handler module is not registered.

    Other debug info:

    Code:

    DB:3.33:Plesk Errors After Upgrading To 11.5.3 Php Version/Handlers 9f




    i had same problem, please check php.ini configuration and add ; before safe_mode=on to disable and test.

  • RELEVANCY SCORE 3.32

    DB:3.32:Upgrade To Php 5.3 On Centos 5.7 Using Plesk 10.2 9x





    I have seen many threads regarding upgrading PHP to 5.3 but none of the suggestions in any of the threads has worked so I am starting a new thread.

    *** I am running Plesk Panel 10.2 on CentOS 5.7 and my current version of PHP is 5.1.6 ***:

    # cat /etc/redhat-release
    CentOS release 5.7 (Final)

    # php -v
    PHP 5.1.6 (cli) (built: Nov 29 2010 16:47:46)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with the ionCube PHP Loader v4.0.7, Copyright (c) 2002-2011, by ionCube Ltd.

    I have tried upgrading PHP to 5.3 using both the CLI and GUI.

    When I open the GUI and choose the following:

    Server Management - Tools and Utilities - Panel - Updates and select Add Components

    I do NOT have the following option:

    Different PHP interpreter versions

    The only option I have is called PHP5 support and it says that it is up-to-date.

    Here is the response using the CLI:

    # /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component php53
    File downloading products.inf3: 100% was finished.
    File downloading plesk.inf3: 10%..24%..38%..51%..78%..100% was finished.
    File downloading pp-sitebuilder.inf3: 21%..32%..44%..56%..67%..79%..91%..100% was finished.
    Checking for installed packages...
    File downloading PSA_10.2.0/plesk-10.2.0-cos5-x86_64.inf3: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading PSA_10.2.0/plesk-patches-10.2.0-all.inf3: 28%..43%..75%..100% was finished.
    File downloading SITEBUILDER_5.2.0/sitebuilder-5.2.0-rhall-all.inf3: 100% was finished.
    Detecting installed product components.
    Warning: following component(s) not found: php53
    You already have the latest version of product(s) and all selected components
    installed. Installation will not continue.

    Q1: Can you tell me why neither the CLI or GUI solutions listed on these forums is working in this case as I would prefer to use a solution supported by Parallels?

    Q2: Can I use a CentOS mirror and yum to upgrade to php53 or will this break the Plesk Panel?

    More info that may help:

    # yum list php*
    Installed Packages
    php.x86_64 5.1.6-27.el5_5.3 installed
    php-bcmath.x86_64 5.1.6-27.el5_5.3 installed
    php-cli.x86_64 5.1.6-27.el5_5.3 installed
    php-common.x86_64 5.1.6-27.el5_5.3 installed
    php-dba.x86_64 5.1.6-27.el5_5.3 installed
    php-devel.x86_64 5.1.6-27.el5_5.3 installed
    php-gd.x86_64 5.1.6-27.el5_5.3 installed
    php-imap.x86_64 5.1.6-27.el5_5.3 installed
    php-ldap.x86_64 5.1.6-27.el5_5.3 installed
    php-mbstring.x86_64 5.1.6-27.el5_5.3 installed
    php-mysql.x86_64 5.1.6-27.el5_5.3 installed
    php-ncurses.x86_64 5.1.6-27.el5_5.3 installed
    php-odbc.x86_64 5.1.6-27.el5_5.3 installed
    php-pdo.x86_64 5.1.6-27.el5_5.3 installed
    php-pear.noarch 1:1.4.9-6.el5 installed
    php-snmp.x86_64 5.1.6-27.el5_5.3 installed
    php-soap.x86_64 5.1.6-27.el5_5.3 installed
    php-xml.x86_64 5.1.6-27.el5_5.3 installed
    php-xmlrpc.x86_64 5.1.6-27.el5_5.3 installed
    php5-ioncube-loader.x86_64 4.0.7-11030112 installed
    Available Packages
    php-dbase.x86_64 5.1.6-15.el5.centos.1 extras
    php-mcrypt.x86_64 5.1.6-15.el5.centos.1 extras
    php-mhash.x86_64 5.1.6-15.el5.centos.1 extras
    php-mssql.x86_64 5.1.6-15.el5.centos.1 extras
    php-pear-Auth-SASL.noarch 1.0.2-4.el5.centos extras
    php-pear-DB.noarch 1.7.13-1.el5.centos extras
    php-pear-Date.noarch 1.4.7-2.el5.centos extras
    php-pear-File.noarch 1.2.2-1.el5.centos extras
    php-pear-HTTP-Request.noarch 1.4.2-1.el5.centos extras
    php-pear-Log.noarch 1.9.13-1.el5.centos extras
    php-pear-MDB2.noarch 2.4.1-2.el5.centos extras
    php-pear-MDB2-Driver-mysql.noarch 1.4.1-3.el5.centos extras
    php-pear-Mail.noarch 1.1.14-1.el5.centos extras
    php-pear-Mail-Mime.noarch 1.4.0-1.el5.centos extras
    php-pear-Net-SMTP.noarch 1.2.10-1.el5.centos extras
    php-pear-Net-Sieve.noarch 1.1.5-2.el5.centos extras
    php-pear-Net-Socket.noarch 1.0.8-1.el5.centos extras
    php-pear-Net-URL.noarch 1.0.15-1.el5.centos extras
    php-pecl-Fileinfo.x86_64 1.0.4-3.el5.centos extras
    php-pecl-memcache.x86_64 2.2.3-1.el5_2 extras
    php-pgsql.x86_64 5.1.6-27.el5_5.3 base
    php-readline.x86_64 5.1.6-15.el5.centos.1 extras
    php-tidy.x86_64 5.1.6-15.el5.centos.1 extras
    php53.x86_64 5.3.3-1.el5_7.3 updates
    php53-bcmath.x86_64 5.3.3-1.el5_7.3 updates
    php53-cli.x86_64 5.3.3-1.el5_7.3 updates
    php53-common.x86_64 5.3.3-1.el5_7.3 updates
    php53-dba.x86_64 5.3.3-1.el5_7.3 updates
    php53-devel.x86_64 5.3.3-1.el5_7.3 updates
    php53-gd.x86_64 5.3.3-1.el5_7.3 updates
    php53-imap.x86_64 5.3.3-1.el5_7.3 updates
    php53-intl.x86_64 5.3.3-1.el5_7.3 updates
    php53-ldap.x86_64 5.3.3-1.el5_7.3 updates
    php53-mbstring.x86_64 5.3.3-1.el5_7.3 updates
    php53-mysql.x86_64 5.3.3-1.el5_7.3 updates
    php53-odbc.x86_64 5.3.3-1.el5_7.3 updates
    php53-pdo.x86_64 5.3.3-1.el5_7.3 updates
    php53-pgsql.x86_64 5.3.3-1.el5_7.3 updates
    php53-process.x86_64 5.3.3-1.el5_7.3 updates
    php53-pspell.x86_64 5.3.3-1.el5_7.3 updates
    php53-snmp.x86_64 5.3.3-1.el5_7.3 updates
    php53-soap.x86_64 5.3.3-1.el5_7.3 updates
    php53-xml.x86_64 5.3.3-1.el5_7.3 updates
    php53-xmlrpc.x86_64 5.3.3-1.el5_7.3 updates

    # rpm -qa | grep -i php
    php-ldap-5.1.6-27.el5_5.3
    php-pdo-5.1.6-27.el5_5.3
    php-imap-5.1.6-27.el5_5.3
    php-dba-5.1.6-27.el5_5.3
    php-odbc-5.1.6-27.el5_5.3
    php-soap-5.1.6-27.el5_5.3
    php-mbstring-5.1.6-27.el5_5.3
    php-ncurses-5.1.6-27.el5_5.3
    php-cli-5.1.6-27.el5_5.3
    php-mysql-5.1.6-27.el5_5.3
    php-xmlrpc-5.1.6-27.el5_5.3
    php-gd-5.1.6-27.el5_5.3
    php-pear-1.4.9-6.el5
    psa-php5-configurator-1.6.1-cos5.build1011110330.18
    php-common-5.1.6-27.el5_5.3
    php-5.1.6-27.el5_5.3
    php-xml-5.1.6-27.el5_5.3
    php-devel-5.1.6-27.el5_5.3
    php5-ioncube-loader-4.0.7-11030112
    php-snmp-5.1.6-27.el5_5.3
    php-bcmath-5.1.6-27.el5_5.3

    Thanks,
    Ben

    DB:3.32:Upgrade To Php 5.3 On Centos 5.7 Using Plesk 10.2 9x




    Anyone have any suggestions on how I can use the Updates and Upgrades feature from the UI?

    Thanks,
    charles

  • RELEVANCY SCORE 3.32

    DB:3.32:How Do I Uprading Php 4.2 To 4.3.11 On Plesk 7.5 Reloaded 17





    I wish to upgrade php4.2 to 4.3 on plesk 7.5 reloaded. my operating system redhat 9 on a virtuoso virtual dedicated server.
    Can anyone please give me a step by step instructions on how I can do this upgrade.

    DB:3.32:How Do I Uprading Php 4.2 To 4.3.11 On Plesk 7.5 Reloaded 17




    Yep, yum should do it for you automatically. You might have to use yum upgrade instead of yum update on older versions.

  • RELEVANCY SCORE 3.32

    DB:3.32:Php 5.1.4 And Plesk 8 On Fc4 a7





    Has anyone tried to succesfuly install PHP 5.1.4 on FC4 with plesk 8 ?

    I have tried upgrading to it but have encountered several problems with php modules being loaded.

    Can someone write some instructions if you were able to succesfuly do it ?

    DB:3.32:Php 5.1.4 And Plesk 8 On Fc4 a7




    Has anyone tried to succesfuly install PHP 5.1.4 on FC4 with plesk 8 ?

    I have tried upgrading to it but have encountered several problems with php modules being loaded.

    Can someone write some instructions if you were able to succesfuly do it ?

  • RELEVANCY SCORE 3.31

    DB:3.31:Migration From 11.5 To 12 - Some Questions 7k





    Hi,

    Im thinking about migrating a plesk 11.5 server to plesk 12.

    Therefore, some questions raised:
    - Are specific PHP-handler versions kept after migration? I installed 3 different versions of PHP, and I want to be sure these settings will be kept without the need of setting them up again.
    - Is the core PHP version (installed with the OS) updated during migration? Or it will remain as it is?
    - Ive fail2ban installed manually on plesk 11.5. Shall I manually remove it prior to migration? No you should not need to remove it, just upgrade Plesk, and install Fail2Ban from the Plesk installer and it will do the rest, keeping trusted IPs, and any config you already have will be available in the Plesk GUI. = see answer below
    - Ive installed paid modules to Roundcube plesk default installation. Will these modules be kept after migration?
    - After migration, if I install modsec through PLESK 12, is it possible to disable it on a per-domain rule? YES = Answer found here: http://forum.odin.com/threads/modsec-on-a-per-domain-rule-basis.332234/#post-776515

    Thanks for your help/advice.
    Regards,

  • RELEVANCY SCORE 3.31

    DB:3.31:Plesk Detects Php 5.2.17 As 5.2.1 78





    When I try to install Wordpress through the Applications inside Plesk, it says the following:

    PHP Version 5.2.4 or greater, while current is 5.2.1

    But my PHP Version is 5.2.17
    -bash-3.2# php -v
    PHP 5.2.17 (cli) (built: Jan 7 2011 10:39:29)

    How can I solve this?

  • RELEVANCY SCORE 3.30

    DB:3.30:Php Upgrade 5.1.6 To 5.3.1 On Plesk 9.2.3 cz





    Hello,

    Ive read this thread here (http://forum.parallels.com/showthread.php?t=95806), but wondered if it would be okay to upgrade to PHP 5.3.1. Im new to Plesk and have found a quick guide here (http://www.christianmontoya.com/2008/10/01/upgrading-php-and-installing-apc-on-centos-5-with-plesk/) that mentions doing this:

    Code:

    DB:3.30:Php Upgrade 5.1.6 To 5.3.1 On Plesk 9.2.3 cz




    The post stating that yum command not found is probably using a Debian Derived OS (i.e. Debian, Ubuntu etc) which doesnt use YUM, but apt-get instead.

    Look at using the dotdeb.org source instead

  • RELEVANCY SCORE 3.29

    DB:3.29:Plesk 7.5.3 On Freebsd - Updating 83





    1) Update your ports tree.
    2) install Perl 5.8.6 (required for Plesk 7.5.3):

    PHP:

    DB:3.29:Plesk 7.5.3 On Freebsd - Updating 83




    I tried, but got a canned response about my service contract being expired. heh.

    What I dont understand is why they dont have some type of bug tracking database where (registered/authenticated) users could submit bugs. It blows my mind... really.

  • RELEVANCY SCORE 3.28

    DB:3.28:Help Please - 11.5.30 Update #29 But It Has Php 5.3, Shouldnt It Be 5.4 ? p7





    I moved my server from a provider to another.
    I have big performance issues. So Im trying everything.
    I hope PHP 5.4.23 will solve my problems

    In Plesk I see that current version is 11.5.30 Update #29
    But websites has PHP 5.3.3.

    My old server also had 11.5.30 Update #29
    but it had PHP 5.4.23.

    When I try to update from Plesk panel
    example.com/update_components.html
    I get that I have latest version.

    Although I selected Early adopter release in update settings.
    How can I update Plesk ??
    Please help me

    DB:3.28:Help Please - 11.5.30 Update #29 But It Has Php 5.3, Shouldnt It Be 5.4 ? p7




    Plesk would not automatically upgrade it either. You would have to accept the update when it prompts you there to as well

  • RELEVANCY SCORE 3.28

    DB:3.28:Plesk Errors After Upgrading To 11.5.3: Php Version 5.4 And Php Handlers 5.3 zj





    Hello,

    After upgrading to Plesk 11.5.3 Im getting errors when trying to access Websites section of a particular Customer:
    Unable to create or update the subscription: The PHP handler fastcgi is not registered.
    or
    Unable to create or update the subscription: The PHP handler module is not registered.

    Other debug info:

    Code:

  • RELEVANCY SCORE 3.27

    DB:3.27:Migration Problem From Confixx 3.3.5 To Plesk 9.5 df





    Hello,

    i trying to migrate domains and resellers from Confixx to Plesk with the Migration Manager. The logs of the migration reveal the following errors. So far i cannot deal with this problem. There is only one thread and that is going nowhere.

    Have anybody seen this before?

    [11:23:29|DEBG: 7707.Ssh] Execution finished with return code 0
    [11:23:29|DEBG: 7707.libssh2pp.Channel] Closed
    [11:23:29|DEBG: 7707.libssh2pp.Session] SSH session finished
    [11:23:29|DEBG: 7707.libssh2pp.Socket] Connection closed
    [11:23:29|INFO: 7707.log] CantRetrieveDump: Error during dump retrieval [./actions.cpp:490]
    Inner exception:
    AssertionFailed: Assertion failed: content.size() [./xml_parse.cpp:108]
    [11:23:29|INFO: 7707.log] Launchpad finished. Exit code: 2

    DB:3.27:Migration Problem From Confixx 3.3.5 To Plesk 9.5 df




    Hello,

    i trying to migrate domains and resellers from Confixx to Plesk with the Migration Manager. The logs of the migration reveal the following errors. So far i cannot deal with this problem. There is only one thread and that is going nowhere.

    Have anybody seen this before?

    [11:23:29|DEBG: 7707.Ssh] Execution finished with return code 0
    [11:23:29|DEBG: 7707.libssh2pp.Channel] Closed
    [11:23:29|DEBG: 7707.libssh2pp.Session] SSH session finished
    [11:23:29|DEBG: 7707.libssh2pp.Socket] Connection closed
    [11:23:29|INFO: 7707.log] CantRetrieveDump: Error during dump retrieval [./actions.cpp:490]
    Inner exception:
    AssertionFailed: Assertion failed: content.size() [./xml_parse.cpp:108]
    [11:23:29|INFO: 7707.log] Launchpad finished. Exit code: 2

  • RELEVANCY SCORE 3.27

    DB:3.27:Php 5.1.6 To 5.3.6 Centos 5.6 Need Help. jz





    Hi guys,

    I want to upgrade the PHP version.

    My Server info is as follows:
    Server: CentOS release 5.6 (Final)

    Current PHP Version: PHP 5.1.6 (cli) (built: Nov 29 2010 16:47:46)
    Zend Engine v2.1.0 with ionCube PHP Loader v4.0.7

    Linux 2.6.18-238.e15 x86_64 GNU/Li

    Parallels Plesk Panel 10.2

    I just had this server setup and want to upgrade the PHP version myself yet after reading many forms about php53 name instead of PHP errors I decided to make a post. I have SSH root access on this dedicated server and since its a clean install if something does end up happening at least I have no websites connected to it right now.

    Can someone let me know the SSH commands Ill have to do so that I can upgrade to the new PHP version or some more forms to read that will help me with doing this? If you need more info let me know and Ill post it.

    DB:3.27:Php 5.1.6 To 5.3.6 Centos 5.6 Need Help. jz




    try
    wget -q -O - http://www.atomicorp.com/installers/atomic | sh
    answer yes
    yum update php mysql

    what it is your plesk verion ?
    and what is the full output of yum update php mysql

  • RELEVANCY SCORE 3.26

    DB:3.26:Site_Isolation_Settings For Php_Handler_Type Are Ignored 9m





    Hello,
    On a server which was running for years now and was updated from plesk 10 to plesk 11 and also to plesk 12 (12.0.18 Update #29) there seems to be a bug.

    Customers are able to change PHP handler while in site_isolation_settings.ini it is not allowed:
    php_handler_type = fastcgi

    PSA service was restarted too:
    /etc/init.d/psa restart

    This is a serious issue because customers should not be able to change PHP handler type.

    EDIT:
    Only abonnements created with older Plesk versions are affected. I cannot say which version exactly because server had installed Plesk 10, 11 and 12. What do we have to modify to disallow changing the PHP handler type for this abonnements created with Plesk versions befor Plesk 12?

    Thanks.
    Thomas

    DB:3.26:Site_Isolation_Settings For Php_Handler_Type Are Ignored 9m




    Thank you for details. I have forwarded them to developers. I will keep this thread updated with results as soon as I receive them.

  • RELEVANCY SCORE 3.25

    DB:3.25:Migration From Plesk 9.3 Windows To Plesk 9.5 Linux m7





    hello,

    I want to move one of my sites from plesk 9.3 on windows to plesk 9.5 linux?
    what do i do? Is it possible? It works with PHP and Mysql?

    thx before,

    DB:3.25:Migration From Plesk 9.3 Windows To Plesk 9.5 Linux m7




    As you can see in Plesk Migration Guide here - http://download1.parallels.com/Plesk/PPP9/Doc/en-US/plesk-9.5-migration-guide/63279.htm it is impossible.

  • RELEVANCY SCORE 3.25

    DB:3.25:Does Plesk 11 Has Php 5.4 Support? af





    Hi there.

    Just wanted to know if Plesk 11 has PHP 5.4 Support.

    We plan to Upgrade from PHP 5.3.14 to PHP 5.4 because of some requests from our Customers.

    Didnt find anything in the Changelog.

    Hopfe you can help me.

    Regards from Germany

    Sascha urbansky

    DB:3.25:Does Plesk 11 Has Php 5.4 Support? af




    It depends on your OS. Im guessing you are on Centos. But this is a thread about 5.4. Please can you start a new thread in the Problems, Suggested fixes and How-tos section of the forum? Be sure to state what OS you have, and what you have already tried etc etc.

  • RELEVANCY SCORE 3.25

    DB:3.25:Downgrade Php From 5.4.X To 5.3.X k3





    Hi there!

    I am trying to make a php downgrade from 5.4.x to 5.3.x because i have some software not supported by 5.4.x version. With a yum remove php to remove php to after install 5.3, i have discovered too many dependencies with psa-* packages so i am worried for crashing Plesk Panel.

    Is there any way to downgrade php without crashing plesk panel?

    Thanks

    PD. I am with Plesk 11 and Centos 6

    DB:3.25:Downgrade Php From 5.4.X To 5.3.X k3




    By using yum to downgrade its safe. It wont break package dependencies. If you exclude a downgrade of a package of the group that has to be downgraded, you get a dependency error and it wont give you the option.

    So yes its safe. It will downgrade. Just see what packages it tells you are being downgraded.

  • RELEVANCY SCORE 3.25

    DB:3.25:Php 5.3.9 ,Plesk 10.4.4 With Latest Microupdates 1p





    I have the latest version off Plesk installed with PHP 5.3 update. It only installed PHP 5.3.9. According to http://kb.parallels.com/en/113306, PHP was updated to 5.3.10 in MU#16. I have the latest microupdates installed. Where can I get the PHP 5.3.10 Plesk install?

    Thanks
    Patrick

    DB:3.25:Php 5.3.9 ,Plesk 10.4.4 With Latest Microupdates 1p




    I had already tried that, and had to manually re-install the msi package afterwards as even though the package was un-installed, it did not re-appear in the Updates and Upgrade list. It again installed v 5.3.9.

    However last night I received an email stating that Plesk was successfully updated by the autoinstaller. It looks like MU#19 was pushed last night and indeed updated PHP to v 5.3.10. I confirmed the version using msiinv, and the fact that the php53.msi file had a new modified date of 2/29/2012.

    On 2/28/2012
    PHP 5.3 script engine
    Product code: {7D5CDFE7-B531-4C59-B58A-E89F1BEBBF7C}
    Product state: (5) Installed.
    Assignment: per machine
    Package code: {B0CB11AA-8E32-46CA-8B57-F1BA406B97EF}
    Version: 5.3.9
    Publisher: Parallels
    Language: 1033
    Suggested installation location: C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP53\
    Installed from: C:\2076b899516c9b74fb0aecbb8587c5e3\parallels\PANEL-WIN_10.4.4\dist-msi-Microsoft-2003-i386\
    Package: php53.msi
    About link: http://www.parallels.com
    Help link: http://www.parallels.com/en/support/plesk
    Help telephone: (703) 815-5670
    Instance type: 0
    Local package: C:\Windows\Installer\775532e.msi
    Install date: 2012\02\28
    0 patch packages.

    On 2/29/2012
    PHP 5.3 script engine
    Product code: {91D771D0-B9C1-4ADF-9944-0601E5751B93}
    Product state: (5) Installed.
    Assignment: per machine
    Package code: {8CAD49E7-ACAA-48BF-8545-D97C5EC70FB4}
    Version: 5.3.10
    Publisher: Parallels
    Language: 1033
    Suggested installation location: C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP53\
    Installed from: C:\2076b899516c9b74fb0aecbb8587c5e3\parallels\PANEL-WIN_10.4.4\dist-msi-Microsoft-2003-i386\
    Package: php53.msi
    About link: http://www.parallels.com
    Help link: http://www.parallels.com/en/support/plesk
    Help telephone: (703) 815-5670
    Instance type: 0
    Local package: C:\Windows\Installer\bb4542c.msi
    Install date: 2012\02\29
    0 patch packages.

    Is it possible you might be able to to reply to my other post regarding the File Sharing not working http://forum.parallels.com/showthread.php?t=257678

    At least to let me know if this is a known issue or not.

    Thanks again IgorG

  • RELEVANCY SCORE 3.24

    DB:3.24:Installing Mcrypt On Plesk 10.3.1 With Php 5.3.3 3z





    Okay,

    Well i managed to upgrade my server through Plesk control Panel to Plesk 10.3.1 from 10.1. All is good and i also installed PHP 5.3.3 in the process as my website needs this to function.

    Question is how do install Mcrypt as an extension to PHP?

    DB:3.24:Installing Mcrypt On Plesk 10.3.1 With Php 5.3.3 3z




    I think you need to install the version for your php:
    yum install php53-mcrypt

    Restart the web server and it is done!
    /etc/rc.d/init.d/httpd restart

    It worked for me.

  • RELEVANCY SCORE 3.24

    DB:3.24:Php/Mysql 5 On Plesk 8.1.1/Centos 3.6 p9





    Im thinking about updating PHP my Plesk 8.1.1 on CentOS 3.6

    Ideally Id like to upgrade it to PHP5 get MySQL 5..

    Has anyone done this? Any suggestions would be great!

    Thanks!

    DB:3.24:Php/Mysql 5 On Plesk 8.1.1/Centos 3.6 p9




    php 5.0, and mysql 4.1 were the last releases I made for that platform. I dont think Ill be able to do any Mysql 5, or php 5.1 rpms for 3ES based distros. There are just way too many dependencies to take care of to get it to work right.

  • RELEVANCY SCORE 3.24

    DB:3.24:11.5 Multi-Php Error When Registering Php Handler. (Php 4.3.11 From Source) cp





    Hi,

    Im using Plesk 11.5.30 on CentOS 6.4 with Apache 2.2.15.
    I have successfully compiled and installed following handlers:
    4.4.9 and 5.2.17,
    but I have problem installing 4.3.11 I managed to compile properly

    Here is the error:

    /usr/local/psa/bin/php_handler --add -displayname 4.3.11 -path /usr/local/php-4.3.11/bin/php -phpini /usr/local/php-4.3.11/etc/php.ini -type cgi -id fastcgi-4.3
    ERR (3) [util_exec]: proc_close() failed
    Unable to register the PHP handler: can not get version from /usr/local/php-4.3.11/bin/php

    So I tried
    echo ?php print phpversion(); ? |/usr/local/php-4.3.11/bin/php -q -c /usr/local/php-4.3.11/etc/php.ini
    and I am getting:
    4.3.11

    Version check from command line reports correctly without segmentation faults

    /usr/local/php-4.3.11/bin/php -v
    PHP 4.3.11 (cgi-fcgi) (built: Oct 29 2013 11:40:56)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

    Below output from /usr/local/psa/bin/php_handler --list

    id: display name: full version: version: type: cgi-bin: php.ini: custom:
    cgi 5.3.25 5.3.25 5.3 cgi /usr/bin/php-cgi /etc/php.ini false
    fastcgi 5.3.25 5.3.25 5.3 fastcgi /usr/bin/php-cgi /etc/php.ini false
    fastcgi-52 5.2.17 5.2.17 5.2 fastcgi /usr/local/php-5.2.17/bin/php-cgi /usr/local/php-5.2.17/etc/php.ini true
    fastcgi-44 4.4.9 4.4.9 4.4 fastcgi /usr/local/php-4.4.9/bin/php-cgi /usr/local/php-4.4.9/etc/php.ini true
    fastcgi-54 5.4 5.4.20 5.4 fastcgi /opt/atomic/atomic-php54/root/usr/bin/php-cgi /opt/atomic/atomic-php54/root/etc/php.ini true
    fastcgi-55 5.5 5.5.4 5.5 fastcgi /opt/atomic/atomic-php55/root/usr/bin/php-cgi /opt/atomic/atomic-php55/root/etc/php.ini true
    module 5.3.25 5.3.25 5.3 module /usr/bin/php-cgi /etc/php.ini false

    Is is possible the php_handler command does not recognize PHP 4.3.x ?

    Any hints to solve this problem are greatly appreciated.

  • RELEVANCY SCORE 3.21

    DB:3.21:Upgrade Mysql And Php On Fc3 And Plesk 7.5.4 ak





    Hi,

    i want upgrade the default version of MySql and PHP installed with Fedora Core 3 and Plesk 7.5.4

    How do i upgrade mysql and php with Plesk 7.5.4 ?

    If i make this upgrade manually..... have any problems with Plesk?

    Thanks for your suggestions.

    DB:3.21:Upgrade Mysql And Php On Fc3 And Plesk 7.5.4 ak




    okay, so I type:

    rpm -Uvh glibc-common-2.3.3-27.1.1.legacy.i386.rpm

    and get :

    package glibc-common-2.3.3-27.1.1.legacy is already installed

    If its already installed how come I got the error

    Failed dependencies:
    glibc-common = 2.3.3-27.1.1.legacy is needed by (installed) glibc-dummy-fedora-core-2-2.3.3-27.1.1.legacy.1.swsoft

    Is this something Ive done wrong with mixed distributions? Is there a way to step back? Pardon the NOOBISHNESS of this posting. How can I tell that I am using the correct distribution?

    I am on live chat with the provider now, so far they are not of much help. Any suggestions on a provider that ROCKS! Im still in my 30 trial, the price is good($35/mo), but the hassle stinks. Any way I can migrate all the settings to the new server and not have to redo all the DNS, mail accounts and domains settings -- just a thought, Im losing production time with these issues, THANKS!

  • RELEVANCY SCORE 3.21

    DB:3.21:Rhel 6 Php-5.3 Vs Plesk Installer am





    1. Im running RHEL 6.2 on my server, which therefore comes with php-5.3.3-3.el6.x86_64 installed. However, I have not told plesk to upgrade to php 5.3. When I run autoinstaller it has the php option selected rather than the php 5.3. Should I change this to match the version of php actually running on my server?

    2. Could this be the reason I have error messages regarding php, xmlrpc-c and tomcat when I run yum update:
    Error: Protected multilib versions: xmlrpc-c-1.16.24-1200.1840.el6_1.4.x86_64 != xmlrpc-c-1.16.24-1200.1840.el6.i686

    When the server is working I dont like changing things, but do like to keep everything up to date.

    Matt

    Plesk version 10.4.4 up to date with MU as of 2012-03-15

    DB:3.21:Rhel 6 Php-5.3 Vs Plesk Installer am




    1. Im running RHEL 6.2 on my server, which therefore comes with php-5.3.3-3.el6.x86_64 installed. However, I have not told plesk to upgrade to php 5.3. When I run autoinstaller it has the php option selected rather than the php 5.3. Should I change this to match the version of php actually running on my server?

    2. Could this be the reason I have error messages regarding php, xmlrpc-c and tomcat when I run yum update:
    Error: Protected multilib versions: xmlrpc-c-1.16.24-1200.1840.el6_1.4.x86_64 != xmlrpc-c-1.16.24-1200.1840.el6.i686

    When the server is working I dont like changing things, but do like to keep everything up to date.

    Matt

    Plesk version 10.4.4 up to date with MU as of 2012-03-15

  • RELEVANCY SCORE 3.19

    DB:3.19:Help Php Removed mp





    Hi,

    I did something really stupid. Using the command line i did a # yum reinstall php instead of update. Now it deleted some things related to plesk, and i cant access the controll pannel again.

    Is there i was to reinstall a php version integrated to plesk?

    The log i got is the following:

    ----------------------------

    -- Running transaction check
    --- Package php.i386 0:5.3.1-1 set to be erased
    -- Processing Dependency: php for package: psa-php5-configurator
    --- Package php-cli.i386 0:5.3.1-1 set to be erased
    --- Package php-common.i386 0:5.3.1-1 set to be erased
    -- Processing Dependency: php-common = 5.3.1-1 for package: php-mbstring
    --- Package php-gd.i386 0:5.3.1-1 set to be erased
    --- Package php-imap.i386 0:5.3.1-1 set to be erased
    --- Package php-mysql.i386 0:5.3.1-1 set to be erased
    --- Package php-pdo.i386 0:5.3.1-1 set to be erased
    --- Package php-xml.i386 0:5.3.1-1 set to be erased
    -- Running transaction check
    --- Package php-mbstring.i386 0:5.3.1-1 set to be erased
    --- Package psa-php5-configurator.noarch 0:1.5.1-cos5.build92091016.19 set to be erased
    -- Processing Dependency: psa-php-configurator = 1.5.1 for package: psa
    -- Running transaction check
    --- Package psa.i586 0:9.2.3-cos5.build92091016.19 set to be erased
    -- Processing Dependency: psa = 8.0.0 for package: psa-libpam-plesk
    -- Processing Dependency: psa = 9.2.3 for package: psa-updates
    -- Processing Dependency: psa = 9.2.3 for package: psa-awstats-configurator
    -- Running transaction check
    --- Package psa-awstats-configurator.noarch 0:1.0.0-cos5.build92091016.19 set to be erased
    --- Package psa-libpam-plesk.i586 0:9.2.3-cos5.build92091016.19 set to be erased
    --- Package psa-updates.noarch 0:9.2.3-cos5.build92091016.19 set to be erased
    -- Finished Dependency Resolution

    Dependencies Resolved

    ========================================================================================================================================================================
    Package Arch Version Repository Size
    ========================================================================================================================================================================
    Removing:
    php i386 5.3.1-1 installed 14 M
    php-cli i386 5.3.1-1 installed 8.3 M
    php-common i386 5.3.1-1 installed 4.4 M
    php-gd i386 5.3.1-1 installed 833 k
    php-imap i386 5.3.1-1 installed 203 k
    php-mysql i386 5.3.1-1 installed 619 k
    php-pdo i386 5.3.1-1 installed 363 k
    php-xml i386 5.3.1-1 installed 1.1 M
    Removing for dependencies:
    php-mbstring i386 5.3.1-1 installed 2.6 M
    psa i586 9.2.3-cos5.build92091016.19 installed 30 M
    psa-awstats-configurator noarch 1.0.0-cos5.build92091016.19 installed 0.0
    psa-libpam-plesk i586 9.2.3-cos5.build92091016.19 installed 153 k
    psa-php5-configurator noarch 1.5.1-cos5.build92091016.19 installed 69
    psa-updates noarch 9.2.3-cos5.build92091016.19 installed 0.0

    Transaction Summary
    ========================================================================================================================================================================
    Install 0 Package(s)
    Update 0 Package(s)
    Remove 14 Package(s)

    Is this ok [y/N]: y
    Downloading Packages:
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Erasing : php-cli 1/14
    Erasing : php-mysql 2/14
    Erasing : psa 3/14
    warning: /usr/local/psa/version saved as /usr/local/psa/version.rpmsave
    Erasing : php-gd 4/14
    Erasing : php-mbstring 5/14
    Erasing : php-common 6/14
    warning: /etc/php.ini saved as /etc/php.ini.rpmsave
    Erasing : php-pdo 7/14
    Trying to ... done
    Erasing : psa-libpam-plesk 8/14
    Erasing : php-imap 9/14
    Erasing : psa-updates 10/14
    Erasing : php 11/14
    Erasing : psa-awstats-configurator 12/14
    Erasing : php-xml 13/14
    Erasing : psa-php5-configurator 14/14

    Removed:
    php.i386 0:5.3.1-1 php-cli.i386 0:5.3.1-1 php-common.i386 0:5.3.1-1 php-gd.i386 0:5.3.1-1 php-imap.i386 0:5.3.1-1 php-mysql.i386 0:5.3.1-1 php-pdo.i386 0:5.3.1-1
    php-xml.i386 0:5.3.1-1

    Dependency Removed:
    php-mbstring.i386 0:5.3.1-1 psa.i586 0:9.2.3-cos5.build92091016.19
    psa-awstats-configurator.noarch 0:1.0.0-cos5.build92091016.19 psa-libpam-plesk.i586 0:9.2.3-cos5.build92091016.19
    psa-php5-configurator.noarch 0:1.5.1-cos5.build92091016.19 psa-updates.noarch 0:9.2.3-cos5.build92091016.19

    Complete!

    DB:3.19:Help Php Removed mp




    Just install it back with something like:

    yum install php php-cli php-common ....

    It should be enough.

  • RELEVANCY SCORE 3.18

    DB:3.18:Multiple Php Versions, Plesk 11.5.30, Centos 6.4 ss





    Hello,

    i have a Centos6.4 linux with Plesk 11.5.30 #11, and php 5.4.17.
    I would love if someone could write down step-by-step the instructions for installing ALSO PHP 5.3.23 as additional php on the system (and PLESK).
    I tried the instructions from the ADdministrators Guide, but i keep overwriting the previous version of php and NOT adding a new one.
    My php is located at:
    ----------------------
    [root@server httpd]# whereis php
    php: /usr/bin/php /etc/php.ini /etc/php.d /usr/lib64/php /usr/local/bin/php /usr/include/php /usr/share/php /usr/share/man/man1/php.1.gz /usr/share/man/man1/php.1
    [root@server httpd]#
    ----------------------
    Thank you in advance.

    Zero

    DB:3.18:Multiple Php Versions, Plesk 11.5.30, Centos 6.4 ss




    Look at this thread - http://forum.parallels.com/showthread.php?289011

  • RELEVANCY SCORE 3.17

    DB:3.17:Safely Downgrade Php 5.3 To 5.2 9d





    When I installed Windows/IIS (including PHP) it installed PHP 5.3.

    Plesk 10 doesnt support PHP 5.3, so I have to downgrade it to 5.2.

    What is the best way to do this without breaking Plesk?

    DB:3.17:Safely Downgrade Php 5.3 To 5.2 9d




    I installed PHP 5.2.17 and everything appears to be OK

    5.3 seems to be ignored even though its still installed.

  • RELEVANCY SCORE 3.17

    DB:3.17:Bug In Php 5.2.11 (Opensuse 10.3) xa





    Hi,

    I am (still) using an openSuse 10.3 and upgraded my plesk to 10.

    With the upgrade, php 5.2.11 was installed which has a known bug, which was fixed more than a year ago:

    http://bugs.php.net/bug.php?id=49913

    Now openSuse 10.3 is quite old and I can not find anywhere a newer version of php -

    Any Ideas?

    Cheers, Ron

  • RELEVANCY SCORE 3.17

    DB:3.17:Plesk Prevents Me From Upgrading Php 5.1 To 5.3 Or Higher jf





    I have CentOS 5.9 with Plesk 9.5 and it has PHP 5.1

    Now php 5.1 cant be simply upgraded to 5.3 with yum update because php starting from 5.3 is a different package, php53 (while php 5.1 is just php).

    But I cant install the package php53 without uninstalling php 5.1 because they conflict:
    php53-common conflicts with php-common

    So I should first uninstall the php package (php 5.1).
    BUT I cant because plesk depends on it, so if I uninstall php I will be forced to uninstall Plesk.

    So how do I upgrade php to 5.3 while keeping plesk?

    Thanks
    m.

    DB:3.17:Plesk Prevents Me From Upgrading Php 5.1 To 5.3 Or Higher jf




    Hi,

    You should be able to just use yum

    yum upgrade php

    and there is also the downgrade that yum can do too.

  • RELEVANCY SCORE 3.16

    DB:3.16:Php Upgrade From 5.3.3 zm





    I have Parallel Plesk 11 running on my Centos 6.3 VPS.

    As a result PHP is at version 5.3.3

    I need to upgrade PHP to version in the range of 5.3.8 to 5.3.15

    If I do this using SSH, will this break Paralles Plesk 11?

    Thanks in advance.

    DB:3.16:Php Upgrade From 5.3.3 zm




    I think that it is safely but you can try and check.

  • RELEVANCY SCORE 3.16

    DB:3.16:Zend Guard Loader Causing Conflicts Php 5.3 Plesk mf





    This is very frustrating. I am running a brand new server and am unable to get a key script for my site to run because Zend Guard Loader will not install without causing conflicts and taking down HTTPD on my server.

    I am running CentOS 64bit
    PHP 5.3
    Plesk Panel 10

    Code:

    DB:3.16:Zend Guard Loader Causing Conflicts Php 5.3 Plesk mf




    Initial issue has been fixed in MU#28 - http://kb.parallels.com/en/113785

  • RELEVANCY SCORE 3.16

    DB:3.16:Virtuozzo 3, Centos 4.5, Plesk 8.3 And Php 5 cs





    My servers are currently Virtuozzo 3, CentOS 4.5, Plesk 8.3 with PHP 4.x. I would like to deploy a new server with PHP 5 but dont find a template for this combination. I do see an eztemplate for PHP 5.

    How can I get PHP 5 installed? Can I mix an eztemplates with standard templates? If it makes a difference, should I push these from HSP? Up until now we have deployed outside of HSP and just registered the node.

    I am a rookie and would greatly appreciate a more detailed response, but of course, appreciate any and all suggestions.

    DB:3.16:Virtuozzo 3, Centos 4.5, Plesk 8.3 And Php 5 cs




    Awesome. Ill load one up in the morning. 2am here and time for some sleep.

  • RELEVANCY SCORE 3.16

    DB:3.16:What Versions Of Mysql, Php And Apache In Plesk 10? 88





    I need to reinstall Plesk 10 on my Debian 5 server, and I was wondering what versions of mySQL, PHP and Apache are included in the Plesk installation setup?

  • RELEVANCY SCORE 3.16

    DB:3.16:Update To Php 5.3.3 9m





    Hi,

    I have a Virtual Server with plesk 11 with php 5.3.2 installed. Unfortunately I need 5.3.3!
    Can I run Plesk 11 with 5.3.3?

    DB:3.16:Update To Php 5.3.3 9m




    Hello,

    Yes you can install php 5.3.3 on your Plesk 11

  • RELEVANCY SCORE 3.15

    DB:3.15:Upgrading Php To 5.3.6 Or Higher And Libxml2 p7





    Hi,

    Im running Plesk Panel 10.4.4 on Centos 5.7 system. Right now i have PHP 5.3.3 that is shipped with Plesk but this version is a bit outdated and it have some bugs, especially related with libxml2. My libxml2 shipped with Centos 5.7 is very old (2.6.26) and i need to update it also. So can anyone suggest any way to upgrade my PHP to a higher version (5.3.8 or may be 5.3.10) and also libxml2 on Centos? Doing this can bring any problem with Plesk 10.4.4?

    many thanks in advance,

  • RELEVANCY SCORE 3.13

    DB:3.13:Php 5.3 Support ax





    I have Plesk Panel 10.3.1 on Ubuntu 8.04

    http://kb.odin.com/en/111711
    APPLIES TO:

    Plesk 10.x for Linux

    Resolution
    To enable the PHP 5.3 support on the Parallels Plesk Panel server you may want to use the Autoinstaller tool or Parallel Plesk Panel graphical user interface.

    1 install PHP 5.3 using Autoinstaller tool you should run the following command on your server:
    /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component php53

    Ive tried to follow this instruction and the answer was :

    Warning : following components not found hp53
    You already have the latest version of products and all selected components installed.Instalation will not continue.

    So ...i did check with php -v and got that php version is 5.2.4....
    how am I suppose to upgrade to php 5.3.8 which contains important security updates?

    DB:3.13:Php 5.3 Support ax




    PHP53 can be installed via Plesk autoinstaller only on Redhat based OSes. You can use PHP53 for Ubuntu from official vendors repositories.

  • RELEVANCY SCORE 3.13

    DB:3.13:Is Compatible With Php 4 Plesk 9.5.4? a7





    Hello,

    I have a server with Plesk 8.3.0 and PHP 4.3.9 installed, I wonder if I can install Plesk 9.5.4 without eliminating PHP 4.3.9.
    In ester webs server I have programmed in PHP4 and I can not install PHP5.

    Thanks!

    DB:3.13:Is Compatible With Php 4 Plesk 9.5.4? a7




    As you can see in Plesk 9.5.4 Release Notes http://download1.parallels.com/Plesk/PPP9/rn/en-US/plesk-9.5.4-for-rpm-based-os.html#5 PHP 4 is supported by this Plesk version.

  • RELEVANCY SCORE 3.13

    DB:3.13:Plesk 11 - Php 5.3 3k





    Hey.
    Can i update PHP of 5.2.17 on 5.3(.21) from Plesk?

    DB:3.13:Plesk 11 - Php 5.3 3k




    PHP 5.3 has been updated to version 5.3.21 in MU#38 - http://kb.parallels.com/115579

  • RELEVANCY SCORE 3.13

    DB:3.13:Plesk 9.2 And Php 5.3 ak





    Hi

    Is it possible to install PHP 5.3.x beside 5.2.9 on our Plesk 9.2 System?

    If not, is it possible to upgrade the PHP Version to 5.3.x?

    Best regards,
    Stefan

    DB:3.13:Plesk 9.2 And Php 5.3 ak




    How do you install version 5.2.17? I did PHP info on a sample site on a Windows server that has been upgraded to 9.5.5 and its displaying version 4.4.9.

    EDIT: I found these instructions:

    [How to] upgrade custom PHP 5 for Parallels Plesk Panel 8.x and 9.x
    http://kb.parallels.com/6670

    Our problem was however that we just needed to select 5.2.17 from the Web Hosting setup dialog.

  • RELEVANCY SCORE 3.13

    DB:3.13:Plesk Installer Updated Php To 5.3.3 We Need 5.3.21 fd





    What we have: 11.0.9 Update #60 running on CentOS 5.10 (Final)
    Problem: After an update from Php 5.3.21 to Php 5.4, Plesk did not work anymore so we downgraded to Php 5.1 and used the Plesk installer to get back to Php 5.3.3 After this update many sites on the host arent working optimum so we want to get back to 5.3.21 how can we do this without breaking plesk? Why: we needed soap

    DB:3.13:Plesk Installer Updated Php To 5.3.3 We Need 5.3.21 fd




    Were maintaining PHP 5.3.x in the Nucleus repo, backporting security fixes from PHP 5.4 and/or 5.5 when necessary. More info on Nucleus is available here:

    https://www.atomicorp.com/products/nucleus.html

  • RELEVANCY SCORE 3.12

    DB:3.12:Upgrade From Plesk 7.5.4 To Plesk 8 33





    i have redhat 9 server plesk installed psa v7.5.4_build75060321.21 os_RedHat 9. My questions are:
    1) what shall i do before upgrade to plesk 8 (any fixes, pacthes etc).
    2) what is the easyest way of upgrade, is there auto installer/upgrader?
    3)during upgrade is there anything to care about.
    4)after upgrading will php and mysql version upgrade also?
    Thanks;

    DB:3.12:Upgrade From Plesk 7.5.4 To Plesk 8 33




    1) Order a clean server with Plesk 8 installed already. sw-soft really screwed up the upgrade process, and youll find you will end up with more headaches than are worth it. Either go clean, or stick with 7.5.4, which you know works.
    2) The easiest is not always the best. The web-based updater will work, sometimes. There are a lot of problems people are discovering in the update that you would have to hunt through server logs in order to fix. The best way is to download the ~1.5mb autoinstaller from the sw-soft downloads page, and run it from SSH. This will let you observe the process as it happens, and know right away of any problems it runs into.
    3) Other than whether the server will still serve webpages without some tweaking and reupdating? Nothing more than usual. If you update, you run the risk of some pretty hefty server loads, and your server no longer delivering mail to root (logwatch files, and Plesk cron notices, for example). drweb is causing quite a number of headaches, as is the communications between spamassassin and qmail slowing to a crawl, and shooting the resource usage through the roof. Those who start clean with 8.0 are finding this less. Oh yeah... the backup process is **** now, and the files you generate with 7.5.4 are VERY likely not going to be readable with 8.0 (there are a few people who say that they are, but a search of the forum will show many more saying they are not).
    4) No. You will want to use a program like yum to update your php and mysql manually. atomicrocketturtle has a repository that can handle this for you.

    I am really pushing on you here to either stick with 7.5.4 until sw-soft figures out how to release patches, or migrate to a clean Plesk 8. A search of Plesk 8 problems on any number of support boards or Google will only further support this suggestion.

  • RELEVANCY SCORE 3.12

    DB:3.12:Upgrade Php To 5.2.4 Or Higher On Plesk 10.3.1 x9





    Hello, how do i upgrade php on CentOS 5.6 64bits on Plesk 10.3.1

    and on Plesk 9.6 CentOS 32 bits

    Both servers has web sites.

    Thanks
    Jc

    DB:3.12:Upgrade Php To 5.2.4 Or Higher On Plesk 10.3.1 x9




    I tryed to upgrade the PHP I got the error below

    File downloading PSA_9.5.4/update-rpm-CentOS-5-i386/php53-xml-5.3.3-1.el5_6.1.i386.rpm: was skipped because of md5 checksum match.
    File downloading PSA_9.5.4/update-rpm-CentOS-5-i386/php53-common-5.3.3-1.el5_6.1.i386.rpm: was skipped because of md5 checksum match.
    Starting installation of packages
    Installing the package psa-migration-manager-9.5.4-cos5.build95110630.11.i586, psa-backup-manager-9.5.4-cos5.build95110630.11.i586, psa-api-rpc-9.5.4-cos5.build95110630.11.noarch, psa-api-9.5.4-cos5.build95110630.11.noarch
    error: Failed dependencies:
    psa 9.5.4 conflicts with psa-api-9.5.4-cos5.build95110630.11.noarch
    ERROR: Unable to install the requested packages because either there is
    not enough free disk space left, or there are package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.
    [root@ns2 ~]#

  • RELEVANCY SCORE 3.12

    DB:3.12:Plesk 11.X To 11.5 Upgrade Gone Bad m1





    Hello,

    After upgrading nothing loads and the error I get when trying to login to plesk is the following...

    Unable to execute php_handlers_control: [Warning] removing handler `5.3 (module) due to errors in getting php version : can not get version from /usr/bin/php-cgi
    [Warning] removing handler `5.3 (cgi) due to errors in getting php version : can not get version from /usr/bin/php-cgi

    Any help would be awesome. Im at a loss.

  • RELEVANCY SCORE 3.11

    DB:3.11:Php 5.3 Modules cj





    Hi

    I currently got plesk 11.5.30 and due to some clients sites, I am unable to install php 5.4.

    I am currently running php 5.3.3 and need to install php-mycrypt. I have searched your documents high and low. We need this urgently.

    I have tried yum install php53-common and pyp53-mycrpt but it prompts us to install php v5.4 but we cannot upgrade to 5.4

    Thanks

    DB:3.11:Php 5.3 Modules cj




    I believe that php-mcrypt is available for 5.3 from the EPEL repo.

  • RELEVANCY SCORE 3.11

    DB:3.11:Upgrade To Latest Php 5.4.7 Or 5.3.17 1x





    My hosting with 1and1 running using plesk 11 uses php version 5.3.3. How can this be upgraded to the latest version(s) either 5.3.17 or 5.4.7? Im concerned about security problems.

  • RELEVANCY SCORE 3.09

    DB:3.09:Plesk 11 Install Fails: Zend_Exception: File Db\Adapter\Pdo\Mysql.Php Does Not Exis 81





    I am trying to install Plesk 11 on a fresh Windows 2008 SP2 64bit server. After I run the autoinstaller (AI.EXE) and I try to open the Plesk interface in a browser, I receive the following error message:



    ERROR: Zend_Exception
    File Db\Adapter\Pdo\Mysql.php does not exist or class Db_Adapter_Pdo_Mysql was not found in the file

    0: Loader.php:99
    Zend_Loader::loadClass(string Db_Adapter_Pdo_Mysql)
    1: Db.php:250
    Zend_Db::factory(object of type Zend_Config)
    2: Abstract.php:155
    CommonPanel_Application_Abstract::initDbAdapter()
    3: Abstract.php:118
    CommonPanel_Application_Abstract-_initDbAdapter()
    4: Abstract.php:39
    CommonPanel_Application_Abstract-run()
    5: Abstract.php:24
    CommonPanel_Application_Abstract::init()
    6: auth.php3:136

    DB:3.09:Plesk 11 Install Fails: Zend_Exception: File Db\Adapter\Pdo\Mysql.Php Does Not Exis 81




    Well, I reuninstalled (?) Plesk, and then removed the /Program Files (x86)/Parallels/Plesk/admin folder as well as the /Plesk/admin folder. After that, I redownloaded the autoinstaller, and installed it again. This time it worked. Strange. Perhaps there was an issue when attempting to download the mysql.php file. Thanks for your help.

  • RELEVANCY SCORE 3.09

    DB:3.09:11.5.30 Ui Buttons And Php Options Missing z3





    Upgraded to 11.5.30 (CentOS) and everything seems to have gone smoothly aside from a few issues:

    1) In Service Plans, the Save button is missing when editing or adding a new service plan. I just receive two dots where a button should be. Cant save any Service Plan edits or add new Service Plans.
    2) In Hosting Parameters, Run PHP As shows an empty dropdown without any options.
    3) PHP now runs as Apache module for all domains now that were previously running under FastCGI in Plesk 11.9.

    Anyone else experiencing something similar?

    DB:3.09:11.5.30 Ui Buttons And Php Options Missing z3




    Cant reproduce issue with Button.

    Try to do following with PHP handlers:
    Check the PHP version with this command:

    # php -v

    Make sure that it does not show any error.
    Check the PHP handlers in /etc/psa/php_versions.json or with this command:

    # /usr/local/psa/admin/sbin/php_handlers_control --list

    Make sure that the PHP version is correct.

    Check the PHP handlers in the Plesk database. They should appear as below:

    mysql select section,name from ServiceNodeEnvironment where section=phphandlers;
    +-------------+---------+
    | section | name |
    +-------------+---------+
    | phphandlers | cgi |
    | phphandlers | fastcgi |
    | phphandlers | module |
    | phphandlers | synced |
    +-------------+---------+

    If some handlers are missing from the database, it is necessary to refresh the Plesk Components in the Plesk Control Panel Tools and Utilities Server Components and press the Refresh button.
    Also you can reread the PHP handlers from php_versions.json with this command:

    # /usr/local/psa/admin/sbin/php_handlers_control --reread

  • RELEVANCY SCORE 3.09

    DB:3.09:Plesk 8.3 Php Problem fx





    Hi
    i have a plesk 8.3 for windows . i have a problem for php support.
    i user wordpress or joomla and wp or joomla are run but foreach command in php file dosnt support . Repair plesk or install php 5.2.5 but dont resolve this problem.
    help me

    DB:3.09:Plesk 8.3 Php Problem fx




    Hi
    i have a plesk 8.3 for windows . i have a problem for php support.
    i user wordpress or joomla and wp or joomla are run but foreach command in php file dosnt support . Repair plesk or install php 5.2.5 but dont resolve this problem.
    help me

  • RELEVANCY SCORE 3.09

    DB:3.09:Plesk 9.5.4 Installation From Rhel6 (X64) 1d





    Hi, All

    I dont see people use RHEL6 to install Plesk (but my company do, because RHEL6 is compatible with Plesk 9.5.4)
    Background:
    Our old hosting in RHEL5 use Plesk 9.2 and look like it was compromised from Plesk vulnerability.
    Our Security Team suggest us to reinstall to OS and Restore the config and file.
    migrate to new version of Plesk is not choice because this is our old customer and they are not yet try to use the new one. (by the way, some customer already use PSA10)
    So I setup new RHEL6 becuase Plesk 9.5.4 support it.

    ---------------------------------------------------------------
    PRODUCT: Parallel Plesk Control Panel
    VERSION: 9.5.4
    OPERATING SYSTEM: Redhat Enterprise Linux 6.4
    ARCHITECTURE: x64

    PROBLEM DESCRIPTION
    Everthing is going smoothly until it try to prepare for php-mbstring-5.3.2-6.el6.1.x86_64 (PLESK_9_5_4-thirdparty) and php-imap-5.3.2-6.el6.1.x86_64 (PLESK_9_5_4-thirdparty)
    it fail and quit.

    STEPS TO REPRODUCE
    1. Run parallels_installer_v3.9.0_build110316.16_os_RedHat_el6_x86_64

    2. Install from Official Parallels server and install to /root/parallels

    3. No Proxy

    4. Select Product 1

    5. Select Version 8
    1. [*] Parallels Plesk Panel
    2. ( ) Parallels Plesk Panel 11.5.30
    3. ( ) Parallels Plesk Panel 11.0.9 (stable)
    4. ( ) Parallels Plesk Panel 10.4.4 (stable)
    5. ( ) Parallels Plesk Panel 10.3.1
    6. ( ) Parallels Plesk Panel 10.3.0
    7. ( ) Parallels Plesk Panel 10.2.0
    8. (*) Parallels Plesk Panel 9.5.4

    6 Select Installation Option 1 (Typical)

    7. Install it...and fail

    ACTUAL RESULT
    ....
    --- Package php-imap.x86_64 0:5.3.2-6.el6.1 will be installed
    -- Processing Dependency: php-common = 5.3.2-6.el6.1 for package: php-imap-5.3.2-6.el6.1.x86_64
    --- Package php-mbstring.x86_64 0:5.3.2-6.el6.1 will be installed
    -- Processing Dependency: php-common = 5.3.2-6.el6.1 for package: php-mbstring-5.3.2-6.el6.1.x86_64
    --- Package zlib.i686 0:1.2.3-29.el6 will be installed
    -- Finished Dependency Resolution
    Error: Package: php-mbstring-5.3.2-6.el6.1.x86_64 (PLESK_9_5_4-thirdparty)
    Requires: php-common = 5.3.2-6.el6.1
    Available: php-common-5.3.2-6.el6.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.2-6.el6
    Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.2-6.el6_0.1
    Available: php-common-5.3.2-6.el6.1.x86_64 (PLESK_9_5_4-thirdparty)
    php-common = 5.3.2-6.el6.1
    Available: php-common-5.3.3-3.el6.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6
    Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6_1.3
    Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6_2.5
    Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6_2.6
    Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6_2.8
    Available: php-common-5.3.3-14.el6_3.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-14.el6_3
    Available: php-common-5.3.3-22.el6.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-22.el6
    Installing: php-common-5.3.3-23.el6_4.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-23.el6_4
    Error: Package: php-imap-5.3.2-6.el6.1.x86_64 (PLESK_9_5_4-thirdparty)
    Requires: php-common = 5.3.2-6.el6.1
    Available: php-common-5.3.2-6.el6.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.2-6.el6
    Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.2-6.el6_0.1
    Available: php-common-5.3.2-6.el6.1.x86_64 (PLESK_9_5_4-thirdparty)
    php-common = 5.3.2-6.el6.1
    Available: php-common-5.3.3-3.el6.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6
    Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6_1.3
    Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6_2.5
    Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6_2.6
    Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-3.el6_2.8
    Available: php-common-5.3.3-14.el6_3.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-14.el6_3
    Available: php-common-5.3.3-22.el6.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-22.el6
    Installing: php-common-5.3.3-23.el6_4.x86_64 (rhel-x86_64-server-6)
    php-common = 5.3.3-23.el6_4
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    ERROR: The Yum utility failed to install the required packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.

    EXPECTED RESULT
    its install completely.

    if you need debug log. please inform.

    DB:3.09:Plesk 9.5.4 Installation From Rhel6 (X64) 1d




    #1 I would recommend not to install 9.5.x anymore, since its been EOL (end of lifed) you wont get updates or support on it. With that said, I would also not use the third party stuff to install it. Add in the third party repos once you are done installing and then update your system.

    If you have to use a third party repo to install, I would recomend using Atomic, its easy and updated and pretty straight forward. You can install it on your system like this
    wget -q -O - http://www.atomicorp.com/installers/atomic | sh

  • RELEVANCY SCORE 3.09

    DB:3.09:Upgraded 11.0.9 , Where Is My Php 5.3.10? f1





    How to enable and run Apache with php5-fpm not php5-cgi?

    Hi
    just installed everything
    is there any easy way to enable mod_fastcgi with php-fpm? instead of fcgid

    in cpanel it was pretty easy to do, just add this in virtual host include:
    IfModule mod_fastcgi.c
    FastCGIExternalServer /usr/sbin/php-fpm -host 127.0.0.1:9000
    AddHandler php-fastcgi .php

    Action php-fastcgi /usr/sbin/php-fpm.fcgi
    ScriptAlias /usr/sbin/php-fpm.fcgi /usr/sbin/php-fpm

    /IfModule

    but it doesnt wokr with plesk, it keep running as php5-cgi
    i have changed everything, maybe i forgot something?

    thank you

    DB:3.09:Upgraded 11.0.9 , Where Is My Php 5.3.10? f1




    You could try doing the same with /var/www/vhosts/domain.com/conf/vhost.conf and the rebuild the vhosts

  • RELEVANCY SCORE 3.09

    DB:3.09:Upgrading Php 5.2 To 5.3.17 On Debian 5 93





    Hello everybody,

    I am a plesk newbie but I have long experience with webservers and php, I need an advice about the upgrade of Php on plesk 9.5.4: I have found some posts on the forum and some kb articles, but regarding other versions of plesk and centos, it seems like not about debian and Php 5.3.

    On debian 5 I cannot find any package newer than 5.3.10, lets assume I am able to download the last tarball from php.net, then compile it and deploy properly for a server without plesk, my question is: once the new php is up and running, how I manage to set up things properly for plesk?

    Thank you for any advice you may give to me...

    Best to all!

    DB:3.09:Upgrading Php 5.2 To 5.3.17 On Debian 5 93




    Thank you Alexey for your answer.

    As you suggested I installed binaries from dotdeb, php 5.3.10, forcing a bit on dependencies but after the installation all runs smooth, so I have checked all scripts against 5.3 as first thing.

    I tried to build from 5.3.17 source a php.fcgi almost as configured in debian and to substitute to the binary php-cgi in /var/www/cgi-bin/cgi_wrapper/cgi_wrapper touching as minus as possible the configuration, and, setting in plesk that a domain uses fcgi, I have php 5.3.17 running on that domain wit fcgi.

    Now I will try to build php again using the same path on package, as you suggest, and I will report about my progress.

    I think I will start to use this congiguration on production site, switching to the new php domain by domain on the panel webpage, then I will use the 5.3.10 version only (?1) on horde; if/when all domains are ok, I will install the rebuilded php with the same path of the package.

    I try to create as small problem as I can to users now, this way we will have a more secure server in short time, then we will hold on till next year when we will switch directly to new server with plesk 11.

    Do you think this procedure will work?

    Thank you!

  • RELEVANCY SCORE 3.08

    DB:3.08:Fileinfo.So And Zip.So Modules Issues In Php 5.3.3 With Plesk 9f





    I keep getting the following error message on one of my Plesk machines running 11.0.9



    # php -v
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib64/php/modules/fileinfo.so - /usr/lib64/php/modules/fileinfo.so: undefined symbol: zval_property_ctor in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib64/php/modules/zip.so - /usr/lib64/php/modules/zip.so: undefined symbol: zval_property_ctor in Unknown on line 0
    PHP Warning: Directive safe_mode is deprecated in PHP 5.3 and greater in Unknown on line 0
    PHP 5.3.3 (cli) (built: Jun 27 2012 12:25:48)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.14, Copyright (c) 2002-2011, by ionCube Ltd.

    DB:3.08:Fileinfo.So And Zip.So Modules Issues In Php 5.3.3 With Plesk 9f




    Uf, no, it does not work neither.

    yum install yum-utils: OK

    yumdownloader php-zip: No Match for argument php-zip
    yumdownloader php-fileinfo

    rpm -Uvh --force php-zip.***.rpm error: File not found by glob: php-zip.***.rpm
    rpm -Uvh --force php-fileinfo***.prm

    Thanks again!

  • RELEVANCY SCORE 3.08

    DB:3.08:Plesk 11.5 Multiple Php Versions: Php.Ini Files Do Not Load d8





    I was able to configure my Plesk to read the latest version of PHP from source. However, when I edit the php.ini file associated with the particular installation (the one I assigned to the Plesk php_handler), the modifications are not loaded at runtime.

    For example, changing memory_limit from 128M to 64M, still shows 128M in runtime, despite of a reboot and running the --reread flag on the Plesk php_handler

    Code:

  • RELEVANCY SCORE 3.07

    DB:3.07:Oci8 Module Doesn't Load On Rhel6 With Php 5.3.8 mm


    Dear friends,

    I spent my last 3 days for this problem. I didn't solve yet. Below I will show OS PHP parameters. Please give me your solution for solving problem.

    OS version: RHEL6 - 2.6.32-71.29.1.el6.x86_64
    php version : PHP 5.3.8 (cli) (built: Sep 25 2011 11:33:49

    and when I try command php -v , output below:

    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/oci8.so' - libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/pdo_oci.so' - libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP 5.3.8 (cli) (built: Sep 25 2011 11:33:49)
    Copyright (c) 1997-2011 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies

    installed modules:

    php-dba-5.3.8-5.el6.remi.x86_64
    php-gd-5.3.8-5.el6.remi.x86_64
    php-pgsql-5.3.8-5.el6.remi.x86_64
    php-mysqlnd-5.3.8-5.el6.remi.x86_64
    php-xmlrpc-5.3.8-5.el6.remi.x86_64
    php-fpm-5.3.8-5.el6.remi.x86_64
    php-cli-5.3.8-5.el6.remi.x86_64
    php-oci8-5.3.8-5.el6.remi.x86_64
    php-mcrypt-5.3.8-5.el6.remi.x86_64
    php-devel-5.3.8-5.el6.remi.x86_64
    php-soap-5.3.8-5.el6.remi.x86_64
    php-intl-5.3.8-5.el6.remi.x86_64
    php-common-5.3.8-5.el6.remi.x86_64
    php-pdo-5.3.8-5.el6.remi.x86_64
    php-mbstring-5.3.8-5.el6.remi.x86_64
    phpMyAdmin-3.4.8-1.el6.remi.noarch
    php-tidy-5.3.8-5.el6.remi.x86_64
    php-ldap-5.3.8-5.el6.remi.x86_64
    php-bcmath-5.3.8-5.el6.remi.x86_64
    php-embedded-5.3.8-5.el6.remi.x86_64
    php-xml-5.3.8-5.el6.remi.x86_64
    php-enchant-5.3.8-5.el6.remi.x86_64
    php-5.3.8-5.el6.remi.x86_64
    php-process-5.3.8-5.el6.remi.x86_64

    DB:3.07:Oci8 Module Doesn't Load On Rhel6 With Php 5.3.8 mm

    Maybe those RPMs depend on http://www.oracle.com/technetwork/topics/linuxx86-64soft-092277.html

    Actually, I wouldn't try to solve it, I would just install Zend Server CE http://www.zend.com/en/products/server-ce/downloads
    which has OCI8 and the Instant Client libraries already included.

    Note that Oracle libraries are not certified on RHEL 6.

  • RELEVANCY SCORE 3.07

    DB:3.07:Php 5.2.6 kc





    Hello,

    I have a VPS with PHP 4.3.9, Virtuozzo, Plesk 8.4.0, and Centos release 4.5.

    How can I upgrade to PHP 5.2.6?

    Thanks,
    Jack

    DB:3.07:Php 5.2.6 kc




    I have no idea, I dont use SuSE. If there is anyone who packages the latest PHP for SuSE 10.0 you might be able to use those packages. Otherwise youd have to do it yourself.

  • RELEVANCY SCORE 3.07

    DB:3.07:9.5.3 From 9.5.2 Update Failure. Sites Offline. Please Help. Details Included. k1





    went into parallels plesk updater within admin, said there was an update to 9.5.3 from 9.5.2.

    Ran the update from within the admin, something went wrong and sites went down.

    Various things I tried, took 10 hrs and finally had to restore server image to a week old build to get sites back.

    When on the non working 9.5.3 I noticed it was adding additional these additional lines to the bottom of the http.conf file:

    AddType text/html .shtml
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

    meaning these lines were written twice in the file. I obivously the duplicate lines out and restarted server but sites still didnt work.

    Here are the email details I got after update, please can someone let me know what happened and what I should do if I want to update to a working 9.5.3 build? As it stands I cant update.

    for reference I always keep things upto date with yum upgrade.

    Parallels Products Installer 3.6.0 (built on 2010-04-13 11:20 svn rev. 290858) started at (timezone GMT) Wed Nov 3 22:07:03 2010
    Command line arguments: /usr/local/psa/admin/bin/autoinstaller --enable-xml-output --source-type=plesk --target=/root/psa --select-release-id=PLESK_9_5_3 --notify-email=blah.com --install-component=psa-autoinstaller --no-daemon

    Try to find rcfile...
    Autoinstaller rcfile not found.
    Checking hostname is sucessfull.
    Opsys detected as: os_vendor=CentOS os_name=Linux version=5.5 arch=x86_64 environment=vz
    Final opsys (with overriding) is: os_vendor=CentOS os_name=Linux version=5.5 arch=x86_64 environment=vz
    File downloading products.inf3: 100% was finished.
    File downloading plesk.inf3: 10%..21%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading ppsmbe.inf3: 18%..29%..39%..50%..61%..71%..82%..92%..100% was finished.
    File downloading sitebuilder.inf3: 10%..22%..35%..48%..61%..74%..87%..99%..100% was finished.
    File downloading setemplates.inf3: 19%..44%..69%..94%..100% was finished.
    File downloading pp-sitebuilder.inf3: 28%..65%..100% was finished.
    File downloading billing.inf3: 15%..34%..54%..73%..93%..100% was finished.
    repository: Get brief packages info for all sources
    Checking for installed packages...
    File downloading PSA_9.5.3/plesk-9.5.3-cos5-x86_64.inf3: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    Parallels Containers were detected. Trying to connect to VZAgent...Warning! Failed to connect to VZAgent: open: No such device or address
    repository: Get brief packages info for all sources
    Detecting installed product components.
    Component plesk/base: mode upgrade, installed=1272946091, available=1287745188
    Checking if key update required for component plesk/base
    Config allows upgrade from version 9.5 without key update
    Currently installed component version is 9.5.2-cos5.build95100504.10
    No keyupdate need for this component
    Component plesk/psa-autoinstaller: mode up2date, installed=1271132654, available=1271132654
    Component plesk/postgresql: mode install, installed=0, available=1274830765
    Component plesk/vault: mode upgrade, installed=1272946147, available=1287721334
    Component plesk/ppwse: mode install, installed=0, available=1287721309
    Component plesk/api: mode upgrade, installed=1272946057, available=1287721245
    Component plesk/pmm-vz: mode upgrade, installed=1272946008, available=1287721205
    Component plesk/sb-publish: mode install, installed=0, available=1179887889
    Component plesk/sbm: mode install, installed=0, available=1220864885
    Component plesk/cf-support: mode install, installed=0, available=1287721323
    Component plesk/miva: mode install, installed=0, available=1287721326
    Component plesk/billing: mode install, installed=0, available=1245902780
    Component plesk/mod-bw: mode install, installed=0, available=1194490345
    Component plesk/asp: mode up2date, installed=1261760091, available=1223518800
    Component plesk/java: mode install, installed=0, available=1287721250
    Component plesk/mod_python: mode up2date, installed=1168104152, available=1168104152
    Component plesk/ruby: mode install, installed=0, available=1287721324
    Component plesk/php5: mode upgrade, installed=1272946161, available=1287721348
    Component plesk/qmail: mode install, installed=0, available=1287721343
    Component plesk/postfix: mode upgrade, installed=1272946149, available=1287721343
    Component plesk/psa-firewall: mode install, installed=0, available=1287721249
    Component plesk/psa-vpn: mode install, installed=0, available=1287721290
    Component plesk/psa-fileserver: mode install, installed=0, available=1287721242
    Component plesk/sshterm: mode up2date, installed=1228112978, available=1228112978
    Component plesk/watchdog: mode install, installed=0, available=1287721313
    Component plesk/cs-gs: mode install, installed=0, available=1287721247
    Component plesk/battlefield: mode install, installed=0, available=1287721302
    Component plesk/bf2: mode install, installed=0, available=1287721322
    Component plesk/mailman: mode install, installed=0, available=1287721320
    Component plesk/kav: mode install, installed=0, available=1287721330
    Component plesk/drweb: mode install, installed=0, available=1287721225
    Component plesk/spamassassin: mode install, installed=0, available=1287721253
    Component plesk/backup-vz: mode upgrade, installed=1272946128, available=1287721319
    Component plesk/de-DE-locale: mode upgrade, installed=1272361765, available=1279175238
    Component plesk/ja-JP-locale: mode install, installed=0, available=1279175390
    Component plesk/es-ES-locale: mode upgrade, installed=1272361796, available=1285925794
    Component plesk/ru-RU-locale: mode install, installed=0, available=1279175419
    Component plesk/fr-FR-locale: mode upgrade, installed=1272361827, available=1279175331
    Component plesk/it-IT-locale: mode install, installed=0, available=1279175362
    Component plesk/zh-CN-locale: mode install, installed=0, available=1279175445
    Component plesk/zh-TW-locale: mode install, installed=0, available=1279175471
    Component plesk/nl-NL-locale: mode install, installed=0, available=1279175499
    Component plesk/horde: mode upgrade, installed=1272946110, available=1287721300
    Component plesk/atmail: mode install, installed=0, available=1287721220
    You already have the latest version of product(s) and all selected components
    installed. Installation will not continue.


    ---
    Parallels Products Installer.

    DB:3.07:9.5.3 From 9.5.2 Update Failure. Sites Offline. Please Help. Details Included. k1




    Plesk support is useless, especially when the software breaks. always has been.

    no email response, no forum response.

    its about time parallels employed some full time people to manage these forums, they have loads of customers and the amount of unanswered support queries in this forum is huge.

    im fed up waiting for help for a product I pay good money for, well be migrating all our services to cpanel, at least they support their software adequately.

    thanks for the help!

  • RELEVANCY SCORE 3.06

    DB:3.06:Upgrade 8.0.0 To Latest Version On Centos 4.3 Error pc





    All,

    When attempting to upgrade version 8.0.0 (psa v8.0.0_build80060425.18 os_CentOS 4.2) to 8.0.1 (build80060713.16) the autoinstaller fails. It appears it wants to first update to build80060613.20, which doesnt work. Has anyone seen this behaviour and if so; found a solution?

    Please select the components you wish to install:

    1. [*] Base packages of Plesk
    2. [*] Plesk Updater
    3. [=] Frontpage 2002 support
    4. [*] Apache ASP support
    5. [*] Mailman mailing list manager support
    6. [=] PosgreSQL server support
    7. [ ] Tomcat Java Servlets support
    8. [*] SpamAssassin support
    9. [*] SPAM blocker for QMail daemon
    10. [=] Apache mod_python module
    11. [*] Application vault packages
    12. [*] Additional Horde (webmail) components for Plesk
    13. [*] Additional Plesk manuals
    14. [*] Backup utilities
    15. [ ] Dr. Web antivirus
    16. [ ] Plesk Professional Web Site Editor
    17. [*] Plesk API [former Plesk Agent]
    18. [ ] SSHTerm - SSH Terminal java applet
    19. [*] Plesk migration manager
    20. [*] Plesk Firewall module
    21. [ ] Plesk Counter-Strike game server module
    22. [ ] Plesk VPN module
    23. [ ] Plesk Battlefield 1942 game server module
    24. [ ] Plesk Battlefield2 game server module
    25. [ ] Plesk Fileserver module and SMB file server package
    26. [*] Watchdog (System monitoring module)
    27. [ ] SiteBuilder and Sitebuilder module for Plesk
    28. [ ] ColdFusion support for Plesk
    29. [ ] Acronis TrueImage module

    N) Next page; P) Go back; Q) Cancel installing;
    A) Select all; D) Deselect all;
    To toggle component enter its number;
    Type a number or a character of desired action [N]: n
    Reading system installed packages...done.
    Download file plesk-8.0.1-cos4.2-i386.hdr.gz: 11%..21%..33%..46%..58%..72%..85%..97%..100% done
    Download file plesk-8.0.1-cos4.2-i386.hdr.gz: 30%..72%..100% done
    Resolve components
    ERROR: Package perl-HTML-Tree-1:1:3.16-centos4.2.build80060613.20.noarch listed in inf3 file, but not found in build headers (hdr.gz) file, possible versions mismatch.
    ERROR: Installation failed

    DB:3.06:Upgrade 8.0.0 To Latest Version On Centos 4.3 Error pc




    Ok, ill give that a try.

    How did you remove the Tomcat rpm?

  • RELEVANCY SCORE 3.06

    DB:3.06:Php 4.3.11 In Plesk 7.5.2? f9





    I am running Plesk 7.5.2 in a Fedora Core 2 Linux dedicated hosting server. The hosting company installed php version 4.3.10-2.4in that server and plesk is running fine. But if I upgrade to php version 4.3.11. Would that cause any problem to the plesk in that server? Thanks

    Scott

    DB:3.06:Php 4.3.11 In Plesk 7.5.2? f9




    There are a couple of other posts in this forum regarding 4.3.11, one person cant get it to install/upgrade, the other jshanley found that Plesk on FreeBSD has 2 versions already installed, on for the CP the other for general use.

    Search the forum for 4.3.11

  • RELEVANCY SCORE 3.06

    DB:3.06:Plesk Not Working After Update To Php 5.3 xs





    I added support for PHP 5.3 using Plesk Update interface and after update Plesk stopped working!

    Any suggestions?

    DB:3.06:Plesk Not Working After Update To Php 5.3 xs




    I think, Plesk wants to have a path to the ius.community repositories, from where you have installed the php.

    try http://dl.iuscommunity.org/pub/ius instead

  • RELEVANCY SCORE 3.05

    DB:3.05:Php Update To 5.3.8 cf





    Hello

    How can I update my PHP version from 5.3.3 to 5.3.8 ?
    Im on a debian 6.0.5 with Plesk 11.0.9

    Thank you in advance

    DB:3.05:Php Update To 5.3.8 cf




    Hello stecoco,

    There is several ways:

    1. Most simple, if you trust third-party repositories, its just add dotdeb repo in apts sources list.

    2. Less simple and ideologically wrong is just build from sources via make make intall

    3. ideologically correct is to create your own package, for example, by this guide: http://www.debian.org/doc/manuals/maint-guide/index.en.html

  • RELEVANCY SCORE 3.04

    DB:3.04:Upgrading 9z





    can i upgrade my mysql database? and php?? will plesk be ok with it?? whats the max verion of max and php i can install with plesk? its fedora core 3.. and plesk 7.5.4

    DB:3.04:Upgrading 9z




    For 7.5.4 latest PHP of 5 or 4 branch and latest MySQL of 4.1 branch.

  • RELEVANCY SCORE 3.04

    DB:3.04:Update Broken Php ad





    Plesk 10.2 Centos 4.8 x86

    Issue
    -----
    After upgrade from 10.0.1 to 10.2 php FastCGI module runs as version 4 and does not have MySQL support.

    /usr/bin/php does not exist but yum says php is installed (5.1.6-3.el4s1.10).

    /usr/bin/php-cgi -v:
    Failed loading /opt/php51/lib/php5/ioncube_loader_lin_5.1.so: /opt/php51/lib/php5/ioncube_loader_lin_5.1.so: undefined symbol: _zend_hash_add_or_update
    PHP 4.3.9 (cgi-fcgi) (built: Jan 14 2011 11:59:31)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

    Running php as an apache module uses PHP version 5.

    Question
    --------
    How can I get php to run as version 5 for fastcgi with Mysql support.
    Where did my /usr/bin/php go?

    Thanks.

    DB:3.04:Update Broken Php ad




    Sounds like its safe to try a yum remove and yum reinstall for php and install it like I would for a generic Apache box??

    Or is RPM preferred?

    [...]# /usr/bin/php -v
    -bash: /usr/bin/php: No such file or directory

    [...]# rpm -qf /usr/bin/php
    error: file /usr/bin/php: No such file or directory

    [...]# /usr/bin/php-cgi -v
    Failed loading /opt/php51/lib/php5/ioncube_loader_lin_5.1.so: /opt/php51/lib/php5/ioncube_loader_lin_5.1.so: undefined symbol: _zend_hash_add_or_update
    PHP 4.3.9 (cgi-fcgi) (built: Jan 14 2011 11:59:31)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

    [...]# rpm -qf /usr/bin/php-cgi
    psa-php4-cgi-4.3.9-11011411

    [...]# cat /usr/local/psa/version
    10.2.0 CentOS 4.2 1011110331.11

  • RELEVANCY SCORE 3.04

    DB:3.04:11.5 Php-Fpm Fails To Restart 9s





    Running the latest version of plesk and when I try to restart php-fpm, I get the below error:

    Anyone have any ideas on how I can resolve this issue?

    Code:

    DB:3.04:11.5 Php-Fpm Fails To Restart 9s




    Update:

    Was able to fix this by re-installing apc via:

    Code:

  • RELEVANCY SCORE 3.04

    DB:3.04:Plesk Update 9.5.4 Failure ad





    Hi all,

    Ive a problem, i need php 5.2.6 for my cms, and in the plesk updater was not 5.2.6 also ive updatet php manually to 5.2.6, now plesk has the problem that he dont see php! Ive tryed to run plesk update, but he says only php is allready installed, failure to install, an on the domains i cant active php support

    what i can do??

    cheers

  • RELEVANCY SCORE 3.03

    DB:3.03:Upgrade Php 5.1.6 To 5.3.2 In Plesk Linux 9.5 z1





    Hi,

    We just upgraded the server from Plesk Panel Linux 8.6 to 9.5, but I noticed the PHP version in 9.5 still showing

    5.1.6-23.2.el5_3

    Can we upgrade the version to 5.3.2? Any risk for doing so as the PHP is integrated with Plesk? Please also advice the steps.

    Thanks.

    Regards,
    Hostpro2u

    DB:3.03:Upgrade Php 5.1.6 To 5.3.2 In Plesk Linux 9.5 z1




    Hi,

    Weve just upgraded the PHP version from 5.1.6 to 5.2.17-1.el5.art but weve received complaints from customer that their website having problem to connect to external MySQL DB (cause we dont use the local MySQL server)

    The error seems like : the php library version is different with the existing mysql version

    Any advice what can we do on this?

    How do we reverse back to old PHP version if still cannot fix?

    Thanks.

  • RELEVANCY SCORE 3.03

    DB:3.03:Plesk 8.2 With Php 5.2.4 k3





    Is it possible to install a new server with php5 as standard and plesk 8.2?

    DB:3.03:Plesk 8.2 With Php 5.2.4 k3




    I did it on a test box and it worked great, and I also did a in place upgrade from 8.1.1 to 8.2.0 with php 5.2.3 installed on a test box and it also worked great.

    I just upgraded production this morning and so far all is well

  • RELEVANCY SCORE 3.03

    DB:3.03:Have Anyone Upgraded To 7.5.3 With Arts Mysql And Php? ds





    Just wondering if anyone upgraded to 7.5.3 with Arts mysql and php and what did you do to upgrade it? Did you downgrade the mysql and php then upgrade or just upgraded it via plesk control panel without doing anything to the mysql and php?

    Thanks
    Bill

    DB:3.03:Have Anyone Upgraded To 7.5.3 With Arts Mysql And Php? ds




    I have updated 2 servers.
    On 1 I have a smll problem on PHP asked me for php-domxml or something like this, was a conflict between PLESK and ART one. I installed from ART this package and then upgrade went well. Always is an error message in mail at the end and that can help to fix the problem.

  • RELEVANCY SCORE 3.02

    DB:3.02:Plesk Fails To Reslove In Browser After Php 5.3 Upgrade 3k





    Hi everyone,

    I upgraded my php installation to 5.3 using these instructions http://chrisjean.com/2011/06/24/upgrade-php-5-1-or-5-2-to-5-3-on-centos/

    Unfortunately Plesk now fails to resolve in the browser now.

    Can anyone help?

    Thanks,

    Charlie

    DB:3.02:Plesk Fails To Reslove In Browser After Php 5.3 Upgrade 3k




    Thanks for your help Paul. I ended up having to roll the server back to before the upgrade.

    Again thanks for your help Paul.

  • RELEVANCY SCORE 3.02

    DB:3.02:Update Centos 6 With Ples 11.5.30 Php 7x





    Hi all im little new on these.

    I just installed and configured Centos 6 with Plesk 11.5.30 and see php that come is php 5.3.3

    Sites i will put on server need at least php 5.3.27 version.

    Any1 can help me on how update php version??

    Ty

  • RELEVANCY SCORE 3.02

    DB:3.02:How To Install Php-Pear (Plesk 10.X Debian 5) ? s7





    Hello, how to install php-pear to work?

    I have Debian 5, and php-pear here to install apt-get install php-pear and restarted apache2 but it gave me the phpinfo it does not show can anyone help?

    DB:3.02:How To Install Php-Pear (Plesk 10.X Debian 5) ? s7




    After editing php.ini has everything works well and thank you for your help.

  • RELEVANCY SCORE 3.02

    DB:3.02:Cant Install Plesk On Centos4 With Php5 j9





    Hello,

    Ime using centos4.5(New install) and I need php5.

    Php 5 was installed using command:
    yum --enablerepo=centosplus install php

    Everything looks fine, and then I start plesk install and I get following error:

    The following could cause the installation failure:
    Packages php-4.3.9-3.22.5.i386 and php-5.1.6-3.el4s1.8.i386 cannot be installed at the same time
    .

    Not all packages were installed.
    Please, contact product technical support.

    I prefer not use atomic rpms, is there any chance to get this working?

    Thanks in advance.

    Regards,

    DB:3.02:Cant Install Plesk On Centos4 With Php5 j9




    It would have worked if you first intalled Plesk and then updated your system using yum afterwards. You can also create an .autoinstallerrc file to tell the Plesk autoinstaller about update channels, so the autoinstaller can deal with newer versions than it expects for the OS.

    But yes, if you want PHP 5 going with CentOS 5 is just the easier way as that comes with PHP 5 out of the box.

  • RELEVANCY SCORE 3.02

    DB:3.02:New Include_Path After Upgrade To 11.5.30 Version? Php-Pear Problem 9k





    Just upgraded to Plesk 11.5.30 and found out that sending SMTP emails with php pear arent working anymore with following error message:



    mod_fcgid: stderr: PHP Fatal error: require_once():
    Failed opening required Mail.php
    (include_path=.:/usr/share/pear)
    in /var/www/vhosts/mydomain.com/httpdocs/check.php on line 4

    DB:3.02:New Include_Path After Upgrade To 11.5.30 Version? Php-Pear Problem 9k




    PEAR bundled with Plesk is not for public use, but is there only for Horde webmail. Therefore it is not recommended to use it, as path to it can change, its content may be removed or added, or it may be removed in future versions at all. Since Horde was upgraded from 3 to 5, bundled PEAR repository also had to be updated.

    Please use your own PEAR installation.

  • RELEVANCY SCORE 3.02

    DB:3.02:Is Plesk 8 + Centos 4.3 + Php 5 Possible? fa





    Hi,

    Im trying to get our server provider to do the above installation and theyre saying they cant do PHP5. Main reason is that

    Apache 2.0 and Plesk 8 need the package php-domxml and its not available for PHP5

    Can anyone verify this or are there workarounds? Ive been reading the other threads and cant tell if folks have this set up.

    Seems like Plesk 8 and PHP 5 should work:
    http://kb.swsoft.com/article_37_378_en.html

    Thanks.

  • RELEVANCY SCORE 3.01

    DB:3.01:Upgrade To Plesk 7.0.2 And Php 4.3.9 3z





    Plesk says PHP not installed. HELP!!!

    Upgrade to plesk 7.0.2 and PHP 4.3.9

    After upgrade I noticed sites are working great, but Plesk say php is not installed anymore..

    the php.ini is still the same... no files are deleted.. path the same.. what does it use to recognize php? its not working... and the php pages are encrypted so I cant check..

    DB:3.01:Upgrade To Plesk 7.0.2 And Php 4.3.9 3z




    Plesk says PHP not installed. HELP!!!

    Upgrade to plesk 7.0.2 and PHP 4.3.9

    After upgrade I noticed sites are working great, but Plesk say php is not installed anymore..

    the php.ini is still the same... no files are deleted.. path the same.. what does it use to recognize php? its not working... and the php pages are encrypted so I cant check..

  • RELEVANCY SCORE 3.01

    DB:3.01:Upgrade To 7.5.3 Fails - Php-Domxml fz





    Received the following report when attempting to upgrade to 7.5.3. Installing php-domxml-4.3.8-1.1.i386.rpm
    error: Failed dependencies: php = 4.3.8-1.1 is needed by php-domxml-4.3.8-1.

    Currently running Plesk 7.5.2 on Fedora Core 1.

    rpm -q php returns php-4.3.10-3.2

    rpm -q php-domxml returns package php-domxml is not installed

    yum install php-domxml returns ....Unable to satisfy dependencies Package php-domxml needs php = 4.3.10-1.1.legacy, this is not available.

    And, unfortunately, I am not a linux guy.. Please assist.

    DB:3.01:Upgrade To 7.5.3 Fails - Php-Domxml fz




    I was getting the same error while trying to upgrade to 7.5.3. I finally got it to work by doing the following.

    Find php-domxml-4.3.8-1.1.i386.rpm, i think by default it will be located in /root/psa/PSA_7.5.3/FC1_std.updates/

    then i manually installed just this file with the --nodeps flag.

    rpm -Uvh --nodeps php-domxml-4.3.8-1.1.i386.rpm

    install success.

    Logged back into the control panel https://www.domain.com:8443 and proceeded to the update manager and updated to 7.5.3 with no further errors.

    Hope this helps.

  • RELEVANCY SCORE 3.00

    DB:3.00:Php 5.5.8 With Plesk 11.5 - Also Php-Fpm 99





    Using Plesk 11.5 on Centos 6 server.
    Built-in PHP version is 5.3.3.

    I have additionally compiled and installed PHP 5.5.8.
    Did not try to use yum as that would overwrite the built-in 5.3.3.

    I used /usr/local/psa/bin/php_handler as below to show it in the domain setting scripting listing box
    /usr/local/psa/bin/php_handler --add -displayname 5.5.8 \
    -path /usr/local/php-5.5.8/bin/php-cgi \
    -phpini /usr/local/php-5.5.8/etc/php.ini \
    -type fastcgi -id fastcgi-5.5.8
    All seems well and good.
    In Plesk domain websites and domains settings it shows 5.5.
    Followed these instructions:
    http://brainforge.co.uk/downloads/category/26-php-plesk-centos

    Now taken it a step further to try to use PHP-FPM with 5.5.8
    Through Plesk panel installed the nginx and php-fpm components in the normal way.
    Then tried to make it use the 5.5.8 executable as follows:
    service php-fpm stop

    rm -f /usr/sbin/php-fpm
    ln -s /usr/local/php-5.5.8/sbin/php-fpm /usr/sbin/php-fpm

    rm -f /etc/init.d/php-fpm
    ln -s /usr/local/php-5.5.8/etc/init.d/php-fpm /etc/init.d/php-fpm

    rm -f /usr/local/php-5.5.8/etc/php-fpm.conf
    rm -f /usr/local/php-5.5.8/etc/php-fpm.d
    ln -s /etc/php-fpm.conf /usr/local/php-5.5.8/etc
    ln -s /etc/php-fpm.d /usr/local/php-5.5.8/etc

    service php-fpm start
    Again it seems to work OK.
    However, in Plesk domain websites and domains settings it still shows 5.3.3, the site itself is using 5.5.8/
    This is confusing.
    Is there something similar to /usr/local/psa/bin/php_handler which will enable this to be corrected.

    DB:3.00:Php 5.5.8 With Plesk 11.5 - Also Php-Fpm 99




    No, multiple PHP versions with PHP-FPM is not supported.

  • RELEVANCY SCORE 3.00

    DB:3.00:Plesk 10.4.4 - Php 5.3.3 Unable To Load Dynamic Library Imap.So mz





    Hi,

    I have a very serious problem with Plesk 10.4.4

    I installed a server with Plesk and standard installation, with webmail horde and php 5.3.3
    I have found that horde does not work by releasing the error:
    Auth_imp Required IMAP extension not found

    By analyzing the problem better discover that:



    # tail -n16 /var/log/httpd/error_log
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib64/php/modules/imap.so - /usr/lib64/php/m
    odules/imap.so: undefined symbol: file_globals in Unknown on line 0

    DB:3.00:Plesk 10.4.4 - Php 5.3.3 Unable To Load Dynamic Library Imap.So mz




    Hi,

    I discovered the problem stems from the fact that using the module worker on apache php tries to load the libraries php-tzs that do not exist (php is not compiled into centos 6.x 64bit with these libraries). By disabling the module everything works properly.

  • RELEVANCY SCORE 3.00

    DB:3.00:11.5.3 Multi-Php Error When Registering Php Handler. (Php 5.5.4 From Source) a8





    Hello.

    Im using Plesk 11.5.3 on CentOS 6.4 with Apache 2.2.15, MySQL 5.5.30 and a default PHP 5.4.13 installation (A Media Temple DV Managed server). Im trying to install a side-installation of PHP 5.5.4 (from source). Im able to configure PHP and make the installation fine, but I am receiving an error when registering the handler with the following command:

    /usr/local/psa/bin/php_handler --add -displayname 5.5.4 -path /usr/local/php-5.5.4/bin/ -phpini /etc -type fastcgi -id 5.5.4-custom

    Here is the error I receive:

    2013-10-14T02:57:48-07:00 ERR (3) [util_exec]: proc_close() failed
    Unable to register the PHP handler: can not get version from /usr/local/php-5.5.4/bin/

    Steps I took:

    Gunzip/Untar PHP 5.5.4 directly from php.net

    ./configure --prefix=/usr/local/php-5.5.4 \
    --sysconfdir=/etc \
    --with-config-file-path=/etc \
    --disable-ipv6 \
    --with-openssl \
    --with-kerberos \
    --with-zlib \
    --enable-bcmath \
    --enable-calendar \
    --enable-exif \
    --enable-ftp \
    --with-openssl-dir=/usr \
    --with-t1lib \
    --with-gettext \
    --enable-mbstring \
    --with-mysql \
    --with-mysqli=mysqlnd \
    --with-mysql-sock=/var/run/mysql \
    --with-pdo-mysql \
    --without-pdo-sqlite \
    --enable-sockets \
    --with-iconv

    make

    make test

    make install

    cp php.ini-development /usr/local/lib/php.ini

    /usr/local/psa/bin/php_handler --add -displayname 5.5.4 -path /usr/local/php-5.5.4/bin/ -phpini /etc -type fastcgi -id 5.5.4-custom

    Any ideas? http://kb.parallels.com/en/117768 does not help as php -v yields the version of the default installation. Thanks!

  • RELEVANCY SCORE 3.00

    DB:3.00:Need Php 5 On Plesk 7.5.4 kk





    I need php 5 on my server so it can work with plesk with out making it break. Can some one do it and i will be willing to pay.

    Any ideas or anything i can do

    DB:3.00:Need Php 5 On Plesk 7.5.4 kk




    I need php 5 on my server so it can work with plesk with out making it break. Can some one do it and i will be willing to pay.

    Any ideas or anything i can do

  • RELEVANCY SCORE 3.00

    DB:3.00:Need Tutorial With Info Upgrade Plesk For Windows 9.3.0 - Mysql 5.6.10 And Php 5.4.17 x7





    Hello Community,

    im a German Plesk User and I search a Tutorial for Update this Komponents.

    MySQL 5.0.45 to Mysql 5.6.10
    PHP 5.2.6 to Php 5.4.17 ( I have find this, when i use this i have not Permisson on PHP Files ( Error 500 ) and Wordpress find not the Localhost Database )
    phpMyAdmin 2.11.6 to 3.5.8

    Thx and nice Weekend

    basti

    DB:3.00:Need Tutorial With Info Upgrade Plesk For Windows 9.3.0 - Mysql 5.6.10 And Php 5.4.17 x7




    Hello Community,

    im a German Plesk User and I search a Tutorial for Update this Komponents.

    MySQL 5.0.45 to Mysql 5.6.10
    PHP 5.2.6 to Php 5.4.17 ( I have find this, when i use this i have not Permisson on PHP Files ( Error 500 ) and Wordpress find not the Localhost Database )
    phpMyAdmin 2.11.6 to 3.5.8

    Thx and nice Weekend

    basti

  • RELEVANCY SCORE 3.00

    DB:3.00:Cant Launch Plesk 7.5.4 71





    Hi all
    plz help me , I install plesk 7.5.4 and up php version to php 5 . its okie for 3 weeks but now i cant launch plesk . I aldready restarted server and plesk but plesk still cant not launch.
    p/s : what are errors . dont show me the way to remove and install plesk plz.

    DB:3.00:Cant Launch Plesk 7.5.4 71




    thanks servertechs , I reconfigured plesk with check and repain function but it still not work.
    when i restart all service at plesk monitor its appear error. i attacked . thanks

  • RELEVANCY SCORE 3.00

    DB:3.00:Plesk 11.5 Linux - Php-Fpm And Nginx - Index.Html Error 97





    When i activate the PHP-FPM portion of a users domain in Plesk 11.5, NGINX continues to look for index.html at the end of every url. For example, www.mydomain.com/blog/ would normally take me to my blog. Instead, Nginx is looking for www.mydomain.com/blog/index.html, which isnt there.

    any help please?

    DB:3.00:Plesk 11.5 Linux - Php-Fpm And Nginx - Index.Html Error 97




    You cannot modify files in plesk.conf.d - they will be rewritten on the next web server configuration re-generation. You can technically workaround this issue by using custom web server templates, but it will likely lead to issues in future upgrades.

    However, after reading nginx documentation solution seems really obvious. I cannot fathom why nobody came up with it yet.

    Here it is (should be placed in custom nginx vhost configuration, i.e., either in /var/www/vhosts/system/domain.tld/conf/vhost_nginx.conf or via Panel UI):

    Code:

  • RELEVANCY SCORE 3.00

    DB:3.00:From Php 4.3.9 To Php 5 mx





    Hi all,

    I am running CentOS 4.5 with Ensim Pro 10.3.0-rhel.4ES.11 i386.
    One of my customers needs to run wiki on his website, and of course, it required PHP 5.

    Did someone do it yet ? Is it working OK ? Can you share the procedures ?

    DB:3.00:From Php 4.3.9 To Php 5 mx




    Which package that you download and install?

  • RELEVANCY SCORE 2.99

    DB:2.99:Php 4.3.11 Problem W/ 7.0.4 az





    Well, we upgraded PHP from 4.3.2 to 4.3.11 last night and we cant get Plesk 7.0.2 to recognize it as a component. Were aware of the patch for PHP 4.3.10, but is there one for 4.3.11?

    Something were missing?

    thanx
    -markd

    DB:2.99:Php 4.3.11 Problem W/ 7.0.4 az




    yes, but when i go to setup a new domain, the php option is grayed out, and therefore plesk does not write the php section into the domains httpd.conf file. (i.e. open-based restriction command, etc).

    -markd

  • RELEVANCY SCORE 2.99

    DB:2.99:Is It Possible To Add Php 5.6 To Plesk For Windows 11.5 zx





    Hello.
    Is it possible to add php 5.6 to Plesk for Windows 11.5?
    If I follow the instructions about multiple php versions installation there is no php 5.6 on
    the page
    https://127.0.0.1:8447/add_components.html

    I can install php 5.6 and add it to web site manually. But any change in Plesk can drop these settings.
    Thats why the main question is how to add php 5.6 the way it will be showed in Plesk and not to touch current php versions?

  • RELEVANCY SCORE 2.99

    DB:2.99:Php 5.3.3 And 5.2.17 x8





    Hey there,

    I got Plesk 10.2 running on Debian 6 (x64) with PHP 5.3.3. Now I need to use PHP 5.2.17 for a single subdomain, cause it needs the old Zend Optimizer to run. Now I have no idea how to do this. PHP 5.2.17 has been installed to /usr/local/bin/php and linked to /usr/lib/cgi-bin/php52:

    Code:

    DB:2.99:Php 5.3.3 And 5.2.17 x8




    No

    What to configure where is essential knowledge of every server administrator

    http://httpd.apache.org/docs/
    http://www.php.net/manual/en/

    If you dont have that knowledge it is time to start reading the manuals, or hire someone who knows how to admin a server.

  • RELEVANCY SCORE 2.99

    DB:2.99:Php 5.3.3 Cgi And Fast-Cgi Broke Down After Adding Php 5.5.13 sf





    Hello Parallels Forum,

    According to de Plesk Administrator Guide and according to the kb article: http://kb.parallels.com/en/118378, Plesk Panel is suitable to enable multiple php versions After I performed the steps mentioned in the kb article, all seemed fine until somehow php-cgi and php-fcgi broke down after

    Code:

    DB:2.99:Php 5.3.3 Cgi And Fast-Cgi Broke Down After Adding Php 5.5.13 sf




    After opening a Paralles Support ticket and a long session with a couple of support engineers, this issue was fixed by re-installing php 5.3.3 as default.

    The assessment was that somehow the default php 5.3.3 installation got overwritten by the php 5.5.13 installation, causing the problems decribed.

    Case closed.

  • RELEVANCY SCORE 2.99

    DB:2.99:Plesk: Error 500 When Opening Control Panel a7





    Hello everyone

    I would like to ask you a few things. I had my machine set up yesterday and everything went smoothly.

    Now, all of a sudden, I can access the plesk control panel.

    In /var/log/sw-cp-server/error_log I have this:

    2012-06-01 15:55:29: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
    2012-06-01 15:55:29: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
    2012-06-01 15:55:29: (connections.c.1737) SSL (error): 5 -1 0 Success
    2012-06-01 15:55:30: (connections.c.1737) SSL (error): 5 -1 0 Success
    2012-06-01 15:55:30: (connections.c.1737) SSL (error): 5 -1 0 Success
    2012-06-01 15:55:41: (connections.c.1737) SSL (error): 5 -1 104 Connection reset by peer
    2012-06-01 16:11:52: (log.c.135) server stopped
    2012-06-01 16:11:52: (log.c.75) server started
    2012-06-01 17:02:49: (connections.c.299) SSL: 1 error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
    2012-06-01 17:02:49: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
    2012-06-01 17:05:11: (log.c.135) server stopped
    2012-06-01 17:05:12: (log.c.75) server started
    PHP Fatal error: PHP Startup: apc_fcntl_create: open(, O_RDWR|O_CREAT, 0666) failed: in Unknown on line 0
    PHP Fatal error: PHP Startup: apc_fcntl_lock failed: in Unknown on line 0
    PHP Fatal error: PHP Startup: apc_fcntl_unlock failed: in Unknown on line 0
    PHP Fatal error: PHP Startup: apc_fcntl_create: open(, O_RDWR|O_CREAT, 0666) failed: in Unknown on line 0
    PHP Fatal error: PHP Startup: apc_fcntl_create: open(, O_RDWR|O_CREAT, 0666) failed: in Unknown on line 0
    PHP Fatal error: PHP Startup: apc_fcntl_lock failed: in Unknown on line 0
    PHP Fatal error: PHP Startup: apc_fcntl_unlock failed: in Unknown on line 0
    PHP Fatal error: PHP Startup: apc_fcntl_create: open(, O_RDWR|O_CREAT, 0666) failed: in Unknown on line 0
    PHP Fatal error: PHP Startup: apc_fcntl_create: open(, O_RDWR|O_CREAT, 0666) failed: in Unknown on line 0
    Unable to create timestamp file for dynamic children: Permission denied
    Dynamic spawn is disabled
    2012-06-01 17:30:36: (mod_fastcgi.c.2588) FastCGI-stderr: PHP Fatal error: Unknown: apc_fcntl_lock failed: in Unknown on line 0

    Since Ive been changing a few things regarding permissions - was hacked before - does Unable to create timestamp file for dynamic children: Permission denied mean something meaningful?

    Thanks for any help you guys can give me, I would and will really appreciate it.

    Ricardo

    DB:2.99:Plesk: Error 500 When Opening Control Panel a7




    Hello Ricardo,

    Please check the owner and permissions of your /tmp directory . Plesk 10.4 just downloaded a buggy microupdate (MU#41 http://kb.parallels.com/en/114503 ) that reads from php the session.save_path directory and changes its permissions. If you happen to have changed the session.save_path to /tmp it ends up changing your /tmp directory permissions. You can correct it with:
    chown root.root /tmp
    chmod 1777 /tmp