• RELEVANCY SCORE 5.31

    DB:5.31:Quote Problem In String ca




    Hello,
    I have the following Regex:

    Regex regex = new Regex(@\s*([^=;]+?)\s*=\s*(([^;]+)|([^]*)), RegexOptions.Compiled);

    DB:5.31:Quote Problem In String ca

    I was looking at DBConnectionStringBuilder and though I couldn't get the fields from there.
    Only create a connection from the fields.
    That is great. I have this working now.
    Thank You,
    Miguel

  • RELEVANCY SCORE 5.31

    DB:5.31:Regex In Alertfilter sk




    DB:5.31:Regex In Alertfilter sk


    SP3 was pulled off the site but has since been reposted. I don't know that it will solve your issue. If it does please post back to let everyone know that it did.

  • RELEVANCY SCORE 5.12

    DB:5.12:Regex zm




    Is this correct?

    Regex r = new Regex(X);
    string[] v = r.Split(oneXtwoXthree); // v = [one, two, three]

    But:

    Regex r = new Regex((X));
    string[] v = r.Split(oneXtwoXthree); // v = [one, X, two, X, three]

    In my opinion the result must be the same.

    DB:5.12:Regex zm

    Hello juanisho,
    Is this correct?
    The result is correct because if capturing parentheses are used in a

    Regex.Split expression, any captured text is included in the resulting string array. If you want to know about this method, please refer to this link:
    http://msdn.microsoft.com/en-us/library/ze12yx1d(v=vs.110).aspx
    Regards.We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click
    HERE to participate the survey.

  • RELEVANCY SCORE 4.86

    DB:4.86:Re: Convert A String To An Array/Collection z9


    phdk wrote:
    String s = "[ab,cd,ef,gh]";
    String regex = ""; // the regex to remove [].
    String[] stringArray = s.replaceAll(regex, "").split(",");Shouldn't that regex be more like this?

    String regex = ["\\[\\]]{1}";

    DB:4.86:Re: Convert A String To An Array/Collection z9

    Double post

    Edited by: codingMonkey on 2008/11/20 11:57

  • RELEVANCY SCORE 4.86

    DB:4.86:Asa 5510 Http Filtering With Regex ac



    hi

    I have problem to filter http traffic with regex . URL filtering works fine, but domain name filtering doesn't work correctly. Hire is configuration:

    regex MP3Files ".+\.[Mm][Pp][3]"regex AVIFiles ".+\.[Aa][Vv][Ii]"

    regex Domain1 "myspace\.com"regex Domain2 "facebook\.com"

    access-list Inside_Subnet extended permit tcp 172.17.0.0 255.255.0.0 any eq 80access-list Inside_Subnet extended permit tcp 172.17.0.0 255.255.0.0 any eq 8080

    class-map type regex match-any File_Exstension_Class match regex AVIFiles match regex MP3Files

    class-map type regex match-any Domain_List_Class match regex Domain1 match regex Domain2

    class-map Inside_Subnet match access-list Inside_Subnet

    class-map type inspect http match-any File_Exstensions match request uri regex class File_Exstension_Class

    class-map type inspect http match-any Domain_Class match request header host regex class Domain_List_Class

    policy-map type inspect http Inside_Policy parameters class File_Exstensions  drop-connection class Domain_Class

      drop-connection

    policy-map inside-policy class Inside_Subnet  inspect http Inside_Policy

    service-policy inside-policy interface inside

    DB:4.86:Asa 5510 Http Filtering With Regex ac


    Hi Giorgi,

    thx i think i miss to write letter 's' on class-map type inspect http match-any File_Exstensions, that way i get any thing not work.

    once more thx u so much Giorgi

  • RELEVANCY SCORE 4.86

    DB:4.86:Re: Regex - Pattern For Positive Numbers pf


    I don't know much about regex, but I guess this
    should work
    Pattern p =
    Pattern.compile("[^-][\\d+]*");No, this would allow ;123 or !123 or %123.Sorry, I misread you regex. You seem to be saying that +123 shoudl be allowed but -123 not allowed. If so then regex = "[+]?\\d+" .

    DB:4.86:Re: Regex - Pattern For Positive Numbers pf

    Just to make your life easier:snip

    Just a warning. E.g. 5,000.42 is not a valid number
    in Sweden and some other countries. We would write
    it as 5000,42 (or 5.000,42 or 5 000,42)

    /KajYes, I know that, it is not valid here too as with you, it would be 5.000,42. The solution I gave it is not complete and should not be. It is intended to be a pointer. But thanks for the waring.

    May the code be with you.

  • RELEVANCY SCORE 4.75

    DB:4.75:Re: Multiline Regex 1a


    In what way is it not working?

    DB:4.75:Re: Multiline Regex 1a

    Using regexes to parse html/xml is not a good idea
    unless the source is very strictly formatted.For example

    taga bunch of stuff in here tagincluding many/someothertag newlines and other tags/someothertag

  • RELEVANCY SCORE 4.75

    DB:4.75:Aide Dans Lcriture Dune Regex ac


    Bonjour le forum,

    DB:4.75:Aide Dans Lcriture Dune Regex ac

    Bonjour JP Ronse,
    Merci pour la réponse.

  • RELEVANCY SCORE 4.75

    DB:4.75:Regex Pattern d7


     i have a regex pattern in a file, i want to take the specified row which is not matching the regex pattern example regex pattern like [,X325C,][,X325D,][,X325F,],but in this i want to select [,x325A,] field?

  • RELEVANCY SCORE 4.72

    DB:4.72:How To Get The Length Of This Regex? cz


    How to get the length of this regex:   ((.|\n)*?)

    DB:4.72:How To Get The Length Of This Regex? cz

    Hi AlexVorn,
     
    I find the clear description of your question in this thread:
    http://www.vbforums.com/showthread.php?p=3122597

    ((.|\n)*?)This is the regex (regular expression) code that find all the text:Example: ((.|\n)*?) - this code finds the text between from 1 or more lines:cat+dog =friendsMy question is how to get only the text that is between example: for specific length example: less 35 characters.cat + dog=friends -- less than 35 characters

  • RELEVANCY SCORE 4.72

    DB:4.72:.Net Version Of Regex Coach? kd


    I love The Regex Coach program (http://weitz.de/regex-coach), but unfortunately it is meant to work with Perl regular expressions, which don't have named groups. I tried a few other programs that were .net regex compliant, but these programs were not nearly as good as The Regex Coach in terms of robustness and completeness.
    Can anyone suggest a good .net Regex coach?

    DB:4.72:.Net Version Of Regex Coach? kd

    I tried Expresso and I think it's ok, but I've taken a liking for RegexBuddy, especially it's bracket highlighting feature. Not free, but only 30$. PowerRegex (made by the same guys as Regex Buddy) is more for applyin a regex to multiple files, so that was useless to me.

  • RELEVANCY SCORE 4.72

    DB:4.72:Postscript File With Regex 7m


    Hi,

    DB:4.72:Postscript File With Regex 7m

    Look ahead and lookbehind constructs are your friends. Use the following pattern with IgnorePatternWhitespace (because I have broken it out and commented it) and Singleline regex options:
    (?=%%BeginResource:) # Look behind but don't capture
    (?Inner.*?) # Put text into named capture group Inner
    (?=%%EndResource) # Look ahead for the closing tag.
    HTH GLWilliam Wegerson (www.OmegaCoder.Com)

  • RELEVANCY SCORE 4.54

    DB:4.54:Regex In Nbar mx



    Folks,

    Could someone tell me what does this following regex mean?

    /.hash=*

    \.hash=*

    Any URL would he highly appreciated.

    Tom

    DB:4.54:Regex In Nbar mx


    Folks,

    Could someone tell me what does this following regex mean?

    /.hash=*

    \.hash=*

    Any URL would he highly appreciated.

    Tom

  • RELEVANCY SCORE 4.45

    DB:4.45:Re: Regex Issue xx


    Your regex:
    "(([0-9]+[,.])+[0-9]+)+|[0-9]+"could be written as:
    "[0-9]+([,.][0-9]+)?"And it would probably suffice to use only this look-ahead after your regex:
    "(?!([0-9]*[}]))"

    DB:4.45:Re: Regex Issue xx

    I have tried to write a comment in behalf of uncle_alice.
    public static void main(String... args)
    {
    String str = "1 2,300.00 {45.6} {78.00 90}";
    String digiReg = "(?:\\d++[.,])*+\\d+";

    // We'd like to find matches to the digiReg from space delimited
    // tokens in str.

    // A match should not be a substring of a token, so we put a
    // (?![\\d,.]), which means it should not begin from mid-way
    // of a full digiReg token.

    // The string that starts with a match should not have the
    // form digiReg + "\\}", so we put a (?!....) for that unwanted
    // form immediately before the target digiReg.

    // Also, the 'digiReg + "\\}"' we want to exclude must have a
    // "\\{" as its lookbehind, so we put a (?=\\{) before the
    // 'digiReg + "\\}"'
    // (If a 'digiReg + "\\}"' has other thing than a "\\{" as its lookbehind,
    // we have to pick up the digiReg as a legitimate match.)

    // So we get:
    Pattern p = Pattern.compile(
    "(?![\\d,.])(?!(?=\\{)" + digiReg + "\\})" + digiReg);

    // In essence, the key to understand this regexp is to know
    // the meaning and the correct form of a lookahead put BEFORE
    // the target sub-regexp, which is the last digiReg above.

    ...
    ...
    }

  • RELEVANCY SCORE 4.45

    DB:4.45:Regex ? km



    Hi,

    I am doing a validation for valid mail-ids thru REGEX . Here is the code for this . but it is not giving any results back.

    report zars.

    data: regex type ref to cl_abap_regex,
    matcher type ref to cl_abap_matcher,
    match type c length 1.

    create object regex exporting pattern = ' [A-Z0-9._%+-]+@[A-Z0-9.-]+.[A-Z]{2,4} '
    ignore_case = ''.

    matcher = regex-create_matcher( text = '"abc^abc.ca"' ).

    match = matcher-match( ).

    write match.

    DB:4.45:Regex ? km


    this looks better!

    "[a-z0-9!#$%'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%'*+/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?"

  • RELEVANCY SCORE 4.45

    DB:4.45:Re: Regex Problem kk


    thanks to update my knowledge!
    but i think what i want to do is best possible by regex

    regards

    DB:4.45:Re: Regex Problem kk

    Hmm...

    use List::Util qw(max);
    $a = "dog cat dog horse cat dog dog ";
    $a =~ s/(\S+)/++$words{$1}/ge;
    $a = max(split(/\s+/, $a));
    print $a;Combining the regexp sub and the following line into one is left as an exercise for the reader.

  • RELEVANCY SCORE 4.45

    DB:4.45:Switch -Regex In Powershell. x8


    $source |% {switch -regex ($_){'\'+$primaryKey+'\(.+)\/'+$primaryKey+'\' { $primaryKeyValue = $matches[1]; continue; }}

    I want to use dynamic key value with switch-regex, is that possible?

    DB:4.45:Switch -Regex In Powershell. x8

    I 'd have to go back and dig out the exact references, but I remember reading it on a third party book on Powershell.
    I always want my scripts to look clean, but if it's dealing with a data set that's large enough for the performance to become an issue it's good to know what the options are for optimizing.
    There almost always multiple ways to get the same result, and it's good to know what the trade-offs are when you have to choose between different operations and methods, which ones are cheap and which ones are expensive resource-wise.

    Thank you.

  • RELEVANCY SCORE 4.37

    DB:4.37:Regex Understanding dk


    can someone explain me what this string regex means?
    [a-zA-Z][a-zA-Z0-9_$]*

    DB:4.37:Regex Understanding dk

    It matches one letter, followed by zero more letters, digits, underscores, or dollar signs.

  • RELEVANCY SCORE 4.37

    DB:4.37:Simple Regex Problem mx


    As simple as it is, I cannot get it to work. The goal is to highlight strings red in csharp code.

    private void HighlightStrings()
    {
    Regex regex = new Regex(@^*$, RegexOptions.CultureInvariant);
    MatchCollection MC = regex.Matches(this.Text);

    foreach (Match match in MC)
    {
    this.Select(match.Index, match.Length);
    this.SelectionColor = Color.Red;
    }
    }

    DB:4.37:Simple Regex Problem mx

    Hi,
    I recommend to use the regex-forum.
    Valid strings in c# are
    \
    and
    @
    So your pattern has to handle both of them.
    @(|[^])*|(\\|[^\n])*
    Written as c#-string, it's
    @@(|[^])*|(\\|[^\n])*
    You use ^ and $. With this, the string has the be the only thing inside your text. I don't think that's the intention.
    Greetings,

    Wolfgang Kluge
    gehirnwindung.de

  • RELEVANCY SCORE 4.37

    DB:4.37:Regex Match Start Position? ks


    I want to scan a string for a regex match. Then pickup the scan after the 1st match, looking for a 2nd regex pattern. Match.NextMatch( ) does not work because the next match needs to apply a 2nd regex pattern. And Regex.Match does not accept
    a start position argument.

    How do I start a regex match at a specified position in the string?
    thanks,

    DB:4.37:Regex Match Start Position? ks


    There's a special regex control character for that:

    aka - a hack.
    thanks,

  • RELEVANCY SCORE 4.37

    DB:4.37:Re: Problems Parsing Text Addresses m7


    use regex.

    thats the only way to do this and stay sane.

    if you dont know what regex is, read up on it, it will be far easier to learn some regex then try to figure out this problem, plus you can use regex for other things.

    DB:4.37:Re: Problems Parsing Text Addresses m7

    The main problem with it as I see it is that you have
    records with varying numbers of data elements, so you
    end up having to program by exception which makes for
    very complex logic and is going to be VERY prone to
    errors even if the code is right.Sorry, I just noticed where I may have thrown your thinking for a loop. The only elements I care about are addr1, addr2, csz. I'm throwing the rest away. My fault... I should have explained that better.

    this is for a customer, not a java class programming assignment.

    The solution above using regex just worked on the whole list (all 6,000 addresses), so I think I'm good... thanks for helping me think through this!

  • RELEVANCY SCORE 4.37

    DB:4.37:Regex And Substringing cc


    is it possible to use regex for substringing according to character position , something like String.substring(n,m)?

    DB:4.37:Regex And Substringing cc

    is it possible to use regex for substringing according to character position , something like String.substring(n,m)?

  • RELEVANCY SCORE 4.37

    DB:4.37:Help Understanding A Bgp Regex fz



    Folks,

    Can someone help me understand the below regex in BGP?

     

    ip as-path access-list 40 permit ^(65030)?$

     

    Regards,

    Nik

    DB:4.37:Help Understanding A Bgp Regex fz


    Hi,

     

    https://supportforums.cisco.com/discussion/11512666/explanation-bgp-regex 

    Regards

     

    Alain

  • RELEVANCY SCORE 4.37

    DB:4.37:Regex Issue Post X8 Upgrade az



    I see the Regular Expression that handles the Calls to Internet Via DNS Zone, which was working properly till my X7 versions has stopped from X8.

    .*(?!%localdomains%)

    The above regex will only allow non local domains to be queried to the DNS.

    But, we see that the regex is now failing to process non local domain addresses. Is there any changes to regex behavior in X8...?

    DB:4.37:Regex Issue Post X8 Upgrade az


    Noticed someone opened a TAC case for the negative lookbehind regex issue in the X8.x software.

    CSCuo23974

  • RELEVANCY SCORE 4.37

    DB:4.37:Regex Cost A Lot Of Resource? m7


    I tried using regex within three-level subquery, and it ran VERY slow. Is regex that slow?

    DB:4.37:Regex Cost A Lot Of Resource? m7

    Welcome to the forum.

    I tried using regex within three-level subquery, and it ran VERY slow.It would be nice to see the query.
    Perhaps some optimization can be gained.
    In order to post a SQL statement tuning request, see:
    HOW TO: Post a SQL statement tuning request - template posting
    in order to provide the nessecary information we would need.

    Is regex that slow?Well, "as for performance, regexp has a high CPU cost associated with it"
    http://asktom.oracle.com/pls/asktom/f?p=100:11:0::::P11_QUESTION_ID:86800200346092611#tom2251353700346255035
    http://asktom.oracle.com/pls/asktom/f?p=100:11:0::::P11_QUESTION_ID:1794145000346577404#tom1794911900346530802

    edit
    And http://www.oracle.com/technetwork/database/features/application-development/twp-regular-expressions-133133.pdf
    warns on page 19:

    "The trick to writing fast performing regular expressions is to aim at avoiding costly
    backtracking that most often comes with liberal use of the infinite quantifiers (+
    and *). This statement is especially valid when dealing with large volumes of data,
    the matching engine can consume large amounts of CPU cycles and memory
    particularly when the pattern does not exist as every possibility has to be exhausted."

  • RELEVANCY SCORE 4.37

    DB:4.37:Re: Regex Challange pd


    NumberFormat.getCurrencyInstance()

    DB:4.37:Re: Regex Challange pd

    mkoryak wrote:
    thanks for your answers, and code, i love you.No problem, the feeling is mutual!
    ; )

  • RELEVANCY SCORE 4.37

    DB:4.37:Regex dc


    Preciso uma regex pra VARCHAR(SÓ NUMEROS AQUI)

    @VARCHAR([0-9]{1,5}) Não funciona

    DB:4.37:Regex dc

    tenta utilizar dessa forma:
    @^VARCHAR\(\d{1,5}\)$

    Abraço!A vida é um paraíso, mas os homens não o sabem e não se preocupam em sabê-lo. Fiodor Dostoievski

  • RELEVANCY SCORE 4.37

    DB:4.37:Re: Need Help With A Regex Pattern kp


    "[a-z]+\\s[a-z]+"

    DB:4.37:Re: Need Help With A Regex Pattern kp

    Thanks for the help!! The negative lookahead code provided by uncle_alice is exactly what I was looking for. Just to let you know, BaggianH your code does accomplish the same thing. I like the way you were able to do this with the use of loops.

  • RELEVANCY SCORE 4.34

    DB:4.34:Blocking .Torrent Files With Regex sm



    I am trying to block users from downloading .torrent files as another way of limiting the amount of BT traffic I am seeing on the network. I can't seem to get it to stop the files from being downloaded though.

    Here is the current configs I am using.

    **************

    show run policy

    !

    policy-map type inspect http http_inspection_policy

    parameters

    class BlockDomainsClass

    reset log

    match request uri regex class URLBlockList

    reset log

    policy-map global_policy

    policy-map inside-policy

    class httptraffic

    inspect http http_inspection_policy

    sho run class-map

    !

    class-map type regex match-any URLBlockList

    match regex urllist1

    class-map type regex match-any DomainBlockList

    match regex domainlist1

    match regex domainlist2

    match regex domainlist3

    match regex torrent

    class-map type inspect http match-all BlockDomainsClass

    match request header host regex class DomainBlockList

    class-map httptraffic

    match access-list inside_mpc

    class-map type inspect http match-all BlockURLsClass

    match request uri regex class URLBlockList

    sho run regex

    !

    regex urllist1 ".*\.([Tt][Oo][Rr][Rr][Ee][Nn][Tt]) HTTP/1.[01]"

    regex domainlist1 "(h33t|btbot|meganova|fulldls|bitsoup|fenopy|isohunt|mininova|gpirate|monova)\.(org|com|net)"

    regex domainlist2 "(zoozle|vertor|thunderbytes|demonoid|thepiratebay|flixflux|entertane)\.(org|com|net)"

    regex domainlist3 "(btjunkie|piratic|piratenova|empornium|filemp3|topmango)\.(us|org|com|net)"

    regex torrent "torrent"

    sho run service-policy

    !

    service-policy global_policy global

    service-policy inside-policy interface PRIVATE

    ACL

    access-list inside_mpc extended permit tcp any any eq www

    access-list inside_mpc extended permit tcp any any eq 8080

    DB:4.34:Blocking .Torrent Files With Regex sm


    This may help you out.

    http://www.nortfm.com/?View=entryEntryID=44

  • RELEVANCY SCORE 4.34

    DB:4.34:(\W)* Vs [\W]* In Regex 11


    HI,
    What is difference between (\w)* vs [\w]* in Regex ?

    DB:4.34:(\W)* Vs [\W]* In Regex 11

    Hello,
    It's not so much different than \w* except that the first is within a
    capturing group and the other is redundant, you can just do \w*

    Regards, Eyal Shilony

  • RELEVANCY SCORE 4.32

    DB:4.32:Generate Best Matching Regex/Rule From String Set j1


    does there exist a tool which:
    given a set of strings, will parse those strings and output a the simplest possible regex which matches those strings

    or

    does there exist a tool which, given a regex, can output a simplified(bonus points for optimal) version of the same regex

    ?

    DB:4.32:Generate Best Matching Regex/Rule From String Set j1

    (What you describe could be solved using a normal tree, or trie http://en.wikipedia.org/wiki/Trie)

    Message was edited by:
    kajbj

  • RELEVANCY SCORE 4.32

    DB:4.32:Re: Regex Replaceall Question pf


    test

    DB:4.32:Re: Regex Replaceall Question pf

    it automatically escapes the replacement textWe should say it just cheats appendReplacement() method. It can do anything you arbitrarily want.

    I'd use an honest method:
    public static String quoteDollarBs(String s){
    if ((s.indexOf('\\') == -1) (s.indexOf('$') == -1)){
    return s;
    }
    else{
    StringBuffer sb = new StringBuffer();
    for (int i = 0; i s.length(); ++i) {
    char c = s.charAt(i);
    if (c == '\\') {
    sb.append("\\\\"); // \ - \\
    }
    else if (c == '$') {
    sb.append("\\$"); // $ - \$
    }
    else {
    sb.append(c);
    }
    }
    return sb.toString();
    }
    }

  • RELEVANCY SCORE 4.32

    DB:4.32:Re: Regex Question dj


    java.util.regex.Pattern and java.util.regex.Matcher

    Please insert coin for next hint.

    DB:4.32:Re: Regex Question dj

    What was wrong with Sabre's version?

  • RELEVANCY SCORE 4.32

    DB:4.32:Regex - Range Of Numbers z9


    HI,

    I am looking for following regex condition:

    Include (A-Z) or (1- 92) but exclude 25, 45, 65.

    Plz reply asap if there is a solution with regex ??

    Thanks

    DB:4.32:Regex - Range Of Numbers z9

    Hemanth.452 wrote:
    HI,

    I am looking for following regex condition:

    Include (A-Z) or (1- 92) but exclude 25, 45, 65.

    Plz reply asap if there is a solution with regex ??Why ASAP?
    The answer is "yes", b.t.w.
    ; )

  • RELEVANCY SCORE 4.32

    DB:4.32:Re: Java Regex Behavior Problem 3a


    is having the ':' important to the application?

    DB:4.32:Re: Java Regex Behavior Problem 3a

    799081 wrote:
    I want to know why the engines work differentlyYou want to know why two different things work differently? Um, maybe because they're not the same?

    Blame the original developer for the original regex, not me...The original developer is to blame if he took an overly complex approach just to be able to do it in one step. However, you are to blame if you are insisting on translating the code literally, rather than in creating appropriate Java code that has the same result.

  • RELEVANCY SCORE 4.32

    DB:4.32:Re: Regex Help a7


    Thanks Sir

    DB:4.32:Re: Regex Help a7

    i found this site to be of great utility when messing with regex stuff
    [http://www.fileformat.info/tool/regex.htm]

  • RELEVANCY SCORE 4.32

    DB:4.32:Better Regex? p1



    I want to find the "sbeed" from a string. I have written the following regex for that.

    But I am in confusion which is better regex?

    regex = '(?!sbeed$).*$'.

    regex = '^$|^[^s].*|^s$|^s[^b].*|^sb$|^sb[^e].*|^sbe$|^sbe[^e].*|^sbee$|^sbee[^d].*|^sbeed.+'.

    DB:4.32:Better Regex? p1


    As the following RegEx processes little bit faster than the other while doing with large strings

    regex = '(?!sbeed$).*$'.

  • RELEVANCY SCORE 4.32

    DB:4.32:Any Regex sd


    i have become fan of regex.
    i am trying to find a regex which would match the patterns below
    Abcdefgh Aikljes 2345

    HJK 7689

    Alk Cdagh 6789

    i tried badly..[A-Za-z]+\s\d+ but it can not cover all of the above . do u know any smart regex which can cover all the aboves ?

    DB:4.32:Any Regex sd

    We have two different assumptions. Any more hairs to
    split? :)This should satisfy both of us - especially since I don't like split ends :)

    (\s+[A-Za-z]+)+\s+\d+

    OP: Don't forget the extra backslahes

  • RELEVANCY SCORE 4.32

    DB:4.32:How To Replace Values Using Regex mk



    Hi All,

    Can somebody help me how to replace values using regex

    DB:4.32:How To Replace Values Using Regex mk


    As of one example, where I want to keep only numeric data on a string:

    var oldValue = '438tgg786786gyg76

    var newValue = oldValue.replace(/[^0-9]/ig, "");

    The new value will contain only '43878678676'.

    Hope this helps!

    thanks,

    Reza R.

  • RELEVANCY SCORE 4.32

    DB:4.32:Re: Regex Query 3x


    (\b\w+\b)\1 Pop quiz: why will that regex never match anything?

    DB:4.32:Re: Regex Query 3x

    Ah, got it.I was thinking the ... well, nevermind
    I just wasn't thinking much at al I guess. :-)...which is probably as good a way to approach the subject as any. There's nothing intuitive about regexes.

  • RELEVANCY SCORE 4.32

    DB:4.32:Re: Replaceall 1c


    "[int]"
    should be represented as follows in the regex
    "\\[int\\]"

    DB:4.32:Re: Replaceall 1c

    ...
    String sdata3 = sdata2.replaceAll("[i][n][t]","11");That's a bit of an overkill (although it will work). This will do the same:String sdata3 = sdata2.replaceAll("int","11");But I think the OP needs to get the square brackets replaced too, as masijade's example from reply #4 does.

  • RELEVANCY SCORE 4.32

    DB:4.32:Re: Java Regex Question 8a


    i got a clear uderstand on this topiic

    DB:4.32:Re: Java Regex Question 8a

    You say your regexp validates dd/mm/yyyy. How about d/m/yyyy as in 3/3/09. Thats a valid date. Are you sure you want to force end users to pad it with zeros as in 03/03/2009. If your program says 3/3/09 is invalid, I'll assume your validator is broken since I see nothing wrong with the date. How about 32/12/2009. Its a valid format, but invalid date. How about 03/03/1709. Its a valid format and valid date, but I dont think your customer is 200 years old. Wouldn't it confuse countries that use mm/dd/yyyy instead of dd/mm/yyyy. They enter 01/02/2009, it that Jan 2 2009 or Feb 1 2009? How about countries that use mm-dd-yyyy? Just thought I'll complicate your life!

  • RELEVANCY SCORE 4.32

    DB:4.32:Regex: Different Results When Using Find Or Regex Classes 8c



    Hi,

    I am just playing around with Regular Expressions and I found something I could not explain. I try to find the regex

    ^\*

    DB:4.32:Regex: Different Results When Using Find Or Regex Classes 8c


    Hi Jerry,

    thank you for your reply, but I think if I will use

    gx_matcher-find_next( )

  • RELEVANCY SCORE 4.32

    DB:4.32:Regex For Logical Operands (Need Help To Write Regex) sm


    DB:4.32:Regex For Logical Operands (Need Help To Write Regex) sm


    Hi,

    Has your issue been resolved? Would you mind letting us know the result of the suggestions?

    Now I will mark an answer.If you still have any questions about this issue, please feel free to let me know. We will
    continue to work with you on this issue.

    Have a nice day!Paul Zhou [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

  • RELEVANCY SCORE 4.32

    DB:4.32:Regex Format Question 8x


    Hi,
    i have been trying to write a regex for the parse the following format: I need to have the regex divides into array of three sections. Please note each section is separated by space.. Would anyone suggest the best regex format for this?

    DB:4.32:Regex Format Question 8x


    Does this help with out Reg ex
    string[] inputs = new string[] { 6 /10,11 / 1,2,3,4,7,10 $12.1 ABC, 6,8,9 /10,11 $12.1 XYZ };

    foreach (var input in inputs)
    {
    var arr1 = input.Substring(0,input.IndexOf($));
    var arr2 = input.Replace(arr1, ).Split(' ')[0];
    var arr3 = input.Replace(arr1, ).Split(' ')[1];

    Console.WriteLine(arr1= {0} arr2 = {1} arr3 = {2} , arr1,arr2,arr3);
    }

    Hi Venkat,
    I would not recommend this.
    First thing, He is asking for a reg ex expression.
    Second one, Replace, Split, Replace, Split, may impact in performance, if the source has so many items.
    Take it as a positive feedback.Muthukrishnan Ramasamy
    net4.rmkrishnan.net
    Use only what you need, Reduce global warming

  • RELEVANCY SCORE 4.32

    DB:4.32:How To Display A String In A Messagebox From A Regex-String. sk


    Hi,
    I have this line but it shows a emply messagebox:
    Regex regEx = new Regex(@(\d)/(\d)/(\d)/(\d));
    Match match = regEx.Match(gridView1.GetRowCellValue(gridView1.FocusedRowHandle, value').ToString());
    MessageBox.Show(match.ToString());
    What am i doing wrong?
    Greetings, Peter Kiers

    DB:4.32:How To Display A String In A Messagebox From A Regex-String. sk

    Its seems like your code does not able to find any match please check
    If found useful please mark as answer...
    thank you.

  • RELEVANCY SCORE 4.32

    DB:4.32:Regex With Wildcards In The String zk


    Trying to do a match between two strings when both the strings have * wildcards. E.g. license plates witness 1 sees A*23* and withness 2 sees *123*Z. I want these to flag up as a match.

    e.g. if I niavely do

    string plate = A.*23.*;

    Regex r1 = new Regex(@.*3.*);
    Console.WriteLine(r1.IsMatch(plate));

    Regex r2 = new Regex(@A123);
    Console.WriteLine(r2.IsMatch(plate));

    Regex r3 = new Regex(@.*Z);
    Console.WriteLine(r3.IsMatch(plate));

    Regex r4 = new Regex(@.*123.*Z.*);
    Console.WriteLine(r4.IsMatch(plate));

    then I get

    true
    false
    false
    false

    whereas I want them all to be true. The problem is a bit more complex than this, but understanding how to deal with wildcard in the original string (not just the regex) would be a good start. Any ideas?

    DB:4.32:Regex With Wildcards In The String zk

    Awesome Louis, I think you're cracked it, many thanks! You're a genius, recursion was making my sponge hurt :)

  • RELEVANCY SCORE 4.32

    DB:4.32:Capture A List fp


    Regex regex = new Regex(@sectionstart(\W*a(?capture[a-zA-Z]+)/a[^X]*X)+), RegexOptions.ExplicitCapture); 

    DB:4.32:Capture A List fp

                string test = @sectionstart +                                aInformationOne/ablubblaX +                                aInformationTwo/ablubblaX +                             ;             string pattern = @(?=sectionstart.*)(a(?capture[a-zA-Z]+)/a[^X]*X)(?=.*);             Regex regex = new Regex(pattern);             Match mx = regex.Match(test);             while(mx.Success)             {                 Console.WriteLine({0} {1} {2}, mx.Groups[capture].Index, mx.Groups[capture].Length, mx.Groups[capture].Value);                 mx = mx.NextMatch();             }   

  • RELEVANCY SCORE 4.32

    DB:4.32:Regex List Need For Speed cp


    Hi,
    I'm facing the problem to classify a continuous stream of long strings using a list of regex, if a regex matches the system assigns a class to the string; all the regex (200) have to be evaluated, hence many classes could be assigned to the string.
    Obviously the speed is crucial requirement.
    Any suggestion ? Are regex the best choice?
    Thanks
    n.

    DB:4.32:Regex List Need For Speed cp

    Hi uncle_alice,
    thanks for the suggestion.
    I should have written messages flow instead of stream because I receive strings to be evaluated embedded in messages coming from another system.
    Thanks
    Regards
    ny

  • RELEVANCY SCORE 4.32

    DB:4.32:Split A String Using Regex In C# 1x


    I want to split a String by New Line(\r\n) and .(Dot)fololwed By space) for ex Exp in Java(.dot) Developer (new line)
    My Current regex is Regex regex=new Regex(@[\r\n|/.\s]);

    But Above Won't work in spliting .(dot)

    Pls Suggest me
    With Regards, Maha

    DB:4.32:Split A String Using Regex In C# 1x

    You're using the wrong grouping construct.
    It's either (...|..) or [......], using | in a [......] just makes | one of the allowed characters.
    So your expression should look like this:

    (?:\r\n|\.\s)

  • RELEVANCY SCORE 4.32

    DB:4.32:Re: Regex. Remove A Whitespace Line 1z


    Am I missing something?
    String regex = "\n\\s*\n";
    System.out.println("abcz[\n \r\n]aaaa\nxxx\rpppp\r\ncccc".replaceAll(regex, "\n"));
    \System.out.println("Hello\n \nWorld\r\n \nAgain".replaceAll(regex, "\n"));

    DB:4.32:Re: Regex. Remove A Whitespace Line 1z

    hiwa wrote:
    What is a Whitespace Line?Good question. The OP said the regex {color:800000}^[#92;\s*]${color} "works well" in Notepad++. I fired up Notepad++ and found, as expected, that that regex matches a line consisting entirely of a backslash, an 's', or an asterisk. I'm pretty sure the regex was supposed to be {color:800000}^\s*${color}, which should match one or more lines, each containing zero or more spaces or TABs. In other words, starting right after a line separator, it should match zero or more of any of the ASCII whitespace characters, [ \t\r\n\f\v], ending right before a line separator. But in Notepad++, apparently \s never matches a carriage return or a linefeed. Or maybe Notepad++ always limits its searches to a single line, so it doesn't have to deal with the issue of what constitutes a line separator for matching purposes.

    Anyway, I think what the OP is looking for is this: str = str.replaceAll("^[ \t]+$", ""); That is, if a line contains nothing but spaces or TABs, delete them, leaving the line truly empty.

    nclow wrote:(quote}I think \n is a character that is mapped out by the jvm to the OS-specific line break codes. It is a high-level metacharacter (someone correct me if I'm wrong here).You're wrong. :D Perl 6 regexes do the kind of mapping you're talking about, and there may be other regex implementations that do so as well, but in Java, \n matches a linefeed and \r matches a carriage return. If you want to match a generic line separator, you have to do as others have suggested and use
    (\r\n|\r|\n) However, in multiline mode, the ^ and $ anchors do recognize all three line separator styles, so they won't match between the \r and \n of a DOS-style separator.

  • RELEVANCY SCORE 4.32

    DB:4.32:Firefox Starts In Offline Mode While Sandboxed mf



    I'm trying to run Firefox sandboxed for security reasons. Everything works except it always starts in Offline Mode. Do I need to allow access to something in particular to fix this? Below are the contents of my sandbox profile:

    firefox - sandbox profile

    http://codereview.chromium.org/379019/diff/1/2

    (version 1)
    (deny default)

    (allow file-write* file-read-data file-read-metadata

    (regex "^/Users/james/Downloads")
    (regex "^/Users/james/Library/Application Support/Mozilla")
    (regex "^/Users/james/Library/Application Support/Firefox")
    (regex "^/Users/james/Library/Preferences")
    (regex "^/Users/james/Library/PreferencePanes")
    (regex "^/Users/james/Library/Caches/Firefox")
    (regex "^/Users/james/Library/Caches/TemporaryItems")
    (regex "^/Applications/Firefox.app")
    (regex "^(/private)?/tmp/"))

    (allow file-read-data file-read-metadata

    (regex "^/dev/autofs.*")
    (regex "^/Library/Preferences")
    (regex "^/Library/Internet Plug-Ins")
    (regex "^/Library/PreferencePanes")
    (regex "^/usr/share/icu")
    (regex "^/usr/share/locale")
    (regex "^/System/Library")
    (regex "^/Applications/Firefox.app")
    (regex "^/usr/lib")
    (regex "^/var")
    (regex #"Frameworks/SDL.framework")

    Our Module Directory Services cache

    (regex "^/private/var/tmp/mds/")
    (regex "^/private/var/tmp/mds/[0-9]+(/|$)")
    (regex "^/Users/james"))

    (allow mach* sysctl-read)

    (import "/usr/share/sandbox/bsd.sb")
    (deny file-write-data

    (regex #"^(/private)?/etc/localtime$"
    #"^/usr/share/nls/"

    #"^/usr/share/zoneinfo/"))

    (allow process-exec

    (regex "^/Applications/Firefox.app"))

    (allow network*)

    (allow file-read-data (regex #"^/System/Library/Fonts"))  ; 10.5.6
    (allow file-read-data (regex #"^/Library/Fonts"))  ; 10.6
    (allow mach-lookup (global-name "com.apple.FontObjectsServer"))  ; 10.5.6
    (allow mach-lookup (global-name "com.apple.FontServer"))  ; 10.6

    This happened

    Every time Firefox opened

    == Running

    DB:4.32:Firefox Starts In Offline Mode While Sandboxed mf

    Helpful Reply


    This solved the problem for me.

    Right-click on the about:config page to open the right-click context menu and use "New Boolean" to create a new Boolean pref.

    Name: network.manage-offline-status
    Value: false

  • RELEVANCY SCORE 4.32

    DB:4.32:Regex For Canadian Postal Code jd


    im trying to validate a canadian postal code using regex but i dont know that correct syntax..

    can someone please help me ..thanks in advance

    here is my code .. (postal code is letter number letter space number letter number ex R5Y 1E3)
    String regex;
    Pattern pattern;
    Matcher matcher;

    regex = "[A-Z][0-9][A-Z] [0-9][A-Z][0-9]";

    pattern = Pattern.compile(regex);

    if(! pattern.matcher(param).matches())

    DB:4.32:Regex For Canadian Postal Code jd

    but what i really need is the regex for it...Did you follow the links given to you?

  • RELEVANCY SCORE 4.32

    DB:4.32:How To Specify The Regex-Format. zj


    Hi,
    In need the regex format of this:
    number (number/number/number)
    Does anyone know how to specify the regex-format.
    Peter

  • RELEVANCY SCORE 4.26

    DB:4.26:Ips 5.X Regex String With Space? 89



    If I want to match a string for the following, what should my regex value be? Would it accept a space?

    user 1 1

    -or-

    get setup_

    I'm trying to find documentation that tells me how to use a space in the regex.

    Thanks in advance

    DB:4.26:Ips 5.X Regex String With Space? 89


    I don't know if I'd go call it a standard. We (meaning the sig team) tend to use the hex value (\x20) because it's a clearly definitive "thing" to represent one space, and one space only. We do it simply because there's no mistaking exactly what it is.

  • RELEVANCY SCORE 4.24

    DB:4.24:Regex For Strings 7a


    HelloI am looking for RegEx for below strings. I am new to RegEx and would like to get started with these simple strings to build RegEx. I really appreciate if anyone can provide RegEx for these.1.34MG25MG/ML25MG6.25MG/5ML1.5GM2GM125-31.25500-125MG1GM/50ML2G/100ML3.1GM/100 ML200MG/100MLThanks

    DB:4.24:Regex For Strings 7a

    Good catch, sorry about that.John Grove - TFD Group, Senior Software Engineer, EI Division, http://www.tfdg.com

  • RELEVANCY SCORE 4.18

    DB:4.18:Delete Line Before Regex z3



    i thought accomplishing this could be as simple as a:

    sed -n /regex/-1!p

    Guess not.Any Suggestions?

    DB:4.18:Delete Line Before Regex z3


    So, it is homework which means.... CLOSED.

  • RELEVANCY SCORE 4.18

    DB:4.18:.Net Flavor Regex Utility 3d


    I am testing all my expressions on a different flavor regEx. You can imagine the frustration of finding out the working regEx doesnt work in .NET Is there a .NET flavor regEx engine editor/tester out there?Thanks for any suggestions

    DB:4.18:.Net Flavor Regex Utility 3d

    Yes. Espresso is more robust than the one I originally found. Thanks.

  • RELEVANCY SCORE 4.18

    DB:4.18:New Paragraph And Regex pm


    How can I know about the new para using regex

    thanks best regards

    DB:4.18:New Paragraph And Regex pm

    prometheuzz wrote:
    farakh wrote:
    How can I know about the new para using regex

    thanks best regards?I think it may be the same as this question:

    http://forum.java.sun.com/thread.jspa?threadID=5223568tstart=0

    Farakh, don't post the same question multiple times please.

  • RELEVANCY SCORE 4.18

    DB:4.18:Regex.Equals Implementation Doesnt Seem To Work. c9


    I'm wondering how to test for equality between two System.Text.RegularExpressions.Regex instances.    Regex r1 = new Regex(Test);    Regex r2 = new Regex(Test);    if (!r1.Equals(r2))        Console.Error.WriteLine(Two same Regex instances do not match.);r1.Equals(r2) is never true, is this a fault with the Regex.Equals(Object) implementation?-Brett

    DB:4.18:Regex.Equals Implementation Doesnt Seem To Work. c9

    I wrote a command level security module that allows administrators to configure command names to have security applied by allowing a list of security roles. Consider the following:

    Code Block

  • RELEVANCY SCORE 4.18

    DB:4.18:[Closed] Regular Expressions xd



    this works for anyone who comes across a similar prob

    Regex rgx = new Regex([^-][^0-9]+);

    DB:4.18:[Closed] Regular Expressions xd


    this works for anyone who comes across a similar prob

    Regex rgx = new Regex([^-][^0-9]+);

  • RELEVANCY SCORE 4.18

    DB:4.18:Regex For Polynomial 3k


    Good day.

  • RELEVANCY SCORE 4.18

    DB:4.18:Sed Rules To Java Regex c9


    Hi,
    what is the connection between sed regex rules and java regex rule. Is there an easy way to convert sed to java? or do i have to learn sed?....

    Thanks

    DB:4.18:Sed Rules To Java Regex c9

    rsv-us wrote:
    I have a sed regex,now I want to convert to java regex,how do i do that?Impossible to answer.
    Try creating a thread of your own and explain what you're trying to do in a bit more detail.

  • RELEVANCY SCORE 4.18

    DB:4.18:Regex Help Required d8


    What is the Regex for validating strings
    that can contain

    alphanumeric, digits, spaces, -, _ and .

    DB:4.18:Regex Help Required d8

    [a-zA-Z_\-\.0-9]+$ is better i think

  • RELEVANCY SCORE 4.18

    DB:4.18:Re: Stringtokenizer d7


    Use String.split and an appropriate regex.

    DB:4.18:Re: Stringtokenizer d7

    Thank you for all the help

    I only read the string so I can't change the separator, luckly, I know exactly what those fields should be, so I simply using tokenizer "/" parse the string, into an arrayList, then read the list element from the end, if it dones't start at certain string, like not"a=" or"b="or"c=", I add this to the list element before it, it's a simply solution, although not perfect.

    Thanks again

  • RELEVANCY SCORE 4.18

    DB:4.18:Regex Expression 79


    Hello all
    i need regex expression for multiple domain separation

    Niki

    DB:4.18:Regex Expression 79


    i need regex expression for multiple domain separation

    Please offer us:
    1) Your sample of domain data contents.
    2) What do you expect to get?Click For donating:Free Rice For the poor
    For spamming-sender issues, you can either report it at
    Microsoft Spamming Issue, or just find Report Spam HereNumber at
    Forum Issue;You can also find Verify Your AccountNumber at Forum Issue, where you can submit to be confirmed to paste links or images.
    For more things to talk about? StackOverFlow
    is your choice.

  • RELEVANCY SCORE 4.18

    DB:4.18:Simple Regex Not Working mf


    Hi,

    Can somebody tell me why the following regex matching does not work:

    Pattern.matches("(hi)*", "hithere");

    DB:4.18:Simple Regex Not Working mf

    then try matcher.find() rather than .matches().
    This way the regex can remain "hi" alone.

  • RELEVANCY SCORE 4.18

    DB:4.18:Regex Conditionals dk



    Hello guys,

    is there conditionals in indesign regex?

    if. then do someone share a good guide?

    thank you in advance.

    DB:4.18:Regex Conditionals dk


    ID's implementation of GREP used both positive and negative look-behind and look-ahead. Is that what you mean?

    The Help file for GREP is pretty good, and you can buy Peter Kahrel's very excellent eBook at GREP in InDesign - O'Reilly Media

  • RELEVANCY SCORE 4.18

    DB:4.18:Asa Regex Match az



    Hi All,

    I've configured a FTP inspect policy-map, within the policy map I'm using the match filename command to identify certain files

    regex test ^cisco.*

    policy-map type inspect ftp FTP_PMAP

    match filename regex test

       reset

    The problem I have is that the regex above does not work but the regex below does.

    regex test2 cisco.*

    filenames are in the format cisco1.txt, cisco2.txt etc....

    Any ideas?  the ASA is running version 8.2(2)

    DB:4.18:Asa Regex Match az


    Peter,

    Did a short test.

    ^cisco.* should match anything begining with "cisco" followed by any number of characters.

    --------------

    ciscoasa# test regex cisco2.txt ^cisco.*  INFO: Regular expression match succeeded.ciscoasa# test regex 1_cisco2.txt ^cisco.*INFO: Regular expression match failed.

    ---------------

    If you want to match the ciscoX.txt files

    -------

    ciscoasa# test regex cisco2.txt cisco[0-9]\.txtINFO: Regular expression match succeeded.-------

    Theory is regexps in test and in policy maps should be working same way ... provided no extra characters are added.

  • RELEVANCY SCORE 4.18

    DB:4.18:From Regex To Regex j7


    sed -n /regexp/,$p

    DB:4.18:From Regex To Regex j7


    If you already got the file to look like that then what happens if you just do bash FileA

    And
    bash FileA FileA.output
    bash FileB FileB.output
    diff FileA.output FileB.output

  • RELEVANCY SCORE 4.18

    DB:4.18:Regex Validation For Email Address In Java dd


    How can i validate an email address with an regex where the condition is domain won't be gmail.com or yahoo.com... how can i do that with an regex??

    DB:4.18:Regex Validation For Email Address In Java dd

    i found my regex its

    "[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]|[^gmail]|[^yahoo]+\.[A-Za-z]{2,4}"

    not it will filter the email address by domain name, gmail and yahoo domains are not allowed in this regex email validation

    Thanks
    Sudeep

  • RELEVANCY SCORE 4.18

    DB:4.18:Regex Expressions In Asa 7c



    Does default regex in asa 5520 cause problems with any sites. our clients are facing problems with some website. Occurs when some core modules are used.

    My asa has regex for aspx . this wasnt configured , but seems to be default.

    Appreciate if someone can point on methods to verify the regex doesnt block anything or any other aspect in asa.

    TIA.

    DB:4.18:Regex Expressions In Asa 7c


    If it is not on a layer 7 policy map, then it is not applied or doing anything, I would suggest you to take a look at any websense configuration, CSC module policy and also to try to hook up a computer outside of the firewall and try to go to these websites and check if you get the same results.

    Mike

  • RELEVANCY SCORE 4.18

    DB:4.18:Simple Regex Help 3d


    Hello,

    I have this regex

    \d{1,3}\)

    matching against pattern like this (not these exact numbers)

    (10,0,0,2,123,234)

    in this case the regex returns 234)

    is there a way using regex I could just return 234

    Thanks,
    jd

    DB:4.18:Simple Regex Help 3d

    thanks , i will look into lookaheads

    jd

  • RELEVANCY SCORE 4.18

    DB:4.18:Basic Regex Q. m8


    I would like to learn RegEx. Could someone direct me to the most basic RegEx examples for Visual Basic 2008?

    Would appreciate the help.Inforequester123 - social.msdn.microsoft.com forums

    DB:4.18:Basic Regex Q. m8

    Hi Inforequester123,
    Here using regular expression is breaking a fly upon a wheel if you have litter knowledge about it.
    Please check out my solution as below, just create a new winform project and copy the code into the form's back code to test:

    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Data;
    using System.Drawing;
    using System.Linq;
    using System.Text;
    using System.Windows.Forms;
    using System.IO;
    using System.Globalization;

    namespace WindowsFormsApplication1
    {
    public partial class Form1 : Form
    {
    public Form1()
    {
    InitializeComponent();
    InitializeControls();

    textBox1.Text = new StreamReader(@C:\test.txt).ReadToEnd();
    }

    bool isNewSection = false;
    bool isFirstNumFoundInSection = false;
    int tempParsedNum;
    CultureInfo provider = CultureInfo.InvariantCulture;

    private void button1_Click(object sender, EventArgs e)
    {
    var lines = textBox1.Text.Split(new string[] { Environment.NewLine }, StringSplitOptions.RemoveEmptyEntries);

    foreach (var line in lines)
    {
    if (line.StartsWith([))
    {
    textBox2.Text += line.Trim(new char[] { [, ] }) + Environment.NewLine;
    isNewSection = true;
    isFirstNumFoundInSection = false;
    }
    else if (int.TryParse(line, NumberStyles.AllowThousands, provider, out tempParsedNum) !isFirstNumFoundInSection)
    {
    textBox3.Text += line + Environment.NewLine;
    isFirstNumFoundInSection = true;
    }
    }
    }

    private System.Windows.Forms.TextBox textBox1;
    private System.Windows.Forms.TextBox textBox2;
    private System.Windows.Forms.TextBox textBox3;
    private System.Windows.Forms.Button button1;

    private void InitializeControls()
    {
    this.textBox1 = new System.Windows.Forms.TextBox();
    this.textBox2 = new System.Windows.Forms.TextBox();
    this.textBox3 = new System.Windows.Forms.TextBox();
    this.button1 = new System.Windows.Forms.Button();

    //
    // textBox1
    //
    this.textBox1.Location = new System.Drawing.Point(13, 13);
    this.textBox1.Multiline = true;
    this.textBox1.Name = textBox1;
    this.textBox1.ScrollBars = System.Windows.Forms.ScrollBars.Vertical;
    this.textBox1.Size = new System.Drawing.Size(247, 704);
    this.textBox1.TabIndex = 0;
    //
    // textBox2
    //
    this.textBox2.Location = new System.Drawing.Point(295, 54);
    this.textBox2.Multiline = true;
    this.textBox2.Name = textBox2;
    this.textBox2.ScrollBars = System.Windows.Forms.ScrollBars.Vertical;
    this.textBox2.Size = new System.Drawing.Size(247, 662);
    this.textBox2.TabIndex = 1;
    //
    // textBox3
    //
    this.textBox3.Location = new System.Drawing.Point(578, 54);
    this.textBox3.Multiline = true;
    this.textBox3.Name = textBox3;
    this.textBox3.ScrollBars = System.Windows.Forms.ScrollBars.Vertical;
    this.textBox3.Size = new System.Drawing.Size(247, 662);
    this.textBox3.TabIndex = 2;
    //
    // button1
    //
    this.button1.Location = new System.Drawing.Point(295, 13);
    this.button1.Name = button1;
    this.button1.Size = new System.Drawing.Size(530, 23);
    this.button1.TabIndex = 3;
    this.button1.Text = Process;
    this.button1.UseVisualStyleBackColor = true;
    this.button1.Click += new System.EventHandler(this.button1_Click);

    this.Controls.Add(this.button1);
    this.Controls.Add(this.textBox3);
    this.Controls.Add(this.textBox2);
    this.Controls.Add(this.textBox1);
    }
    }
    }

  • RELEVANCY SCORE 4.18

    DB:4.18:Re: Can't Get Package Regex To Work 1d


    Make that Java 1.4.1_01 SDK...

    DB:4.18:Re: Can't Get Package Regex To Work 1d

    You can also give Oracle's JDeveloper a try. The latest version is pretty stable and pretty easy to use.

  • RELEVANCY SCORE 4.18

    DB:4.18:Re: Regarding Regex..?? kk


    I've tried adding the + but it doesn't work.

    DB:4.18:Re: Regarding Regex..?? kk

    I did follow ur advice. It took me a day or more to understand the url you gave me. I did all possible. Yet I still didn't get the end product I need. I am sorry. But to me forum is for us to learn regardless if the person would like to take the comment or not. well Its also unadvisable for forum to be negative. Regardless how dumb someone might sound . yOU CAN'T ASSUME THAT I DIDN'T FOLLOW YOUR ADVICE TO READ. IT DOES LET ME UNDERSTOOD ABOUT REGEX WHICH I NEVER UNDERSTOOD BEFORE . THERE MIGHT BE BETTER PLACE I COULD UNDERSTAND REGEX BETTER. GUESS I am too dumb to understand a simple things. That's what all of you are saying to me. That I am not being precise enough and stuff like that. Well to me I read the comment and that comments are just redundant. But don't tell me that I never listen cos i listen and i did go to the url I REPEAT I DID GO TO THE URL..... ish ... i don't understand. what's wrong with forums???

  • RELEVANCY SCORE 4.18

    DB:4.18:How To Convert The Text File Into An Xml Using Plsql Code sf


    Hi all ,I need to convert an TEXT file into an XML file how can i do it Below is my sample TEXT file .TDETL00000000020000000000000120131021115854ST2225SKU77598059 0023-000000010000I want the above to be converted into the below format?xml version="1.0" encoding="UTF-8"?txt2xml !-- Processor splits text into lines -- processor type="RegexDelimited" regex\n/regex !-- This is used to specify that a message should be created per line in the incoming file; NOTE: this was designed to work with all the processors, however it only works correctly with 'RegexDelimited' processors (check the enclosing top processor type) -- maxIterationsPerMsg1/maxIterationsPerMsg !-- For lines beginning with FHEAD (File Header) -- processor type="RegexMatch" elementFHEAD/element regex^FHEAD(.*)/regex processor type="RegexMatch" elementOriginalLine/element regex(.*)/regex consumeMatchedCharsfalse/consumeMatchedChars /processor processor type="RegexMatch" elementLineSeq,Type,Date/element regex^(\d{10})(\w{4})(\d{14})$/regex /processor /processor !-- For lines beginning with TDETL (Transaction Details) -- processor type="RegexMatch" elementTDETL/element regex^TDETL(.*)/regex processor type="RegexMatch" elementOriginalLine/element regex(.*)/regex consumeMatchedCharsfalse/consumeMatchedChars /processor processor type="RegexMatch" elementLineSeq,TransControlNumber,TransDate,LocationType,Location,ItemType,Item,UPCSupplement,InventoryStatus,AdjustReason,AdjustSign,AdjustQty/element regex^(\d{10})(\d{14})(\d{14})(\w{2})(\d{4})(\w{3})([\w ]{13})([\w ]{5})(\d{2})(\d{2})([+-]{1})(\d{12})$/regex /processor /processor !-- For lines beginning with FTAIL (File Tail) -- processor type="RegexMatch" elementFTAIL/element regex^FTAIL(.*)/regex processor type="RegexMatch" elementOriginalLine/element regex(.*)/regex consumeMatchedCharsfalse/consumeMatchedChars /processor processor type="RegexMatch" elementLineSeq,TransCount/element regex^(\d{10})(\d{6})$/regex /processor /processor /processor/txt2xmlThanks

    DB:4.18:How To Convert The Text File Into An Xml Using Plsql Code sf

    Sorry, that doesn't make much sense.The XML you gave is a configuration file for txt2xml utility. It doesn't represent the output format.Are you a user of this utility?

  • RELEVANCY SCORE 4.18

    DB:4.18:Re: Stripping Chars From Strings cx


    Have a look at String.replaceAll(Regex).

    DB:4.18:Re: Stripping Chars From Strings cx

    It seems to be working ok now. It was only a problem on the host server, worked fine on my local machine.

    Thanks for the suggestion though sjasja, i'll give it a go if it goes wrong again.

  • RELEVANCY SCORE 4.18

    DB:4.18:Re: Best Way To Validate License Plate s1


    Regex time!

    DB:4.18:Re: Best Way To Validate License Plate s1

    Ok.
    problem solved then!

    xD

    thank you very much!

  • RELEVANCY SCORE 4.18

    DB:4.18:Asp Regex And Oracle Regex 7f


    Hello,

    I'm currently using asp to make regular expressions to then use for a search in my database. I've read some material on how Oracle DBs handle RegEx and they don't seem to follow the same RegEx rules as ASP/VBScript. I was wondering, if I make a query using a regex made in ASP if the DB will be able to understand it?

    DB:4.18:Asp Regex And Oracle Regex 7f

    Thank you, that's what I wanted to know.

    I was curious to know that if I would have built a rule with VB is the Oracle would have "translated" into it's own rules recognizing it as a VB rule.

    But now I know to make sure to use the DB with the DB and vice versa.

  • RELEVANCY SCORE 4.18

    DB:4.18:Configure Weblogic To Use The Correct Version Of Regex Library - How? mf


    How can I configure WebLogic 10 to use my version of REGEX library?

    DB:4.18:Configure Weblogic To Use The Correct Version Of Regex Library - How? mf

    I have no idea why you think this could have something to do with some "REGEX" library. It's clearly an issue with your ognl library.

    Are you trying to include a version of the ognl jar in your EAR or WAR? As I described, you may need to specify "prefer-web-inf-classes" in your WAR's weblogic.xml, or "prefer-application-packages" in your weblogic-application.xml. That will make WebLogic use the version of the jar in your app, as opposed to what it uses for itself.

    On the other hand, that expression is pretty simple. Is "sql" supposed to be a context automatically made available by the library? I would think not. I would think it's more likely your problem is that "sql" isn't defined at that point in the relevant scope.

  • RELEVANCY SCORE 4.18

    DB:4.18:Arg Name And Arg Value Regex Matching 8c



    Signature 5045-0 (WWW xterm Remote Shell Access) fired an alarm with "log pair packets" enabled. I cannot provide the trace for confidentiality reasons. Here are the regex from that signature:

    Arg Name Regex: term([ \t]|(%(20|09)))

    Arg Value Regex: [-]display

    Only the very 1st packet matched the Arg Value Regex (contained the string "-display"). It did not match the Arg Name Regex. How is this possible?

    Do these particular regex's basically match anywhere in the HTTP stream and in any order?

    DB:4.18:Arg Name And Arg Value Regex Matching 8c


    Shouldn't the ip logging process have the whole stream, or at least all relevant parts that match the regex?

    Let's assume it doesn't, and I'm missing the first regex match. I'm just trying to understand how these particular regex's work. They will match query params and anywhere in the HTTP message-body (for an HTTP post for example). The order does matter, but for example a file upload of a text file with the following contents will trigger(i've tested and it does):

    long term health insurance

    The quick brown fox jumped over the fence

    non-display

    I just want to make sure that is that the expected behavior?

  • RELEVANCY SCORE 4.18

    DB:4.18:Re: Regular Expression For Url Matching cj


    After all that it is so easy!

    String regex = "(\\.do)?(\\?.*)?$";
    String replacement = ".do$2";
    {
    String url = "http://domain.com/something?id=12345";
    System.out.println(url + " - " + url.replaceFirst(regex,replacement));
    }

    {
    String url = "http://domain.com/something.do?id=12345";
    System.out.println(url + " - " + url.replaceFirst(regex,replacement));
    }
    {
    String url = "http://domain.com/something";
    System.out.println(url + " - " + url.replaceFirst(regex,replacement));
    }

    {
    String url = "http://domain.com/something.do";
    System.out.println(url + " - " + url.replaceFirst(regex,replacement));
    }

    DB:4.18:Re: Regular Expression For Url Matching cj

    Well I'll be damned, it works! Thanks so much to all of you involved in arriving at this regex :)

  • RELEVANCY SCORE 4.18

    DB:4.18:Syntax Error With Regex Literal fm


    I'm getting a syntax error in the Flex Builder environment
    when I define a regEx value in literal form

    var mypattern:RegEx = /sh/i;
    Gives me the error 1083: Syntax Error: div is unexpected.

    But
    var mypattern:RegEx = new RegEx("sh", "i");
    works.

    Is there a configuration setting I can change to allow RegEx
    literal notation?

    Thanks,

    DB:4.18:Syntax Error With Regex Literal fm

    I'm getting a syntax error in the Flex Builder environment
    when I define a regEx value in literal form

    var mypattern:RegEx = /sh/i;
    Gives me the error 1083: Syntax Error: div is unexpected.

    But
    var mypattern:RegEx = new RegEx("sh", "i");
    works.

    Is there a configuration setting I can change to allow RegEx
    literal notation?

    Thanks,

  • RELEVANCY SCORE 4.16

    DB:4.16:Asa 5505 Url Filtering 8k



    Hi at all and sorry for my bad english...

    I have a problem configuring url filtering on ASA 5505 rel 8.3.1: I have to block the web navigation to facebook and, with my configuration, it works fine.

    The problem is when I try to access on other sites where there are a links to facebook, I cannot see that site and not only the button of facebook.

    I hope that I explain it well, here is my configuration, thanks at all!!!

    Hubert7

    regex urllist1 ".*\.([Ee][Xx][Ee]|[Cc][Oo][Mm]|[Bb][Aa][Tt]) HTTP/1.[01]"

    regex urllist2 ".*\.([Pp][Ii][Ff]|[Vv][Bb][Ss]|[Ww][Ss][Hh]) HTTP/1.[01]"

    regex urllist3 ".*\.([Dd][Oo][Cc]|[Xx][Ll][Ss]|[Pp][Pp][Tt]) HTTP/1.[01]"

    regex urllist4 ".*\.([Zz][Ii][Pp]|[Tt][Aa][Rr]|[Tt][Gg][Zz]) HTTP/1.[01]"

    regex domainlist1 "\.facebook\.it"

    regex domainlist2 "\.facebook\.*"

    regex domainlist3 "*\.facebook\.*"

    regex contenttype "Content-Type"

    regex applicationheader "application/.*"

    access-list inside_mpc extended permit tcp any any eq www

    access-list inside_mpc extended permit tcp any any eq 8080

    class-map type regex match-any DomainBlockList

    match regex domainlist1

    match regex domainlist2

    match regex domainlist3

    class-map type inspect http match-all BlockDomainsClass

    match request header host regex class DomainBlockList

    class-map type regex match-any URLBlockList

    match regex urllist1

    match regex urllist2

    match regex urllist3

    match regex urllist4

    class-map type inspect http match-all AppHeaderClass

    match response header regex contenttype regex applicationheader

    class-map httptraffic

    match access-list inside_mpc

    class-map type inspect http match-all BlockURLsClass

    match request uri regex class URLBlockList

    policy-map type inspect http http_inspection_policy

    parameters

      protocol-violation action drop-connection

    class AppHeaderClass

    drop-connection log

    match request method connect

      drop-connection log

    class BlockDomainsClass

      reset log

    class BlockURLsClass

      reset log

    policy-map inside-policy

    class httptraffic

      inspect http http_inspection_policy

    service-policy inside-policy interface inside

    DB:4.16:Asa 5505 Url Filtering 8k


    if things are fine please mark the question as answered.

    Have a good one.

  • RELEVANCY SCORE 4.16

    DB:4.16:Regex And Grouping Questions zx



    Hi all, I have a 5510 in route mode, when I add a regex to block 2 sites, it somehow blocks all sites, when I remove it it's back to normal, here's the regex code along with my other nat setting that gives inside users outside access. Thanks in advanced.

    (regex entry to block sites)

    regex domain1 "\.yahoo\.com"

    regex domain2 "\.google\.com"

    !

    class-map type regex match-any domain-list

    match regex domain1

    match regex domain2

    !

    class-map web

    match port tcp eq www

    !

    policy-map type inspect http URL

    parameters

    match not request header host regex class domain-list

    drop-connection

    !

    policy-map global_policy

    class web

    inspect http URL

    (nat outside access)

    object network obj-LAN

    subnet 0.0.0.0 0.0.0.0

    object network obj-LAN

    nat (inside,outside) dynamic interface

    route outside 0.0.0.0 0.0.0.0 12.54.x.x 1

    DB:4.16:Regex And Grouping Questions zx


    It's working now, I'll open a new thread for my blocking sites questions, thanks for all the help Marius

  • RELEVANCY SCORE 4.15

    DB:4.15:Issue With Regex Editor xa


    Loss of cursor when RegEx Editor extension installedand enabled in VS2010.

    DB:4.15:Issue With Regex Editor xa

    Just
    downloaded the latest version after going to comments on Visual Studio Gallery and found a comment saying there had been an update to fix the cursor issue and is has :D

    There has the fix already. Had I got the info earlier!

  • RELEVANCY SCORE 4.15

    DB:4.15:Regex Strings m1


    Hallo,
    Ich habe wie bereits gesagt ein kleines regex-problem.
    Sehen wir uns zunchst folgenden RegEx an:

    Regex re = new Regex(var c1Arr = new Array\(.\));

    So. Was knnte das Problem sein?
    Richtig! ...\)... - unknown escape sequenz - compilierung wird nicht zugelassen :)
    Schn und gut. Aber leider ist das in der regex-sprache so gewollt.
    Ich will nach der klammer suchen, und nicht gruppen bilden! :D
    Wie kann man das elegant umgehen?

    Michael D.

    DB:4.15:Regex Strings m1

    Hallo Michael,
    Cool.Schn, dass Dein Problem damit gelst ist.
    Gru
    Marcel

  • RELEVANCY SCORE 4.13

    DB:4.13:Cannot Open Include File: Regex ks


    Hi,all, I tried

    #include regex

    DB:4.13:Cannot Open Include File: Regex ks


    Microsoft Update is different from Windows Update, which only update Windows, not updating other Microsoft programs like Microsoft Update does. Visit update.microsoft.com instead.
    RTM stands for release to manufacturing, which is theoriginallyreleased version (without service packs). If you installed the service pack you will have a higher version number in Help-About.

    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.

    Visual C MVP

    yea, I tried to install the sp1 and the version number increased, and regex is in there.
    ps. windows update and microsoft update are the same thing in Windows, I download the sp1 installer from
    http://www.microsoft.com/downloads/en/details.aspx?FamilyId=FBEE1648-7106-44A7-9649-6D9F6D58056Edisplaylang=en
    thanks for the help
    daiyue

  • RELEVANCY SCORE 4.13

    DB:4.13:Re: Streamtokenizer ax


    Seems to be a continuation of Regex pattern .

    DB:4.13:Re: Streamtokenizer ax

    Thought about doing that but I did not want to have to verify itThat doesn't make sense. The product of a parser generator scarcely needs any verifying: it's good as the grammar you feed into it. That's one of the major benefits.
    because I felt that would be the same as writing and verifying my own parser.But it isn't. It's many times as quick to produce, more reliable, less cost, etc etc etc. That's why they exist. And the tools they provide for lexical analyis are infinitely superior to regex, StreamTokenizer, and friends.
    The saving of time in auto-generation I felt was not sufficient.You would have been finished by now, instead of being still searching around for a toolset, not having implemented anything.

  • RELEVANCY SCORE 4.13

    DB:4.13:Problem In Policy 3s



    Dear All

    I am binding the policy in ASA 5500, everthing works fine except we are not able to download the mail attachment from MSN.

    The ASA OS Version is 8.2(1).

    regex domainlist2 ".*sandai.*"

    regex domainlist4 ".*megaupload.*"

    regex domainlist5 ".*sendspace.*"

    regex domainlist6 ".*rapidshare.*"

    access-list inside_mpc extended permit tcp any any eq www

    access-list inside_mpc extended permit tcp any any eq 8080

    class-map type regex match-any DomainBlockList

    match regex domainlist2

    match regex domainlist4

    match regex domainlist5

    match regex domainlist6

    class-map type inspect http match-all BlockDomainsClass

    match request header host regex class DomainBlockList

    class-map httptraffic

    match access-list inside_mpc

    policy-map type inspect http http_inspection_policy

    parameters

    protocol-violation action drop-connection

    match request method connect

    drop-connection log

    class BlockDomainsClass

    reset log

    policy-map inside-policy

    class httptraffic

    inspect http http_inspection_policy

    service-policy inside-policy interface Internal

    regards

    shivlu jain

    DB:4.13:Problem In Policy 3s


    Try removing the non-standard HTTP check and see how it goes:

    no protocol-violation action drop-connection

    Or change the action from drop to logging only

    Regards

    Farrukh

  • RELEVANCY SCORE 4.13

    DB:4.13:How I Can Cancel A Regex.Ismatch() When Its Working kf


     
    Regex re = new Regex(text, RegexOptions.IgnoreCase);if (re.IsMatch(text))    //it will be working for long time if the regex is not very right
    .....
    i can't have a timeout property for the regex member,so how i can solve this

    DB:4.13:How I Can Cancel A Regex.Ismatch() When Its Working kf

    FYI: I taken the
    opportunity to post a Microsoft Connect Suggestion Issue entitled Regular
    Expression (Regex) Improvements - Timeout Pattern
    Tester which suggests that the Regular Expression be modified
    as following: 1) Asynchronous operations available just as a
    web service to allow a user to run known regex'es in such a
    fashion.1.a) Ability to cancel a
    regex.2) Ability to specify a timeout on a match
    operation.3)
    Preprocess pattern evaluator to indicate if a regex pattern has
    identified regex pattern no-no's which could cause a regex match to not
    return or is malformed, such as missing a closing group parenthesis
    item such as (\d Maybe some of these could help your
    situation if implemented. Check out the connect item and vote on it if
    you feel it answers to your situation.

  • RELEVANCY SCORE 4.13

    DB:4.13:Regex Character Classes dd


    You can match ']' in a regex character class by specifying it as the first literal
    "[]]"How do you match '[' in a regex character class?

    Thanks in advance, Mel

    DB:4.13:Regex Character Classes dd

    sabre150 wrote:
    Escape it as in
    "[\\[]"Check the Javadoc for Pattern.I swear i initially tried that... thanks sabre

  • RELEVANCY SCORE 4.13

    DB:4.13:How To Color A Text String Using Regex (Java.Util.Regex) 73


    Hello,

    How can I color a text string using regex class in 1.4?

  • RELEVANCY SCORE 4.13

    DB:4.13:Help With Regex af


    Hi,

    DB:4.13:Help With Regex af

    No, i didn't, but i had a look at rules of REGEXP for powershell on the MS site...
    It should work. don't know why it doesn't...
    perhaps there are differences in the new behaviour in powershell that i don't know...
    Anyway nevermind... :-) Happy you solved with lookaheads!Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito così com'è. Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione segna come risposta per i post che ti hanno aiutato a
    risolvere il problema e deseleziona come risposta quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting
    is provided AS IS with no warranties, and confers no rights. Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This
    can be beneficial to other community members reading the thread.

  • RELEVANCY SCORE 4.13

    DB:4.13:Regex For Custom Signatures ap



    Hi,

    Can anyone explain the difference between [/\\][Aa][Nn][Dd] and [Aa][Nn][Dd]

    Thanks.

    DB:4.13:Regex For Custom Signatures ap


    In short the difference of the first regular expression from the second is if you see ascii character / or \ match. The second regular expression simply matches [Aa][Nn][Dd].

    To give you a bit more detail, the [] is a character class which means that with each character within the class an OR is in place. So [Bb] means match B OR b. [/\\] is the same as a hex 0x2f which is ascii / and 0x5c means \. In this case you will notice that there are two 0x5c characters. This is to escape the character since it is a meta character.

    Here is a link that may help you further:http://www.cisco.com/univercd/cc/td/doc/product/iaabu/csids/csids11/cliguide/cliintro.htm#wp1031526

    I hope that helps.

  • RELEVANCY SCORE 4.13

    DB:4.13:Looking For Regex Format 8p


    looking for help with regex format

    DB:4.13:Looking For Regex Format 8p

    I think this one is simpler: 05?\d-?\d{7}

  • RELEVANCY SCORE 4.13

    DB:4.13:Perlregex In Cf-Regex 8f


    Hi,

    how can I make this RegEx workin in CF:
    $test= join ' ', /(\w*und\w*)/g;

    br
    Charlie

    DB:4.13:Perlregex In Cf-Regex 8f

    thank you very much for your great help.

    No probs. Sorry to be so circuitous, but if there's a way for
    me to "help"
    (it's arguable as to how "helpful" my tone can be, sometimes
    ;-) someone to
    work something out for themselves, then I'll take that
    approach rather than
    just giving them the answer.


    http://forge.mysql.com/projects/view.php?id=86

    I did not know about that. Excellent. Will come in handy.

    Take it easy.

    --
    Adam

  • RELEVANCY SCORE 4.13

    DB:4.13:Exclude A Word Regex m7


    Currently i am using one regex foraccepting some records from a file.That regex is ^[a-zA-Z0-9| ].*$. This regex accepts record starting with alphanumerics or blank space.I want to modify this regex such that, previous conditions should be there and regex should not accept record starting with word 'bbb'. Which regex should be used?

    DB:4.13:Exclude A Word Regex m7

    Ok found this solution in the wrong section/thread but yea, thanksExtendable Dining Table
    Bedroom Carpet

  • RELEVANCY SCORE 4.11

    DB:4.11:Regex Question k8


    Hi

    I have seen the regex expression "[^*]*\*"
    What is the meaning of the [^*]? Is it valid in java?

    Thanks

    DB:4.11:Regex Question k8

    Hi

    I have seen the regex expression "[^*]*\*"
    What is the meaning of the [^*]? Is it valid in java?

    ThanksHi,

    [^*] basically finds every character. It is valid.

    http://galileo.spaceports.com/~ibidris/