• RELEVANCY SCORE 4.63

    DB:4.63:Unable To Resolve Resource Bundle jm





    Hello When I add more than one language in the Flex compiler, always gives a error.

    I leave Flex Compiler thus:-locale = en_US,pt_BR en and do these errors:

    Description Resource Path Location Type Unable to resolve resource bundle "components" for locale "en_US". Project Unknown Flex ProblemDescription Resource Path Location Type Unable to resolve resource bundle "core" for locale "en_US". Project Unknown Flex ProblemDescription Resource Path Location Type Unable to resolve resource bundle "effects" for locale "en_US". Project Unknown Flex ProblemDescription Resource Path Location Type Unable to resolve resource bundle "layout" for locale "en_US". Project Unknown Flex ProblemDescription Resource Path Location Type Unable to resolve resource bundle "skins" for locale "en_US". Project Unknown Flex ProblemDescription Resource Path Location Type Unable to resolve resource bundle "styles" for locale "en_US". Project Unknown Flex Problem

    DB:4.63:Unable To Resolve Resource Bundle jm


    I only went to Project menu - Clean... and all problems disappeared.

    I've got installed Flash Builder 4 and 4.5 on the same machine (WinXP)

  • RELEVANCY SCORE 4.28

    DB:4.28:Day 5 Last Exercise Bundle Error fz




    found this after fixing some errors in my code.
    Unable to resolve resource bundle "localization".
    Resource= ReservationSystem
    Location= Unknown

    so how do I fix this problem?

    DB:4.28:Day 5 Last Exercise Bundle Error fz


    was able to figure this out from the docs under topic:

    Advanced Flex Programming

    Localizing Flex Applications

    Creating resources ( http://livedocs.adobe.com/flex/3/html/l10n_3.html#158343 )

    step 19 needs an additional command-line argument to add your locale resources to the source-path, so all of the command-line options I am using look like this (the ../locale is relative to the src directory):

    -locale=en_US,es_ES -source-path=../locale/{locale} -allow-source-path-overlap=true

    making this change allows the solution to compile (I'm using sdk version 3.4).

    Another detail I had to correct on my workstation was to reset the command-line flex_sdk_home and path environment variables when using the copylocale command from my shell (it was pointing to another version of the flex sdk, putting the locale/es_ES assets in the wrong place).

    edit: this relates to exercise 26 (Localization using resource bundles) on the 5th day of the Flex in a week series.

  • RELEVANCY SCORE 4.11

    DB:4.11:Fab Installation And Dependencies Resolution cd





    Hi,

    I'm trying to install a bundle with a dependency to com.google.code.gson/gson/2.2.4. However when starting the bundle, I get the following message:

    Error executing command: Error starting bundles:
    Unable to start bundle 242: Unresolved constraint in bundle gopressComponants [242]: Unable to resolve 242.0: missing requirement [242.0] osgi.wiring.package; ((osgi.wiring.package=com.google.gson)(version=2.2.0)(!(version=3.0.0)))

    DB:4.11:Fab Installation And Dependencies Resolution cd


    Hi,

    I'm trying to install a bundle with a dependency to com.google.code.gson/gson/2.2.4. However when starting the bundle, I get the following message:

    Error executing command: Error starting bundles:
    Unable to start bundle 242: Unresolved constraint in bundle gopressComponants [242]: Unable to resolve 242.0: missing requirement [242.0] osgi.wiring.package; ((osgi.wiring.package=com.google.gson)(version=2.2.0)(!(version=3.0.0)))

  • RELEVANCY SCORE 3.86

    DB:3.86:Selecting Locale dz


    hi
    I have 2 resource bundles of ENGLISH and SPANISH languages, I have a struts applcation which uses these resource bundles, I want to know how to select a particular resource bundle at runtime.

    DB:3.86:Selecting Locale dz

    And you're not asking this at a Struts support forum because?

  • RELEVANCY SCORE 3.76

    DB:3.76:Resource Bundle Question ps


    Hi,
    I have a message in my resource bundle say:

    static final Object[] messages_ =
    { T2zosMessageKeys.MYDETAILS_,
    " My name is = {0} and my age is "{1}"},

    ....
    ....
    }

    My question is when I invoke this message in my resource bundle , how do I supply the parameters to the arguments {0} and {1}?

    DB:3.76:Resource Bundle Question ps

    Use the MessageFormat.format() method.

  • RELEVANCY SCORE 3.52

    DB:3.52:Referecing Property Of Resource Bundle From Within Resource Bundle 7z


    Hi,
    I want to reference a resource bundle property from within the resource bundle but am not able to do it successfully.

    Resourcebundle:
    global.title=Test Title
    module.tile={global.title}

    ADF Code:
    c:set var="viewcontrollerBundle" value="#{adfBundle['com.resource.ViewControllerBundle']}"/
    af:document title="#{viewcontrollerBundle['module.tile']}" id="d1"
    /af:document

    The result is showing title as "{global.title}", I want it to show "Test title". Anyhelp will be appreciated.

    thanks,
    -Srini.

    DB:3.52:Referecing Property Of Resource Bundle From Within Resource Bundle 7z

    Well, that's the wrappers that provide that functionality; it's not what ADF gives you.

    John

  • RELEVANCY SCORE 3.52

    DB:3.52:Load Resource Bundle 79



    Hi,I'm trying to load a Resource Bundle for a particular Locale.In faces-config.xml I have:

    message-bundlemessages/message-bundle
    locale-config
    default-localefr/default-locale
    supported-localefr/supported-locale
    /locale-config

    DB:3.52:Load Resource Bundle 79


    resourceBundle.getBundle is a static method on java.util.ResourceBundle. Make sure you have set LocaleSelector.instance().locale to your desired locale and the access it with resourceBundle.getString()

  • RELEVANCY SCORE 3.52

    DB:3.52:How To Get Message From Resource Bundle In Webremote k8


    Hi.
    Why doesn't it work to get message from resource bundle inside webremote?Any workaround?
    @WebRemote
    public void web() {
    Messages.instance.get('thisDoesntWork')
    }

  • RELEVANCY SCORE 3.47

    DB:3.47:Warn Unable To Locate Resource Bundle: Com.Sun.Jms.Client.Localstrings 73


    Hi

    I have created a SWING client and a thread which listens to JMS postings.

    After i published the data, i had this error over at my client side together with the data which i posted, but its all messed up:
    ----
    WARN unable to locate resource bundle: com.sun.jms.client.LocalStrings
    ----
    can someone tell me whats wrong? whats the meaning of this error msg?

    pls. advise. thanks.

    DB:3.47:Warn Unable To Locate Resource Bundle: Com.Sun.Jms.Client.Localstrings 73

    HI,

    just a few days ago, i readed about that "resource"

    comprehensive information at

    http://java.sun.com/j2se/1.3/docs/api/java/util/ResourceBundle.html

    hope this helps a little

  • RELEVANCY SCORE 3.41

    DB:3.41:Resource Bundle Refresh cx


    After making some changes in my resource bundle i need to restart my application.
    How can I avoid restating the application after making changes in the resource bundle?

    Any help?

    DB:3.41:Resource Bundle Refresh cx

    After making some changes in my resource bundle i need to restart my application.
    How can I avoid restating the application after making changes in the resource bundle?

    Any help?

  • RELEVANCY SCORE 3.40

    DB:3.40:How To Add External Resource Bundle To Webcenter Portal Application?? dz


    How can we add external Resource Bundle(Properties File/Java Class) to a web center portal application in jdeveloper 11.1.1.5???

    -Harsha

    DB:3.40:How To Add External Resource Bundle To Webcenter Portal Application?? dz

    Hi, is it not possible to have an external resource bundle? I'm planning to have a resource bundle and deployed as an WebCenter Portal Extension, then I'm trying to work out on accessing those resource bundle in my other project. I'm thinking this approach to avoid redeploying the application or re-building the project everytime there's a change in the resource bundle... any hint? Thanks..

  • RELEVANCY SCORE 3.35

    DB:3.35:Initial Problems In Development 1z



    This is my first app for Blackberry Playbook and when I created a new Flex project and had the default MXML file in my project ( have only set size to 1024 X 640 ), I get 25 errors

    UNABLE TO RESOLVE RESOURCE BUNDLE 'COLLECTIONS' for 'local en_US'.

    CAn you tell me how to proceed ?

    Thanks







    Solved!
    Go to Solution.

  • RELEVANCY SCORE 3.34

    DB:3.34:Weblogic 8.1.4 Net Installer Problem On Solaris 10 m3


    Hi,
    We try to install weblogic 8.1.4 using net_platform814_solaris32.bin on Solaris 10. We getting below error kindly help resolve this issue.
    2011-03-21 14:03:16,584 INFO [main] com.bea.plateng.wizard.WizardController - Wizard Controller Version 3.1.0.0 (Gandalf) Started.
    2011-03-21 14:03:16,605 INFO [main] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/wizard/i18n_wizard) in namespace (wizard-internal) in locale (en).
    2011-03-21 14:03:16,644 INFO [main] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/wizard/i18n_public) in namespace (public) in locale (en).
    2011-03-21 14:03:16,650 INFO [main] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/wizard/i18n_wizard_gui) in namespace (wizard-internal) in locale (en).
    2011-03-21 14:03:20,392 INFO [main] com.bea.plateng.wizard.WizardController - Executing BEA Installer 3.0.0.0 in GUI Mode under namespace public
    2011-03-21 14:03:20,606 INFO [main] com.bea.plateng.wizard.WizardController - Loaded target: transfer
    2011-03-21 14:03:20,607 INFO [WizardController] com.bea.plateng.wizard.WizardController - Excecuting.
    2011-03-21 14:03:20,731 WARN [loadNamespace] com.bea.plateng.wizard.silent.tasks.LoadObjectStoreTask - Unable to load object store namespace bids with file (bids_bsu_namespace.properties)!
    java.io.FileNotFoundException: Unable to read namespace property file: (bids_bsu_namespace.properties)!
    at com.bea.plateng.wizard.WizardController.loadNamespace(WizardController.java:457)
    at com.bea.plateng.wizard.ControllerProxy.storeAll(ControllerProxy.java:210)
    at com.bea.plateng.wizard.silent.tasks.LoadObjectStoreTask.execute(LoadObjectStoreTask.java:95)
    at com.bea.plateng.wizard.silent.tasks.AbstractSilentTask.run(AbstractSilentTask.java:32)
    at java.lang.Thread.run(Thread.java:536)
    Caused by: java.io.FileNotFoundException: bids_bsu_namespace.properties (No such file or directory)
    at java.io.FileInputStream.open(Native Method)
    at java.io.FileInputStream.init(FileInputStream.java:103)
    at java.io.FileInputStream.init(FileInputStream.java:66)
    at com.bea.plateng.wizard.WizardController.loadNamespace(WizardController.java:449)
    ... 4 more
    2011-03-21 14:03:20,771 INFO [readInstallOptions] com.bea.plateng.wizard.installer.utils.InstallerUtils - Reading: /apps/bea/bea/installoptions.bea
    2011-03-21 14:03:20,798 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/bids/i18n_bids) in namespace (bids) in locale (en).
    2011-03-21 14:03:20,817 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/comdev/comdev) in namespace (comdev) in locale (en).
    2011-03-21 14:03:20,831 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/comdev/gpr) in namespace (comdev) in locale (en).
    2011-03-21 14:03:20,838 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/bids/i18n_bids_gui) in namespace (bids) in locale (en).
    2011-03-21 14:03:20,857 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/comdev/comdev_gui) in namespace (comdev) in locale (en).
    2011-03-21 14:03:49,774 INFO [WizardController] com.bea.plateng.wizard.installer.utils.InstallerUtils - Reading: /apps/bea/bea/installoptions.bea
    2011-03-21 14:03:49,821 WARN [readCachedArchiveInfo] com.bea.plateng.wizard.installer.silent.tasks.ReadCachedArchiveInfoTask - Unable to read archive.bea from /apps/bea/beaTemp
    2011-03-21 14:03:51,900 WARN [writeCachedArchiveInfo] com.bea.plateng.wizard.installer.silent.tasks.WriteCachedArchiveInfoTask - Unable to read archive.bea from /apps/bea/beaTemp

    Regards,
    Ravi.

    DB:3.34:Weblogic 8.1.4 Net Installer Problem On Solaris 10 m3

    Hi,
    We try to install weblogic 8.1.4 using net_platform814_solaris32.bin on Solaris 10. We getting below error kindly help resolve this issue.
    2011-03-21 14:03:16,584 INFO [main] com.bea.plateng.wizard.WizardController - Wizard Controller Version 3.1.0.0 (Gandalf) Started.
    2011-03-21 14:03:16,605 INFO [main] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/wizard/i18n_wizard) in namespace (wizard-internal) in locale (en).
    2011-03-21 14:03:16,644 INFO [main] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/wizard/i18n_public) in namespace (public) in locale (en).
    2011-03-21 14:03:16,650 INFO [main] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/wizard/i18n_wizard_gui) in namespace (wizard-internal) in locale (en).
    2011-03-21 14:03:20,392 INFO [main] com.bea.plateng.wizard.WizardController - Executing BEA Installer 3.0.0.0 in GUI Mode under namespace public
    2011-03-21 14:03:20,606 INFO [main] com.bea.plateng.wizard.WizardController - Loaded target: transfer
    2011-03-21 14:03:20,607 INFO [WizardController] com.bea.plateng.wizard.WizardController - Excecuting.
    2011-03-21 14:03:20,731 WARN [loadNamespace] com.bea.plateng.wizard.silent.tasks.LoadObjectStoreTask - Unable to load object store namespace bids with file (bids_bsu_namespace.properties)!
    java.io.FileNotFoundException: Unable to read namespace property file: (bids_bsu_namespace.properties)!
    at com.bea.plateng.wizard.WizardController.loadNamespace(WizardController.java:457)
    at com.bea.plateng.wizard.ControllerProxy.storeAll(ControllerProxy.java:210)
    at com.bea.plateng.wizard.silent.tasks.LoadObjectStoreTask.execute(LoadObjectStoreTask.java:95)
    at com.bea.plateng.wizard.silent.tasks.AbstractSilentTask.run(AbstractSilentTask.java:32)
    at java.lang.Thread.run(Thread.java:536)
    Caused by: java.io.FileNotFoundException: bids_bsu_namespace.properties (No such file or directory)
    at java.io.FileInputStream.open(Native Method)
    at java.io.FileInputStream.init(FileInputStream.java:103)
    at java.io.FileInputStream.init(FileInputStream.java:66)
    at com.bea.plateng.wizard.WizardController.loadNamespace(WizardController.java:449)
    ... 4 more
    2011-03-21 14:03:20,771 INFO [readInstallOptions] com.bea.plateng.wizard.installer.utils.InstallerUtils - Reading: /apps/bea/bea/installoptions.bea
    2011-03-21 14:03:20,798 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/bids/i18n_bids) in namespace (bids) in locale (en).
    2011-03-21 14:03:20,817 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/comdev/comdev) in namespace (comdev) in locale (en).
    2011-03-21 14:03:20,831 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/comdev/gpr) in namespace (comdev) in locale (en).
    2011-03-21 14:03:20,838 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/bids/i18n_bids_gui) in namespace (bids) in locale (en).
    2011-03-21 14:03:20,857 INFO [loadResources] com.bea.plateng.common.util.ResourceBundleManager - Attempting to managing resource bundle (resources/comdev/comdev_gui) in namespace (comdev) in locale (en).
    2011-03-21 14:03:49,774 INFO [WizardController] com.bea.plateng.wizard.installer.utils.InstallerUtils - Reading: /apps/bea/bea/installoptions.bea
    2011-03-21 14:03:49,821 WARN [readCachedArchiveInfo] com.bea.plateng.wizard.installer.silent.tasks.ReadCachedArchiveInfoTask - Unable to read archive.bea from /apps/bea/beaTemp
    2011-03-21 14:03:51,900 WARN [writeCachedArchiveInfo] com.bea.plateng.wizard.installer.silent.tasks.WriteCachedArchiveInfoTask - Unable to read archive.bea from /apps/bea/beaTemp

    Regards,
    Ravi.

  • RELEVANCY SCORE 3.33

    DB:3.33:Loading Resource Bundle From Jar dz



    Hi,

    In my application i have a local resource bundle name as "resources*.properties".

    We are also using a Jar file, which has its own resource bundle and it is same as my application's local resource bundle ("resources*.properties").

    At runtime resource keys from the Jar file are not accessible. I am using seam way to access the resource files.

    core:resource-loader core:bundle-names valueresources/value valueerror_messages/value /core:bundle-names /core:resource-loader

    Is there anthing else i need to do to get it work??

    DB:3.33:Loading Resource Bundle From Jar dz


    Hi,

    In my application i have a local resource bundle name as "resources*.properties".

    We are also using a Jar file, which has its own resource bundle and it is same as my application's local resource bundle ("resources*.properties").

    At runtime resource keys from the Jar file are not accessible. I am using seam way to access the resource files.

    core:resource-loader core:bundle-names valueresources/value valueerror_messages/value /core:bundle-names /core:resource-loader

    Is there anthing else i need to do to get it work??

  • RELEVANCY SCORE 3.32

    DB:3.32:Modeshape 4 And Fuse 6.2 1j



    Good morning, I am trying to use modeshape 4.0.0 in Fuse 6.2 environment. I added the modeshape features in the features.xml. When the feature that contains the modeshape bundles is installed I receive the following error in Fuse logs:

    Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.modeshape.jcr-api [327]: Unable to resolve 327.0: missing requirement [327.0] osgi.wiring.package; ((osgi.wiring.package=javax.servlet.http)(version=3.1.0)(!(version=4.0.0)))

    the bundles added in the features.xml are:

    bundlemvn:org.modeshape/modeshape-jcr-api/4.0.0.Final/bundle

    bundlemvn:javax.jcr/jcr/2.0/bundle

    bundlemvn:org.modeshape/modeshape-common/4.0.0.Final/bundle

    bundlemvn:org.modeshape/modeshape-jcr/4.0.0.Final/bundle

    bundlemvn:org.modeshape/modeshape-schematic/4.0.0.Final/bundle

    DB:3.32:Modeshape 4 And Fuse 6.2 1j


    ModeShape uses this artifact Sonatype Nexus Professional as a provided dependency. This seems fine to me and you should be able to get this from Nexus.

  • RELEVANCY SCORE 3.31

    DB:3.31:Fuse Esb 4.4 Installation Error sc



    Hi All,

    When trying to run servicemix.bat I am getting the below error

    Please advice.

    ERROR: Error parsing system bundle export statement: org.osgi.framework; version=1.5.0, org.osgi.framework.launch; version=1.0.0, org.osgi.framework.hooks.service; version=1.0.0, org.osgi.service.packageadmin; version=1.2.0, org.osgi.service.startlevel; version=1.1.0, org.osgi.service.url; version=1.0.0, org.osgi.util.tracker; version=1.4.0, org.apache.karaf.jaas.boot; version=2.2.0.fuse-00-43, org.apache.karaf.version; version=2.2.0.fuse-00-43, ,org.apache.karaf.branding, com.sun.org.apache.xalan.internal.xsltc.trax, com.sun.org.apache.xerces.internal.dom, com.sun.org.apache.xerces.internal.jaxp, com.sun.org.apache.xerces.internal.xni, com.sun.jndi.ldap, org.apache.xalan.extensions; version="2.7.1", org.apache.xalan.xsltc.compiler; version="2.7.1", org.apache.xalan.xsltc.cmdline.getopt; version="2.7.1", org.apache.xalan.xsltc.util; version="2.7.1", org.apache.xalan.transformer; version="2.7.1", org.apache.xalan.xsltc.trax; version="2.7.1", org.apache.xalan.processor; version="2.7.1", org.apache.xalan.lib; version="2.7.1", org.apache.xalan.trace; version="2.7.1", org.apache.xalan.xsltc.compiler.util; version="2.7.1", org.apache.xalan.templates; version="2.7.1", org.apache.xalan.xsltc; version="2.7.1", org.apache.xalan.xsltc.runtime; version="2.7.1", org.apache.xalan; version="2.7.1", org.apache.xalan.xslt; version="2.7.1", org.apache.xalan.lib.sql; version="2.7.1", org.apache.xalan.xsltc.runtime.output; version="2.7.1", org.apache.xalan.xsltc.dom; version="2.7.1", org.apache.xalan.client; version="2.7.1", org.apache.xalan.xsltc.cmdline; version="2.7.1", org.apache.xalan.serialize; version="2.7.1", org.apache.xalan.res; version="2.7.1", org.apache.xml.dtm.ref; version="2.7.1", org.apache.xml.dtm; version="2.7.1", org.apache.xml.dtm.ref.sax2dtm; version="2.7.1", org.apache.xml.dtm.ref.dom2dtm; version="2.7.1", org.apache.xml.res; version="2.7.1", org.apache.xml.serializer.dom3; version="2.7.1", org.apache.xml.serializer; version="2.7.1", org.apache.xml.serializer.utils; version="2.7.1", org.apache.xml.utils.res; version="2.7.1", org.apache.xml.utils; version="2.7.1", org.apache.xpath.functions; version="2.7.1", org.apache.xpath.jaxp; version="2.7.1", org.apache.xpath.patterns; version="2.7.1", org.apache.xpath.objects; version="2.7.1", org.apache.xpath.res; version="2.7.1", org.apache.xpath; version="2.7.1", org.apache.xpath.axes; version="2.7.1", org.apache.xpath.compiler; version="2.7.1", org.apache.xpath.operations; version="2.7.1", org.apache.xpath.domapi; version="2.7.1", org.apache.html.dom; version="2.11.0", org.apache.wml.dom; version="2.11.0", org.apache.wml; version="2.11.0", org.apache.xerces.parsers; version="2.11.0", org.apache.xerces.impl.dtd.models; version="2.11.0", org.apache.xerces.xni.parser; version="2.11.0", org.apache.xerces.impl.dv.xs; version="2.11.0", org.apache.xerces.impl.xs.traversers; version="2.11.0", org.apache.xerces.util; version="2.11.0", org.apache.xerces.impl.dtd; version="2.11.0", org.apache.xerces.jaxp.validation; version="2.11.0", org.apache.xerces.dom3.as; version="2.11.0", org.apache.xerces.impl.dv; version="2.11.0", org.apache.xerces.jaxp; version="2.11.0", org.apache.xerces.jaxp.datatype; version="2.11.0", org.apache.xerces.impl.xpath.regex; version="2.11.0", org.apache.xerces.xni; version="2.11.0", org.apache.xerces.impl.msg; version="2.11.0", org.apache.xerces.impl.dv.util; version="2.11.0", org.apache.xerces.impl.xs.util; version="2.11.0", org.apache.xerces.dom; version="2.11.0", org.apache.xerces.dom.events; version="2.11.0", org.apache.xerces.impl.xs.opti; version="2.11.0", org.apache.xerces.impl; version="2.11.0", org.apache.xerces.xs; version="2.11.0", org.apache.xerces.impl.io; version="2.11.0", org.apache.xerces.xpointer; version="2.11.0", org.apache.xerces.impl.dv.dtd; version="2.11.0", org.apache.xerces.xinclude; version="2.11.0", org.apache.xerces.impl.xpath; version="2.11.0", org.apache.xerces.xs.datatypes; version="2.11.0", org.apache.xerces.impl.xs.identity; version="2.11.0", org.apache.xerces.impl.xs.models; version="2.11.0", org.apache.xerces.xni.grammars; version="2.11.0", org.apache.xerces.impl.xs; version="2.11.0", org.apache.xerces.impl.validation; version="2.11.0", org.apache.xml.serialize; version="2.11.0", (java.lang.IllegalArgumentException: No paths specified in header: )

    ERROR: Bundle org.ops4j.pax.url.wrap Error starting mvn:org.ops4j.pax.url/pax-url-wrap/1.2.6 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.wrap : Unable to resolve 1.0: missing requirement package; (package=javax.net.ssl))

    ERROR: Bundle org.ops4j.pax.url.mvn Error starting mvn:org.ops4j.pax.url/pax-url-mvn/1.2.6 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.mvn : Unable to resolve 2.0: missing requirement package; (package=javax.net.ssl))

    ERROR: Bundle org.ops4j.pax.logging.pax-logging-service Error starting mvn:org.ops4j.pax.logging/pax-logging-service/1.6.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-service : Unable to resolve 3.0: missing requirement package; (package=javax.xml.parsers))

    ERROR: Bundle org.ops4j.pax.logging.pax-logging-api Error starting mvn:org.ops4j.pax.logging/pax-logging-api/1.6.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-api : Unable to resolve 4.0: missing requirement package; (package=javax.xml.parsers))

    ERROR: Bundle org.apache.felix.configadmin Error starting mvn:org.apache.felix/org.apache.felix.configadmin/1.2.8-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.configadmin : Unable to resolve 5.0: missing requirement package; (package=javax.security.auth))

    ERROR: Bundle org.apache.felix.bundlerepository Error starting mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.4 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository : Unable to resolve 6.0: missing requirement package; ((package=org.osgi.framework)(version=1.3.0)(!(version=2.0.0))))

    ERROR: Bundle org.apache.felix.fileinstall Error starting mvn:org.apache.felix/org.apache.felix.fileinstall/3.1.11-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.fileinstall : Unable to resolve 7.0: missing requirement package; ((package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0))))

    ERROR: Bundle org.apache.aries.proxy Error starting mvn:org.apache.aries.proxy/org.apache.aries.proxy/0.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy : Unable to resolve 8.0: missing requirement package; ((package=org.apache.aries.util)(version=0.3.0)(!(version=1.0.0))) [caused by: Unable to resolve 9.0: missing requirement package; ((package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))])

    ERROR: Bundle org.apache.aries.util Error starting mvn:org.apache.aries/org.apache.aries.util/0.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.util : Unable to resolve 9.0: missing requirement package; ((package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0))))

    ERROR: Bundle org.apache.aries.blueprint Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint/0.3.1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint : Unable to resolve 10.0: missing requirement package; (package=javax.xml.parsers))

    ERROR: Bundle org.apache.karaf.shell.commands Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.commands/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands : Unable to resolve 12.0: missing requirement package; ((package=jline)(version=2.5.0)(!(version=3.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

    ERROR: Bundle org.apache.karaf.deployer.wrap Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.wrap/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap : Unable to resolve 13.0: missing requirement package; ((package=org.apache.felix.fileinstall)(version=3.1.0)(!(version=4.0.0))) [caused by: Unable to resolve 7.0: missing requirement package; ((package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0)))])

    ERROR: Bundle org.apache.karaf.shell.dev Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev : Unable to resolve 14.0: missing requirement package; (package=javax.net.ssl))

    ERROR: Bundle org.apache.karaf.deployer.kar Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.kar/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.kar : Unable to resolve 15.0: missing requirement package; (package=javax.xml.parsers))

    ERROR: Bundle org.apache.karaf.jaas.modules Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.modules/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.modules : Unable to resolve 16.0: missing requirement package; (package=javax.naming))

    ERROR: Bundle org.apache.karaf.shell.ssh Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.ssh/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.ssh : Unable to resolve 17.0: missing requirement package; (package=javax.security.auth))

    ERROR: Bundle org.apache.karaf.features.command Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.command/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command : Unable to resolve 18.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.karaf.deployer.spring Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.spring/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.spring : Unable to resolve 19.0: missing requirement package; (package=javax.xml.parsers))

    ERROR: Bundle org.apache.karaf.admin.core Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.core/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.core : Unable to resolve 20.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.karaf.shell.osgi Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.osgi/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi : Unable to resolve 21.0: missing requirement package; ((package=jline)(version=2.5.0)(!(version=3.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

    ERROR: Bundle org.apache.karaf.diagnostic.management Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.management/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.management : Unable to resolve 22.0: missing requirement package; (package=javax.management))

    ERROR: Bundle sshd-core Error starting mvn:org.apache.sshd/sshd-core/0.5.0 (org.osgi.framework.BundleException: Unresolved constraint in bundle sshd-core : Unable to resolve 23.0: missing requirement package; (package=javax.crypto))

    ERROR: Bundle org.apache.aries.jmx.blueprint Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.blueprint/0.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint : Unable to resolve 25.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.karaf.features.management Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.management/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management : Unable to resolve 26.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.karaf.diagnostic.common Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.common/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.common : Unable to resolve 27.0: missing requirement package; ((package=org.apache.karaf.features)(version=2.2.0)(!(version=3.0.0))) [caused by: Unable to resolve 41.0: missing requirement package; (package=javax.management)])

    ERROR: Bundle org.apache.karaf.admin.management Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.management/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management : Unable to resolve 28.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.karaf.jaas.command Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command : Unable to resolve 29.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.karaf.jaas.config Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.config/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.config : Unable to resolve 30.0: missing requirement package; (package=javax.net.ssl))

    ERROR: Bundle org.apache.karaf.shell.log Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.log/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log : Unable to resolve 31.0: missing requirement package; ((package=org.apache.felix.gogo.commands)(version=0.6.0)(!(version=1.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

    ERROR: Bundle org.apache.karaf.deployer.features Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.features/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.features : Unable to resolve 32.0: missing requirement package; (package=javax.xml.parsers))

    ERROR: Bundle org.apache.karaf.admin.command Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.command/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.command : Unable to resolve 33.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.aries.jmx Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx/0.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx : Unable to resolve 34.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.karaf.features.obr Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.obr/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.obr : Unable to resolve 35.0: missing requirement package; ((package=org.apache.felix.bundlerepository)(version=2.0.0)(!(version=3.0.0))) [caused by: Unable to resolve 6.0: missing requirement package; ((package=org.osgi.framework)(version=1.3.0)(!(version=2.0.0)))])

    ERROR: Bundle org.apache.karaf.diagnostic.command Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.command/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.command : Unable to resolve 36.0: missing requirement package; ((package=org.apache.felix.gogo.commands)(version=0.6.0)(!(version=1.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

    ERROR: Bundle org.apache.karaf.management Error starting mvn:org.apache.karaf/org.apache.karaf.management/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.management : Unable to resolve 37.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.karaf.shell.console Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console : Unable to resolve 38.0: missing requirement package; (package=javax.security.auth))

    ERROR: Bundle org.apache.karaf.shell.packages Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages : Unable to resolve 39.0: missing requirement package; ((package=org.apache.felix.gogo.commands)(version=0.6.0)(!(version=1.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

    ERROR: Bundle org.apache.mina.core Error starting mvn:org.apache.mina/mina-core/2.0.1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.mina.core : Unable to resolve 40.0: missing requirement package; (package=javax.crypto))

    ERROR: Bundle org.apache.karaf.features.core Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.core/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.core : Unable to resolve 41.0: missing requirement package; (package=javax.management))

    ERROR: Bundle org.apache.karaf.deployer.blueprint Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.blueprint/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.blueprint : Unable to resolve 42.0: missing requirement package; (package=javax.xml.parsers))

    DB:3.31:Fuse Esb 4.4 Installation Error sc


    Thanks for posting solution. But, i changed the jre-1.7= \ inside jre.properties , which worked fine for now.

  • RELEVANCY SCORE 3.29

    DB:3.29:Using Resource Bundle Value Into A Groovy Expression 1z


    Hi,

    I want to add a resource bundle value inside a Groovy expression.

    My working groovy expression on a view object attribute is:
    TransientExpression![CDATA[Name + ", " + Quantity + ", " + PackagePrice]]/TransientExpression

    I want to add from the resource bundle to build something like the following:

    ![CDATA[Name + ", *VALUE FROM RESOURCE BUNDLE* " + Quantity + ", *VALUE FROM RESOURCE BUNDLE* " + PackagePrice]]

    Is there a way to do that?

    Thanks
    Jamil

    DB:3.29:Using Resource Bundle Value Into A Groovy Expression 1z

    Great John...Thank you

    It is working as explained into the link you sent

    My groovy expression is something like that now:

    ![CDATA[adf.object.getLocalizedValue("package.package") + " " +Name + ", " + adf.object.getLocalizedValue("package.quantity") + " " + Quantity + ", "+ adf.object.getLocalizedValue("package.price") + " " + PackagePrice + " "+ adf.object.getLocalizedValue("package.riyals") ]]

    Jamil

  • RELEVANCY SCORE 3.27

    DB:3.27:Automation_Agent And Qtp_Air Resource Bundles Not Found! x9



    Hi,

    i'm trying to add the automation libraries to my project so we can automate our testing. I've added this to the additional compiler settings:

    -include-libraries+="${flexlib}/libs/automation/automation.swc","${flexlib}/libs/automatio n/automation_agent.swc","${flexlib}/libs/automation/automation_dmv.swc","${flexlib}/libs/a utomation/automation_spark.swc","${flexlib}/libs/automation/automation_air.swc","${flexlib }/libs/automation/automation_airspark.swc","${flexlib}/libs/automation/qtp_air.swc"

    and -locale nl_BE fr_BE

    After compiling this I get 2 errors:
    DescriptionResourcePathLocationTypeUnable to resolve resource bundle "automation_agent".a327-shellUnknownFlex ProblemUnable to resolve resource bundle "qtp_air".a327-shellUnknownFlex Problem

    However, in my nl_BE and fr_BE folders under flex_sdk\frameworks\locale\ the automation_agent_rb.swc and qtp_air_rb.swc are present.

    Can somebody explain to me why Flash Builder can't find these resource bundles?

    If I switch to en_US, it works fine.

  • RELEVANCY SCORE 3.25

    DB:3.25:Resource Bundle Refresh 81


    Hi!
    I've implemented my custom resource bundle class that gets all translations from database table. I know a lot has been written about resource bundle:
    - http://technology.amis.nl/2012/08/14/refresh-resource-bundle-from-within-the-adf-application-to-absorb-changes-in-database-backed-bundles/
    - http://technology.amis.nl/2012/07/11/adf-11g-label-modifications-and-persisting-resource-bundle-changes/

    But I still can't manage it to work. When I change specific translation and refresh the page it still gets all translations from cache and the changes commited aren't reflected o a page.

    I tried to clear the cache with following instructions:
    ResourceBundle.clearCache();
    CustomResource.clearCache(); // My custom resource bundle
    ResourceBundle.getBundle("translations.model.CustomResource");
    ResourceBundle.getBundle("translations.model.CustomResource_sl").clearCache();
    BundleFactory.releaseBundle("translations.model.CustomResource_sl");
    BundleFactory.flush();

    but nothing works. I still get all translations from cache. How can I enforce invocation of getContents() in my custom resource bundle CustomResource
    Please help. I'm pretty desperate :(
    Regards, Marko

    I use JDeveloper 11.1.2.1.0

    DB:3.25:Resource Bundle Refresh 81

    Hi!

    I also have the same problem, witch was solved by putting f:loadBundle element on the page.

    But only for the bundle in the ViewControl. If I put a bundle from the Model it only refreshes the first time and then never again.

    Did anyone solved this problem?

    I also use JDeveloper 11.1.2.1.0

  • RELEVANCY SCORE 3.24

    DB:3.24:Resource Bundle Loading In Java kx


    Hi,
    I want to know how to load resource bundle in java? I have a requirement of reading xml files by looking the path in resource bundle.
    Any help would be highly appreciated.

  • RELEVANCY SCORE 3.24

    DB:3.24:Jee5 Booking Example Deployment On Geronimo 2.1 3c


    When trying to deploy jee5/booking example to Geronimo 2.1 the following exception:
    org.apache.geronimo.common.DeploymentException: Unable to resolve resource reference 'org.jboss.seam.async.TimerServiceDispatcher/timerService' (Could not auto-map to resource. Try adding a resource-ref mapping to your Geronimo deployment plan.Any tips on how to resolve?

    DB:3.24:Jee5 Booking Example Deployment On Geronimo 2.1 3c

    Geronimo is not a supported platform for Seam, but it would be great if you add your experience the Knowledge Base. I would follow what the error message says - you need to provide a mapping for the TimerServiceDispatcher EJB3 to a Geronimo deployment descriptor.

  • RELEVANCY SCORE 3.24

    DB:3.24:Unable To Resolve Resource Bundle Quot;Stringsquot; For Locale Quot;En_Usquot; kz


    Hi

    I'm trying to use Flex 3 to compile the Flex 2 PhotoViewer
    sample project, and encountered this error: Unable to resolve
    resource bundle "strings" for locale "en_US".

    I found the Flex 2 TechNote which suggested to add
    "-use-network=false -library-path+=locale/{locale}
    -source-path+=locale/{locale} -locale=en_US" as compiler options.

    So I tried adding the above options into the build.bat files
    I can find at:
    a) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\samples\explorer
    b) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\templates\automation-runtimeloading-files
    but still the error persists

    Can anyone please help? Thanks!

    Regards
    freshflex

    DB:3.24:Unable To Resolve Resource Bundle Quot;Stringsquot; For Locale Quot;En_Usquot; kz

    Hi

    I'm trying to use Flex 3 to compile the Flex 2 PhotoViewer
    sample project, and encountered this error: Unable to resolve
    resource bundle "strings" for locale "en_US".

    I found the Flex 2 TechNote which suggested to add
    "-use-network=false -library-path+=locale/{locale}
    -source-path+=locale/{locale} -locale=en_US" as compiler options.

    So I tried adding the above options into the build.bat files
    I can find at:
    a) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\samples\explorer
    b) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\templates\automation-runtimeloading-files
    but still the error persists

    Can anyone please help? Thanks!

    Regards
    freshflex

  • RELEVANCY SCORE 3.24

    DB:3.24:About Resource Bundle jf



    Hi all,

    I have doubt about resource bundle. what is resource bundle? where we'll use this resource bundle? .

    pls provide solution for this.

    thanks regards,

    Sreelaxmi

  • RELEVANCY SCORE 3.24

    DB:3.24:Adding Mx Libraries To Source Path Causes Errors In Fb 3.0.2/ Flex 3.5 Sdk dz



    Hi all,

    I am working on a ActionScript project in Flex Builder 3.0.2, using the flex 3.5 sdk. I was having problems importing mx.controls.HorizontalList, (mx.controls.HorizontalList could not be found) so I added the src directory from the sdk to my source path. When I did this, instead of fixing my problems, this caused more errors:

    Unable to resolve resource bundle "collections" for locale "en_US".

    Unable to resolve resource bundle "containers" for locale "en_US".

    Unable to resolve resource bundle "core" for locale "en_US".

    Unable to resolve resource bundle "effects" for locale "en_US".

    Unable to resolve resource bundle "skins" for locale "en_US".

    Unable to resolve resource bundle "styles" for locale "en_US".

    If I comment out all references to HorizontalList or remove the sdk's framework src directory from the source path, I get no errors. However, I'd like to be able to use HorizontalList and I'm not understanding why I would have to add the source for it any way. It's internal to the sdk and works fine when used in mxml files. Can someone show me how to get access to the mx classes without breaking flex builder?

    Thanks,

    Erica

    DB:3.24:Adding Mx Libraries To Source Path Causes Errors In Fb 3.0.2/ Flex 3.5 Sdk dz


    Hi all,

    Thanks RUSH-ME, for looking into this and responding. I think I found a solution that seems to be working for me, here:

    http://flexblog.edchipman.ca/definition-mx-could-not-be-found#more-26

    I've been able to compile with no issues from missing mx classes or other resources. For anyone that may also use this solution, there is a typo in his explanation. Add "-locale=" to your additional compiler arguements, not "-local=".

    Thanks,

    Erica

  • RELEVANCY SCORE 3.22

    DB:3.22:Thread: Unable To Push 10.1.3 Zcm To Clients sa


    I am able to manually install the client by going to the Zen server.

    I am not able to push out the client though.

    The zcc.log file is showing me:

    18 Mar 2009 10:59:48 ResourceUtils.......180 :MissingResourceException: Can\'t find resource for bundle java.util.PropertyResourceBundle, key

    18 Mar 2009 10:59:51 ResourceUtils.......180 :MissingResourceException: Can\'t find resource for bundle java.util.PropertyResourceBundle, key

    18 Mar 2009 10:59:59 ResourceUtils.......180 :MissingResourceException: Can\'t find resource for bundle java.util.PropertyResourceBundle, key

    18 Mar 2009 11:00:01 ResourceUtils.......180 :MissingResourceException: Can\'t find resource for bundle java.util.PropertyResourceBundle, key

    Can anyone assist me in figuring out what this error is and how I can resolve it?

    DB:3.22:Thread: Unable To Push 10.1.3 Zcm To Clients sa

    nwresd,

    It appears that in the past few days you have not received a response to your

    posting. That concerns us, and has triggered this automated reply.

    Has your problem been resolved? If not, you might try one of the following options:

    - Visit http://support.novell.com and search the knowledgebase and/or check all

    the other self support options and support programs available.

    - You could also try posting your message again. Make sure it is posted in the

    correct newsgroup. (http://forums.novell.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:

    http://forums.novell.com/faq.php

    If this is a reply to a duplicate posting, please ignore and accept our apologies

    and rest assured we will issue a stern reprimand to our posting bot.

    Good luck!

    Your Novell Product Support Forums Team

    http://support.novell.com/forums/

  • RELEVANCY SCORE 3.20

    DB:3.20:Fuseesb Doesn't Start On Macos X 10.10 With Jdk 8 38



    Hey All,

    I've updated my Mac to Yosemite and have installed java 1.8.0.25 and have downloaded FuseESB and it doesn't start.

    Please let me know what I'm doing wrong.

    Attached is the screen shot of the errors on startup.

    John-Therons-iMac-4:bin johntheron$ java -version
    java version "1.8.0_25"
    Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
    Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)
    John-Therons-iMac-4:bin johntheron$

    John-Therons-iMac-4:bin johntheron$ sw_vers
    ProductName: Mac OS X
    ProductVersion: 10.10
    BuildVersion: 14A389

    Last login: Mon Nov 10 16:43:43 on ttys000
    John-Therons-iMac-4:~ johntheron$ cd Desktop/
    John-Therons-iMac-4:Desktop johntheron$ cd jboss-fuse-6.1.0.redhat-379/
    John-Therons-iMac-4:jboss-fuse-6.1.0.redhat-379 johntheron$ cd bin
    John-Therons-iMac-4:bin johntheron$ ./fuse
    Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=16M; support was removed in 8.0
    Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128M; support was removed in 8.0
    Please wait while JBoss Fuse is loading...
    ERROR: Error parsing system bundle export statement: org.osgi.framework.startlevel;uses:="org.osgi.framework";version="1.0", org.osgi.framework.wiring;uses:="org.osgi.resource,org.osgi.framework";version="1.1", org.osgi.framework.hooks.bundle;uses:="org.osgi.framework";version="1.1", org.osgi.framework.hooks.service;uses:="org.osgi.framework";version="1.1", org.osgi.framework.hooks.resolver;uses:="org.osgi.framework.wiring";version="1.0", org.osgi.framework.launch;uses:="org.osgi.framework";version="1.1", org.osgi.framework.namespace;uses:="org.osgi.resource";version="1.0", org.osgi.framework;version="1.7",org.osgi.framework.hooks.weaving;uses:="org.osgi.framework.wiring";version="1.0",org.osgi.resource;version="1.0",org.osgi.service.url;version="1.0",org.osgi.service.startlevel;uses:="org.osgi.framework";version="1.1",org.osgi.service.packageadmin;uses:="org.osgi.framework";version="1.2",org.osgi.service.url;version="1.0", org.osgi.util.tracker;uses:="org.osgi.framework";version="1.5.1", org.apache.felix.framework.monitor;version="1.0", org.apache.karaf.jaas.boot;version="2.3.0.redhat-610379", org.apache.karaf.jaas.boot.principal;version="2.3.0.redhat-610379", org.apache.karaf.version;version="2.3.0.redhat-610379", org.apache.xalan.extensions; version="2.7.1", org.apache.xalan.xsltc.compiler; version="2.7.1", org.apache.xalan.xsltc.cmdline.getopt; version="2.7.1", org.apache.xalan.xsltc.util; version="2.7.1", org.apache.xalan.transformer; version="2.7.1", org.apache.xalan.xsltc.trax; version="2.7.1", org.apache.xalan.processor; version="2.7.1", org.apache.xalan.lib; version="2.7.1", org.apache.xalan.trace; version="2.7.1", org.apache.xalan.xsltc.compiler.util; version="2.7.1", org.apache.xalan.templates; version="2.7.1", org.apache.xalan.xsltc; version="2.7.1", org.apache.xalan.xsltc.runtime; version="2.7.1", org.apache.xalan; version="2.7.1", org.apache.xalan.xslt; version="2.7.1", org.apache.xalan.lib.sql; version="2.7.1", org.apache.xalan.xsltc.runtime.output; version="2.7.1", org.apache.xalan.xsltc.dom; version="2.7.1", org.apache.xalan.client; version="2.7.1", org.apache.xalan.xsltc.cmdline; version="2.7.1", org.apache.xalan.serialize; version="2.7.1", org.apache.xalan.res; version="2.7.1", org.apache.xml.dtm.ref; version="2.7.1", org.apache.xml.dtm; version="2.7.1", org.apache.xml.dtm.ref.sax2dtm; version="2.7.1", org.apache.xml.dtm.ref.dom2dtm; version="2.7.1", org.apache.xml.res; version="2.7.1", org.apache.xml.serializer.dom3; version="2.7.1", org.apache.xml.serializer; version="2.7.1", org.apache.xml.serializer.utils; version="2.7.1", org.apache.xml.utils.res; version="2.7.1", org.apache.xml.utils; version="2.7.1", org.apache.xpath.functions; version="2.7.1", org.apache.xpath.jaxp; version="2.7.1", org.apache.xpath.patterns; version="2.7.1", org.apache.xpath.objects; version="2.7.1", org.apache.xpath.res; version="2.7.1", org.apache.xpath; version="2.7.1", org.apache.xpath.axes; version="2.7.1", org.apache.xpath.compiler; version="2.7.1", org.apache.xpath.operations; version="2.7.1", org.apache.xpath.domapi; version="2.7.1", org.apache.html.dom; version="2.11.0", org.apache.wml.dom; version="2.11.0", org.apache.wml; version="2.11.0", org.apache.xerces.parsers; version="2.11.0", org.apache.xerces.impl.dtd.models; version="2.11.0", org.apache.xerces.xni.parser; version="2.11.0", org.apache.xerces.impl.dv.xs; version="2.11.0", org.apache.xerces.impl.xs.traversers; version="2.11.0", org.apache.xerces.util; version="2.11.0", org.apache.xerces.impl.dtd; version="2.11.0", org.apache.xerces.jaxp.validation; version="2.11.0", org.apache.xerces.dom3.as; version="2.11.0", org.apache.xerces.impl.dv; version="2.11.0", org.apache.xerces.jaxp; version="2.11.0", org.apache.xerces.jaxp.datatype; version="2.11.0", org.apache.xerces.impl.xpath.regex; version="2.11.0", org.apache.xerces.xni; version="2.11.0", org.apache.xerces.impl.msg; version="2.11.0", org.apache.xerces.impl.dv.util; version="2.11.0", org.apache.xerces.impl.xs.util; version="2.11.0", org.apache.xerces.dom; version="2.11.0", org.apache.xerces.dom.events; version="2.11.0", org.apache.xerces.impl.xs.opti; version="2.11.0", org.apache.xerces.impl; version="2.11.0", org.apache.xerces.xs; version="2.11.0", org.apache.xerces.impl.io; version="2.11.0", org.apache.xerces.xpointer; version="2.11.0", org.apache.xerces.impl.dv.dtd; version="2.11.0", org.apache.xerces.xinclude; version="2.11.0", org.apache.xerces.impl.xpath; version="2.11.0", org.apache.xerces.xs.datatypes; version="2.11.0", org.apache.xerces.impl.xs.identity; version="2.11.0", org.apache.xerces.impl.xs.models; version="2.11.0", org.apache.xerces.xni.grammars; version="2.11.0", org.apache.xerces.impl.xs; version="2.11.0", org.apache.xerces.impl.validation; version="2.11.0", org.apache.xml.serialize; version="2.11.0", ,org.apache.karaf.branding, com.sun.org.apache.xalan.internal.xsltc.trax, com.sun.org.apache.xerces.internal.dom, com.sun.org.apache.xerces.internal.jaxp, com.sun.org.apache.xerces.internal.xni, com.sun.jndi.ldap (org.osgi.framework.BundleException: Exported package names cannot be zero length.)
    org.osgi.framework.BundleException: Exported package names cannot be zero length.
    at org.apache.felix.framework.util.manifestparser.ManifestParser.normalizeExportClauses(ManifestParser.java:744)
    at org.apache.felix.framework.util.manifestparser.ManifestParser.init(ManifestParser.java:191)
    at org.apache.felix.framework.ExtensionManager.init(ExtensionManager.java:221)
    at org.apache.felix.framework.Felix.init(Felix.java:406)
    at org.apache.felix.framework.FrameworkFactory.newFramework(FrameworkFactory.java:28)
    at org.apache.karaf.main.Main.launch(Main.java:310)
    at org.apache.karaf.main.Main.main(Main.java:537)
    ERROR: Bundle org.ops4j.pax.url.mvn [1] Error starting mvn:org.ops4j.pax.url/pax-url-mvn/1.3.7 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.mvn [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.mvn [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.ops4j.pax.url.wrap [2] Error starting mvn:org.ops4j.pax.url/pax-url-wrap/1.3.7 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.wrap [2]: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.wrap [2]: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.ops4j.pax.logging.pax-logging-service [3] Error starting mvn:org.ops4j.pax.logging/pax-logging-service/1.7.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-service [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-service [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.ops4j.pax.logging.pax-logging-api [4] Error starting mvn:org.ops4j.pax.logging/pax-logging-api/1.7.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-api [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-api [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.felix.bundlerepository [5] Error starting mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository [5]: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository [5]: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0)))
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.felix.configadmin [6] Error starting mvn:org.apache.felix/org.apache.felix.configadmin/1.4.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.configadmin [6]: Unable to resolve 6.0: missing requirement [6.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.configadmin [6]: Unable to resolve 6.0: missing requirement [6.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.felix.fileinstall [7] Error starting mvn:org.apache.felix/org.apache.felix.fileinstall/3.3.11.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.fileinstall [7]: Unable to resolve 7.0: missing requirement [7.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.fileinstall [7]: Unable to resolve 7.0: missing requirement [7.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0)))
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.aries.proxy.api [8] Error starting mvn:org.apache.aries.proxy/org.apache.aries.proxy.api/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy.api [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy.api [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.aries.blueprint.core [9] Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint.core/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint.core [9]: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint.core [9]: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    2% [= ]ERROR: Bundle org.apache.aries.util [11] Error starting mvn:org.apache.aries/org.apache.aries.util/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.util [11]: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.util [11]: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.aries.proxy.impl [12] Error starting mvn:org.apache.aries.proxy/org.apache.aries.proxy.impl/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy.impl [12]: Unable to resolve 12.0: missing requirement [12.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.proxy)(version=1.0.0)(!(version=1.1.0))) [caused by: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))]])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy.impl [12]: Unable to resolve 12.0: missing requirement [12.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.proxy)(version=1.0.0)(!(version=1.1.0))) [caused by: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))]]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.aries.blueprint.cm [13] Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint.cm/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint.cm [13]: Unable to resolve 13.0: missing requirement [13.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.blueprint)(version=1.0.0)(!(version=1.1.0))) [caused by: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint.cm [13]: Unable to resolve 13.0: missing requirement [13.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.blueprint)(version=1.0.0)(!(version=1.1.0))) [caused by: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.aries.blueprint.api [14] Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint.api/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint.api [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint.api [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.felix.gogo.runtime [15] Error starting mvn:org.apache.felix/org.apache.felix.gogo.runtime/0.11.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.gogo.runtime [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.3.0)(!(version=2.0.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.gogo.runtime [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.3.0)(!(version=2.0.0)))
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    4% [== ]ERROR: Bundle org.apache.karaf.shell.console [17] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console [17]: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console [17]: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.features.obr [18] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.obr/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.obr [18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.bundlerepository)(version=2.0.0)(!(version=3.0.0))) [caused by: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0)))])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.obr [18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.bundlerepository)(version=2.0.0)(!(version=3.0.0))) [caused by: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0)))]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.deployer.spring [19] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.spring/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.spring [19]: Unable to resolve 19.0: missing requirement [19.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.spring [19]: Unable to resolve 19.0: missing requirement [19.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.jaas.config [20] Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.config/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.config [20]: Unable to resolve 20.0: missing requirement [20.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.config [20]: Unable to resolve 20.0: missing requirement [20.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.deployer.blueprint [21] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.blueprint/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.blueprint [21]: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.blueprint [21]: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.features.core [22] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.core/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.core [22]: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.core [22]: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.admin.core [23] Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.core/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.core [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.core [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.management.server [24] Error starting mvn:org.apache.karaf.management/org.apache.karaf.management.server/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.management.server [24]: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.management.server [24]: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.shell.dev2 [25] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev2/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev2 [25]: Unable to resolve 25.0: missing requirement [25.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev2 [25]: Unable to resolve 25.0: missing requirement [25.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.features.command [26] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.command/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command [26]: Unable to resolve 26.0: missing requirement [26.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command [26]: Unable to resolve 26.0: missing requirement [26.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.jaas.modules [27] Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.modules/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.modules [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (osgi.wiring.package=javax.naming))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.modules [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (osgi.wiring.package=javax.naming)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.diagnostic.management [28] Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.management/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.management [28]: Unable to resolve 28.0: missing requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.management [28]: Unable to resolve 28.0: missing requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.deployer.wrap [29] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.wrap/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.sshd.core [30] Error starting mvn:org.apache.sshd/sshd-core/0.9.0 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.sshd.core [30]: Unable to resolve 30.0: missing requirement [30.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.sshd.core [30]: Unable to resolve 30.0: missing requirement [30.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.shell.osgi [31] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.osgi/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi [31]: Unable to resolve 31.0: missing requirement [31.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi [31]: Unable to resolve 31.0: missing requirement [31.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.diagnostic.command [32] Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.command/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.command [32]: Unable to resolve 32.0: missing requirement [32.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.gogo.commands)(version=0.11.0)(!(version=1.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.command [32]: Unable to resolve 32.0: missing requirement [32.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.gogo.commands)(version=0.11.0)(!(version=1.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.mina.core [33] Error starting mvn:org.apache.mina/mina-core/2.0.7 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.mina.core [33]: Unable to resolve 33.0: missing requirement [33.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.mina.core [33]: Unable to resolve 33.0: missing requirement [33.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.admin.management [34] Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.management/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management [34]: Unable to resolve 34.0: missing requirement [34.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management [34]: Unable to resolve 34.0: missing requirement [34.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.shell.commands [35] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.commands/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands [35]: Unable to resolve 35.0: missing requirement [35.0] osgi.wiring.package; ((osgi.wiring.package=jline)(version=2.11.0)(!(version=3.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands [35]: Unable to resolve 35.0: missing requirement [35.0] osgi.wiring.package; ((osgi.wiring.package=jline)(version=2.11.0)(!(version=3.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.deployer.features [36] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.features/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.features [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.features [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.jaas.command [37] Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command [37]: Unable to resolve 37.0: missing requirement [37.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command [37]: Unable to resolve 37.0: missing requirement [37.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.shell.packages [38] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages [38]: Unable to resolve 38.0: missing requirement [38.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.gogo.commands)(version=0.11.0)(!(version=1.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages [38]: Unable to resolve 38.0: missing requirement [38.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.gogo.commands)(version=0.11.0)(!(version=1.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.deployer.kar [39] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.kar/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.kar [39]: Unable to resolve 39.0: missing requirement [39.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.kar [39]: Unable to resolve 39.0: missing requirement [39.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.diagnostic.common [40] Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.common/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.common [40]: Unable to resolve 40.0: missing requirement [40.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.karaf.features)(version=2.3.0)(!(version=3.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.common [40]: Unable to resolve 40.0: missing requirement [40.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.karaf.features)(version=2.3.0)(!(version=3.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.shell.dev [41] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev [41]: Unable to resolve 41.0: missing requirement [41.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev [41]: Unable to resolve 41.0: missing requirement [41.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.shell.log [42] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.log/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log [42]: Unable to resolve 42.0: missing requirement [42.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.gogo.commands)(version=0.11.0)(!(version=1.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log [42]: Unable to resolve 42.0: missing requirement [42.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.gogo.commands)(version=0.11.0)(!(version=1.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    5% [=== ]ERROR: Bundle org.apache.karaf.admin.command [44] Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.command/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.command [44]: Unable to resolve 44.0: missing requirement [44.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.command [44]: Unable to resolve 44.0: missing requirement [44.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.aries.jmx.core [45] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.core/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [45]: Unable to resolve 45.0: missing requirement [45.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [45]: Unable to resolve 45.0: missing requirement [45.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.aries.jmx.blueprint.api [46] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.blueprint.api/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint.api [46]: Unable to resolve 46.0: missing requirement [46.0] osgi.wiring.package; (osgi.wiring.package=javax.management.openmbean))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint.api [46]: Unable to resolve 46.0: missing requirement [46.0] osgi.wiring.package; (osgi.wiring.package=javax.management.openmbean)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.aries.jmx.api [47] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.api/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.api [47]: Unable to resolve 47.0: missing requirement [47.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.api [47]: Unable to resolve 47.0: missing requirement [47.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.aries.jmx.blueprint.core [48] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.blueprint.core/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint.core [48]: Unable to resolve 48.0: missing requirement [48.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint.core [48]: Unable to resolve 48.0: missing requirement [48.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.shell.ssh [49] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.ssh/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.ssh [49]: Unable to resolve 49.0: missing requirement [49.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.ssh [49]: Unable to resolve 49.0: missing requirement [49.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.karaf.features.management [50] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.management/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management [50]: Unable to resolve 50.0: missing requirement [50.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management [50]: Unable to resolve 50.0: missing requirement [50.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    7% [===== ]ERROR: Bundle org.apache.commons.beanutils [52] Error starting mvn:commons-beanutils/commons-beanutils/1.8.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.commons.beanutils [52]: Unable to resolve 52.0: missing requirement [52.0] osgi.wiring.package; (osgi.wiring.package=org.apache.commons.logging) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.commons.beanutils [52]: Unable to resolve 52.0: missing requirement [52.0] osgi.wiring.package; (osgi.wiring.package=org.apache.commons.logging) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle io.fabric8.fabric-zookeeper [53] Error starting mvn:io.fabric8/fabric-zookeeper/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-zookeeper [53]: Unable to resolve 53.0: missing requirement [53.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-zookeeper [53]: Unable to resolve 53.0: missing requirement [53.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0)))
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle jackson-mapper-asl [54] Error starting mvn:org.codehaus.jackson/jackson-mapper-asl/1.9.12 (org.osgi.framework.BundleException: Unresolved constraint in bundle jackson-mapper-asl [54]: Unable to resolve 54.0: missing requirement [54.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.datatype))
    org.osgi.framework.BundleException: Unresolved constraint in bundle jackson-mapper-asl [54]: Unable to resolve 54.0: missing requirement [54.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.datatype)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    8% [===== ]ERROR: Bundle org.apache.servicemix.bundles.jasypt [56] Error starting mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.1_1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.jasypt [56]: Unable to resolve 56.0: missing requirement [56.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.jasypt [56]: Unable to resolve 56.0: missing requirement [56.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    11% [======= ]ERROR: Bundle org.fusesource.insight.insight-log [59] Error starting mvn:org.fusesource.insight/insight-log/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.fusesource.insight.insight-log [59]: Unable to resolve 59.0: missing requirement [59.0] osgi.wiring.package; (osgi.wiring.package=javax.management))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.fusesource.insight.insight-log [59]: Unable to resolve 59.0: missing requirement [59.0] osgi.wiring.package; (osgi.wiring.package=javax.management)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle io.fabric8.fabric-agent [60] Error starting mvn:io.fabric8/fabric-agent/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-agent [60]: Unable to resolve 60.0: missing requirement [60.0] osgi.wiring.package; ((osgi.wiring.package=io.fabric8.api)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-agent [60]: Unable to resolve 60.0: missing requirement [60.0] osgi.wiring.package; ((osgi.wiring.package=io.fabric8.api)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle scala-library [61] Error starting mvn:com.weiglewilczek.scala-lang-osgi/scala-library/2.9.1 (org.osgi.framework.BundleException: Unresolved constraint in bundle scala-library [61]: Unable to resolve 61.0: missing requirement [61.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle scala-library [61]: Unable to resolve 61.0: missing requirement [61.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle io.fabric8.fabric-api [62] Error starting mvn:io.fabric8/fabric-api/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-api [62]: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-api [62]: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle io.fabric8.fabric-boot-commands [63] Error starting mvn:io.fabric8/fabric-boot-commands/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-boot-commands [63]: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-boot-commands [63]: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0)))
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.apache.servicemix.bundles.jsch [64] Error starting mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jsch/0.1.49_1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.jsch [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.jsch [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle io.fabric8.fabric-core [65] Error starting mvn:io.fabric8/fabric-core/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0)))
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle io.fabric8.fabric-commands [66] Error starting mvn:io.fabric8/fabric-commands/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-commands [66]: Unable to resolve 66.0: missing requirement [66.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0))))
    org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-commands [66]: Unable to resolve 66.0: missing requirement [66.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0)))
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle io.fabric8.fabric-configadmin [67] Error starting mvn:io.fabric8/fabric-configadmin/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-configadmin [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; ((osgi.wiring.package=io.fabric8.api)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-configadmin [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; ((osgi.wiring.package=io.fabric8.api)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
    ERROR: Bundle org.jboss.fuse.esb-commands [68] Error starting mvn:org.jboss.fuse/esb-commands/6.1.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.jboss.fuse.esb-commands [68]: Unable to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.jboss.fuse.esb-commands [68]: Unable to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)

    Please let me know what I'm doing wrong ? Thanks

    DB:3.20:Fuseesb Doesn't Start On Macos X 10.10 With Jdk 8 38


    JBoss Fuse 6.1 requires Java 6 or 7.

    https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Fuse/6.1/html-single/Installation_Guide/

    The next release JBoss Fuse 6.2 requires Java 7 or 8.

  • RELEVANCY SCORE 3.18

    DB:3.18:Hope Its A Bug-Resource Bundle Problem- Not Able To Render Text In Uieditor zc


    Hai Friends,

    Am having a problem in using resource bundle. The following is the situation, am adding a Component(Say JButton) in jdeveloper using uieditor, if am specifying the text for JButton using resource bundle, the jbutton is visible in uieditor but the text on jbutton is not visible. its saying 'cannot create live instance for resource bundle', this is applicable to any component.

    its rendering it in the runtime. The string is taken from the '.properties' file using Resource Bundle, thats y its unable to create live instance to render it in design time.. am using Jdeveloper 9.0.5, The following is the code am using...

    Example:

    ResourceBundle jACResources = ResourceBundle.getBundle("Resources", Locale.English);

    public JButton Link_id = new JButton(jACResources.getString("link_id"));

    the string is taken from 'Resources.properties' file
    so, now it shows in runtime and but unable to render it in design time...
    Frank i hope i have discussed with u abt this...
    can u provide a solution for this,

    Friends,

    Can anyone help me in this?Have anyone tried this,pls post ur ideas regarding this. this will b more useful for me and also for u all.... Coz, most of the projects are multilingual..... tell me whether it can be done or this can be posted as a bug in jdeveloper......

    Thanx in advance....

    Ciya.

    DB:3.18:Hope Its A Bug-Resource Bundle Problem- Not Able To Render Text In Uieditor zc

    Hi,

    I am not sure if this is supposed to work in design time. For example, using resource bundles in web application projects and rendering a page in the visual editor (e.g. JSF) doesn't show either.

    The design time environment doesn't run the Swing file and thus doesn't lookup teh locale the developer is working in.

    Frank

  • RELEVANCY SCORE 3.16

    DB:3.16:An Error Has Occurred: Can't Find Resource For Bundle Java.Util.Propertyresourcebundle, Key Msg_Mybusines 8p



    Post Author: kmspsu93

    CA Forum: Administration

    Unable to determine why a single user (that we know of) receives the following message when clicking on the 'General' tab under Infoview preferences... An error has occurred: Can't find resource for bundle java.util.PropertyResourceBundle, key MSG_MYBUSINES All other tabs display fine. Unable to find any other user that experiences this. This error occurs when the same user logs on other PCs using their account...so it is not a PC config issue. Unable to see anything under permissions that would govern this. Any ideas would be great.

    DB:3.16:An Error Has Occurred: Can't Find Resource For Bundle Java.Util.Propertyresourcebundle, Key Msg_Mybusines 8p


    Post Author: kmspsu93

    CA Forum: Administration

    Unable to determine why a single user (that we know of) receives the following message when clicking on the 'General' tab under Infoview preferences... An error has occurred: Can't find resource for bundle java.util.PropertyResourceBundle, key MSG_MYBUSINES All other tabs display fine. Unable to find any other user that experiences this. This error occurs when the same user logs on other PCs using their account...so it is not a PC config issue. Unable to see anything under permissions that would govern this. Any ideas would be great.

  • RELEVANCY SCORE 3.16

    DB:3.16:How To Set Title Of Jsp Page From Resource Bundle s1


    hi ,
    How to set title of jsp page from resource bundle....

  • RELEVANCY SCORE 3.15

    DB:3.15:How To Overwrite The Groovyportlet Resource Bundle? km



    Hi,

    I tried to overwrite the locale.portlet.web.GroovyPortlet resource bundle as described here. Unfortunately, it does not work. Overwriting locale.portal.webui works fine.

    Regards,

    Joerg

    DB:3.15:How To Overwrite The Groovyportlet Resource Bundle? km


    I do not think GateIn supports to overwrite resource bundles of a portlet like that way.

    As the loading mechanism of resource bundles in a portlet is that the portlet's resource bundle will be detected first then to the portal's one.

  • RELEVANCY SCORE 3.14

    DB:3.14:Accessing Common Resource Bundle Problem 3z


    Hi,
    I have created a project for common resource bundles.
    I have added the created project to Model project throught Project Properties-Resource bundle-Bundle Search.

    Added labels to bundle for View Object.
    When I run the page, throwing the below error.

    java.util.MissingResourceException: unable to find bundle for:com.redsamurai.common.model.ModelCommonBundle

    com.redsamurai.common.model.ModelCommonBundle is bundle directory.

    Please help!

    Thanks,
    Vinod

    DB:3.14:Accessing Common Resource Bundle Problem 3z

    Thanks Pino.

    After adding the resource bundle to faces-config.xml, it worked.

    Thanks,
    Vinod

  • RELEVANCY SCORE 3.14

    DB:3.14:Resource Bundle Issue z8


    Hie

    I am on latest jdev 11g from otn.

    I have set the property of one resource bundle per file.

    Now i have a page called AskQuestion.jspx. In this defined a text using resource bundle.
    On running the page i get error:
    java.util.MissingResourceException: unable to find bundle for:oracle.apps.xteam.npe.view.AskQuestionBundle
    at oracle.javatools.resourcebundle.BundleFactory.getMap(BundleFactory.java:114)
    at oracle.javatools.resourcebundle.BundleFactory.getMap(BundleFactory.java:55)
    at oracle.javatools.resourcebundle.BundleVariableResolver$LocaleMap.get(BundleVariableResolver.java:69)
    at oracle.javatools.resourcebundle.BundleVariableResolver$LocaleMap.get(BundleVariableResolver.java:56)
    at javax.el.MapELResolver.getValue(MapELResolver.java:164)
    Truncated. see log file for complete stacktrace

    I have confirmed that there is file created by jdev at this location.

    In the source mode of the page i see something at the top:
    c:set var="viewcontrollerBundle"
    value="#{adfBundle['oracle.apps.xteam.npe.view.AskQuestionBundle']}"/

    and adfBundle mouseover shows a tooltip adfBundle is unknown variable.

    Any idea how to fix this?

    DB:3.14:Resource Bundle Issue z8

    anyone any updates on this please?

  • RELEVANCY SCORE 3.10

    DB:3.10:Working With .Resx File With Resource Bundle 38


    Hi All,
    I am working with resource bundle...
    so how to use .resx file with resource bundle instead of properties file that is used in resource bundle ??
    can anyone give me sample code to use .resx file in resource bundle??

    Thanks,
    Amita.

    DB:3.10:Working With .Resx File With Resource Bundle 38

    Hi All,
    I am working with resource bundle...
    so how to use .resx file with resource bundle instead of properties file that is used in resource bundle ??
    can anyone give me sample code to use .resx file in resource bundle??

    Thanks,
    Amita.

  • RELEVANCY SCORE 3.09

    DB:3.09:Resource Bundle For Different Language? x1


    Hi, all

    I prepared 2 resource bundle for my application (english and chinese). Now it come to me, which resource bundle will be used if this application run on japanese or france operation system? chinese or english? Can I choose one as default?

    Thanks,

    Vincent Chen

    DB:3.09:Resource Bundle For Different Language? x1

    Yes, as long as you don't have a server locale in the mix, then you are right, all other locales will fall back to the default bundle with these files.

  • RELEVANCY SCORE 3.09

    DB:3.09:Pom Settings For Jms Consumer Bundle a8



    Hi,

    I am trying to create an OSGI bundle that will consumer messages off a broker's queue.

    I used the servicemix-jms-provider-endpoint archetype to create a maven project in my eclipse but it could resolve a maven plugin

    Unable to get resource 'org.apache.servicemix.tooling:jbi-maven-plugin:pom:4.1.0-psc-01-00M2' from repository central (http://repo1.maven.org/maven2) Unable to locate resource in repository

    How do I resolve this?

    Is there an example showing how to use maven to setup jms endpoints?

    kr.

    DB:3.09:Pom Settings For Jms Consumer Bundle a8


    L.S.,

    That archetype references a version that should only have been used for internal purposes. Could you provide us with the build log from running the archetype or the command you were using to get this result so we can remove the archetype again from the public repositories?

    To get around this issue yourself, you can always try specifying the archetype version 2009.01.0.3-fuse explicitly (add -DarchetypeVersion=2009.01.0.3-fuse in the command)

    Regards,

    Gert

  • RELEVANCY SCORE 3.06

    DB:3.06:Adf 11g + View Controler Resource Bundle sf


    Hello,

    I see three option to create resource bundle in adf 11g.

    1. List Resource bundle
    2. properties file(default)

    3. Xliff Resource Bundle

    What is recommended way of creating the resource bundle comparing to XLiff vs Java resource bundle(properties or list) in ADF 11g??

    Regards,
    RB

    DB:3.06:Adf 11g + View Controler Resource Bundle sf

    Ravi,

    Any of them works fine, I guess. I personally have grown to prefer xliff, because there are xliff-based tools available for translators to use. I've used properties files in the past as well.

    John

  • RELEVANCY SCORE 3.06

    DB:3.06:Reg: Linking Resource Bundle With Jdeveloper. s1


    Hai All,

    Am having a problem in using resource bundle. If am adding a Component(Say JButton) in jdeveloper using uieditor, if am specifying the text using resource bundle, the jbutton is visible in uieditor but the text on jbutton is not visible. its saying 'cannot create live instance for resource bundle',
    this is applicable to any component can anyone suggest a solution for this.

    Thanking you in advance.

    DB:3.06:Reg: Linking Resource Bundle With Jdeveloper. s1

    Jdeveloper team(Visual Java editor) - anybody watching this?
    i have been waiting for the reply for the past 4 days, so
    Is anyone having suggestion, whether it will work or not? is there any additional feature for this? Every project is multilingual, not only my project, every project is supporting internationalization, so at design time it should support for resource bundle usage. am using Jdev 9.0.5 version, client side we are using swing, so i need a solution for this, does jdev supports this? if so whats d way? if it is not supporting y cant it be considered as a bug? it should be user friendly, so y this can be added as a new feature in the forthcoming version,

    waiting for ur suggestions, whatever it is juz explain,

    Thanking in advance...

  • RELEVANCY SCORE 3.06

    DB:3.06:How Do I Define ≪Resource-Bundle≫ In Faces-Config.Xml 8c


    On the web, I see several examples of defining a resource-bundle in faces-config.xml. They look like this:

    application
    resource-bundle
    base-namebundle.messages/base-name
    varmsg/var
    /resource-bundle
    /application

    But when I try to add a resource-bundle child to application in RAD 7.5, it tells me that resource-bundle isn't a valid child of application. I'm using ICE 1.8, which is based on jsf 1.2.

    Does anyone know what I'm missing?

    Thanks,
    Eli

    DB:3.06:How Do I Define ≪Resource-Bundle≫ In Faces-Config.Xml 8c

    Are you naming your resource bundles something like:

    1. messages_en.properties (for English)
    2. messages_de.properties (for German)

    and so on.

    Also, do you include these properties files in your final deployment package, because if they're not there then the messages won't be displayed.

  • RELEVANCY SCORE 3.06

    DB:3.06:How To Configure Resource Bundle File To Be Referenced By Managed Bean? 18


    I have a POJO class that access a properties file in its constructor:

    public ConveroTaskFlowsMapping() {
    resourceBundle = ResourceBundle.getBundle("com.myapp.MyMappings");
    }

    The POJO class is used mainly by managed session bean in the ViewController project. The "MyMappings.properties" was saved in the corresponding source path com/myapp.

    The application runs fine in integrated WLS.

    When I deployed the application to a standalone WLS 10.3.2, I got the following error when the bean tried to access the properties file:

    JspServlet error: Servlet unable to dispatch to the following requested page: The following exception occurred:javax.el.ELException: java.util.MissingResourceException: Can't find bundle for base name
    com.myapp.MyMappings, locale en_US

    I added the following to faces-config.xml, but didn't help to resolve the error

    resource-bundle
    base-namecom.myapp.MyMappings/base-name
    varmyMappings/var
    /resource-bundle

    What did I miss?

    DB:3.06:How To Configure Resource Bundle File To Be Referenced By Managed Bean? 18

    I tried your solution.

    It didn't work the first time with my old path like "com.myapp.viewcontroller.bean.MyMappings".

    When I changed the path to one level higher to "com.myapp.viewcontroller.MyMappings", it worked on both integrated WLS and standalone WLS... STRANGE....

    Anyway, it is working now. Thanks for your help!

    BTW, I learnt my lession not to use ResourceBundle.getBundle() in ViewController project....

    Edited by: Pricilla on May 26, 2010 12:33 PM

  • RELEVANCY SCORE 3.04

    DB:3.04:Accessing Resource Bundle In ≪H:Inputtext 88


    Hi,

    I am trying to dynamically populate the label attribute of h:inputText tag;

    h:inputText id="fullNameField" value="#{newUserFormBean.fullName}"
    label="#{resourceBundle.fullName}"
    f:validateLength minimum="3" maximum="64"/
    /h:inputTextWhen I validate this field i want to populate the error message with the value of label attribute from resource bundle. But it isn't showing up anything, but if i hard code the value of the label field, it displays that value. How do i resolve it?

    Thanks.

    Edited by: Mujju101 on Aug 29, 2010 10:26 PM

    Edited by: Mujju101 on Aug 29, 2010 10:26 PM

    DB:3.04:Accessing Resource Bundle In ≪H:Inputtext 88

    I want to make it work locale specific way, the label will be fetched from the locale and then will be displayed on the screen if any validation error pops up.

  • RELEVANCY SCORE 3.04

    DB:3.04:Internationialization And Rich:Calendar 9k



    hi,i want to use the rich:calendar component.i read in the documentation i could change the labels using application resource bundle. but which var name must be used?i defined

    application
    resource-bundle
    base-namemybundle/base-name
    varmsg/var
    /resource-bundle
    /application

    DB:3.04:Internationialization And Rich:Calendar 9k


    name shouldn't have any impact as long as you follow the "name_language.properties" pattern and declare it with "message-bundle" in your faces-config.xml.

  • RELEVANCY SCORE 3.03

    DB:3.03:Unable To Register Xlf As A Default Resource Bundle In Faces-Config.Xml xa


    Hi,

    When I try to make an XLF Bundle as Default in my Project properties --gt; Resource Bundle --gt; Default Project Bundle Name and register the same in faces-config.xml as below, I am getting an error "java.util.MissingResourceException: Can't find bundle for base name abc.def.ghi.TestingXLFBundle, locale e"

    The file TestingXLFBundle.xlf is present in Application Source under abc.def.ghi folder.

    lt;resource-bundlegt;
    lt;base-namegt;abc.def.ghi.TestingXLFBundlelt;/base-namegt;
    lt;vargt;bundlelt;/vargt;
    lt;/resource-bundlegt;

    Resource Bundle Properties:
    Resource Bundle Type: Xliff Resource Bundle
    Default Project Bundle Name: abc.def.ghi.TestingXLFBundle
    One Bundle per Project is selected in the options

    But the same is working fine with properties file with the below properties and TestingPropertiesBundle.properties

    Resource Bundle Type: Properties Bundle
    Default Project Bundle Name: abc.def.ghi.TestingPropertiesBundle
    One Bundle per Project is selected in the options.

    I am using JDEV Drop 5 Build 26.

    Thanks
    Raza

    Edited by: Raza Naqui on Dec 16, 2008 12:19 PM

    Edited by: Raza Naqui on Feb 9, 2009 5:48 PM

    Edited by: Raza Naqui on Feb 9, 2009 5:49 PM

    DB:3.03:Unable To Register Xlf As A Default Resource Bundle In Faces-Config.Xml xa

    Raza - did you ever find a resolution to this?? I'm having the same issue.

  • RELEVANCY SCORE 3.02

    DB:3.02:Issue While Applying Bundle Patch 11.1.1.3.8 18


    Hi Experts,We are facing issue after applying the bundle patch 11.1.1.3.8. We are unable to edit IT Resource and create/edit connectorafter appying Bundle Patch BP08 for oim 11.1.1.3.Below are the steps followed1.Click on manage IT Resource2.Click on edit for a specific it resource.3.Shows "A system error occured.Please contact your system administrator"The patch was applied for fixing email notification issue. Before appying this the mentioned functionalities were working as expected.Just wanted to check if anyone has faced this issue and what was done to resolve this.Thanks,Partha

  • RELEVANCY SCORE 3.02

    DB:3.02:Formatting Within Resource Bundle kp


    Hi,
    even though i know it's no good practice i was wondering whether it's possible to do some basic formatting (such as line breaks) within a resource bundle.
    thanks in advance

    DB:3.02:Formatting Within Resource Bundle kp

    No, that would be an issue with your program which is not specific to the application server it is running in.

  • RELEVANCY SCORE 3.01

    DB:3.01:Adding New Propery File On The Fly jm


    Hi,

    I am doing a web project.it already contains many resource bundle files for
    spanish,english.i want to create a new resource bundle for german,on the
    execution of my project.then from the next time that resource bundle should be
    added to the previous files.

    Thanx for any help in advance,
    Thirupathi

    DB:3.01:Adding New Propery File On The Fly jm

    If you place your property file in the same location as other property files, it should be available to new users when they run the application. Is that not working?

    --
    John O'Conner

  • RELEVANCY SCORE 3.00

    DB:3.00:Esx 3.5 U4: Unable To Apply Drs Resource Settings On Host (Reason: A General System Error Occurred: Invalid Fault). 11


    How do you resolve this?

    Unable to apply DRS resource settings on host (Reason: A general system error occurred: Invalid fault). This can significantly reduce the effectiveness of DRS.

    DB:3.00:Esx 3.5 U4: Unable To Apply Drs Resource Settings On Host (Reason: A General System Error Occurred: Invalid Fault). 11

    Verify that your Datastores and port groups are mapped identically.

    If you have the Cluster properl;y set up, run a health check script to conpare configuration:

    Plenty available online

    e.g.

    http://communities.vmware.com/blogs/virtuallysi/2009/04/02/esx-healthcheck-script-winner

    Fix any anomalies and try again

  • RELEVANCY SCORE 2.98

    DB:2.98:Pure As3 Project Unable To Resolve Resource Bundle j8



    I've been working on a pure AS3 project in Flash Builder and all has been going just fine. All of a sudden, I started getting errors such as:

    Unable to resolve resource bundle "core" for locale "en_US". Player Unknown Flex Problem

    What in the heck did I likely do? Any hints welcome.

    DB:2.98:Pure As3 Project Unable To Resolve Resource Bundle j8


    I've been working on a pure AS3 project in Flash Builder and all has been going just fine. All of a sudden, I started getting errors such as:

    Unable to resolve resource bundle "core" for locale "en_US". Player Unknown Flex Problem

    What in the heck did I likely do? Any hints welcome.

  • RELEVANCY SCORE 2.98

    DB:2.98:Plugin 1.3 Displays ?? Values When Chinese Characters Are Used pm


    Hi,
    I am developing an applet that displays the text based on the user's language. When, I am trying to display chinese characters through the use of
    resource bundle , I am unable to display it in the
    Text Area, Text Fields, i.e. Editable components with
    Sun Plugin 1.3. Non-Editable components like Labels, Button captions are all displaying chinese characters correctly thro' the use of resource bundle Unicode.
    I had tried converting the string to Unicode using the UTF8 encoding specified, but nothing works.

    regards
    siva

    DB:2.98:Plugin 1.3 Displays ?? Values When Chinese Characters Are Used pm

    Would you mind to give me the part for displaying chinese code??

  • RELEVANCY SCORE 2.97

    DB:2.97:Problem With Refresh Resource Bundle... xs


    Hi Iam refreshing the resource bundle. Iam using the following code:

    hsModelServiceProvider.getInstance().setFallbackBindingContainerEL("");
    JhsModelService jhsService = JhsModelServiceProvider.getInstance().getJhsModelService();
    System.out.print("UserId is :"+userId);
    jhsService.getTransaction().executeCommand("begin APP_USER_CTXT_mgr.set_user('"+userId+"');end;");
    System.out.print("after execute command");;
    // refresh resource bundle
    MethodBinding refreshBundles = FacesContext.getCurrentInstance().getApplication().createMethodBinding("#{nls.refreshBundles}",new Class[] { ActionEvent.class});
    refreshBundles.invoke(FacesContext.getCurrentInstance(),new Object[] {null});

    Iam gettin the following error Upon executing

    ERROR (MessageFactory) -Failed to refresh bundle oracle.jheadstart.exception.JhsUserMessages due to null

    Please help me..

    Thanx in Advance!

    DB:2.97:Problem With Refresh Resource Bundle... xs

    Hi Steven, this is the tutorial I found.

    http://technology.amis.nl/blog/?p=2547

  • RELEVANCY SCORE 2.97

    DB:2.97:Missing Resource Exception. 7a


    Was trying to Execute mail application and while deploying got this error.

    Can't find resource for Bundle org.openide.util.BnBundle$PBundle.........

    DB:2.97:Missing Resource Exception. 7a

    Was trying to Execute mail application and while deploying got this error.

    Can't find resource for Bundle org.openide.util.BnBundle$PBundle.........

  • RELEVANCY SCORE 2.97

    DB:2.97:Try Consumer On Playbook, But Error When Compile... 9m



    hai all, I have triedmessagingon SDK Playbook, when i compile appears error like this

    Error: Unable to resolve resource bundle "messaging" for locale "en_US".
    Error: Unable to resolve resource bundle "logging" for locale "en_US".
    Error: Unable to resolve resource bundle "collections" for locale "en_US".

    my code is :

    _consumer =newConsumer();
    _consumer.channelSet =newChannelSet();
    _consumer.channelSet.addChannel(_streamAMF);
    _consumer.destination ="RTStream";
    _consumer.selector ="Viewer='RT'"
    _consumer.addEventListener(MessageEvent.MESSAGE, onMessageHandler);
    _consumer.subscribe();

    anyone can help me?...
    Is Playbook SDK support Streaming?

    thanks before,

    tubagus







    Solved!
    Go to Solution.

    DB:2.97:Try Consumer On Playbook, But Error When Compile... 9m


    You can do this in a "cleaner" fashion by just adding a SWC folder (that points to that same directory) to your library path (right click on project Properties Flex Build Path Library Path (tab) Add SWC Folder...).

  • RELEVANCY SCORE 2.97

    DB:2.97:Resource Bundle Errors Freezing Up Application mz


    We have created a resource bundle file which holds error messages that we throw within the application. For example, if a user tries to enter duplicate information, we call something like this: throw new JhdJboException("JHD-00104");
    This displays the error from the resource bundle file in the information bar of the application just fine. However, it locks up the application and you are unable to navigate to other tabs. It appears that it just kills the application. The only thing that you can do is log out of the application. We want a way to display the errors we have defined for the user to see, but still allow them to navigate within the application without having to log out and log back in. If you need any additional information, please let me know. Any suggestions would be helpful. Thanks.

    Susan

    DB:2.97:Resource Bundle Errors Freezing Up Application mz

    Thanks for your help. It turns out that the message.js file wasn't in the project. Once I added it to the project, it worked like it was supposed to. Again, thanks.

    Susan

  • RELEVANCY SCORE 2.96

    DB:2.96:Textarea Usage ka



    Hi,

    I'm trying to do something similar to http://www.flashwonderland.com/control-components/​textarea.html

    but it's not working for me. I'm not sure what to import to get appendText() and I can get errors like this:

    Error: Unable to resolve resource bundle "core" for locale "en_US". Any assistance will be appreciated.

    Harry




    --------------Accepted PlayBook Applications: Marmi-doos, BASIC, Run and Hide, SuperClipAccepted OS4-7 SmartPhone App: KeepLightOn

    DB:2.96:Textarea Usage ka


    Hi,

    I see your comment on the MXML vs ActionScript thread and that is probably part of my problem as well. I've just started picking of the rudiments of ActionScript ( I prefer C first, assembly second, java third, all others last) and was trying to get it to work that way. in ActionScript, all I get is a blank screen.

    Thanks,

    Harry




    --------------Accepted PlayBook Applications: Marmi-doos, BASIC, Run and Hide, SuperClipAccepted OS4-7 SmartPhone App: KeepLightOn

  • RELEVANCY SCORE 2.96

    DB:2.96:Resource Bundle ds


    hallo
    i want to implement three languages in my java application ....
    how can i use the resource bundle .... can sombody give me an concrete example plz.?
    thanku

    DB:2.96:Resource Bundle ds

    http://icu.sourceforge.net/docs/papers/creating_global_applications/

  • RELEVANCY SCORE 2.94

    DB:2.94:Passing Resource Bundle Key To Outputtext I18n d8


    I have a dataTable with an outputText, the dataTable variable has a property which returns a resource bundle key. The following is what I am doing:

    h:dataTable
    id="menu"
    value="#{myBean.rowItems}"
    var="row"

    h:column
    h:outputLink value="#{row.link}"
    h:outputText value="#{bundle ['row.messageKey']}" /
    /h:outputLink
    /h:column

    /h:dataTableOf course, this doesn't work, because it looks for 'row.messageKey' in the resource bundle, instead I want it to resolve the row.messageKey expression and then look up the result in the resource bundle.

    What syntax must I use to acheive this?

    DB:2.94:Passing Resource Bundle Key To Outputtext I18n d8

    It was so obvious.....

    h:outputText value="#{msg [row.messageKey]}" /Sorry for the noise...

  • RELEVANCY SCORE 2.94

    DB:2.94:Using Resource Bundle - Oim 11g R2 sd


    Hi,We are trying to use resource bundle for e-mail notification, this resource bundle will be used with the notification event that we have created for sending notification using OIM 11g R2 Notification Service.We are getting missing resource bundle when the code hits .getbundle() method, it works fine in IDE though. It looks like there is some issue with class loader or something, we tried using the Upload Resource Bundle utility as well and also tried bundling the resource bundle within the jar. Both didnt work.any idea on how we can go about this ? Thanks

    DB:2.94:Using Resource Bundle - Oim 11g R2 sd

    Hi,We are trying to use resource bundle for e-mail notification, this resource bundle will be used with the notification event that we have created for sending notification using OIM 11g R2 Notification Service.We are getting missing resource bundle when the code hits .getbundle() method, it works fine in IDE though. It looks like there is some issue with class loader or something, we tried using the Upload Resource Bundle utility as well and also tried bundling the resource bundle within the jar. Both didnt work.any idea on how we can go about this ? Thanks

  • RELEVANCY SCORE 2.94

    DB:2.94:How To Set Title Of Jsp Page From Resource Bundle... 8j


    Hi,
    i have a doubt in How to set title of jsp page from resource bundle....

    DB:2.94:How To Set Title Of Jsp Page From Resource Bundle... 8j

    You can use JSTL .

    in your web.xml file add this:

    taglib
    taglib-urihttp://java.sun.com/jstl/fmt/taglib-uri

    taglib-location/WEB-INF/tld/fmt.tld/taglib-location
    /tagliband in your jsp you can set your title like this :

    %@ taglib uri="http://java.sun.com/jstl/fmt" prefix="fmt" %

    html
    head
    title
    fmt:setBundle basename="resource_name" /
    fmt:message key="your_title_message_key"/
    /title
    /head
    /html

  • RELEVANCY SCORE 2.94

    DB:2.94:How To Read Resource Bundle (One Bundle Per Project) kc


    Hi,

    I am working on JDev 11g 11.1.1.1.0

    I want to use Resource Bundle (one bundle per project) to store lable and validation message.

    How can I read bundle and get value from it.

    By EL expression, I can set lable (by configuring bundle in faces-config) from Resource Bundle but to display validation message I want to get the value by passing key in my backing bean.

    Regards,
    Devang

    DB:2.94:How To Read Resource Bundle (One Bundle Per Project) kc

    Hi,

    I am getting compilation error while compiling your ResourceHandler.

    It showing me an error in below method. Could not find method getBinding

    public static ResourceHandler getResourceHandler() {
    return (ResourceHandler)getBinding("#{res}").getValue(getFacesContext());

    }

    Pls let me know where you have declared it.

    Regards,
    Devang

  • RELEVANCY SCORE 2.94

    DB:2.94:Unable To Install Feature Activemq-Broker f9



    Hi

    I am using JBOSS-Fuse 6.0.0.redhat-030.

    Whilst installing feature activemq-broker, I am facing following issue.

    JBossFuse:karaf@root features:install -v activemq-broker

    Installing feature activemq-broker 5.8.0.redhat-60031

    Installing feature activemq 5.8.0.redhat-60031

    Installing feature jetty 7.6.7.v20120910

    Found installed bundle: org.eclipse.jetty.http [72]

    Found installed bundle: org.eclipse.jetty.servlet [73]

    Found installed bundle: org.eclipse.jetty.io [74]

    Found installed bundle: org.eclipse.jetty.security [75]

    Found installed bundle: org.eclipse.jetty.client [76]

    Found installed bundle: org.eclipse.jetty.server [77]

    Found installed bundle: org.eclipse.jetty.jndi [78]

    Found installed bundle: org.eclipse.jetty.continuation [79]

    Found installed bundle: org.eclipse.jetty.servlets [80]

    Found installed bundle: org.eclipse.jetty.webapp [81]

    Found installed bundle: org.eclipse.jetty.xml [82]

    Found installed bundle: org.eclipse.jetty.util [83]

    Found installed bundle: org.eclipse.jetty.websocket [84]

    Found installed bundle: org.eclipse.jetty.plus [85]

    Found installed bundle: org.eclipse.jetty.jmx [86]

    Installing feature activemq-client 5.8.0.redhat-60031

    Installing feature spring 3.1.4.RELEASE

    Found installed bundle: org.springframework.context [61]

    Found installed bundle: org.springframework.beans [62]

    Found installed bundle: org.springframework.context.support [63]

    Found installed bundle: org.springframework.expression [64]

    Found installed bundle: org.springframework.asm [65]

    Found installed bundle: org.springframework.core [66]

    Found installed bundle: org.springframework.aop [67]

    Installing bundle mvn:commons-pool/commons-pool/1.6

    Installing bundle mvn:commons-net/commons-net/3.2

    Installing bundle mvn:org.apache.activemq/activemq-osgi/5.8.0.redhat-60031

    Found installed bundle: org.apache.xbean.spring [130]

    Installing bundle mvn:org.apache.geronimo.specs/geronimo-j2ee-management_1.1_spec/1.0.1

    Installing bundle mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/1.1.1

    Error executing command: URL [mvn:org.scala-lang/scala-library/2.10.0] could not be resolved.

    I suspect this is a bug. But I couldn't find a jira location to raise this issue.

    DB:2.94:Unable To Install Feature Activemq-Broker f9


    Hi

    Thank you for your swift help.

    We are building an rpm which installs fuse. So we are looking for repository location from where maven can download and package the fuse.

  • RELEVANCY SCORE 2.94

    DB:2.94:Unable To Populate Label For Accessor Using Xliff/Properties File m8


    Hi All,I have a requirement ,where in I want to populate the label for an accessor from resource bundle ,but its not populating with the value for the key provided in the label .The portal bundle has following entry:CUST_ADD=Customer Addressand I'm using the below piece of code in the pagedef.xml to render Customer Address on the UI Accessors Item Value="custAddList" Label="#{adfBundle['PortalBundle']['CUST_ADD']}"/ /AccessorsBut it is giving following error on UI :STRINGMANAGER: Key: '#{adfBundle['PortalBundle']['CUST_ADD']}' not found in bundle 'oracle.javatools.resourcebundle.ResourceBundleRT'Can any one tell me how do we populate this label from resource bundle.Thanks,Garima

    DB:2.94:Unable To Populate Label For Accessor Using Xliff/Properties File m8

    Hi,I was able to fix the issue by providing the fully qualified path of the resource bundle as shown below:Accessors Item Value="custAddList" Label="#{adfBundle['portal.PortalBundle']['CUST_ADD']}"/ /AccessorsThanks all for help !!!!

  • RELEVANCY SCORE 2.94

    DB:2.94:Custom Resource Bundle Property Files 1a


    Can Anyone please help me understand what these resource bundle refers to?
    I know this is some thing related to the properties file but not able to understand exactly

    Thanks
    -Mahi

    DB:2.94:Custom Resource Bundle Property Files 1a

    I was talking more with respect to connector's resource bundles . They are only used for localization purpose .
    Localizing process form labels , look ups , response codes etc ...

    Thanks
    Suren

  • RELEVANCY SCORE 2.93

    DB:2.93:Oracle Database Connectivity In Osgi Bundle 9j



    I'm trying to connect oracle database using org.springframework.jdbc.core.JdbcTemplate in OSGI bundle. When deploying bundle, it shows error

    org.osgi.framework.BundleException: Unresolved constraint in bundle My Second Service : Unable to resolve 376.0: missing requirement package; (package=org.springframework.jdbc.core)

    I'm attaching my pom file of this service.

    DB:2.93:Oracle Database Connectivity In Osgi Bundle 9j


    Sorry for the late response.

    Did you get this working?

    If you are still in need for help, then feel free to get back with more details.

  • RELEVANCY SCORE 2.93

    DB:2.93:Unable To Load Main Bundle ps



    I am trying to download Adobe Acrobat Reader XI and I am receiving a message which says unable to load bundle. Does anyone have any suggestions on how to resolve this issue?

    DB:2.93:Unable To Load Main Bundle ps


    Well, what Mac are you on? What version of OSX? This error is indicative of your system not meeting the requirements for whatever reason. Double-check them on the product page.

    Mylenium

  • RELEVANCY SCORE 2.93

    DB:2.93:Get Specific Resource Bundle? dm


    Is there any neat way to get a specific resource bundle except for

    java.util.ResourceBundle svBundle = ResourceBundle.instance().getBundle("messages", new Locale("sv"));

  • RELEVANCY SCORE 2.93

    DB:2.93:How To Enumerate Keys In Resource Bundle? 33



    Is there any way to enumerate all the keys (but not the values) of resource bundle?

    DB:2.93:How To Enumerate Keys In Resource Bundle? 33

    If rb is a ResourceBundle, you can enumerate the keys and values in its 'content' property with the following code:

    for (var key:String in rb.content)
    {
    var value:* = rb.content[key];
    }

    Gordon Smith
    Adobe Flex SDK Team

  • RELEVANCY SCORE 2.93

    DB:2.93:Basic Question - "Deprecated" Reference k7



    Hey,

    I'm new (but learning) to flex programming. I just downloaded the Flex sample photo viewer code (http://www.adobe.com/devnet/flex/samples/photo_explorer/) but I'm having an issue. The code was written in FLex 2.0, but I'm running 3.0. I have a couple error messages:

    -Warning: 3608: 'getString' has been deprecated since 3.0. Please use 'ResourceManager.getInstance().getString()'

    -Error: Unable to resolve resource bundle "strings" for locale "en_US"

    I've played around with it but no luck. Any ideas?

    Take care,

    Colin

  • RELEVANCY SCORE 2.93

    DB:2.93:Osgi Uses Constraint Violation 91



    I try to start my bundle created by Maven in FUSE ESB OSGi container. But I got error with its three dependencies:

    1. libthrift-0.7.0.jar

    2. httpclient-4.0.1.jar

    3. httpcore-4.0.1.jar

    Error executing command: Error starting bundles:

    Unable to start bundle 262: Uses constraint violation. Unable to resolve bundle

    revision file__opt_FuseESBEnterprise-7.1.0_deploy_libthrift-0.7.0.jar

    because it is exposed to package 'org.apache.http' from bundle revisions

    org.apache.httpcomponents.httpcore and org.apache.httpcomponents.httpclient

    via two dependency chains.

    Chain 1:

    file__opt_FuseESBEnterprise-7.1.0_deploy_libthrift-0.7.0.jar

    import: (osgi.wiring.package=org.apache.http)

    export: osgi.wiring.package=org.apache.http

    org.apache.httpcomponents.httpcore

    Chain 2:

    file__opt_FuseESBEnterprise-7.1.0_deploy_libthrift-0.7.0.jar

    import: (osgi.wiring.package=org.apache.http.client)

    export: osgi.wiring.package=org.apache.http.client; uses:=org.apache.http

    export: osgi.wiring.package=org.apache.http

    org.apache.httpcomponents.httpclient

    DB:2.93:Osgi Uses Constraint Violation 91


    Thanks. I got another problem:

    Error executing command: Error starting bundles:

    Unable to start bundle 359: Uses constraint violation. Unable to resolve bundle revision slf4j.api because it exports package 'org.slf4j.spi' and is also exposed to it from bundle revision org.ops4j.pax.logging.pax-logging-api via the following dependency chain:

    slf4j.api

    import: ((osgi.wiring.package=org.slf4j.impl)(version=1.6.0))

    export: osgi.wiring.package=org.slf4j.impl; uses:=org.slf4j.spi

    ch.qos.logback.classic

    import: ((osgi.wiring.package=org.slf4j.spi)(version=1.6.0))

    export: osgi.wiring.package=org.slf4j.spi

    org.ops4j.pax.logging.pax-logging-api

    Is this a similar problem like the httpcore? Is there a osgi bundle for slf4j.api? I have been looking around and find out a bundle named osgi-over-slf4j under org.slf4j group.

  • RELEVANCY SCORE 2.93

    DB:2.93:Hi All.Query On Resource Selection Criteria kk



    While releasing a process order i am getting a error message stating "Resource xxxx in operation 0030 does not meet the resource selection condition" and hence unable to release the order.What does this mean.How to resolve this.

    Thanks in advance

    Edited by: lakshmana murthy shyamsundar on Jun 2, 2008 1:15 PM

    DB:2.93:Hi All.Query On Resource Selection Criteria kk


    Hy,

    In Master Recipe (As selected in Process order) go to Operation screen.Then selecte the Opration 0030 (or Superior operation of phase 0030) and go to Resorce selection creteria tab(available in the botom of the screen. I think some selection condition is maintain with the use of Work center class(019).

    Just remove this condition and save the recipe

    Then as I said in my earlier reply do read master data in preocess order and try to release the Order

    Regards,

    Dhaval

  • RELEVANCY SCORE 2.93

    DB:2.93:How To Programmatically Display Localized Information/ Error Message cj


    Dear gurus,

    I want to display the localized text for an information (or error) message whenever I press an 'update' button in my ADF page.
    Within the action method in my managed bean, I use the FacesContext.getCurrentInstance().addMessage() function but Iam unable to access the Resource Bundle ( a properties file) to get the resource string.

    I use the ADF Resource Bundle for my GUI and not a global one in faces_config.xml

    What is the ADF code or technique to access the resource string ?

    DB:2.93:How To Programmatically Display Localized Information/ Error Message cj

    Hi,
    Check
    http://jobinesh.blogspot.com/2010/06/accessing-resource-bundle-from.html

  • RELEVANCY SCORE 2.92

    DB:2.92:Regarding Registration Of Web Client Plugin Package In Vcenter Server 1f



    Hi,

    I was developing installer to register my plugin-package. Facing problems while including 3rd party jars.

    I have followed below steps from SDK tutorial.

    1. Adding 3rd party jar - jersey-client-1.17.jar to my project

    2. Included all jersey jars in plugins folder of package

    3. Added Bundle-SymbolicName of all jars in plugin-package.xml of package

    bundle id="com.sun.jersey.client" /

    bundle id="com.sun.jersey.core" /

    bundle id="com.sun.jersey.contribs.jersey-apache-client" /

    bundle id="com.sun.jersey.bundle" /

    bundle id="com.sun.jersey.json" /

    bundle id="com.sun.jersey.jersey-server" /

    4. These jars are added in lib of my service jar also

    5. In development set up, it is working fine. These jars are added in server/repository/usr folder of the machine.

    6. Bundle-ClassPath is not included in the manifest file of my service jar. The file is attached.

    Error while deploying the plugin package::

    [2014-09-05 00:58:23.549] [ERROR] Connection(9)-192.168.1.101 org.eclipse.virgo.medic.eventlog.default DE0002E Installation of bundle 'com.sun.jersey.client' version '1.17.0' failed. org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'com.sun.jersey.client' at version '1.17.0': Cannot resolve: com.sun.jersey.client

    Resolver report:

    An Import-Package could not be resolved. Resolver error data Import-Package: com.sun.jersey.core.spi.component; version="1.17.0". Caused by missing constraint in bundle com.sun.jersey.client_1.17.0

    constraint: Import-Package: com.sun.jersey.core.spi.component; version="1.17.0"

    I have many such 3rd party jars to be added in my project.

    Please tell me what I am missing.

  • RELEVANCY SCORE 2.92

    DB:2.92:Mxmlc Error: Unable To Resolve Resource Bundle X For Locale "En_Us" 7j



    Hi all,

    I'm getting this error trying to compile a Flex application using mxmlc.

    I could build the app some time ago using eclipse/Flex Builder 3 in Linux, since now FB3 doesn't work anymore

    and so I'm relying on an old fashioned Makefile/mxmlc build.

    This is my commandline and output:

    /opt/adobe/flex-builder-3.3/sdks/3.0.0/bin/mxmlc -strict -target-player 10.0.0 -incremental=true -library-path+=/opt/adobe/flex-builder-3.3/sdks/3.0.0/frameworks/libs -library-path+=/opt/adobe/flex-builder-3.3/sdks/3.0.0/frameworks/libs/flex.swc -library-path+=/opt/adobe/flex-builder-3.3/sdks/3.0.0/frameworks/libs/player -library-path+=../contrib/as3corelib/lib -library-path /opt/adobe/flex-builder-3.3/sdks/3.0.0/frameworks/libs/player/playerglobal.swc -library-path /opt/adobe/flex-builder-3.3/sdks/3.0.0/frameworks/libs/flex.swc -source-path+=../MyComponent/src -source-path+=/opt/adobe/flex-builder-3.3/sdks/3.0.0/frameworks/locale/en_US -locale=en_US -verbose-stacktraces -compiler.debug src/MyApp.mxml -output bin-debug/MyApp.swf

    Error: Unable to resolve resource bundle "core" for locale "en_US".

    Error: Unable to resolve resource bundle "core" for locale "en_US".

    Error: Unable to resolve resource bundle "core" for locale "en_US".

    Error: Unable to resolve resource bundle "skins" for locale "en_US".

    Error: Unable to resolve resource bundle "core" for locale "en_US".

    Error: Unable to resolve resource bundle "effects" for locale "en_US".

    Error: Unable to resolve resource bundle "core" for locale "en_US".

    Error: Unable to resolve resource bundle "containers" for locale "en_US".

    Error: Unable to resolve resource bundle "styles" for locale "en_US".

    Error: Unable to resolve resource bundle "controls" for locale "en_US".

    Error: Unable to resolve resource bundle "controls" for locale "en_US".

    Error: Unable to resolve resource bundle "controls" for locale "en_US".

    Error: Unable to resolve resource bundle "core" for locale "en_US".

    Error: Unable to resolve resource bundle "skins" for locale "en_US".

    make: *** [bin-debug/F2sClientStresser.swf] Error 13

    I couldn't find relevant information on the net, honestly I have no idea what these resource bundles are.

    I just can see these "controls/styles/effects/core/skins" things correspond to directories in:

    /opt/adobe/flex-builder-3.3/sdks/3.0.0/frameworks/projects/framework/src/mx

    but various random attempts at including them in the -source-path / -library-path failed to fix the problem for me, and now I need some directions.

    Can anybody help?

    Cheers.

    DB:2.92:Mxmlc Error: Unable To Resolve Resource Bundle X For Locale "En_Us" 7j


    4.5 years after your post, I just ran into the same issue with a new Idea ide project and it is all related to referencing xml files in the resource bundle.

    Your solution worked and it is building/packaging fine for en_US, for other locales, I include the full arg for "-locale=xxxx"...

    Thanks for the original post.

  • RELEVANCY SCORE 2.92

    DB:2.92:El-Resolve Bundle.Getstring For An Object 17


    I have a resource bundle with some properties like:hello=Hi #{user.firstname}On an xhtml page this resolves beautifully to 'Hi Daniel'. Getting the string from the resource bundle 'bundle.getString("hellp")', will not resolve for the #{user.firstname}, which is not surprising at all. Is there any way I can do something likeUser user = getUser();ELResolver.resolve(bundle.getString("hello"),user,anotherObject)which resolves the el expressions, given some objects, the same way the xhtml is resolved.Thanks!

    DB:2.92:El-Resolve Bundle.Getstring For An Object 17

    Ah, the interpolator does the trick, thanks!
    The example above is a dummy one. The actual system is a process system where you can do (just about) anything you can do with jBPM. But in this system, any user can add/modify/etc flows and what should happen in any task etc. Often a mail (defined by an administrator) is sent with text containing info about the particular task. Thats where 'Hi #manager, ... your #task.info is ready...'

  • RELEVANCY SCORE 2.92

    DB:2.92:Help On Ifs 12001 ds


    Hello,

    Can any one say me why, this error is comming during file upload.

    IFS-12001 Unable to obtain resource string from resource bundle
    (MULTI.PART.REQUEST.NEW.EXTERNEL.FILE)

    Here is what I'm trying to do.

    I developed a jsp which will upload a file into ifs using ifs api running in weblogic. While trying to upload a file im getting this error.

    DB:2.92:Help On Ifs 12001 ds

    Hello,

    Can any one say me why, this error is comming during file upload.

    IFS-12001 Unable to obtain resource string from resource bundle
    (MULTI.PART.REQUEST.NEW.EXTERNEL.FILE)

    Here is what I'm trying to do.

    I developed a jsp which will upload a file into ifs using ifs api running in weblogic. While trying to upload a file im getting this error.

  • RELEVANCY SCORE 2.91

    DB:2.91:Xerces: Disable Resource-Bundle Lookups? cp


    Hi,

    I am using xerces als library for an applet. Each time the applet is
    being started, there are multiple http-lookups for missing resources.

    I think that this is caused by the usual resource bundle mechanism.

    In order to prevent these unnecessary lookups, I'd like to know
    if there is

    * a way prevent resource bundle lookips for xerces

    or:

    * a resource bundle "implementation" for frequently used language
    codes

    Thank you

    DB:2.91:Xerces: Disable Resource-Bundle Lookups? cp

    Hi,

    I am using xerces als library for an applet. Each time the applet is
    being started, there are multiple http-lookups for missing resources.

    I think that this is caused by the usual resource bundle mechanism.

    In order to prevent these unnecessary lookups, I'd like to know
    if there is

    * a way prevent resource bundle lookips for xerces

    or:

    * a resource bundle "implementation" for frequently used language
    codes

    Thank you

  • RELEVANCY SCORE 2.91

    DB:2.91:Jboss Fuse Does Not Start ka



    Getting the following error when trying to start JBoss Fuse..any help will be appreciated.

    -------------

    Please wait while JBoss Fuse is loading...ERROR: Error parsing system bundle export statement: org.osgi.framework.startlevel;uses:="org.osgi.framework";version="1.0", org.osgi.framework.wiring;uses:="org.osgi.resource,org.osgi.framework";version="1.1", org.osgi.framework.hooks.bundle;uses:="org.osgi.framework";version="1.1", org.osgi.framework.hooks.service;uses:="org.osgi.framework";version="1.1", org.osgi.framework.hooks.resolver;uses:="org.osgi.framework.wiring";version="1.0", org.osgi.framework.launch;uses:="org.osgi.framework";version="1.1", org.osgi.framework.namespace;uses:="org.osgi.resource";version="1.0", org.osgi.framework;version="1.7",org.osgi.framework.hooks.weaving;uses:="org.osgi.framework.wiring";version="1.0",org.osgi.resource;version="1.0",org.osgi.service.url;version="1.0",org.osgi.service.startlevel;uses:="org.osgi.framework";version="1.1",org.osgi.service.packageadmin;uses:="org.osgi.framework";version="1.2",org.osgi.service.url;version="1.0", org.osgi.util.tracker;uses:="org.osgi.framework";version="1.5.1", org.apache.felix.framework.monitor;version="1.0", org.apache.karaf.jaas.boot;version="2.3.0.redhat-610379", org.apache.karaf.jaas.boot.principal;version="2.3.0.redhat-610379", org.apache.karaf.version;version="2.3.0.redhat-610379", org.apache.xalan.extensions; version="2.7.1", org.apache.xalan.xsltc.compiler; version="2.7.1", org.apache.xalan.xsltc.cmdline.getopt; version="2.7.1", org.apache.xalan.xsltc.util; version="2.7.1", org.apache.xalan.transformer; version="2.7.1", org.apache.xalan.xsltc.trax; version="2.7.1", org.apache.xalan.processor; version="2.7.1", org.apache.xalan.lib; version="2.7.1", org.apache.xalan.trace; version="2.7.1", org.apache.xalan.xsltc.compiler.util; version="2.7.1", org.apache.xalan.templates; version="2.7.1", org.apache.xalan.xsltc; version="2.7.1", org.apache.xalan.xsltc.runtime; version="2.7.1", org.apache.xalan; version="2.7.1", org.apache.xalan.xslt; version="2.7.1", org.apache.xalan.lib.sql; version="2.7.1", org.apache.xalan.xsltc.runtime.output; version="2.7.1", org.apache.xalan.xsltc.dom; version="2.7.1", org.apache.xalan.client; version="2.7.1", org.apache.xalan.xsltc.cmdline; version="2.7.1", org.apache.xalan.serialize; version="2.7.1", org.apache.xalan.res; version="2.7.1", org.apache.xml.dtm.ref; version="2.7.1", org.apache.xml.dtm; version="2.7.1", org.apache.xml.dtm.ref.sax2dtm; version="2.7.1", org.apache.xml.dtm.ref.dom2dtm; version="2.7.1", org.apache.xml.res; version="2.7.1", org.apache.xml.serializer.dom3; version="2.7.1", org.apache.xml.serializer; version="2.7.1", org.apache.xml.serializer.utils; version="2.7.1", org.apache.xml.utils.res; version="2.7.1", org.apache.xml.utils; version="2.7.1", org.apache.xpath.functions; version="2.7.1", org.apache.xpath.jaxp; version="2.7.1", org.apache.xpath.patterns; version="2.7.1", org.apache.xpath.objects; version="2.7.1", org.apache.xpath.res; version="2.7.1", org.apache.xpath; version="2.7.1", org.apache.xpath.axes; version="2.7.1", org.apache.xpath.compiler; version="2.7.1", org.apache.xpath.operations; version="2.7.1", org.apache.xpath.domapi; version="2.7.1", org.apache.html.dom; version="2.11.0", org.apache.wml.dom; version="2.11.0", org.apache.wml; version="2.11.0", org.apache.xerces.parsers; version="2.11.0", org.apache.xerces.impl.dtd.models; version="2.11.0", org.apache.xerces.xni.parser; version="2.11.0", org.apache.xerces.impl.dv.xs; version="2.11.0", org.apache.xerces.impl.xs.traversers; version="2.11.0", org.apache.xerces.util; version="2.11.0", org.apache.xerces.impl.dtd; version="2.11.0", org.apache.xerces.jaxp.validation; version="2.11.0", org.apache.xerces.dom3.as; version="2.11.0", org.apache.xerces.impl.dv; version="2.11.0", org.apache.xerces.jaxp; version="2.11.0", org.apache.xerces.jaxp.datatype; version="2.11.0", org.apache.xerces.impl.xpath.regex; version="2.11.0", org.apache.xerces.xni; version="2.11.0", org.apache.xerces.impl.msg; version="2.11.0", org.apache.xerces.impl.dv.util; version="2.11.0", org.apache.xerces.impl.xs.util; version="2.11.0", org.apache.xerces.dom; version="2.11.0", org.apache.xerces.dom.events; version="2.11.0", org.apache.xerces.impl.xs.opti; version="2.11.0", org.apache.xerces.impl; version="2.11.0", org.apache.xerces.xs; version="2.11.0", org.apache.xerces.impl.io; version="2.11.0", org.apache.xerces.xpointer; version="2.11.0", org.apache.xerces.impl.dv.dtd; version="2.11.0", org.apache.xerces.xinclude; version="2.11.0", org.apache.xerces.impl.xpath; version="2.11.0", org.apache.xerces.xs.datatypes; version="2.11.0", org.apache.xerces.impl.xs.identity; version="2.11.0", org.apache.xerces.impl.xs.models; version="2.11.0", org.apache.xerces.xni.grammars; version="2.11.0", org.apache.xerces.impl.xs; version="2.11.0", org.apache.xerces.impl.validation; version="2.11.0", org.apache.xml.serialize; version="2.11.0", ,org.apache.karaf.branding, com.sun.org.apache.xalan.internal.xsltc.trax, com.sun.org.apache.xerces.internal.dom, com.sun.org.apache.xerces.internal.jaxp, com.sun.org.apache.xerces.internal.xni, com.sun.jndi.ldap (org.osgi.framework.BundleException: Exported package names cannot be zero length.)ERROR: Bundle org.ops4j.pax.url.mvn [1] Error starting mvn:org.ops4j.pax.url/pax-url-mvn/1.3.7 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.mvn [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))ERROR: Bundle org.ops4j.pax.url.wrap [2] Error starting mvn:org.ops4j.pax.url/pax-url-wrap/1.3.7 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.wrap [2]: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))ERROR: Bundle org.ops4j.pax.logging.pax-logging-service [3] Error starting mvn:org.ops4j.pax.logging/pax-logging-service/1.7.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-service [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.ops4j.pax.logging.pax-logging-api [4] Error starting mvn:org.ops4j.pax.logging/pax-logging-api/1.7.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-api [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.apache.felix.bundlerepository [5] Error starting mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository [5]: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0))))ERROR: Bundle org.apache.felix.configadmin [6] Error starting mvn:org.apache.felix/org.apache.felix.configadmin/1.4.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.configadmin [6]: Unable to resolve 6.0: missing requirement [6.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth))ERROR: Bundle org.apache.felix.fileinstall [7] Error starting mvn:org.apache.felix/org.apache.felix.fileinstall/3.3.11.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.fileinstall [7]: Unable to resolve 7.0: missing requirement [7.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0))))ERROR: Bundle org.apache.aries.proxy.api [8] Error starting mvn:org.apache.aries.proxy/org.apache.aries.proxy.api/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy.api [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))])ERROR: Bundle org.apache.aries.blueprint.core [9] Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint.core/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint.core [9]: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace))

    1% [ ] 2% [= ]ERROR: Bundle org.apache.aries.util [11] Error starting mvn:org.apache.aries/org.apache.aries.util/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.util [11]: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0))))ERROR: Bundle org.apache.aries.proxy.impl [12] Error starting mvn:org.apache.aries.proxy/org.apache.aries.proxy.impl/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy.impl [12]: Unable to resolve 12.0: missing requirement [12.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.proxy)(version=1.0.0)(!(version=1.1.0))) [caused by: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))]])ERROR: Bundle org.apache.aries.blueprint.cm [13] Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint.cm/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint.cm [13]: Unable to resolve 13.0: missing requirement [13.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.blueprint)(version=1.0.0)(!(version=1.1.0))) [caused by: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)])ERROR: Bundle org.apache.aries.blueprint.api [14] Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint.api/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint.api [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0))))ERROR: Bundle org.apache.felix.gogo.runtime [15] Error starting mvn:org.apache.felix/org.apache.felix.gogo.runtime/0.11.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.gogo.runtime [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.3.0)(!(version=2.0.0))))

    4% [== ]ERROR: Bundle org.apache.karaf.shell.console [17] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console [17]: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth))ERROR: Bundle org.apache.karaf.features.obr [18] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.obr/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.obr [18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.bundlerepository)(version=2.0.0)(!(version=3.0.0))) [caused by: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.4.0)(!(version=2.0.0)))])ERROR: Bundle org.apache.karaf.deployer.spring [19] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.spring/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.spring [19]: Unable to resolve 19.0: missing requirement [19.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.apache.karaf.jaas.config [20] Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.config/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.config [20]: Unable to resolve 20.0: missing requirement [20.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))ERROR: Bundle org.apache.karaf.deployer.blueprint [21] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.blueprint/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.blueprint [21]: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.apache.karaf.features.core [22] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.core/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.core [22]: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.apache.karaf.admin.core [23] Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.core/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.core [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.karaf.management.server [24] Error starting mvn:org.apache.karaf.management/org.apache.karaf.management.server/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.management.server [24]: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.karaf.shell.dev2 [25] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev2/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev2 [25]: Unable to resolve 25.0: missing requirement [25.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.apache.karaf.features.command [26] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.command/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command [26]: Unable to resolve 26.0: missing requirement [26.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.karaf.jaas.modules [27] Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.modules/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.modules [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (osgi.wiring.package=javax.naming))ERROR: Bundle org.apache.karaf.diagnostic.management [28] Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.management/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.management [28]: Unable to resolve 28.0: missing requirement [28.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.karaf.deployer.wrap [29] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.wrap/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.apache.sshd.core [30] Error starting mvn:org.apache.sshd/sshd-core/0.9.0 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.sshd.core [30]: Unable to resolve 30.0: missing requirement [30.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto))ERROR: Bundle org.apache.karaf.shell.osgi [31] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.osgi/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi [31]: Unable to resolve 31.0: missing requirement [31.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.apache.karaf.diagnostic.command [32] Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.command/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.command [32]: Unable to resolve 32.0: missing requirement [32.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.gogo.commands)(version=0.11.0)(!(version=1.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)])ERROR: Bundle org.apache.mina.core [33] Error starting mvn:org.apache.mina/mina-core/2.0.7 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.mina.core [33]: Unable to resolve 33.0: missing requirement [33.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto))ERROR: Bundle org.apache.karaf.admin.management [34] Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.management/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management [34]: Unable to resolve 34.0: missing requirement [34.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.karaf.shell.commands [35] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.commands/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands [35]: Unable to resolve 35.0: missing requirement [35.0] osgi.wiring.package; ((osgi.wiring.package=jline)(version=2.11.0)(!(version=3.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)])ERROR: Bundle org.apache.karaf.deployer.features [36] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.features/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.features [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.apache.karaf.jaas.command [37] Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command [37]: Unable to resolve 37.0: missing requirement [37.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.karaf.shell.packages [38] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages [38]: Unable to resolve 38.0: missing requirement [38.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.gogo.commands)(version=0.11.0)(!(version=1.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)])ERROR: Bundle org.apache.karaf.deployer.kar [39] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.kar/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.kar [39]: Unable to resolve 39.0: missing requirement [39.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle org.apache.karaf.diagnostic.common [40] Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.common/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.common [40]: Unable to resolve 40.0: missing requirement [40.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.karaf.features)(version=2.3.0)(!(version=3.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])ERROR: Bundle org.apache.karaf.shell.dev [41] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev [41]: Unable to resolve 41.0: missing requirement [41.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))ERROR: Bundle org.apache.karaf.shell.log [42] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.log/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log [42]: Unable to resolve 42.0: missing requirement [42.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.felix.gogo.commands)(version=0.11.0)(!(version=1.0.0))) [caused by: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth)])

    5% [=== ]ERROR: Bundle org.apache.karaf.admin.command [44] Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.command/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.command [44]: Unable to resolve 44.0: missing requirement [44.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.aries.jmx.core [45] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.core/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core [45]: Unable to resolve 45.0: missing requirement [45.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.aries.jmx.blueprint.api [46] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.blueprint.api/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint.api [46]: Unable to resolve 46.0: missing requirement [46.0] osgi.wiring.package; (osgi.wiring.package=javax.management.openmbean))ERROR: Bundle org.apache.aries.jmx.api [47] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.api/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.api [47]: Unable to resolve 47.0: missing requirement [47.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.aries.jmx.blueprint.core [48] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.blueprint.core/1.0.1.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint.core [48]: Unable to resolve 48.0: missing requirement [48.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle org.apache.karaf.shell.ssh [49] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.ssh/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.ssh [49]: Unable to resolve 49.0: missing requirement [49.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth))ERROR: Bundle org.apache.karaf.features.management [50] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.management/2.3.0.redhat-610379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management [50]: Unable to resolve 50.0: missing requirement [50.0] osgi.wiring.package; (osgi.wiring.package=javax.management))

    7% [===== ]ERROR: Bundle org.apache.commons.beanutils [52] Error starting mvn:commons-beanutils/commons-beanutils/1.8.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.commons.beanutils [52]: Unable to resolve 52.0: missing requirement [52.0] osgi.wiring.package; (osgi.wiring.package=org.apache.commons.logging) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])ERROR: Bundle io.fabric8.fabric-zookeeper [53] Error starting mvn:io.fabric8/fabric-zookeeper/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-zookeeper [53]: Unable to resolve 53.0: missing requirement [53.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0))))ERROR: Bundle jackson-mapper-asl [54] Error starting mvn:org.codehaus.jackson/jackson-mapper-asl/1.9.12 (org.osgi.framework.BundleException: Unresolved constraint in bundle jackson-mapper-asl [54]: Unable to resolve 54.0: missing requirement [54.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.datatype))

    8% [===== ]ERROR: Bundle org.apache.servicemix.bundles.jasypt [56] Error starting mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.1_1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.jasypt [56]: Unable to resolve 56.0: missing requirement [56.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto))

    10% [======= ] 11% [======= ]ERROR: Bundle org.fusesource.insight.insight-log [59] Error starting mvn:org.fusesource.insight/insight-log/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.fusesource.insight.insight-log [59]: Unable to resolve 59.0: missing requirement [59.0] osgi.wiring.package; (osgi.wiring.package=javax.management))ERROR: Bundle io.fabric8.fabric-agent [60] Error starting mvn:io.fabric8/fabric-agent/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-agent [60]: Unable to resolve 60.0: missing requirement [60.0] osgi.wiring.package; ((osgi.wiring.package=io.fabric8.api)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])ERROR: Bundle scala-library [61] Error starting mvn:com.weiglewilczek.scala-lang-osgi/scala-library/2.9.1 (org.osgi.framework.BundleException: Unresolved constraint in bundle scala-library [61]: Unable to resolve 61.0: missing requirement [61.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle io.fabric8.fabric-api [62] Error starting mvn:io.fabric8/fabric-api/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-api [62]: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers))ERROR: Bundle io.fabric8.fabric-boot-commands [63] Error starting mvn:io.fabric8/fabric-boot-commands/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-boot-commands [63]: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0))))ERROR: Bundle org.apache.servicemix.bundles.jsch [64] Error starting mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jsch/0.1.49_1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.jsch [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto))ERROR: Bundle io.fabric8.fabric-core [65] Error starting mvn:io.fabric8/fabric-core/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0))))ERROR: Bundle io.fabric8.fabric-commands [66] Error starting mvn:io.fabric8/fabric-commands/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-commands [66]: Unable to resolve 66.0: missing requirement [66.0] osgi.wiring.package; ((osgi.wiring.package=com.google.common.base)(version=15.0.0)(!(version=16.0.0))))ERROR: Bundle io.fabric8.fabric-configadmin [67] Error starting mvn:io.fabric8/fabric-configadmin/1.0.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fabric-configadmin [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; ((osgi.wiring.package=io.fabric8.api)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])ERROR: Bundle org.jboss.fuse.esb-commands [68] Error starting mvn:org.jboss.fuse/esb-commands/6.1.0.redhat-379 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.jboss.fuse.esb-commands [68]: Unable to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth))

    DB:2.91:Jboss Fuse Does Not Start ka


    JBoss Fuse 6.1 requires Java 6 or 7.The next release JBoss Fuse 6.2 requires Java 7 or 8

  • RELEVANCY SCORE 2.91

    DB:2.91:Resource Bundle p3


    Where can I get the resource bundle properties file for the french language? Or do I have to create one myself?

    Thanks.

    gtata

    DB:2.91:Resource Bundle p3

    don't cross post
    http://forum.java.sun.com/thread.jsp?forum=33thread=542455

  • RELEVANCY SCORE 2.91

    DB:2.91:Path Of Resourcebundle Properties File In Autovue j3


    Hi,While creating new action in autovue have to create resource bundle properties file. Where is the default resource bundle properties file.Please let know the default path of default resource bundle properties file.

    DB:2.91:Path Of Resourcebundle Properties File In Autovue j3

    the resource bundle is the one you specifyby default, with all java code, the location is your codebase+package namefor more specific info please seeAPI Developer's Guidepage 2-7 or take a look at the VueActionSample that comes with your distribution

  • RELEVANCY SCORE 2.91

    DB:2.91:Bundleexception: Unable To Resolve Package; (Package=Org.Apache.Felix.Scr.Annotations) 9j



    Hi guys,

    My bundle is installed but not active:

    Got the following errors in my log:

    org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle (bundle ID=1246) : myservlet.bundle. Reason: org.osgi.framework.BundleException: Unresolved constraint in bundle myservlet.bundle [1246]: Unable to resolve 1246.0: missing requirement [1246.0] package; (package=org.apache.felix.scr.annotations). Will retry.

    org.apache.felix.scr.annotations is imported and included in the bnd file.

    In Felix console I get this:

    org.apache.felix.scr from org.apache.felix.scr (41)

    org.apache.felix.scr.annotations -- Cannot be resolved

    org.apache.felix.scr.annotations.sling -- Cannot be resolved

    org.apache.sling.api from org.apache.sling.api (92)

    org.apache.sling.api.resource from org.apache.sling.api (92)

    org.apache.sling.api.servlets from org.apache.sling.api (92)

    org.ietf.jgss from org.apache.felix.framework (0)

    org.osgi.framework from org.apache.felix.framework (0)

    org.slf4j from slf4j.api (11)

    org.w3c.dom from org.apache.felix.framework (0)

    org.xml.sax from org.apache.felix.framework (0)

    Just can't figure out what else need to be done to have org.apache.felix.scr.annotations resolved?

    Thanks!!!

    DB:2.91:Bundleexception: Unable To Resolve Package; (Package=Org.Apache.Felix.Scr.Annotations) 9j


    Hi guys,

    My bundle is installed but not active:

    Got the following errors in my log:

    org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle (bundle ID=1246) : myservlet.bundle. Reason: org.osgi.framework.BundleException: Unresolved constraint in bundle myservlet.bundle [1246]: Unable to resolve 1246.0: missing requirement [1246.0] package; (package=org.apache.felix.scr.annotations). Will retry.

    org.apache.felix.scr.annotations is imported and included in the bnd file.

    In Felix console I get this:

    org.apache.felix.scr from org.apache.felix.scr (41)

    org.apache.felix.scr.annotations -- Cannot be resolved

    org.apache.felix.scr.annotations.sling -- Cannot be resolved

    org.apache.sling.api from org.apache.sling.api (92)

    org.apache.sling.api.resource from org.apache.sling.api (92)

    org.apache.sling.api.servlets from org.apache.sling.api (92)

    org.ietf.jgss from org.apache.felix.framework (0)

    org.osgi.framework from org.apache.felix.framework (0)

    org.slf4j from slf4j.api (11)

    org.w3c.dom from org.apache.felix.framework (0)

    org.xml.sax from org.apache.felix.framework (0)

    Just can't figure out what else need to be done to have org.apache.felix.scr.annotations resolved?

    Thanks!!!

  • RELEVANCY SCORE 2.91

    DB:2.91:Resource Bundle Quot;Rft_Flexautomationquot; For Locale Quot;En_Us 87


    Hi,

    I have installed Flex Builder 3 and Rational Functional
    Tester 8.0.0 for automation of flex application.
    So i have executed following steps:-
    1. Start Flex Builder.
    2. Create a new Flex project.
    3. Select the Flex project in the navigator.
    4. Click Select Project Properties Flex Compiler.
    5. Enter the code shown in Listing 1 in the "Additional
    compiler arguments" field.

    Listing 1. Code for additional compiler arguments
    -Include-libraries "flex builder install dir\Flex SDK
    2
    \frameworks\libs\automation.swc" "flex builder install
    dir\Flex SDK 2
    \frameworks\libs\automation_agent.swc" "flex builder
    install dir\Flex SDK 2
    \frameworks\libs\automation_charts.swc" "functional
    tester dir
    \Functional Tester\bin\rft.swc"

    6. Click OK to save your changes.
    7. Click OK to close the Properties dialog box.
    8. Compile your Flex sample application.

    I am getting following error :-
    Unable to resolve resource bundle "rft_flexautomation" for
    locale "en_US"

    Please help me out to resolve this error

    Thanks,
    Samidha

    DB:2.91:Resource Bundle Quot;Rft_Flexautomationquot; For Locale Quot;En_Us 87

    Hi,

    I have installed Flex Builder 3 and Rational Functional
    Tester 8.0.0 for automation of flex application.
    So i have executed following steps:-
    1. Start Flex Builder.
    2. Create a new Flex project.
    3. Select the Flex project in the navigator.
    4. Click Select Project Properties Flex Compiler.
    5. Enter the code shown in Listing 1 in the "Additional
    compiler arguments" field.

    Listing 1. Code for additional compiler arguments
    -Include-libraries "flex builder install dir\Flex SDK
    2
    \frameworks\libs\automation.swc" "flex builder install
    dir\Flex SDK 2
    \frameworks\libs\automation_agent.swc" "flex builder
    install dir\Flex SDK 2
    \frameworks\libs\automation_charts.swc" "functional
    tester dir
    \Functional Tester\bin\rft.swc"

    6. Click OK to save your changes.
    7. Click OK to close the Properties dialog box.
    8. Compile your Flex sample application.

    I am getting following error :-
    Unable to resolve resource bundle "rft_flexautomation" for
    locale "en_US"

    Please help me out to resolve this error

    Thanks,
    Samidha

  • RELEVANCY SCORE 2.91

    DB:2.91:Resource Bundle For Detailed Navigation 17



    Hi All,

    I am trying to modify the text "Detailed Navigation".I was not able to find the Resource Bundle for that.can any one let me know the location for the resource Bundle for changing the Detailed navigation text.

    Thanks,

    sk

    DB:2.91:Resource Bundle For Detailed Navigation 17


    Hi,

    Up until now, there was no resource bundle for admin properties in a portal component. Properties were defined as component properties in the portalapp.xml (in english). Once you created an iView, you could then translate the properties in the PCD (for example, with translation worklist).

    This will change with an upcoming version -- perhaps 2004s SP14.

    Hope this helps and I understood your situation correctly.

    Daniel

  • RELEVANCY SCORE 2.91

    DB:2.91:Unable To Resolve Package Javax.Xml.Rpc 9k



    Hi All

    I have a web service on FUSE ESB which needs to invoke external web service (JasperServer). The external web service WSDL uses RPC/encoded.

    I generated proxy classes using jaxrpc.jar and trying to use the proxy from the web service on FUSE ESB. I have added a dependecy on jaxrpc,

    and also imported the package javax.xml.rpc.

    But when I deploy the web service bundle, the bundle does not start. On trying to explicitly start the bundle, I get an error as:

    Unresolved constraint in bundle runreport-service-interface-impl : Unable to resolve 339.0: missing requirement package; (package=javax.xml.rpc)

    Is there anything that I am missing?

    DB:2.91:Unable To Resolve Package Javax.Xml.Rpc 9k


    Thanks Freeman.

    I will open another thread as the subject of this thread is no longer valid for the issue that I am facing.

  • RELEVANCY SCORE 2.90

    DB:2.90:Jstl Setbundle Tag On Weblogic 8.1 Sp2 - How To Reload A Resource Bundle a8


    Hello,

    I have the following working example that load resource bundles using JSTL:

    Header.jsp has this:
    ...
    fmt:setBundle var="link" basename="resources.LinkResources" scope="session" /
    ..

    Phone.jsp has this:
    ... includes Header.jsp...
    fmt:message key="image.but_clickhere_on.gif.relative" bundle="${link}" /
    ...

    LinkResources.properties looks like this:
    image.but_clickhere_on.gif.relative=/site/en/generic/css/vm_css.css
    ...

    By default JSTL use the ResourceBundle java class to load the bundle. The issue with this example is the resource bundle "resources.LinkResources" is not reloaded when a change is made to the LinkResources.properties file.

    I am attempting to resolve this issue of reloading resource bundles by doing the following:

    1) in a Filter class set the 'link' attribute in the session so that every time a session starts the resource bundle is reloaded. Code is:

    InputStream in = this.getClass().getClassLoader().getResourceAsStream("resources/LinkResources.properties");
    PropertyResourceBundle lrb = new PropertyResourceBundle(in);
    session.setAttribute("link", lrb);

    2) remove from Header.jsp above the code:
    fmt:setBundle ...

    3) leave Phone.jsp unchanged

    I was expecting this to work. But the Phone.jsp page doesn't display. I thought the ${link} would find the attribute in session and use the 'lrb' resource bundle set up in the filter.

    Any suggestions would be appreciated as how to make this work or other approaches....Thanks in advance.

    CDS

    DB:2.90:Jstl Setbundle Tag On Weblogic 8.1 Sp2 - How To Reload A Resource Bundle a8

    Sorry forget to mention, the error mentions "${page}" because I do the same for another bundle attribute with value "${page}". I get the similar error for "${link}".

    javax.servlet.ServletException: An error occurred while evaluating custom action attribute "bundle" with value "${link}": Attempt to coerce a value of type "java.util.PropertyResourceBundle" to type "javax.servlet.jsp.jstl.fmt.LocalizationContext" (null)
    at weblogic.servlet.jsp.PageContextImpl.handlePageException(PageContextImpl.java:323)
    at jsp_servlet._web_45_inf._web._error.__error404._jspService(__error404.java:268)
    at weblogic.servlet.jsp.JspBase.service(JspBase.java:33)

  • RELEVANCY SCORE 2.90

    DB:2.90:Exception While Accessing Extension On Vcenter 5.5 Via Vsphere Web Client j1



    Hello

    I am running into the following problem on vCenter 5.5. This works on vcenter 5.1

    I have an extension that I have deployed successfully on vCenter 5.5.

    Next I used the vSphere web client to connect to the same vcenter server. I can see that my extension was downloaded to the vsphere serenity package location. However I do not see my extension (icon/menu) on the web client UI.

    When i check the vsphere log i see the following exception:

    [ERROR] P Connection(21)-9.11.66.134 org.eclipse.virgo.medic.eventlog.default
    DE0002E Installation of bundle bundle name version '1.0.0' failed. org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException:

    Unable to satisfy dependencies of bundle bundle name at version '1.0.0':

    Cannot resolve: bundle_name
    Resolver report: Uses violation: Import-Package: org.slf4j.impl; version="0.0.0" in bundle bundle_name Resolver reported uses conflict for import A Require-Bundle could not be resolved because of a uses directive conflict.
    Resolver error data Require-Bundle: ch.qos.logback.classic; bundle-version="[1.0.7,1.0.8)". Caused by missing constraint in bundle ch.qos.logback.slf4j_1.0.7.v20121108-1250

    constraint: Require-Bundle: ch.qos.logback.classic; bundle-version="[1.0.7,1.0.8)"

    Appreciate any help.

    Thanks

    liz

  • RELEVANCY SCORE 2.90

    DB:2.90:Java 1m


    What is resource bundle ?

  • RELEVANCY SCORE 2.88

    DB:2.88:Resource Bundle In Shared Library? 8a


    Is it possible to create a resource bundle in a shared library so you can use the same resource bundle in different application?
    We are creating different ADF application and each of them should use the same resource bundle.

    I tried creating a new project that only contains the resource bundle and then add this to my jspx page:

    c:set var="res"
    value="#{adfBundle['general.resources.generalBundle]}"/When i do this, he can't find any entries. When i change the project properties and configure to use a single bundle for the entire project, this works.
    How can i share a bundle so each application does not need to create or copy/paste the bundle?

    Is it possible to deploy the bundle as a shared library? Even if their is nothing else, not even a single java class?

    Edited by: Yannick.O on Jul 28, 2010 10:45 AM

    DB:2.88:Resource Bundle In Shared Library? 8a

    Try to create a JAR with the resource file in it (under /META-INF) and add it as a library in your project.
    If it does not work, try to create a faces-config.xml file inside that directory that declares the resource file.
    I think it gets merged at runtime with the config of your application and resource bundle should be available.

  • RELEVANCY SCORE 2.87

    DB:2.87:Resource Bundle 3z


    I wan to use resource bundle to control visible property in Navigation modle.

    Do I have to configure to use it this way?

    DB:2.87:Resource Bundle 3z

    I wan to use resource bundle to control visible property in Navigation modle.

    Do I have to configure to use it this way?

  • RELEVANCY SCORE 2.87

    DB:2.87:Unable To Load The Message Resources File 1x


    I have a very simple example of a JSF application Taken from page 127 of Core Java Server Faces (2nd edition) by David Geary. I decided to run the application under JDev to better understand the details.

    The problem I am running into is with loading the message resource bundle. In the faces-config.xml file I have:

    application
    resource-bundle
    base-namecom.corejsf.messages/base-name
    varmsgs/var
    /resource-bundle
    /application

    When I run the application none of the message resource bundle's information gets displayed on the .jsp. But, no errors are generated.

    Once I put the following line in the .jsp file:

    f:loadBundle basename="com.corejsf.messages" var="msgs"/

    the resource bundle's information is displayed correctly.

    Any idea why I had to place f:loadBundle line in my .jsp?

    Thanks,
    Matt

    DB:2.87:Unable To Load The Message Resources File 1x

    Hmm... does that mean that every .jsp needs the f:loadBundle statement?

    If so, why even bother to declared it in the faces-config file?

  • RELEVANCY SCORE 2.87

    DB:2.87:≪Message-Bundle≫ Vs ≪Resource-Bundle≫ 39


    Hi,

    I'm currently reading the spec for JSF 1.2 and find the description of when to use message-bundle and when to use resource-bundle a bit ambiguous. From what I can deduce you use message-bundle to define custom messages to be rendered with the h:message and h:messages tags and use resource-bundle for all other message bundles. I doubt this is 100% true so can anyone explain the differences and when to use message-bundle and resource-bundle and why there are 2 bundle tags?

    Thanks for your help.

    DB:2.87:≪Message-Bundle≫ Vs ≪Resource-Bundle≫ 39

    http://forum.java.sun.com/thread.jspa?threadID=677420messageID=9483204

    go through this link...

  • RELEVANCY SCORE 2.87

    DB:2.87:Re: Resourse Bundle And Properties File 8p


    go to project properties - Resource Bundle and specify the resource bundle name
    http://biemond.blogspot.com/2009/03/generate-resource-bundles-for-adf.html

    DB:2.87:Re: Resourse Bundle And Properties File 8p

    Hi friends
    I have created a ADf application of type "Genric application" now i want to add the resourse bundle i.e. properties file in it , I add it by right click -new- file and nme file as test.propeties and click ok the file (test.properties)is created in the Resourses folder .This Resourses folder is created automatically.When i try to access it in my .jspx file iam not able to access it and getting exception that resouse bundle not found.
    Is there any way to add the .properties file in my ADF genric application.

    Note in other application the "view" type of folder is created and we create the .properties file in that view node folder, but in my genric application this view node is not present .Is there any way to create that view node in my genrica application project

    Thanks and Regards
    Bipin patil

    Edited by: Bipin Patil on Aug 3, 2011 3:07 AM

  • RELEVANCY SCORE 2.87

    DB:2.87:Error Resolving Resource Bundle Quot;Stringsquot; c3


    Hi

    I'm trying to use Flex 3 to compile the Flex 2 PhotoViewer
    sample project, and encountered this error: 'Unable to resolve
    resource bundle "strings" for locale "en_US".'

    I found the Flex 2 TechNote which suggested to add
    "-use-network=false -library-path+=locale/{locale}
    -source-path+=locale/{locale} -locale=en_US" as compiler options.

    So I tried adding the above options into the build.bat files
    I can find at:
    a) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\samples\explorer
    b) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\templates\automation-runtimeloading-files
    but still the error persists.

    Can anyone please advise where I should change the compiler
    options? Thanks!

    Regards
    freshflex

    DB:2.87:Error Resolving Resource Bundle Quot;Stringsquot; c3

    Hi

    I'm trying to use Flex 3 to compile the Flex 2 PhotoViewer
    sample project, and encountered this error: 'Unable to resolve
    resource bundle "strings" for locale "en_US".'

    I found the Flex 2 TechNote which suggested to add
    "-use-network=false -library-path+=locale/{locale}
    -source-path+=locale/{locale} -locale=en_US" as compiler options.

    So I tried adding the above options into the build.bat files
    I can find at:
    a) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\samples\explorer
    b) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\templates\automation-runtimeloading-files
    but still the error persists.

    Can anyone please advise where I should change the compiler
    options? Thanks!

    Regards
    freshflex

  • RELEVANCY SCORE 2.87

    DB:2.87:Unable To Find Resource Errors j3


    Hi,
    I have 4 WSUS 3.0 SP1 servers. 3 of 4 are downstream servers. Not sure what happened recently, but the downstream servers are issues referencing content that does not appear to exist. I am getting the following errors on them:
    (Unable to Find Resource:) ServerSyncFileMissingFromUSS
    (Unable to Find Resource:) FileDigest: D00C326DDBAE8F193269C3593CE342EC21F449E4
    (Unable to Find Resource:) Updates:
    9851ba5f-3085-43ee-81b2-53568f613511/101

    (Unable to Find Resource:) ServerSyncFileMissingFromUSS
    (Unable to Find Resource:) FileDigest: 00BB21B1F216FF9C51A4A56096138FE0E48F84DD
    (Unable to Find Resource:) Updates:
    667bb651-5d38-4dd0-82d4-354073e44c24/101

    This started happening within the last week. Do I need to copy these folders over manually or how do I resolve? Thank you.

    DB:2.87:Unable To Find Resource Errors j3

    Thanks Lawrence for the suggestion. I think i have found the solution to our problem.
    When searched with the KB number in SUSDB.PUBLIC_VIEWS.vUpdate, found that there are 2 different revisions for update 100 and 102 where 102 is expired. The DSS server was trying to download the update with revision 102 which was in approved state. So Un
    Approved those and the error is not showing up. Even though we have selected the option Automatically decline updates when a new revision causes them to expire some updates released during October, November 2011 were not declined (Probably some internal
    server issue).
    used this query to identify the updates which are giving trouble.
    select
    distinct up.updateid,
    defaulttitle,
    securitybulletin from
    public_views.vupdate
    up
    inner
    join public_views.vupdateapproval
    upa on
    up.updateid
    = upa.updateid
    where
    publicationstate =
    'expired'
    and
    isdeclined = 0
    and
    action =
    'install'

    So we need to do a WSUS server cleanup after Un Approving those updates to completely remove those stale entries.

    Once again thank you for your valuable support on this.

    Regards, Rajul

  • RELEVANCY SCORE 2.86

    DB:2.86:Resource Bundles. 9z


    I am using resource bundle for storing some properties of application. But once in between the properties may change. This i need to transfer it back to the properties file. Once i transfer the changes, i again create bundle of this perticular resource. But i find that the resource budle has retained the old values.
    Can anyone help.

    DB:2.86:Resource Bundles. 9z

    I believe the resource bundle is loaded once, when you do the findResource or whatever. Have you tried explicitly reloading it?

  • RELEVANCY SCORE 2.86

    DB:2.86:Loading Resource Bundle From Database sc


    Hello,
    I would like JSTL's FMT tags to load the resource bundle from a database table instead of a properties table. Is that possible?
    Thanks in advance,
    Julien Martin.

    DB:2.86:Loading Resource Bundle From Database sc

    Hello,
    I would like JSTL's FMT tags to load the resource
    bundle from a database table instead of a properties
    table. Is that possible?
    Thanks in advance,
    Julien Martin.Sure, you would make a Subclass of either ResourceBundle or maybe easier, ListResourceBundle. Perhaps in the constructor, or in the getObject(key) or getContents() method (depending on which bundle you want) you would contact the DB, pull out the value(s), and return it/store them in an easily accessable manner, such as a Object[][] in the ListResourceBundle, or maybe a java.util.Map if you are using the general ResourceBundle.

  • RELEVANCY SCORE 2.86

    DB:2.86:Unable To Resolve Resource Bundle Quot;Stringsquot; For Locale Quot;En_Usquot; 7a


    Hi

    I'm trying to use Flex 3 to compile the Flex 2 PhotoViewer
    sample project, and encountered this error: Unable to resolve
    resource bundle "strings" for locale "en_US".

    I found the Flex 2 TechNote which suggested to add
    "-use-network=false -library-path+=locale/{locale}
    -source-path+=locale/{locale} -locale=en_US" as compiler options.

    So I tried adding the above options into the build.bat files
    I can find at:
    a) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\samples\explorer
    b) C:\Program Files\Adobe\Flex Builder
    3\sdks\3.1.0\templates\automation-runtimeloading-files
    but still the error persists.

    Can anyone please help? Thanks!

    Regards
    swinging

    DB:2.86:Unable To Resolve Resource Bundle Quot;Stringsquot; For Locale Quot;En_Usquot; 7a


    I jut saw the posting today.

    Place your local folder in application root

    In project properties : Flex Compiler Argument : additional compiler argument : -source-path ../locale/{locale}

    add this.

  • RELEVANCY SCORE 2.86

    DB:2.86:Issue Loading Dependent Bundle - Net.Sf.Json-Lib a3



    Hello there,

    We would like to go with FAB deployment. The project has been created as per FAB template (http://fusesource.com/docs/esbent/7.0/esb_deploy_osgi/BuildFab-Archetypes.html) and we have updated pom.xml with specific dependencies.lt;br

    Our code depends on net.sf.json-lib jar, which in turn depends on 3 other jars. All these jars are in local Maven Repository (downloaded via mvn install step in building the project).

    However, when application bundle is started we get the following error:

    -bash-4.1$ ./karaf

    Please wait while Fuse ESB is loading...

    ERROR: Bundle power-rs Error starting file:/dpz/usr/local/FuseESBEnterprise-7.0.0/deploy/power-rs.fab (org.osgi.framework.BundleException: Unresolved constraint in bundle power-rs : Unable to resolve 305.0: missing requirement osgi.wiring.package; ((osgi.wiring.package=net.sf.json)(version=2.4.0)(!(version=3.0.0))))

    org.osgi.framework.BundleException: Unresolved constraint in bundle power-rs : Unable to resolve 305.0: missing requirement osgi.wiring.package; ((osgi.wiring.package=net.sf.json)(version=2.4.0)(!(version=3.0.0)))

    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3903)

    at org.apache.felix.framework.Felix.startBundle(Felix.java:1890)

    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1213)

    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)

    at java.lang.Thread.run(Thread.java:662)

    This (http://thecarlhall.wordpress.com/2012/01/19/understanding-the-unresolved-constraint-missing-resource-message-from-apache-felix/) URL has a similar/related problem and solution documented.

    We don't come across the above error, if we install net.sf.json-lib manually in karaf console using "install -s mvn..." command.

    So the issue is with application bundle able to load its dependencies on start.

    Please advise what could be wrong here.

    Thank you,

    Ashok

    Edited by: amollin on Aug 15, 2012 1:45 PM

    Edited by: amollin on Aug 15, 2012 1:48 PM

    DB:2.86:Issue Loading Dependent Bundle - Net.Sf.Json-Lib a3


    Hello there,

    We would like to go with FAB deployment. The project has been created as per FAB template (http://fusesource.com/docs/esbent/7.0/esb_deploy_osgi/BuildFab-Archetypes.html) and we have updated pom.xml with specific dependencies.lt;br

    Our code depends on net.sf.json-lib jar, which in turn depends on 3 other jars. All these jars are in local Maven Repository (downloaded via mvn install step in building the project).

    However, when application bundle is started we get the following error:

    -bash-4.1$ ./karaf

    Please wait while Fuse ESB is loading...

    ERROR: Bundle power-rs Error starting file:/dpz/usr/local/FuseESBEnterprise-7.0.0/deploy/power-rs.fab (org.osgi.framework.BundleException: Unresolved constraint in bundle power-rs : Unable to resolve 305.0: missing requirement osgi.wiring.package; ((osgi.wiring.package=net.sf.json)(version=2.4.0)(!(version=3.0.0))))

    org.osgi.framework.BundleException: Unresolved constraint in bundle power-rs : Unable to resolve 305.0: missing requirement osgi.wiring.package; ((osgi.wiring.package=net.sf.json)(version=2.4.0)(!(version=3.0.0)))

    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3903)

    at org.apache.felix.framework.Felix.startBundle(Felix.java:1890)

    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1213)

    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)

    at java.lang.Thread.run(Thread.java:662)

    This (http://thecarlhall.wordpress.com/2012/01/19/understanding-the-unresolved-constraint-missing-resource-message-from-apache-felix/) URL has a similar/related problem and solution documented.

    We don't come across the above error, if we install net.sf.json-lib manually in karaf console using "install -s mvn..." command.

    So the issue is with application bundle able to load its dependencies on start.

    Please advise what could be wrong here.

    Thank you,

    Ashok

    Edited by: amollin on Aug 15, 2012 1:45 PM

    Edited by: amollin on Aug 15, 2012 1:48 PM

  • RELEVANCY SCORE 2.86

    DB:2.86:Hibernate And Datasource md



    Hello Folks,

    We have a web application which exposes some REST services. This app uses Hibernate and is working as expected in Jboss AS7 . However when we packaged this app as a OSGI bundle , we are having some issues getting the data source.

    It throws an exception

    java.lang.classcastexception: org.jboss.jca.adapters.jdbc.wrapperdatasource cannot be cast to javax.sql.datasource

    In web application we had resource references and hibernate configuration included name of the resource reference . However in OSGI bundle there is not such thing so we are directly using the JNDI name of the data source in hibernate configuration file .

    My understanding is the resource reference definition in web applkication specifies the resource type javax.sql.datasource and that could be taking care of conversion . But there is not such resource refernce for OSGI apps.

    Any thoughts what could be causing this isse and solution to resolve it ?

    Thanks

    Sunil

    DB:2.86:Hibernate And Datasource md


    I am also interested in this.

    As far as I know, Hibernate is not yet OSGiyfied so there will be problems when it comes to ClassLoading. Thats why I used EclipseLink within a Eclipse RCP for JPA. However, since AS 7 provides a OSGi-subsystem for web-bundles I expected some kind of integration. Is there a way to use Hibernate or would I have to leave the osgi-subsystem (calling an EJB for instance) which wrapps my data-access-logic?

    Thanks

  • RELEVANCY SCORE 2.86

    DB:2.86:Org.Slf4j.Impl Dependence Problem. 19



    Hi.

    In Apache-ServiceMix-4.4.1-fuse-01-13 from now when I start a bundle, I've :

    Error executing command: Unresolved constraint in bundle hermes-config : Unable to resolve 172.0: missing requirement package; ((package=org.slf4j.impl)(version=1.6.0)(!(version=2.0.0)))

    I do not remember having this problem. I always have had SLF4J in my dependencies

    Thank

    A+JYT

    DB:2.86:Org.Slf4j.Impl Dependence Problem. 19


    HI.

    I added a library that uses the code:

    import org.slf4j.impl.StaticLoggerBinder;

    ...

    logger = StaticLoggerBinder.getSingleton().getLoggerFactory().getLogger(classe.getName());

    whereas previously used it

    import org.slf4j.LoggerFactory;

    ...

    LoggerFactory.getLogger(classe.getName());

    I changed the call in the lib and it works well

    thank you

    A + JYT

  • RELEVANCY SCORE 2.86

    DB:2.86:Resource Bundle ss



    hi, I am using 5 locales in my application, In that each locale folder has 1 resource bundle (messages.properties file). It works fine on execution of the below thing. mxmlc -locale=en_US -source-path=src/locale/{locale} -include-resource-bundles=messages,SharedResources,collections,containers,controls,core,e ffects,formatters,skins,styles -output=src/locale/en_US/en_US_messages.swf mxmlc -locale=ja_JP -source-path=src/locale/{locale} -include-resource-bundles=messages,SharedResources,collections,containers,controls,core,e ffects,formatters,skins,styles -output=src/locale/ja_JP/ja_JP_messages.swf mxmlc -locale=en_FR -source-path=src/locale/{locale} -include-resource-bundles=messages,loginMessages,SharedResources,collections,containers,c ontrols,core,effects,formatters,skins,styles -output=src/locale/en_FR/en_FR_messages.swf Now im in need of using another one resource bundle called loginMessages.properties.So how do i use this.ie How to specify my application that im using in this resource bundle. I tried the below thing.I dont how to include that loginMessages.properties file in the resourcebundle. I tried like this mxmlc -locale=en_FR -source-path=src/locale/{locale} -include-resource-bundles=messages,loginMessages,SharedResources,collections,containers,c ontrols,core,effects,formatters,skins,styles -output=src/locale/en_FR/en_FR_messages.swf Error: Unable to resolve resource bundle "loginMessages" for locale "en_FR". Can you please say where I went wrong. Thanx a lot selva.

    DB:2.86:Resource Bundle ss


    What you have should work, as long as the file is there.

  • RELEVANCY SCORE 2.86

    DB:2.86:Supporting Multiple Message Bundle? f1



    Hi,Is it possible to have multiple message bundles within a Seam app? I would like to isolate licensee's information on a different resource file.I've tried the following and it failed:
    message-bundlemessages/message-bundle
    resource-bundle
    base-namebrokerage/base-name
    varbrokerage/var
    /resource-bundle

  • RELEVANCY SCORE 2.86

    DB:2.86:Unable To Refer To Custom Resource Bundle In Wpc Content Rendered With Xslt za



    Hi,

    I need to use the resource bundle messages inside WPC content.

    When rendered by standard xsl templates the call to XSLTHelper class is done to retrieve message from the standard SAP resource bundle com.sap.nw.wpc.bundles.core.properties, like this:

    xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
    xmlns:wpc="com.sap.nw.wpc.km.service.editor.hslt.XsltHelperCore"
    ......

    xsl:value-of select="wpc:getString([key defined in sap bundle], string(/document/@locale))"/

  • RELEVANCY SCORE 2.86

    DB:2.86:Binding Resource Bundle To Portlet 3d


    When i place resource bundle in my webroot resources folder,and i added the tag resource-bundle for my portlet.
    Its throwing exception can't find resources bundle exception.Anyone knows how to bundle resources to portlet.
    Please help me.

    DB:2.86:Binding Resource Bundle To Portlet 3d

    When i place resource bundle in my webroot resources folder,and i added the tag resource-bundle for my portlet.
    Its throwing exception can't find resources bundle exception.Anyone knows how to bundle resources to portlet.
    Please help me.