• RELEVANCY SCORE 5.52

    DB:5.52:Zend Problems With Php, Vbulletin, Etc?! kz







    Hello,

    I am trying to upgrade to 4.3.10 of PHP, however when I do so, it breaks vBulletin software. They are saying that this is because I have Zend installed. I am NOT running Zend outside of what Plesk is using, I did not install Zend seperatly. The Zend directory I have is /usr/local/psa/admin/include/php/Zend.

    It appears tobe language issues around the upgrade. In fact, my board looks like its in Hebrew, everything reads right to left.

    Any ideas, solutions?

    DB:5.52:Zend Problems With Php, Vbulletin, Etc?! kz




    Duh!!!!!!!!!

    Okay... that was stupid.

    Alright, via another thead I found out I was using ioncube or somethng like that and upgraded that and fixed my issue!

    Im CURRENT! yea!

  • RELEVANCY SCORE 3.69

    DB:3.69:Php Apc Vs Zend z9







    Does anyone know if APC is compatibly with Zend - I know that eAccelerator is not, only one of the two can be installed - and if so is there any benifit to using it over zend in a shared hosting?

    I know there are several benifits in a dedicated when one customer needs it for vbulletin or something, but Ive never used it in shared.

    DB:3.69:Php Apc Vs Zend z9




    The key issue is the loading order. Also if you use them as an extension or zend_extension. I dont recall off the top of my head the order but Ive setup boxes with both Eaccelerator and Zend.

    Also, you may want to take a look at Xcache.

    http://xcache.lighttpd.net/

    If this is for performance reasons on a busy site, I suggest some benchmarking and testing. I found Xcache to be 30% faster on one of our clients sites than Eaccelerator.

  • RELEVANCY SCORE 3.36

    DB:3.36:Reloaded Migration Problems sk







    Since i migrate from Plesk 7.0.2 to Reloaded with the migrations tool everything looks fine.

    But after i find some realy troubles.

    1.) I dont have permission acces in sub folders on domains.
    2.) Php applications like PHP nuke or online Shops from customers with PHP did not work.
    3.) I have a database PHP appilication with an online image gallery, now all of the pictures have a FX on it its like somebody edit it with Fotoshop, maby the zend optmizer make this?
    The database connections works fine no problems.

    Iam Using Plesk Reloaded 7.1.6
    PHP 4.3.4-11
    MySQL 3.23.58-9
    HTTPD 2.0.49-4
    Fedora Core 2.0

    PHP 4.3.4 (cgi) (built: Apr 7 2004 09:43:47)
    Copyright (c) 1997-2003 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies
    with the ionCube PHP Loader v2.4, Copyright (c) 2002-2003, by ionCube Ltd.

    Please somebody can help me???

    DB:3.36:Reloaded Migration Problems sk




    Since i migrate from Plesk 7.0.2 to Reloaded with the migrations tool everything looks fine.

    But after i find some realy troubles.

    1.) I dont have permission acces in sub folders on domains.
    2.) Php applications like PHP nuke or online Shops from customers with PHP did not work.
    3.) I have a database PHP appilication with an online image gallery, now all of the pictures have a FX on it its like somebody edit it with Fotoshop, maby the zend optmizer make this?
    The database connections works fine no problems.

    Iam Using Plesk Reloaded 7.1.6
    PHP 4.3.4-11
    MySQL 3.23.58-9
    HTTPD 2.0.49-4
    Fedora Core 2.0

    PHP 4.3.4 (cgi) (built: Apr 7 2004 09:43:47)
    Copyright (c) 1997-2003 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies
    with the ionCube PHP Loader v2.4, Copyright (c) 2002-2003, by ionCube Ltd.

    Please somebody can help me???

  • RELEVANCY SCORE 3.34

    DB:3.34:Php 5.3 Plesk Biling jj





    php 5.3 plesk billing

    Hi there.

    I have just realised that after updating to php 5.3, plesk billing is no longer working. To be more exact, zend optimizer does not seem to support php 5.3.

    My question is does plesk billing work with the replacement for zend optimiser, ie. Zend Guard and Zend Guard Loader or do I have to downgrade php to get it working again?

    DB:3.34:Php 5.3 Plesk Biling jj




    Ok as there has been no response I have decided to downgrade php. I,e remove psa src files including any php dependencies as well as any php files etc and then try reinstalling plesk and php while restricting access to update to the latest version of php.

    i.e.



    yum update php --exclude=php*5.3*

  • RELEVANCY SCORE 3.28

    DB:3.28:Ioncube Problems cp





    Well, I tried to upgrade to Plesk 8.0.0.

    That was as mistake!

    Im getting this in my apache error log:

    PHP Fatal error: [eAccelerator] eAccelerator 0.9.4-rc1 is incompatible with the ionCube PHP Loader 3.0.10 in Unknown on line 0

    Why is ionCube even being loaded, now, with Plesk 8? Why was this not even mentioned in any of the documentation for Plesk 8?

    Anyone know how to disable ionCube. Ive run across it before, and decided that it sucked extremely badly... Why would anyone chose ionCube over Zend?

    Anyway - my server is down, now, thanks to this!

    DB:3.28:Ioncube Problems cp







    Originally posted by Inaba
    Thats really wierd you dont have a php.d directory. Probably just a red hat/CentOS thing.

    Can you do a search for ioncube-loader.ini ?

  • RELEVANCY SCORE 3.24

    DB:3.24:How Does Plesk Panel Detect Php? jx





    Hello,

    How does Plesk Panel detect whether or not PHP is installed? Ive recently replaced the CentOS stock PHP packages with Zend Server. Alas, Plesk now thinks that PHP is not installed at all, which breaks the Webhosting settings in Plesk. PHP is working fine, though.

    Do I need to set a symlink to the non-standard location of the Zend PHP binaries? Or can I manually override the PHP detection by Plesk?

    Regards
    Ralph

    DB:3.24:How Does Plesk Panel Detect Php? jx




    Hello,

    How does Plesk Panel detect whether or not PHP is installed? Ive recently replaced the CentOS stock PHP packages with Zend Server. Alas, Plesk now thinks that PHP is not installed at all, which breaks the Webhosting settings in Plesk. PHP is working fine, though.

    Do I need to set a symlink to the non-standard location of the Zend PHP binaries? Or can I manually override the PHP detection by Plesk?

    Regards
    Ralph

  • RELEVANCY SCORE 3.20

    DB:3.20:Help """ Flex4 And Zend""" 38



    Hi

    i was setup FlashBuilder 4 and automatically Zend frame work installed .

    but when i try use data services PHP

    and make connection with database or import an php services file and try to

    load it

    this message appear :

    Some body help me about this problem

  • RELEVANCY SCORE 3.19

    DB:3.19:Upgrade To Php5 Issue 7f





    Im running CentOS4, Ive been following the installers to get PHP up to version 5.

    [root@ephraim etc]# php -v
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/dbase.so - /usr/lib/php4/dbase.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/dom.so - /usr/lib/php4/dom.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/gd.so - /usr/lib/php4/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/imap.so - /usr/lib/php4/imap.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/json.so - /usr/lib/php4/json.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/ldap.so - /usr/lib/php4/ldap.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/mbstring.so - /usr/lib/php4/mbstring.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/mysql.so - /usr/lib/php4/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/mysqli.so - /usr/lib/php4/mysqli.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/ncurses.so - /usr/lib/php4/ncurses.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/odbc.so - /usr/lib/php4/odbc.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/pdo.so - /usr/lib/php4/pdo.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/pdo_mysql.so - /usr/lib/php4/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/pdo_odbc.so - /usr/lib/php4/pdo_odbc.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/pdo_pgsql.so - /usr/lib/php4/pdo_pgsql.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/pdo_sqlite.so - /usr/lib/php4/pdo_sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/pgsql.so - /usr/lib/php4/pgsql.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/snmp.so - /usr/lib/php4/snmp.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/xmlreader.so - /usr/lib/php4/xmlreader.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/xmlrpc.so - /usr/lib/php4/xmlrpc.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/xmlwriter.so - /usr/lib/php4/xmlwriter.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/xsl.so - /usr/lib/php4/xsl.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php4/zip.so - /usr/lib/php4/zip.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning: Zend Optimizer for PHP 5.2.x cannot be found (expected at /usr/lib/Zend/Optimizer-2.5.10/php-5.2.x/ZendOptimizer.so) - try reinstalling the Zend Optimizer in Unknown on line 0
    PHP Warning: Zend Optimizer does not support this version of PHP - please upgrade to the latest version of Zend Optimizer in Unknown on line 0
    PHP 5.2.5 (cli) (built: Nov 20 2007 17:25:50)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Extension Manager v1.0.10, Copyright (c) 2003-2006, by Zend Technologies

    Im looking in Plesk and it says the proper module is installed:
    php 5.2.5-2.el4.art

    There is a /php directory (as opposed to php4) but changing it did not work. Any ideas? Ive used Plesk a little in the past, but Im making the move over from cPanel.

    Thanks!

    DB:3.19:Upgrade To Php5 Issue 7f




    That tells me that you didnt update your php.ini.

  • RELEVANCY SCORE 3.18

    DB:3.18:Upgrading Zend. 8z





    Hello All,

    So I have to upgrade my ZendOptimizer for a couple of php apps I have to work properly. I have re-installed Zend as per the documentation and then when It re-starts apache I cannot get to any of my websites. If I try to gracefully restart apache I get this error:

    (98)Address already in use: make_sock: could not bind to address [::]:443
    no listening sockets available, shutting down
    Unable to open logs

    Now If I comment out the following lines in my php.ini file I can restart everything fine. So what is wrong with the following Zend config?

    [Zend]
    zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.0.so
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.0.0
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.0.0
    zend_optimizer.version=3.0.0
    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

    Thanks for your time.

    DB:3.18:Upgrading Zend. 8z




    (98)Address already in use: make_sock: could not bind to address [::]:443
    no listening sockets available, shutting down
    Unable to open logs

    This only means that there are still processes running on port 443. You can see the processes using this command:

    lsof -i tcp:443

    You can than kill them, usually there are some left-over Apache processes running.

    The pid that crashes because of the Segmentation Fault is a child process of Apache, which means that you cant track it anymore because it died.

    You can check the following logfiles for more info:

    /var/log/message
    /var/log/httpd/error_log something like that

  • RELEVANCY SCORE 3.14

    DB:3.14:Php Accelerators sk





    Is anyone using any of the PHP accelerators with recent versions of PHP eg;
    PHP Accelorater is an open source php cacheing program. (Just like ZEND ACCELERATOR but free.) Zend Costs over a $1000.00 . Check it out here:
    http://www.php-accelerator.co.uk/

    But it is stated that it wont work with sites using the zend optimizer. How do we determine if customers are using the zend otimizer?

    Is anyone using Turck MMCache with recent versions of PHP?

    I havent seem much recent development in either of these accelerators and wonder what is going on.

    DB:3.14:Php Accelerators sk




    e-Accelerator

    php-accelerator isnt in active development anymore (they have the commercial ioncube one now). However, e-Accelerator is a fork of turck-mmcache started when the author went to work for zend. Its fixed a lot of the outstanding bugs as well as improved compatability with php 5. Its also hosted on sourceforge so you can easily get the latest cvs version if you have problems, the link is:

    http://eaccelerator.net/

    Ive been using it on one of our semi-dedicated servers (10 sites per server) with some rather heavy traffic clients on there (big bespoke php e-commerce and cms systems) and have seen 0 problems.

    As always though, YMMV.

  • RELEVANCY SCORE 3.04

    DB:3.04:Zend Optimizer On Fedora Core 2 / Plesk 7.5.2 9x





    Hi,

    Im thinking of installing the Zend Optimizer on my system (PHP 4.3.10 on Fedora Core 2 with Plesk 7.5.2) .

    Will this Zend Optimizer stuff break anything in Plesk ?
    Will it only modify the systems PHP and NOT the internal Plesk PHP version ?

    Please share your experiences on this with me.

    DB:3.04:Zend Optimizer On Fedora Core 2 / Plesk 7.5.2 9x




    It didnt break things on my servers, so go ahead !

    Groetjes,
    Bart

  • RELEVANCY SCORE 3.04

    DB:3.04:Upgrading Php 5.1 To 5.2 f1





    Is it possible to upgrade PHP on a system running Plesk 9.2 to a newer version like PHP 5.2 for use with vBulletin software which requires PHP 5.2 or above?

    Thanks,
    Daniel

    DB:3.04:Upgrading Php 5.1 To 5.2 f1




    You can skip mysql by

    yum update php* --exclude=mysql

  • RELEVANCY SCORE 3.04

    DB:3.04:Zend Guard In Php 5.3 7f





    Hello

    Currently I have installed the Zend Guard in PHP 5.3 on my server with Plesk 11, but he does not appear in phpinfo.

    What am I doing wrong?

    http://plesksrv.com/info.php

  • RELEVANCY SCORE 3.02

    DB:3.02:Upgraded Plesk 7.5.4 Update Broke Modernbill Php fk





    All,

    After upgrading the latest Plesk Patch (Didnt read release notes) PHP was upgraded to 4.4.1.

    This broke ModernBill as I needed to upgrade Zend to that next release to support the upgraded PHP.

    After I upgraded zend my PHP page only displays a blank page.

    Any advise would be helpful

    PHP 4.4.1 (cli) (built: Nov 12 2005 20:23:51)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with Zend Extension Manager v1.0.9, Copyright (c) 2003-2005, by Zend Technologies
    with Zend Optimizer v2.6.0, Copyright (c) 1998-2005, by Zend Technologies

    Thank You

    DB:3.02:Upgraded Plesk 7.5.4 Update Broke Modernbill Php fk




    Check your php.ini file PLESK usually overwrites this and you will also have to setup, a custom vhosts file for your main domain which has MB installed.

  • RELEVANCY SCORE 3.01

    DB:3.01:Php Missing After Installing Zend Server 7f





    Hello,

    Ive recently installed Zend Server 5, replacing the PHP provided by CentOS 5. Plesk works fine, but the Panel now thinks that PHP is missing. Consequently, certain options relating to PHP are now grayed out.

    How can I tell Plesk that PHP is actually installed?

    Regards
    Ralph

  • RELEVANCY SCORE 3.00

    DB:3.00:Zend Broke In Latest Psa Update? 1f





    Has anyone installed The Latest Zend Optimize with the Latest PSA build as of December with the php version upgrade?

    Ever since upgrading to that version I can not get Zend to work.

    I have tried everything for the exception of downgrading php ack to an earlier version.

    If anyone has had any trouble or success please advise.
    Any suggestions would be great.

    Thanks

    DB:3.00:Zend Broke In Latest Psa Update? 1f







    Originally posted by poscompo
    i see it is working now. what was the fix?

    thanks

  • RELEVANCY SCORE 3.00

    DB:3.00:Zendguardloader Doesnt Show In Results Of Phpinfo() j3





    Hello, guys!

    I have this configuration of my server:
    CentOS 5.6
    Plesk 10.X
    PHP 5.3.3 (as FastCGI for my current project with custom php.ini)
    Zend Guard Loader 3.3

    If I check php from a command line I see



    # php -v
    PHP 5.3.3 (cli) (built: Mar 30 2011 13:51:54)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.7, Copyright (c) 2002-2011, by ionCube Ltd., and
    with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

    DB:3.00:Zendguardloader Doesnt Show In Results Of Phpinfo() j3




    Hello, guys!

    I have this configuration of my server:
    CentOS 5.6
    Plesk 10.X
    PHP 5.3.3 (as FastCGI for my current project with custom php.ini)
    Zend Guard Loader 3.3

    If I check php from a command line I see



    # php -v
    PHP 5.3.3 (cli) (built: Mar 30 2011 13:51:54)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.7, Copyright (c) 2002-2011, by ionCube Ltd., and
    with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

  • RELEVANCY SCORE 2.95

    DB:2.95:Php.Ini Wrong Location. fz





    My configuration file path (php.ini) is /usr/local/Zend/etc/php.ini I want to change it to /usr/local/psa/apache/conf/php.ini Which file do I have to edit?

    Thanks

    I want to completely remove Zend and try again... do I just rm -rf all Zend things?

    DB:2.95:Php.Ini Wrong Location. fz




    Ive never played with Zend to be honest, I was just hoping that it was an rpm.
    Im sure that they have uninstall instructions.

  • RELEVANCY SCORE 2.95

    DB:2.95:How To Track Down Php Service Fault xs


    I have a small FlashBuilder4 project that runs fine on my local computer under Apache, PHP and MySQL.The first thing it does is populate a DataGrid with data from a MySQL table (the grid's creationcomplete event triggers a PHP service call and has its dataprovider hooked to the callresponder's lastresult property).As is often the case, I'm having trouble deploying the project to a remote, hosted server. I have uploaded the Zend framework, the release build, transferred my tables to the remote server, set the paths, etc. After several initial problems I believe I've got the ini file and everything else set up correctly (if I browse to my gateway.php and open it in notepad I get "Zend endpoint" with no errors). I have entered the credentials in each php service file. However, when I browse to the html wrapper page the grid displays fine but the phpservice call is apparently generating a fault. Unfortunately, there is no error information returned by the fault; i.e. the Alert box is blank.Can anyone suggest a methodical way of trying to track down what is going on?Thanks in advance.

    DB:2.95:How To Track Down Php Service Fault xs

    I have a small FlashBuilder4 project that runs fine on my local computer under Apache, PHP and MySQL.The first thing it does is populate a DataGrid with data from a MySQL table (the grid's creationcomplete event triggers a PHP service call and has its dataprovider hooked to the callresponder's lastresult property).As is often the case, I'm having trouble deploying the project to a remote, hosted server. I have uploaded the Zend framework, the release build, transferred my tables to the remote server, set the paths, etc. After several initial problems I believe I've got the ini file and everything else set up correctly (if I browse to my gateway.php and open it in notepad I get "Zend endpoint" with no errors). I have entered the credentials in each php service file. However, when I browse to the html wrapper page the grid displays fine but the phpservice call is apparently generating a fault. Unfortunately, there is no error information returned by the fault; i.e. the Alert box is blank.Can anyone suggest a methodical way of trying to track down what is going on?Thanks in advance.

  • RELEVANCY SCORE 2.95

    DB:2.95:After Upgrade No Backend Login White Out fa





    Error Log
    is Use parallels_installer_v3.11.0_build111102.17_os_CentOS_5_x86_64 to fix the Problems but no effect
    -------------------------------------------------------------
    2012-09-20 22:17:38: (server.c.1266) [note] graceful shutdown started
    2012-09-20 22:17:39: (log.c.135) server stopped
    2012-09-20 22:17:39: (log.c.75) server started
    2012-09-20 22:17:48: (mod_fastcgi.c.2582) FastCGI-stderr: PHP Fatal error: Call to undefined function db_connect() in /usr/local/psa/admin/smb/application/library/Smb/Plesk/Connection.php on line 19

    2012-09-20 22:17:52: (mod_fastcgi.c.2582) FastCGI-stderr: PHP Fatal error: Call to undefined function db_connect() in /usr/local/psa/admin/smb/application/library/Smb/Plesk/Connection.php on line 19

    all children busy, launch additional (total 3, limit 30)
    2012-09-20 22:49:33: (mod_fastcgi.c.2582) FastCGI-stderr: PHP Fatal error: Call to undefined function db_connect() in /usr/local/psa/admin/smb/application/library/Smb/Plesk/Connection.php on line 19

    2012-09-20 22:49:33: (mod_fastcgi.c.2582) FastCGI-stderr: PHP Fatal error: Uncaught exception Zend_Db_Statement_Exception with message SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction in /usr/local/psa/admin/smb/application/externals/Zend/Db/Statement/Pdo.php:238
    Stack trace:
    #0 /usr/local/psa/admin/smb/application/externals/Zend/Db/Statement.php(283): Zend_Db_Statement_Pdo-_execute(Array)
    #1 /usr/local/psa/admin/smb/application/externals/Zend/Db/Adapter/Abstract.php(433): Zend_Db_Statement-execute(Array)
    #2 /usr/local/psa/admin/smb/application/externals/Zend/Db/Adapter/Pdo/Abstract.php(230): Zend_Db_Adapter_Abstract-query(INSERT INTO `sm..., Array)
    #3 /usr/local/psa/admin/smb/application/externals/Zend/Db/Adapter/Abstract.php(511): Zend_Db_Adapter_Pdo_Abstract-query(INSERT INTO `sm..., Array)
    #4 /usr/local/psa/admin/smb/application/externals/Zend/Db/Table/Abstract.php(924): Zend_Db_Adapter_Abstract-insert(smb_sessions, Array)
    #5 /usr/local/psa/admin/smb/application/library/Smb/Session/SaveHandler/DbTable. in /usr/local/psa/admin/smb/application/externals/Zend/Db/Statement/Pdo.php on line 238

    2012-09-20 22:49:33: (mod_fastcgi.c.2582) FastCGI-stderr: PHP Fatal error: Call to undefined function db_connect() in /usr/local/psa/admin/smb/application/library/Smb/Plesk/Connection.php on line 19

    DB:2.95:After Upgrade No Backend Login White Out fa




    Well. You have Parallels Small Business Panel installed but not Plesk. Now you can use only migration but not upgrade - http://kb.parallels.com/113506

  • RELEVANCY SCORE 2.93

    DB:2.93:Fileinfo.So And Zip.So Modules Issues In Php 5.3.3 With Plesk 9f





    I keep getting the following error message on one of my Plesk machines running 11.0.9



    # php -v
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib64/php/modules/fileinfo.so - /usr/lib64/php/modules/fileinfo.so: undefined symbol: zval_property_ctor in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib64/php/modules/zip.so - /usr/lib64/php/modules/zip.so: undefined symbol: zval_property_ctor in Unknown on line 0
    PHP Warning: Directive safe_mode is deprecated in PHP 5.3 and greater in Unknown on line 0
    PHP 5.3.3 (cli) (built: Jun 27 2012 12:25:48)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.14, Copyright (c) 2002-2011, by ionCube Ltd.

    DB:2.93:Fileinfo.So And Zip.So Modules Issues In Php 5.3.3 With Plesk 9f




    Uf, no, it does not work neither.

    yum install yum-utils: OK

    yumdownloader php-zip: No Match for argument php-zip
    yumdownloader php-fileinfo

    rpm -Uvh --force php-zip.***.rpm error: File not found by glob: php-zip.***.rpm
    rpm -Uvh --force php-fileinfo***.prm

    Thanks again!

  • RELEVANCY SCORE 2.93

    DB:2.93:Modernbill (Zend) Not Working With Php jz





    Hello,
    I am running Plesk 5.0 and recently bought and installed Modern Bill. I also installed curl and the needed modules but when I go to the index.php page that is zend optimized, I get a bunch of funny chars. Like Below,

    Zend 20001120021254713081xù Ÿ2 ½[Ão·ß:÷`Dy0ú}P¦’—ßÃBáJ[@i7Ašöp¾ÛH[èîâ€

    Php has zend as it shows,

    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v1.2.0, Copyright (c) 1998-2002 Zend Technologies

    But the pages just wont load. You can see the output here to see what is happening.

    https://secure.sitehostz.com

    Any help would be appreciated.

    Chris

    DB:2.93:Modernbill (Zend) Not Working With Php jz




    Thanks

    Hello,
    After I made the post, I realized that the optimizer wasnt working. Then when I got snooping around, I realized it wasnt there. I installed it and everything was find.

    Thanks for the help.
    Chris

  • RELEVANCY SCORE 2.92

    DB:2.92:Update To 11.0.9 Destroy Zend Guard Loader d8





    Hello,

    I had Zend Guard Loader installed over Plesk 10.4.4. When I updated to 11.0.9 Zend Guard Loader stop to work.

    I found two changes:

    1.- Lines I added on php.ini for Zend Guard loader was commented:

    [Zend.loader]
    ;zend_extension=/usr/local/lib/zend/ZendGuardLoader.so
    ;zend_extension=/usr/lib/php5/20090626/ioncube_loader_lin_5.3.so
    ;zend_extension=/usr/local/lib/ioncube/ioncube_loader_lin_5.3.so
    ;zend_optimizer.optimization_level=15
    ;zend_loader.enable=1
    ;zend_loader.disable_licensing=0
    ;zend_loader.obfuscation_level_support=3
    ;zend_loader.license_path =

    2.- Found a file called zend_extensions_psa.ini on /etc/php5/conf.d with this content:

    ; Following directives were moved from php.ini files by Plesk to avoid load order errors
    ; Please do not add any zend_extension* or extension directives directly into php.ini

    If I add the line:

    zend_extension=/usr/local/lib/zend/ZendGuardLoader.so

    to:

    00-ioncube-loader-5.3.ini under etc/php5/conf.d and restart apache:

    root@xxx:/etc/php5/conf.d# /etc/init.d/apache2 restart
    Restarting web server: apache2 ... waiting .
    root@xxx:/etc/php5/conf.d# php -v
    PHP Fatal error: [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    root@xxx:/etc/php5/conf.d# top

    So if I can´t add lines to php.ini... Can you please tell me what I have to do to fix the problem? Where I hace to add the lines to load Zend Guard loader? Thanks

    DB:2.92:Update To 11.0.9 Destroy Zend Guard Loader d8




    Finded, but not solving my issue to can use this extension...

  • RELEVANCY SCORE 2.92

    DB:2.92:Strong Typing Zend Services For Flash Builder fc



    Hey

    i have typed some of the return values already with the Data/services tool to a custom classes, but everytime i refresh the imported service, it looses the custom return values...is there anyway to go around this or fix it by adding somekind of metadata to the zend / php service ?

    DB:2.92:Strong Typing Zend Services For Flash Builder fc


    Hey

    i have typed some of the return values already with the Data/services tool to a custom classes, but everytime i refresh the imported service, it looses the custom return values...is there anyway to go around this or fix it by adding somekind of metadata to the zend / php service ?

  • RELEVANCY SCORE 2.92

    DB:2.92:Php 5.2.3 And Ioncube -- 3p





    Ive been able to install Zend and part of ioncube, but php gives this error message.
    Failed loading /usr/lib/php/ioncube/ioncube_loader_lin_.so: /usr/lib/php/ioncub
    e/ioncube_loader_lin_.so: cannot open shared object file: No such file or direct
    ory
    PHP 5.2.3 (cli) (built: Aug 6 2007 11:22:37)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technol
    ogies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies
    [root@ip-72-167-35-123 httpd]#
    -- Well the load failed is found in /etc/php.d/ioncube.ini file. Ive tried chanining it to php_ioncube_lin_5.2.so -- crushes the whole system.

    DB:2.92:Php 5.2.3 And Ioncube -- 3p




    --Awesome !!

    Thanks, Faris

    The instructions you provided work.. Made the changes to the /etc/php.ini via your example and went to /etc/php.d/ and cp ioncube.ini to ioncube.ini.old and deleted that iconcube.ini and php loaded correctly.
    I did leave that out, after I re-read my post. I did keep going back to etc/php.d during my troubleshooting but I was leary of remove it all together even though it was tryign to load an old lib.

    Thanks, again..
    the helper ioncube-helper.php; sadly I did not look at them but then again. I thought that they were there for encoding and Decoding the php files when excuating the files. Now, I know why there was a horrible lack of instructions on website for ioncube loader.. its in the helper.php files.. ARGGH!
    Oh, well thanks again!

  • RELEVANCY SCORE 2.92

    DB:2.92:Some Problems f7





    1. ioncube

    Failed loading /usr/lib/php/ioncube/ioncube_loader_lin_5.1.so: /usr/lib/php/ioncube/ioncube_loader_lin_5.1.so: undefined symbol: zend_unmangle_property_name_ex
    PHP 5.2.11 (cli) (built: Oct 7 2009 08:32:32)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
    with the ionCube PHP Loader v3.3.1, Copyright (c) 2002-2009, by ionCube Ltd., and
    with Zend Optimizer v3.3.9, Copyright (c) 1998-2009, by Zend Technologies

    2. Mail server

    All mails sent from server go to spam. Why ?

    DB:2.92:Some Problems f7




    Mail server

    I check all the server IP`s and I recive OK from all servers, my ip`s are not in blacklist.

    Domainkeys are active.

    I realy don`t know what is the problem.

  • RELEVANCY SCORE 2.92

    DB:2.92:Problems Installing Ioncube On Plesk 8.4 With Php 5.1.6 z3





    Hi there

    Im having problems installing ioncube on my Fedora box running Plesk 8.4 and php 5.1.6. Im trying to install the loaders and the php.ini level and understand that with Plesk I have to create a file called ioncube.ini and put it into the /etc/php.d/ directory. Ive now done that and the contents are as follows:

    zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.1.so

    ioncube.ini is being loaded by php.ini now, but when I do php -v I get the following:

    Failed loading /usr/local/ioncube/ioncube_loader_lin_5.1.so: /usr/local/ioncube/ioncube_loader_lin_5.1.so: wrong ELF class: ELFCLASS32
    PHP 5.1.6 (cli) (built: Sep 18 2007 09:07:28)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

    Does anyone know how to get this working? I have a number of sites that require ioncube and this is holding me up big time!

    Thanks in advance,

    Jim

    DB:2.92:Problems Installing Ioncube On Plesk 8.4 With Php 5.1.6 z3




    I fixed it. Looked up wrong ELF class: ELFCLASS32 and found it meant I was using the wrong .so file! My server is 64 bit and I was using the standard version. Doh!

  • RELEVANCY SCORE 2.91

    DB:2.91:Php - Can-T Load Extensions Php Warning: Php Startup: Unable To Load Dynamic Library C:\Program Files\Php\Ext\Php_Mysqli.Dll - The Specified Module Could Not Be Found. m9


     I am trying to use Expression Web 2.0 with PHP5 and I am getting the following error.  I have lots of experience with both PHP, ASP.NET, and PHP on Windows.  I have edited the PHP.ini:extension_dir = C:\Program Files\PHP\extextension=php_mysqli.dllI do have the MySQLi dll in that directory.I have tried adding these files to the windows diriectory, added to the path, etc.  I think there is a bug in expression web with external modules.If anyone could help that would be great.  I am trying to determine if we are going to buy expression web or zend studio.Here is my error:
    HTTP Error 500 - Internal Server Error.

    PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program Files\PHP\ext\php_curl.dll' - The specified module could not be found.in Unknown on line 0PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program Files\PHP\ext\php_imap.dll' - The specified module could not be found.in Unknown on line 0PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program Files\PHP\ext\php_mysqli.dll' - The specified module could not be found.in Unknown on line 0PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program Files\PHP\ext\php_zip.dll' - The specified module could not be found.in Unknown on line 0Justin

    DB:2.91:Php - Can-T Load Extensions Php Warning: Php Startup: Unable To Load Dynamic Library C:\Program Files\Php\Ext\Php_Mysqli.Dll - The Specified Module Could Not Be Found. m9

    HI There, I am trying to use the built-in web server (Casini) which in the help documentation says it should work with PHP and PHP modules.  They even tell you how to enable modules.  The whole point of them adding php was so you could have an environment to develop locally PHP.  However, I can't get it to work.Thanks, JustinJustin

  • RELEVANCY SCORE 2.89

    DB:2.89:Decent Noob Tutorial On Getting Started With Flash Builder And Zend Server jd



    Can any one please point me to a propper tutorial for Flash Builder for PHP to conect to MySQL using a Zend server.

    Or can any one tell what is better Zend server or Wamp.

    DB:2.89:Decent Noob Tutorial On Getting Started With Flash Builder And Zend Server jd


    Can any one please point me to a propper tutorial for Flash Builder for PHP to conect to MySQL using a Zend server.

    Or can any one tell what is better Zend server or Wamp.

  • RELEVANCY SCORE 2.89

    DB:2.89:Problem Adding Php Extension For Zend Under Plesk 11.5 ff





    We have been rebuilding our websites after a server re-image. Our new server setup is linux centos 6 with the system managed by plesk 11.5. We need to use zendguard for some of our php scripts so I installed the zenguardloader.so module in the /usr/lib64/php/modules folder. The zend installation instructions require adding
    zend_extension=/usr/lib64/php/modules/ZendGuardLoader.so
    zend_loader.enable=1
    to the php.ini file. Under our system there was no overall php.ini file instead there is a ‘system’ folder in /var/www/vhosts/ with /etc/php.ini files for each domain and subdomain. Our server provider said to add the zend code using plesk. In the domains – php settings option (php 5.3) in plesk there is a box at the bottom there is a ‘additional configuration directives’ box into which I put the code above. This disabled ALL the php scripts for the domain, including those that did not use plesk. Can anyone advise about what I did wrong, how do I install zend under plesk 11.5?

    Matt

    DB:2.89:Problem Adding Php Extension For Zend Under Plesk 11.5 ff




    If you need to enable the module server-wide, you should place configuration lines into /etc/php5/conf.d/zend_extensions_psa.ini or equivalent on your system.

    If you need per-vhost configuration, place configuration in the mentioned box in the UI. You can check that such changes were provisioned by viewing /var/www/vhosts/system/domain.tld/etc/php.ini or equivalent on you system. Note that such configuration will not work with mod_php and php-fpm, and may not work with fastcgi or cgi php handlers.

    The most likely potential error is loading ZendGuard loader before ionCube loader. This will effectively turn your PHP into a brick, so avoid it.

  • RELEVANCY SCORE 2.89

    DB:2.89:Httpd Not Loading Php? ja


    [lazarus:/usr/local] root# php -v
    PHP 4.4.4 (cli) (built: Jan 19 2007 19:18:59)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

    [lazarus:/usr/local] root# httpd -V
    Server version: Apache/1.3.33 (Darwin)
    Server built: Mar 20 2005 15:08:27
    Server's Module Magic Number: 19990320:16
    Server compiled with....
    -D EAPI
    -D HAVE_MMAP
    -D USEMMAPSCOREBOARD
    -D USEMMAPFILES
    -D HAVEFCNTL_SERIALIZEDACCEPT
    -D HAVEFLOCK_SERIALIZEDACCEPT
    -D SINGLELISTEN_UNSERIALIZEDACCEPT
    -D DYNAMICMODULELIMIT=64
    -D HARDSERVERLIMIT=2048
    -D HTTPD_ROOT="/usr"
    -D SUEXEC_BIN="/usr/sbin/suexec"
    -D DEFAULT_PIDLOG="/var/run/httpd.pid"
    -D DEFAULT_SCOREBOARD="/var/run/httpd.scoreboard"
    -D DEFAULT_LOCKFILE="/var/run/httpd.lock"
    -D DEFAULTERRORLOG="/var/log/httpd/errorlog"
    -D TYPESCONFIGFILE="/etc/httpd/mime.types"
    -D SERVERCONFIGFILE="/etc/httpd/httpd.conf"
    -D ACCESSCONFIGFILE="/etc/httpd/access.conf"
    -D RESOURCECONFIGFILE="/etc/httpd/srm.conf"

    [lazarus:/usr/local] root# httpd -L | grep php
    [[nothing]]

    [lazarus:/usr/local] root# cat /etc/httpd/httpd.conf | grep php
    LoadModule php4_module libexec/httpd/libphp4.so
    AddModule mod_php4.c
    IfModule mod_php4.c
    # If php is turned on, we repsect .php and .phps files.
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps
    # Since most users will want index.php to work we
    # also automatically enable index.php
    DirectoryIndex index.html index.php
    [[So, it's not commented out, and not fighting with PHP5.]]

    What am I missing?

    dafydd

    DB:2.89:Httpd Not Loading Php? ja

    Man, that was a poor description. The problem turns out to be with httpd.conf not invoking php for .htm or .html extensions. I took the easy way out, and created an index.php, which works fine. A better solution would be to include .html and .htm in the appropriate lines in httpd.conf to ID them as potential php files, but I haven't experimented with that.

  • RELEVANCY SCORE 2.89

    DB:2.89:Will Zend 1.2.0 Beta Work With Php 4.1.2? d3





    Will zend optimizer 1.2.0 beta work with php 4.1.2?

    DB:2.89:Will Zend 1.2.0 Beta Work With Php 4.1.2? d3




    Not sure where it would be on a raq. It would be called either error_log or error.log. Try:
    locate error_log

  • RELEVANCY SCORE 2.89

    DB:2.89:Generating Zendid On Vps 91





    How can you generate a Primary Zendid on a CentOS VPS? Or what do you get when you run the following commands via SSH?

    Here is what we get:

    [root@test /]# cd /usr/local/Zend/bin/
    [root@test bin]# ./zendid
    No primary IDs was detected. Try option allid to see secondary IDs.
    [root@test bin]# ./zendid allid
    P:K66AJ-QD99H-R55T9-8LGHW
    M:5S9EX-2JC3Q-CJ4E4-KFZPV
    [root@test bin]#

    Can a Primary Zendid be created on a VPS? And if so, how?. This is on a Centos VPS with:

    PHP 5.2.5 (cli) (built: Aug 3 2008 12:21:54)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies

    Any help would be greatly appreciated!

    DB:2.89:Generating Zendid On Vps 91




    How can you generate a Primary Zendid on a CentOS VPS? Or what do you get when you run the following commands via SSH?

    Here is what we get:

    [root@test /]# cd /usr/local/Zend/bin/
    [root@test bin]# ./zendid
    No primary IDs was detected. Try option allid to see secondary IDs.
    [root@test bin]# ./zendid allid
    P:K66AJ-QD99H-R55T9-8LGHW
    M:5S9EX-2JC3Q-CJ4E4-KFZPV
    [root@test bin]#

    Can a Primary Zendid be created on a VPS? And if so, how?. This is on a Centos VPS with:

    PHP 5.2.5 (cli) (built: Aug 3 2008 12:21:54)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies

    Any help would be greatly appreciated!

  • RELEVANCY SCORE 2.88

    DB:2.88:7.5.4 - Ioncube - Zend Question jc





    Does 7.5.4 automatically install ioncube? After upgrading php -v shows:
    PHP 4.3.9 (cgi) (built: Oct 15 2004 10:27:20)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v2.5, Copyright (c) 2002-2004, by ionCube Ltd.

    and php.ini now has this line at the bottom:
    zend_extension = /usr/lib/ioncube/Ioncube_loader_lin_4.3.so

    Will this affect servers running zend optimizer? I have a server on 7.5.2 and it needs zend so I need to know before upgrading it.

    DB:2.88:7.5.4 - Ioncube - Zend Question jc




    thank you PaulC, I just did the upgrade and all is working well, ioncube and zend seem to coexist nicely.

  • RELEVANCY SCORE 2.88

    DB:2.88:Calling Vbulletin Into A Cfm Page dm


    Would like to know if it is possible to call a PHP page into
    a CFM page. I would like to have the main page header and footer in
    CFM and the center content load our vBulletin page in PHP. I know
    this is possible with iFrames, but not all browsers support this
    method.

    Is there a better option?

    Thanks in advance for any assistance you may be able to
    provide.

    DB:2.88:Calling Vbulletin Into A Cfm Page dm

    CalTek wrote:
    Would like to know if it is possible to call a PHP page
    into a CFM page. I
    would like to have the main page header and footer in
    CFM and the center
    content load our vBulletin page in PHP. I know this is
    possible with iFrames,
    but not all browsers support this method.

    Is there a better option?

    Thanks in advance for any assistance you may be able to
    provide.

    Theoretically you can run PHP inside ColdFusion:

    http://www.caucho.com/resin-3.0/quercus/,

    http://corfield.org/entry/ColdFusion_8_running_PHP.
    Practically I found
    it's very buggy and unstable for real work so I went the
    CFHTTP way for
    a small project I did.

    Another solution would be to generate the header and footer
    as static
    html and include that in PHP (and regenerate the HTML when
    needed).

    --
    Mack

  • RELEVANCY SCORE 2.87

    DB:2.87:Steps To Use Jdeveloper's Php Extension With Zend Core For Windows Beta 9p


    Here are the things I did to get the PHP Extension for JDeveloper
    (http://www.oracle.com/technology/products/jdev/htdocs/partners/addins/exchange/php/index.html)
    working with Zend Core for Oracle (Beta) on Windows:

    1. Add c:\Program Files\Zend\Core For Oracle\lib\phpext to my PATH
    environment variable. This is in addition to C:\Program
    Files\Zend\Core For Oracle\bin which was already added to PATH by the
    Zend Core installer.

    2. In JDeveloper, navigate to Tools-Preferences-PHP and set the PHP
    command-line executable to C:\Program Files\Zend\Core For
    Oracle\bin\php.exe

    3. Load the Zend Core for Oracle console in a browser. Navigate to
    Configurations-Extensions and enable the "tokenizer" extension.

    Without these steps the structure pane is not able to list functions
    etc.

    -- CJ

    DB:2.87:Steps To Use Jdeveloper's Php Extension With Zend Core For Windows Beta 9p

    Here are the things I did to get the PHP Extension for JDeveloper
    (http://www.oracle.com/technology/products/jdev/htdocs/partners/addins/exchange/php/index.html)
    working with Zend Core for Oracle (Beta) on Windows:

    1. Add c:\Program Files\Zend\Core For Oracle\lib\phpext to my PATH
    environment variable. This is in addition to C:\Program
    Files\Zend\Core For Oracle\bin which was already added to PATH by the
    Zend Core installer.

    2. In JDeveloper, navigate to Tools-Preferences-PHP and set the PHP
    command-line executable to C:\Program Files\Zend\Core For
    Oracle\bin\php.exe

    3. Load the Zend Core for Oracle console in a browser. Navigate to
    Configurations-Extensions and enable the "tokenizer" extension.

    Without these steps the structure pane is not able to list functions
    etc.

    -- CJ

  • RELEVANCY SCORE 2.86

    DB:2.86:Php Shows As Not Installed s8





    Hello there,
    There is the following situation:
    Centos 5.4, plesk 8.6
    A couple of days ago, Zend optimizer has been installed.
    Trying to add php to a newly created domain is not possible. Option is greyed out
    index.php in this newly created site asks to save the file.
    Going to Installed components in Plesk: php shows as not installed
    php -v on shell says 5.1.6, with Ioncube / Zend Optimizer
    phpinfo on any site on the server shows 5.2.11, with php.ini taken from /usr/local/zend/etc/
    So server servers php files, but not for newly created domain, after Zend being installed.

    Any idea what is happening and how can be fixed?

    Thank you.

    DB:2.86:Php Shows As Not Installed s8




    Hello there,
    There is the following situation:
    Centos 5.4, plesk 8.6
    A couple of days ago, Zend optimizer has been installed.
    Trying to add php to a newly created domain is not possible. Option is greyed out
    index.php in this newly created site asks to save the file.
    Going to Installed components in Plesk: php shows as not installed
    php -v on shell says 5.1.6, with Ioncube / Zend Optimizer
    phpinfo on any site on the server shows 5.2.11, with php.ini taken from /usr/local/zend/etc/
    So server servers php files, but not for newly created domain, after Zend being installed.

    Any idea what is happening and how can be fixed?

    Thank you.

  • RELEVANCY SCORE 2.85

    DB:2.85:Issues With Error #2048 On Deployed Flex/Php Web Application sp



    Hello,

    I'm testing out Flash Builder for PHP and I'm running into the following error when deploying to a web servers:

    Send failed

    Channel.Security.Error error Error #2048 url: 'http://testsite.dreamhosters.com/LocatorPHP/public/gateway.php'

    I have looked though documentation and tutorials without any luck. My application works great on the local Zend Server setup but as soon as I jump to a remote web server I get problems.

    Here's what I've tried:

    1) crossdomain.xml in web root

    2) amf_config.ini updated so zend framework on server and gateway.php are reachable (connecting to gateway.php directly gives me no errors)

    3) attemped to change the flex server option in my project but Flash Builder for PHP will not allow me to change this, so I had to change my php service.as endpoint entry to the gateway.php on the webserver

    Is there a log that can help me troubleshoot the error?

    Thanks in advance.

    DB:2.85:Issues With Error #2048 On Deployed Flex/Php Web Application sp


    Any solution I have just ran into the same issue. App works perfect on localhost phpmyadmin as soon I change everything to our public server ERROR#2048

    I have tried same as above no results.

    After countless hours of searching this worked for me!!!!

    http://forums.adobe.com/thread/674871

  • RELEVANCY SCORE 2.85

    DB:2.85:Iweb And Vbulletin? 8p


    Is there anyway I can integrate vBulletin with iWeb?

    DB:2.85:Iweb And Vbulletin? 8p

    Thanks Cedric, for clearing that up. This whole MySQL and ODBC stuff is a bit overwhelming and is still somewhat a mystery to me. But, yes, I installed phpbb3 (a competitor to vbulletin I believe) on my server successfully--with a little guidance from the hosting company's friendly tech support from overseas (networksolutions.com).

    First, I downloaded and installed the free CompleteMySql (v.4.021) from http://www.serverlogistics.com/mysql.php

    Then I struggled, but managed, to read important info in the Install Guide. It put a preference pane in System Preferences. But I also had to type some cryptic stuff in Terminal. It was a bit harrowing. I think I had to do something with ODBC. But it worked.

    Not bad for a photo retoucher (smile).

  • RELEVANCY SCORE 2.84

    DB:2.84:Zend Optimizer mf





    Zend Optimizer only loading for root user

    When logged in as root, php -v renders:

    PHP 4.3.9 (cgi) (built: Nov 7 2006 05:00:50)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.1.16, Copyright (c) 2002-2006, by ionCube Ltd., and
    with Zend Extension Manager v1.0.11, Copyright (c) 2003-2006, by Zend Technologies
    with Zend Optimizer v3.2.0, Copyright (c) 1998-2006, by Zend Technologies

    However, these modules dont load when viewing phpinfo():

    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies with the ionCube PHP Loader v3.1.16, Copyright (c) 2002-2006, by ionCube Ltd.

    Thoughts?

    DB:2.84:Zend Optimizer mf




    There is this post too

    http://forum.swsoft.com/showthread.php?s=threadid=45910

  • RELEVANCY SCORE 2.84

    DB:2.84:Zend Optimizer Plesk. 81





    Is it possible to use Zend optimizer with Plesk together?

    DB:2.84:Zend Optimizer Plesk. 81




    You need only simple copy the php.ini from /usr/local/Zend/etc/ to /usr/local/psa/apache/conf/ and restart apache..))

    Done it and all will be fine...

  • RELEVANCY SCORE 2.83

    DB:2.83:Problems On Windows 7 Professional 64 With Php Data Service 1p



    I've created a data service using PHP in a PHP Eclipse project and I'm trying to connect to it from my new Flash project. When I try to create a custom data type via the Configure Return Type dialog, "Auto detect the return type from sample data" radio button, I get the following error:

    There was an error while invoking the operation. Check your operation inputs or server code and try invoking the operation again. Reason: Warning: mysqli::mysqli() [mysqli.mysqli]: (HY000/2003): Can't connect to MySQL server on 'localhost' (10061) in C:\Users\davidk\workspace\php-global-includes\mysqlAccess.inc.php on line 11 /0/onStatus �SIflex.messaging.messages.ErrorMessage extendedData faultCode faultDetail faultString rootCause correlationId clientId destination messageId timestamp timeToLive headers body m a#0 C:\Zend\ZendServer\share\ZendFramework\library\Zend\Amf\Server.php(550): Zend_Amf_Server-_dispatch('getProductVersi...', Array, 'GetPlayData')#1 C:\Zend\ZendServer\share\ZendFramework\library\Zend\Amf\Server.php(626): Zend_Amf_Server-_handle(Object(Zend_Amf_Request_Http))#2 C:\Zend\Apache2\htdocs\play-debug\gateway.php(69): Zend_Amf_Server-handle()#3 {main} UError instantiating class GetPlayData to invoke method getProductVersions: Error connecting to database server as user via password configured in config_cdna_testdb.php IE83D9958-920E-E203-54BC-E5365BD85289 I5496259E-8C36-AC89-E234-00000D37FD49 I7E8A1BD7-9D60-9329-DBFB-00001B5BE8C7 126823334100

    Note that I've tested the GetPlayData class and the getProductVersions() method with some simple "unit testing" code and it works fine when I execute it directly. It just won't run when called from this dialog.

    I tried to debug the gateway.php process that is used to do this connecting without much success so far.

    Is Windows 7 supported for PHP data service development in this beta release? I'm using Version 4.0 build 253292

    DB:2.83:Problems On Windows 7 Professional 64 With Php Data Service 1p


    One more clue: the message from the exception shows that the global variables I'm using to configure the MySQL connection parameters are not set somehow. Maybe I need to upgrade my Zend Framework?

    Nope. I upgraded to the latest Zend Framework and it still did not work. The global variables are not working. When I hard coded the connection parameters into the constructor of the GetPlayData class, then it worked fine. I just switched to using define() to create constants instead of using the globals and that worked, too.

    It is as if globals set in one include file are not available in another include file. I agree that using them might be a bad programming practice of sorts, but it seems wrong to disallow / not support something that is part of the core language!

    So, I don't know if this is a Windows 7 thing or just a general behavior. Globals within the same file seem to work fine still, but not from another include file.

    So the answer for me is to not use these cross-include file globals in code that is going to be used from Flash Builder.

  • RELEVANCY SCORE 2.83

    DB:2.83:Help: Module Ioncube Loader Already Loaded In Unknown On Line 0 a1





    [root@myserver ~]# php -v
    Hi all,

    After successful upgrade PHP, and not successful with ioncube i get:



    Failed loading /usr/lib/php/modules/ioncube_loader_lin_5.4.so: /usr/lib/php/modules/ioncube_loader_lin_5.4.so: cannot open shared object file: No such file or directory
    PHP Warning: Module ionCube Loader already loaded in Unknown on line 0
    The ionCube PHP Loader is disabled because of startup problems.
    PHP Warning: Module ionCube Loader already loaded in Unknown on line 0
    The ionCube PHP Loader is disabled because of startup problems.
    PHP 5.4.32 (cli) (built: Aug 21 2014 07:33:35)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
    with the ionCube PHP Loader v4.6.1, Copyright (c) 2002-2014, by ionCube Ltd., and

    DB:2.83:Help: Module Ioncube Loader Already Loaded In Unknown On Line 0 a1




    Thank you IgorG,

    i have look for entry at php.ini but not have any entry :s

    have do:



    php -i | grep php.ini

  • RELEVANCY SCORE 2.82

    DB:2.82:Installing Zend Performance Suite mx





    I am attempting to install the Zend Performance Suite (ZPS) on a server and seem to be running into an issue that I think stems from Plesk and how it configures PHP.

    After installation of ZPS, I receive this errorr:
    Zend Performance Suite
    cant read file: /usr/local/Zend/etc/cache/zend_cache.ini

    I have a support ticket open with Zend, hopefully someone here has experienced the same issue and can provide some guidance.

    Thanks,
    Bing Pascual

    DB:2.82:Installing Zend Performance Suite mx




    same here

    cant login the admin panel of zend performance suite 3.5

  • RELEVANCY SCORE 2.82

    DB:2.82:Zend Opt 3.3.0a Installed, Produced Watchdog Cron Errors - Why? jd





    We are running PLESK 8.2 on CENTOS 4. Today we installed Zend Optimizer 3.3.0a on our server and all seemed to take well, php -v is reporting:

    [root@www src]# php -v
    PHP 4.3.9 (cgi) (built: May 10 2007 05:19:09)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.1.16, Copyright (c) 2002-2006, by ionCube Ltd., and
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies
    [root@www src]#

    But tonight, during the cron processes, the following errors were reported by the watchdog program:

    FIRST ERROR:

    From: Cron /usr/local/psa/libexec/modules/watchdog/cp/clean-sysstats
    Error: Failed loading /usr/lib/php4/php_ioncube_loader_lin_4.3.so: /usr/lib/php4/php_ioncube_loader_lin_4.3.so: undefined symbol: zend_hash_add_or_update
    /usr/local/psa/admin/bin/php: symbol lookup error: /usr/local/Zend/lib/ZendExtensionManager.so: undefined symbol: zend_get_configuration_directive

    SECOND ERROR:

    From: Cron /usr/local/psa/libexec/modules/watchdog/cp/pack-sysstats day
    Error: Failed loading /usr/lib/php4/php_ioncube_loader_lin_4.3.so: /usr/lib/php4/php_ioncube_loader_lin_4.3.so: undefined symbol: zend_hash_add_or_update
    /usr/local/psa/admin/bin/php: symbol lookup error: /usr/local/Zend/lib/ZendExtensionManager.so: undefined symbol: zend_get_configuration_directive

    ERROR THREE:

    From: Cron /usr/local/psa/libexec/modules/watchdog/cp/clean-events
    Error: Failed loading /usr/lib/php4/php_ioncube_loader_lin_4.3.so: /usr/lib/php4/php_ioncube_loader_lin_4.3.so: undefined symbol: zend_hash_add_or_update
    /usr/local/psa/admin/bin/php: symbol lookup error: /usr/local/Zend/lib/ZendExtensionManager.so: undefined symbol: zend_get_configuration_directive

    Anyone have any thoughts or ideas on how to fix this problem? There has to be a way to get Zend Optimizer 3.3.0a working well with PLESK 8.2!

    Any advice or input would be GREATLY appreciated!

    Thanks,
    jjsba

    DB:2.82:Zend Opt 3.3.0a Installed, Produced Watchdog Cron Errors - Why? jd




    We are running PLESK 8.2 on CENTOS 4. Today we installed Zend Optimizer 3.3.0a on our server and all seemed to take well, php -v is reporting:

    [root@www src]# php -v
    PHP 4.3.9 (cgi) (built: May 10 2007 05:19:09)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.1.16, Copyright (c) 2002-2006, by ionCube Ltd., and
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies
    [root@www src]#

    But tonight, during the cron processes, the following errors were reported by the watchdog program:

    FIRST ERROR:

    From: Cron /usr/local/psa/libexec/modules/watchdog/cp/clean-sysstats
    Error: Failed loading /usr/lib/php4/php_ioncube_loader_lin_4.3.so: /usr/lib/php4/php_ioncube_loader_lin_4.3.so: undefined symbol: zend_hash_add_or_update
    /usr/local/psa/admin/bin/php: symbol lookup error: /usr/local/Zend/lib/ZendExtensionManager.so: undefined symbol: zend_get_configuration_directive

    SECOND ERROR:

    From: Cron /usr/local/psa/libexec/modules/watchdog/cp/pack-sysstats day
    Error: Failed loading /usr/lib/php4/php_ioncube_loader_lin_4.3.so: /usr/lib/php4/php_ioncube_loader_lin_4.3.so: undefined symbol: zend_hash_add_or_update
    /usr/local/psa/admin/bin/php: symbol lookup error: /usr/local/Zend/lib/ZendExtensionManager.so: undefined symbol: zend_get_configuration_directive

    ERROR THREE:

    From: Cron /usr/local/psa/libexec/modules/watchdog/cp/clean-events
    Error: Failed loading /usr/lib/php4/php_ioncube_loader_lin_4.3.so: /usr/lib/php4/php_ioncube_loader_lin_4.3.so: undefined symbol: zend_hash_add_or_update
    /usr/local/psa/admin/bin/php: symbol lookup error: /usr/local/Zend/lib/ZendExtensionManager.so: undefined symbol: zend_get_configuration_directive

    Anyone have any thoughts or ideas on how to fix this problem? There has to be a way to get Zend Optimizer 3.3.0a working well with PLESK 8.2!

    Any advice or input would be GREATLY appreciated!

    Thanks,
    jjsba

  • RELEVANCY SCORE 2.82

    DB:2.82:Centos 4.7 (64) + Pro 10.3.2 (64), Mysql Not Working sx





    I found that the mysql client is not working.

    My old Ensim is using CentOS 4.3 + Ensim 4.1.0, and new server is CentOS 4.7 (64) + Ensim 10.3.2 (64).

    I use backup / restore methold to move the site from old to new server.

    The hosting account that is PHP cannot read MySQL.

    How to resolve the problem?

    Old Server Config:
    [root@hk01 ~]# rpm -q mysql
    mysql-4.1.20-1.RHEL4.1
    [root@hk01 ~]# php -v
    PHP 4.3.9 (cgi) (built: Jul 12 2006 13:40:25)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    [root@hk01 ~]# rpm -q mysqlclient10
    mysqlclient10-3.23.58-4.RHEL4.1

    New Server:
    [root@hk01 conf]# rpm -q mysql
    mysql-4.1.22-2.el4
    mysql-4.1.22-2.el4
    [root@hk01 conf]# php -v
    PHP 4.3.9 (cgi) (built: Jul 16 2008 16:42:27)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies
    [root@hk01 conf]# rpm -q mysqlclient10
    mysqlclient10-3.23.58-4.RHEL4.1
    mysqlclient10-3.23.58-4.RHEL4.1

    DB:2.82:Centos 4.7 (64) + Pro 10.3.2 (64), Mysql Not Working sx




    Looks like at first you must remove 32bit packages
    rpm -e --nodeps mysql.i386
    rpm -e --nodeps mysqlclient10.i386

    then go through maintence, may be it will help otherwise if it wouldnt help,
    then you must investigate and fix mysql libs in virtualhosts.

  • RELEVANCY SCORE 2.81

    DB:2.81:Json On High Security 7a





    I move medium security sites, located on server with old ensim, to high security sites on a new server with Centos 5 and ppcp 10.4

    PHP 4 not work fine on PHP 5 so i do in high security sites exported:

    1) cp -f /etc/virtualhosting/templates/apache/var/www/interpreters/php-script /home/virtual/siteXX/fst/var/www/interpreters/

    2) pico -w /home/virtual/siteXX/fst/etc/php.ini

    extension_dir = /usr/lib/php4
    changed to:
    extension_dir = /usr/lib/php/modules

    3) cp -r /usr/local/Zend/ /home/virtual/siteXX/fst/usr/local/

    Add zend on php.ini

    service httpd restart

    everthing works ok.

    Now the problem

    But now in install on the new server (php 5.1.6) Json:

    1) yum install php-pear (este ya esta instalado)

    2) yum install php-devel (este hay que instalarlo)

    3) pecl install json

    4) pico -w /etc/php.d/json.ini

    extension=json.so

    5) service httpd restart

    And Json work fine in medium security sites on new server but not work on High security sites...

    Any help?

    DB:2.81:Json On High Security 7a




    As json is not RPM based, it does not get copied to virtual hosting accounts as par of the filesystem (medium security level uses installed components at the server level, hence this working). All that you should need to do is copy the json.so file to the virtual account in question and edit the accounts php.ini to include this as well.

  • RELEVANCY SCORE 2.81

    DB:2.81:[Solved] Problems With Php On Lighttpd jz



    Hello form, I have followed the guide on the ArchWiki (https://wiki.archlinux.org/index.php/lighttpd). However, I am unable to get PHP working.

    I have installed lighttpd (and works if I browsed to the machines IP).I then installed fcgi,php and php-cgi.
    # php-cgi --version
    PHP 5.5.10 (cgi-fcgi) (built: Mar 5 2014 17:41:43)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies

    # php --version
    PHP 5.5.10 (cli) (built: Mar 5 2014 17:41:10)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies

    DB:2.81:[Solved] Problems With Php On Lighttpd jz


    Hello form, I have followed the guide on the ArchWiki (https://wiki.archlinux.org/index.php/lighttpd). However, I am unable to get PHP working.

    I have installed lighttpd (and works if I browsed to the machines IP).I then installed fcgi,php and php-cgi.
    # php-cgi --version
    PHP 5.5.10 (cgi-fcgi) (built: Mar 5 2014 17:41:43)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies

    # php --version
    PHP 5.5.10 (cli) (built: Mar 5 2014 17:41:10)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies

  • RELEVANCY SCORE 2.81

    DB:2.81:Re: Unable To Allocate Memory For Mutex; Resize Mutex Region 3a


    Hi

    I am download Ubuntu 10.10 from http://www.ubuntu.com/server/get-ubuntu/download. Then apt-get install php5 and other packages. No installs from source code or a other deb source.

    PHP Api Version: 20090626
    Zend Module Api No: 20090626
    Zend Extension Api No: 220090626php -v says:

    root@kubuntu:~# php -v
    PHP 5.3.3-1ubuntu9.1 with Suhosin-Patch (cli) (built: Oct 15 2010 14:00:18)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Xdebug v2.1.0, Copyright (c) 2002-2010, by Derick Rethans
    with Suhosin v0.9.31, Copyright (c) 2007-2010, by SektionEins GmbHfree says

    root@kubuntu:~# free
    total used free shared buffers cached
    Mem: 1022924 914520 108404 0 32732 748644
    -/+ buffers/cache: 133144 889780
    Swap: 916476 0 916476I can't use php 5.2, because need php5-fpm. php5-fpm include from version 5.3.3.

    --
    Vitaliy

    DB:2.81:Re: Unable To Allocate Memory For Mutex; Resize Mutex Region 3a

    For everybody having the same problem:
    * It happens with Debian Squeeze x86_64 as well
    * PHP is compiled with dba support (not as an extension, but statically), which includes linking with libdb4. You can check this with "ldd /usr/bin/php5 | grep libdb-4.8.so"
    * DBXML comes with its own libdb-4.8.so
    * the two libraries are not compatible to each other, resulting in the dbxml extension using the system libdb library (at /usr/lib), which does not work

    Solution:
    a) find a PHP release not containing dba or compile PHP yourself
    b) (dangerous, only for testing) symlink /usr/lib/libdb-4.8.so to the libdb-4.8.0.so used by bdbxml

  • RELEVANCY SCORE 2.81

    DB:2.81:Pecl Install Ssh2, Make Failed. ac



    Hi!

    Im trying really hard since two hours to install ssh2 with pecl... But all I get is:
    /bin/sh /root/ssh2-0.11.0/libtool --mode=compile cc -I. -I/root/ssh2-0.11.0 -DPHP_ATOM_INC -I/root/ssh2-0.11.0/include -I/root/ssh2-0.11.0/main -I/root/ssh2-0.11.0 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/ssh2-0.11.0/ssh2.c -o ssh2.lo
    mkdir .libs
    cc -I. -I/root/ssh2-0.11.0 -DPHP_ATOM_INC -I/root/ssh2-0.11.0/include -I/root/ssh2-0.11.0/main -I/root/ssh2-0.11.0 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/ssh2-0.11.0/ssh2.c -fPIC -DPIC -o .libs/ssh2.o
    /root/ssh2-0.11.0/ssh2.c:52: error: duplicate static
    /root/ssh2-0.11.0/ssh2.c: In function zif_ssh2_methods_negotiated:
    /root/ssh2-0.11.0/ssh2.c:503: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c:504: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c:508: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c:509: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c:510: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c:511: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c:516: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c:517: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c:518: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c:519: warning: passing argument 4 of add_assoc_string_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:360: note: expected char * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c: In function zif_ssh2_publickey_add:
    /root/ssh2-0.11.0/ssh2.c:1045: warning: passing argument 1 of _efree discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_alloc.h:46: note: expected void * but argument is of type const char *
    /root/ssh2-0.11.0/ssh2.c: In function zif_ssh2_publickey_list:
    /root/ssh2-0.11.0/ssh2.c:1104: warning: passing argument 4 of add_assoc_stringl_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:361: note: expected char * but argument is of type const unsigned char *
    /root/ssh2-0.11.0/ssh2.c:1105: warning: passing argument 4 of add_assoc_stringl_ex discards qualifiers from pointer target type
    /usr/include/php/Zend/zend_API.h:361: note: expected char * but argument is of type const unsigned char *
    make: *** [ssh2.lo] Error 1

    DB:2.81:Pecl Install Ssh2, Make Failed. ac


    Although the bug title is misleading, the patch does work.

  • RELEVANCY SCORE 2.81

    DB:2.81:Hello, When I Was Working With Php Zend Framework. The Command Prompt Window Of Windows 7 Cannot Paste Text From Clipboard. I Strongly Believe An Attacker Is Manipulating My Windows Os. af


    The command prompt would not let me paste text.

    DB:2.81:Hello, When I Was Working With Php Zend Framework. The Command Prompt Window Of Windows 7 Cannot Paste Text From Clipboard. I Strongly Believe An Attacker Is Manipulating My Windows Os. af

    ​Hi YsmaelZapanta,

    Normally this issue happens when the program is not responding to the copy command. I would like to know more information about the issue, so that we could help you further.
    1. Is this issue confined while copying from the PHP Zend Framework?
    2. Have you tried copying the command to a notepad and checked if you are able to paste the same you have copied?
    3. Have you made any changes to the computer prior to this issue?

    If you have not tried copying the command from the program and then try pasting it to a notepad, then I would suggest you try it and then copy the command from the notepad and paste it in the command prompt and check if it works for you.

    Please reply with more information about the issue, so that we could help you in a better way.

  • RELEVANCY SCORE 2.80

    DB:2.80:Zendoptimizer Sourceguradian Problem With Plesk 10.4.4 Freshinstall f7





    Plesk Panel for Linux, 10.4.4, CentOS6X, X86_64

    we rent a server and install a fresh plesk installation on it ( with PHP 5.3 )
    after that migrate the other server (also Plesk 10.4.4 - update 13 - PHP 5.2.17) domains

    but there are some sites that have problem with sites must be decoded with Source-guardian and ZendOptimizer ( 3.3.0 on old Server )

    as you know we have to use Zend Guard Loader on PHP5.3 but the script is not compatible and Source guardian scripts have the same problem

    we try to Downgrade to PHP 5.2.17 but its not load zend-optimizer
    but its load ioncube!

    here is the php -i | grep zend



    Loaded Configuration File = /usr/local/Zend/etc/php.ini
    Zend Extension = 220060519
    Zend Memory Manager = enabled
    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

    DB:2.80:Zendoptimizer Sourceguradian Problem With Plesk 10.4.4 Freshinstall f7




    Plesk Panel for Linux, 10.4.4, CentOS6X, X86_64

    we rent a server and install a fresh plesk installation on it ( with PHP 5.3 )
    after that migrate the other server (also Plesk 10.4.4 - update 13 - PHP 5.2.17) domains

    but there are some sites that have problem with sites must be decoded with Source-guardian and ZendOptimizer ( 3.3.0 on old Server )

    as you know we have to use Zend Guard Loader on PHP5.3 but the script is not compatible and Source guardian scripts have the same problem

    we try to Downgrade to PHP 5.2.17 but its not load zend-optimizer
    but its load ioncube!

    here is the php -i | grep zend



    Loaded Configuration File = /usr/local/Zend/etc/php.ini
    Zend Extension = 220060519
    Zend Memory Manager = enabled
    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

  • RELEVANCY SCORE 2.80

    DB:2.80:Zend Core For Oracle And Sso Integration kf


    Hi,

    I was wondering if anyone had worked out a method of integrating the Apache2 server that comes with Zend Core for Oracle with Oracle Single Sign-On. My applications are written in PHP.

    Any help or suggestions would be much appreciated,
    Damian

    DB:2.80:Zend Core For Oracle And Sso Integration kf

    Hi,

    Any ideas? A nudge in the right direction would be much appreciated.

    Cheers,
    Damian

  • RELEVANCY SCORE 2.79

    DB:2.79:Ioncube Segfaulting 87





    Hi,
    I am currently running Sitebuilder 4.1 / Plesk 8.3 on RHEL5 x86_64 with PHP 5.1.6
    After Publishing a site that uses eShop or ImageGallery the pages will randomly segfault

    Zend / ioncube config
    [Zend]
    zend_extension=/usr/lib64/php/modules/php_ioncube_loader_lin_5.1_x86_64.so
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.0
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.0
    zend_optimizer.version=3.3.0a
    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so

    DB:2.79:Ioncube Segfaulting 87




    If you have PHP 5.2.5 it my cause this situation due to some issues in this specific PHP version. Try to downgrade to 5.2.4 as JLChafardet suggested or probably upgrade to latest 5.2.6 which was released recently.
    As I remember it could be related to following bugs if you need more info:

    http://bugs.php.net/bug.php?id=43755
    http://bugs.php.net/bug.php?id=43677

    They states that it should be corrected in 5.2.6 version.



    marlon said:

  • RELEVANCY SCORE 2.79

    DB:2.79:Using Zend With Wampserver dc



    I have a development environment that consists of:

    Wampserver 2.1e
    Apache 2.2.17PHP 5.3.5MySQL 5.5.8
    AMFPHP 1.9,

    Flex Builder 3 (now upgrading to Flash Builder 4.5.1 for PHP)

    My production server environment is:

    Linux 2.6.18

    Apache 2.2.17

    PHP 5.2.16

    MySQL 5.1.52

    I want to be able to use the debugging tools (Zend) that will allow me to trace through ActionScript and PHP code, but I don't know how to configure my environment to do this.

    Is this possible? Should I even bother? Is the Zend framework that come with Flash Builder 4.5.1 compatible with AMFPHP/Wampserver?

    Should I change over to Zend framework as my server?

    DB:2.79:Using Zend With Wampserver dc


    I have a development environment that consists of:

    Wampserver 2.1e
    Apache 2.2.17PHP 5.3.5MySQL 5.5.8
    AMFPHP 1.9,

    Flex Builder 3 (now upgrading to Flash Builder 4.5.1 for PHP)

    My production server environment is:

    Linux 2.6.18

    Apache 2.2.17

    PHP 5.2.16

    MySQL 5.1.52

    I want to be able to use the debugging tools (Zend) that will allow me to trace through ActionScript and PHP code, but I don't know how to configure my environment to do this.

    Is this possible? Should I even bother? Is the Zend framework that come with Flash Builder 4.5.1 compatible with AMFPHP/Wampserver?

    Should I change over to Zend framework as my server?

  • RELEVANCY SCORE 2.79

    DB:2.79:Who Has Experience With Developing In Way: Php+Zend+Silverlight? f8


    Hello everybody!
    Today I have installed Zend Core / Server.
    And found one interesting thing.
    Standart PHP hasn't possibility to create web services.
    But with the Zend Framework it can do it.

    And I got some problems to work with Silverlight by PHPZend.
    I don't think, that it will be polite to paste here PHP code, because it's problem with not .NET or Silverlight.
    But, who from this forum has worked with such scheme PHP/Zend == Silverlight.

    May be in private conversation somebody will help me, because at native Zend forum I will wait for the answer very long.

    Best Regads,
    Oleg

    DB:2.79:Who Has Experience With Developing In Way: Php+Zend+Silverlight? f8

    I have try building silverlight with php before and contact the mySQL
    some only some simple code to build the object in xaml
    do you meet some problem?

  • RELEVANCY SCORE 2.78

    DB:2.78:[Problem] Get Data From Data/Services (Mysql + Zend Amf Php) j7



    Hello,

    Im using Zend AMF PHP in Flash Builder 4 to access a MySQL database.

    I have some methods in php generated automatically by Zend AMF.

    My methods is to manipulate a table of Accounts.

    Have method to get all accounts etc...

    I can put the data of method getAllAccounts in a datagrid.

    But, Im making a login system, and I have a method with a parameter: getAccountByName($name)

    I need to know, how I can put this method inside the AC code for example...

    I need to know if already exists a account with "X" name, and for this, I need to execute getAccountByName.

    Someone help-me?

    Thanks,

    Renan.

    DB:2.78:[Problem] Get Data From Data/Services (Mysql + Zend Amf Php) j7


    But if getAccountByName, return an Account object.

    How I get the result of this method?

    Its my doubt...

    Very thanks man!

  • RELEVANCY SCORE 2.78

    DB:2.78:Installing Zend p8





    Hi Guys,

    ANybody have tried to install zend for php security code... before?

    Did you encoutered any problem before...???

    DB:2.78:Installing Zend p8




    Nope, ZEND Studio 3.5 for server and Im using FreeBSD with PLESK Reloaded 7.1.2

    Maybe Ill try this 1st.

    Thanks for the reply faris...

  • RELEVANCY SCORE 2.78

    DB:2.78:Php Cli Version aj





    Hallo
    I have plesk panel server which have installed CGI PHP version. Now I need to change PHP to CLI version.

    PHP 4.3.9 (cgi) (built: Nov 10 2005 20:38:14)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.0.10, Copyright (c) 2002-2005, by
    ionCube Ltd., and
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by
    Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend
    Technologies

    I have talked with my server support and they`re told me that they don`t recompile this things because it might break some stuffs on the server. There is any possibility to change PHP to CLI version ?

    DB:2.78:Php Cli Version aj




    Im using 5.2.3 on my system, which has php-cgi as s separate rpm.

    [root@www ~]# rpm -qf /usr/bin/php-cgi
    php-cli-5.2.3-4.el4.art

  • RELEVANCY SCORE 2.78

    DB:2.78:A New Oci8 Driver Is Available In Zend Core For Oracle xj


    Zend Core for Oracle contains a refactored oci8 driver with substantial
    improvements in code quality, and several new controls over connection.

    Please try the driver out and submit any feedback while it is Beta.

    The driver will be made available in PECL soon for anyone who wants to
    use it against other versions of PHP. It was written so it will compile with
    PHP 4 5.

    Zend Core for Oracle is available from http://www.oracle.com/technology/tech/php/zendcore/index.html

    -- CJ

    DB:2.78:A New Oci8 Driver Is Available In Zend Core For Oracle xj

    Works great! Now I don't have to restart the Apache server after I restart the database! Before the new Zend core, I was getting those lovely ORA-03113 errors when I restarted the database. Such
    things usually turned me into a cursor. The word "cursor" here describes certain way of using the English language, not an internal Oracle structure.
    I am extremely glad to see Oracle Corp. devoting such attention to PHP. Keep up the good work!
    Mladen Gogala!

  • RELEVANCY SCORE 2.78

    DB:2.78:Fatal Error: Extension Sitebuilder Was Not Found ck





    I use SiteBuilder 2.x.
    I am switching my SiteBuilder 2.x to a new server.

    However when open the browser, I have this error:
    Fatal error: extension sitebuilder was not found

    I tried php -v and this is my result:

    [root@localhost Sitebuilder.2.1.3]# php -v
    PHP: Error parsing /etc/php.d/ioncube-loader.ini on line 1
    Failed loading extension_dir: extension_dir: cannot open shared object file: No such file or directory
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php/modules/sitebuilder.so - /usr/lib/php/modules/sitebuilder.so: undefined symbol: empty_string in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php/modules/sitebuilder.so - /usr/lib/php/modules/sitebuilder.so: undefined symbol: empty_string in Unknown on line 0
    PHP 5.2.6 (cli) (built: Sep 13 2008 11:13:29)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
    with the ionCube PHP Loader v3.3.7, Copyright (c) 2002-2009, by ionCube Ltd.

    I open ioncube-loader.ini, it has only 1 line:
    zend_extension=extension_dir = /usr/lib/php/modules = /usr/lib/php/modules/php_ioncube_loader_lin_5.2.so
    and the file php_ioncube_loader_lin_5.2.so is in the folder.

    Can anybody help me with this problem?

    Thanks

    DB:2.78:Fatal Error: Extension Sitebuilder Was Not Found ck




    You have Sitebuilder v2.x installed, which is incompatible with PHP5, once sitebuilder.so is loaded into PHP5 the corresponding error is noted:



    [root@localhost ioncube]# php -v
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php/modules/sitebuilder.so - /usr/lib/php/modules/sitebuilder.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP 5.2.6 (cli) (built: Sep 13 2008 11:13:29)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
    with the ionCube PHP Loader v3.3.7, Copyright (c) 2002-2009, by ionCube Ltd.

  • RELEVANCY SCORE 2.77

    DB:2.77:When Creating Flex And Php Project Where Do The Zend Framework Files Come From ? 7f



    When I create a Flex and PHP project it automatically select me a Zend Framework version and in the tutorial that's in the welcome page it says that the zend framework is automatically setup for my php project and could be located in the include path. I looked up that include path and I found the library/zend folder from the zend framework inside the root of my workspace:

    .metadata\.plugins\org.zend.php.framework.resource\resources\ZendFramework-1\library\Zend

    Ok but where did this copy from ? I compared this with the zend framework I have located in:

    C:\Program Files (x86)\Zend\ZendServer\share\ZendFramework\library\Zend

    and they did not match since the one I have on my zend server had 4 files more than the one that flash builder for php automatically set up for me.

    Which makes me think which version of the zend framework I am going to use now for this project, I thought I will use the one I installed and updated to most recent zend framework version on my server but now I am confused...

    Can someone explain, please ?

    DB:2.77:When Creating Flex And Php Project Where Do The Zend Framework Files Come From ? 7f


    When I create a Flex and PHP project it automatically select me a Zend Framework version and in the tutorial that's in the welcome page it says that the zend framework is automatically setup for my php project and could be located in the include path. I looked up that include path and I found the library/zend folder from the zend framework inside the root of my workspace:

    .metadata\.plugins\org.zend.php.framework.resource\resources\ZendFramework-1\library\Zend

    Ok but where did this copy from ? I compared this with the zend framework I have located in:

    C:\Program Files (x86)\Zend\ZendServer\share\ZendFramework\library\Zend

    and they did not match since the one I have on my zend server had 4 files more than the one that flash builder for php automatically set up for me.

    Which makes me think which version of the zend framework I am going to use now for this project, I thought I will use the one I installed and updated to most recent zend framework version on my server but now I am confused...

    Can someone explain, please ?

  • RELEVANCY SCORE 2.77

    DB:2.77:Zend Optimizer Changed The Php.Ini Location xk





    Hi
    I have installed Zend Optimizer 3.3.3 on my Plesk server and it has changed the location of the main php.ini from /etc/php.ini to /usr/local/Zend/etc/php.ini

    Is this a problem, or will it be in the future?
    Everything seems to be working just fine.

    Phpinfo gives this:
    Configuration File (php.ini) Path /etc
    Loaded Configuration File /usr/local/Zend/etc/php.ini

    Thanks

    DB:2.77:Zend Optimizer Changed The Php.Ini Location xk




    This is normal.

    /etc/php.ini is converted into a symlink (softlink) pointing to /usr/locaL/Zend/etc/php.ini when you install Zend Optimizer.

    Try:

    ls -al /etc/php.ini

    to see whats going on.

    Faris.

  • RELEVANCY SCORE 2.76

    DB:2.76:Php Mail() Function Problems zk





    I run a vBulletin on my server with Plesk.

    For some reason, I dont get EMails to my mailbox at orozery@netvision.net.il, also at orozery@012.net.il and also couple of my friends complained they dont get emails as well.

    Other works fine, for example, my hotmail account is getting emails ok.

    Whats the problem?

    DB:2.76:Php Mail() Function Problems zk




    I run a vBulletin on my server with Plesk.

    For some reason, I dont get EMails to my mailbox at orozery@netvision.net.il, also at orozery@012.net.il and also couple of my friends complained they dont get emails as well.

    Other works fine, for example, my hotmail account is getting emails ok.

    Whats the problem?

  • RELEVANCY SCORE 2.76

    DB:2.76:Cant Install The Plesk Billing: Fatal Error: Cannot Redeclare Sha256() In ... p7





    Hello, today I was all the day trying to install the latest plesk billing software in my Linux Cpanel Server.

    I double checked all server requeriments and all are ok (php config, mysql, Zend, ioncube, etc)

    I tried the Zend and the Ioncube version of the plesk billing 6.0.1 tar.gz file, both give me same error in the install process:

    Fatal error: Cannot redeclare sha256() in /home/wizhosti/public_html/clientes/lib-utils/sha256.php on line 212



    PHP cURL Auto-Detected Answers
    What is PHP cURL? PHP cURL is simply cURL that has already been compiled into your PHP installation. The following tests will determine if your PHP is configured with cURL.
    PHP cURL Enabled? PHP cURL is available.
    PHP cURL Test OK
    PHP cURL Version 7.20.0
    PHP cURL SSL? OpenSSL/0.9.8b

    CLI cURL Auto-Detected Answers
    What is CLI cURL? CLI cURL is simply cURL that is installed on your server and is accessed via the command line. The following tests will determine if your server already has cURL installed and configured correctly.
    CLI cURL Enabled? Skipped
    CLI cURL Test? Skipped
    CLI cURL Path? cURL NOT FOUND
    CLI cURL Version w/ SSL? Skipped

    System Test - Database Connection

    NOTE: Please double check your database and URL settings below before you continue.

    Questions Auto-Detected Answers
    DB Type? mysql
    Database config file? /include/config/config.php
    DB Hostname? 127.0.0.1
    DB Name? wizhosti_billing
    DB Username? wizhosti_billing
    DB Password? ************
    Connection Test 1? mysql connection OK.
    Connection Test 2? wizhosti_billing connection OK.

    System Test - PHP

    NOTE: We will now attempt to determine your PHP settings below. If you see any settings in red, please review the description for more information. If you make changes to your php.ini file, please restart your web server, then refresh this page.

    General Questions Auto-Detected Answers
    Where is your php.ini file?
    What is your include_path? .:/usr/lib/php:/usr/local/lib/php
    Is Zend Optimizer installed? Yes, Zend Optimizer is installed. You may use the Zend version of ModernBill.
    Is ionCube Loader installed? Yes, ionCube loader is already installed and run-time loading is unnecessary. You may use the ionCube version of ModernBill.

    PHP Settings and Capabilities

    Critical requirements are satisfied. You may continue.

    * You SHOULD have the php.ini setting disable_functions unset for proper operation [you do not].
    * You MAY have the sysvshm extension loaded for Unix performance optimizations [you do not].
    * You MAY have the sysvsem extension loaded for Unix performance optimizations [you do not].

    DB:2.76:Cant Install The Plesk Billing: Fatal Error: Cannot Redeclare Sha256() In ... p7




    Hello, today I was all the day trying to install the latest plesk billing software in my Linux Cpanel Server.

    I double checked all server requeriments and all are ok (php config, mysql, Zend, ioncube, etc)

    I tried the Zend and the Ioncube version of the plesk billing 6.0.1 tar.gz file, both give me same error in the install process:

    Fatal error: Cannot redeclare sha256() in /home/wizhosti/public_html/clientes/lib-utils/sha256.php on line 212



    PHP cURL Auto-Detected Answers
    What is PHP cURL? PHP cURL is simply cURL that has already been compiled into your PHP installation. The following tests will determine if your PHP is configured with cURL.
    PHP cURL Enabled? PHP cURL is available.
    PHP cURL Test OK
    PHP cURL Version 7.20.0
    PHP cURL SSL? OpenSSL/0.9.8b

    CLI cURL Auto-Detected Answers
    What is CLI cURL? CLI cURL is simply cURL that is installed on your server and is accessed via the command line. The following tests will determine if your server already has cURL installed and configured correctly.
    CLI cURL Enabled? Skipped
    CLI cURL Test? Skipped
    CLI cURL Path? cURL NOT FOUND
    CLI cURL Version w/ SSL? Skipped

    System Test - Database Connection

    NOTE: Please double check your database and URL settings below before you continue.

    Questions Auto-Detected Answers
    DB Type? mysql
    Database config file? /include/config/config.php
    DB Hostname? 127.0.0.1
    DB Name? wizhosti_billing
    DB Username? wizhosti_billing
    DB Password? ************
    Connection Test 1? mysql connection OK.
    Connection Test 2? wizhosti_billing connection OK.

    System Test - PHP

    NOTE: We will now attempt to determine your PHP settings below. If you see any settings in red, please review the description for more information. If you make changes to your php.ini file, please restart your web server, then refresh this page.

    General Questions Auto-Detected Answers
    Where is your php.ini file?
    What is your include_path? .:/usr/lib/php:/usr/local/lib/php
    Is Zend Optimizer installed? Yes, Zend Optimizer is installed. You may use the Zend version of ModernBill.
    Is ionCube Loader installed? Yes, ionCube loader is already installed and run-time loading is unnecessary. You may use the ionCube version of ModernBill.

    PHP Settings and Capabilities

    Critical requirements are satisfied. You may continue.

    * You SHOULD have the php.ini setting disable_functions unset for proper operation [you do not].
    * You MAY have the sysvshm extension loaded for Unix performance optimizations [you do not].
    * You MAY have the sysvsem extension loaded for Unix performance optimizations [you do not].

  • RELEVANCY SCORE 2.75

    DB:2.75:404 Error After Install sp


    I have an OracleXE database on Win2003. Works fine.
    I installed Apache 1.3. Works fine.

    I downloaded and installed the ZendCore for Oracle and when I try to access the admin console at http://localhost/ZendCore I get a 404 error.

    The httpd.conf has entries for:
    LoadModule php5_module "D:/Program Files/Zend/Core For Oracle/bin/php5apache.dll"
    SetEnv PHPRC "D:/Program Files/Zend/Core For Oracle/etc"
    IfModule mod_mime.c
    AddType application/x-httpd-php .php
    /IfModule
    Location /ZendCore
    AllowOverride none
    Order deny,allow
    Allow from all
    /Location
    Alias /ZendCore "D:/Program Files/Zend/Core For Oracle/GUI"

    Files are there. If I try and go directly to D:/Program Files/Zend/Core For Oracle/GUI it trys to load index.php which doesn't work, so something is wrong with the PHP environment. I can deinstall / reinstall, but I'd rather have something definite to look at.

    Ideas?

    DB:2.75:404 Error After Install sp

    The answer was to disable IIS.

    I had seen it listed during the install of ZendCore, but I didn't realize that it was running. In fact, going to 127.0.0.1 took me to the Apache docroot. I went to the computer admin, services and diabled it.

  • RELEVANCY SCORE 2.75

    DB:2.75:Php-Sqlite2 Problem After Upgrade mx





    Hello,

    I have recently upgraded php to 5.2.x from 5.1.x and removed php-sqlite2 and sb-publish to fix some dependency issues. However, I need Sitebuilder so after the upgrade I tried to reinstall php-sqlite2 and get an error which appears to say I require at least php5.2.0?

    yum install php-sqlite2
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * addons: centos.arcticnetwork.ca
    * atomic: www.atomicorp.com
    * base: centos.arcticnetwork.ca
    * extras: centos.arcticnetwork.ca
    * updates: www.ontime1405.com
    Setting up Install Process
    Resolving Dependencies
    -- Running transaction check
    --- Package php-sqlite2.i386 0:5.1.6-200705230938 set to be updated
    -- Processing Dependency: php = 5.2.0 for package: php-sqlite2
    -- Finished Dependency Resolution
    php-sqlite2-5.1.6-200705230938.i386 from plesk has depsolving problems
    -- Missing Dependency: php = 5.2.0 is needed by package php-sqlite2-5.1.6-200705230938.i386 (plesk)
    Error: Missing Dependency: php = 5.2.0 is needed by package php-sqlite2-5.1.6-200705230938.i386 (plesk)

    However, I am running php5.2.x

    php -v

    PHP 5.2.12 (cli) (built: Jan 31 2010 11:31:11)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
    with the ionCube PHP Loader v3.1.29, Copyright (c) 2002-2007, by ionCube Ltd.

    Would I be ok to download the rpm and force the install?

    Thank you,

    DB:2.75:Php-Sqlite2 Problem After Upgrade mx




    Hello,

    I have recently upgraded php to 5.2.x from 5.1.x and removed php-sqlite2 and sb-publish to fix some dependency issues. However, I need Sitebuilder so after the upgrade I tried to reinstall php-sqlite2 and get an error which appears to say I require at least php5.2.0?

    yum install php-sqlite2
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * addons: centos.arcticnetwork.ca
    * atomic: www.atomicorp.com
    * base: centos.arcticnetwork.ca
    * extras: centos.arcticnetwork.ca
    * updates: www.ontime1405.com
    Setting up Install Process
    Resolving Dependencies
    -- Running transaction check
    --- Package php-sqlite2.i386 0:5.1.6-200705230938 set to be updated
    -- Processing Dependency: php = 5.2.0 for package: php-sqlite2
    -- Finished Dependency Resolution
    php-sqlite2-5.1.6-200705230938.i386 from plesk has depsolving problems
    -- Missing Dependency: php = 5.2.0 is needed by package php-sqlite2-5.1.6-200705230938.i386 (plesk)
    Error: Missing Dependency: php = 5.2.0 is needed by package php-sqlite2-5.1.6-200705230938.i386 (plesk)

    However, I am running php5.2.x

    php -v

    PHP 5.2.12 (cli) (built: Jan 31 2010 11:31:11)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
    with the ionCube PHP Loader v3.1.29, Copyright (c) 2002-2007, by ionCube Ltd.

    Would I be ok to download the rpm and force the install?

    Thank you,

  • RELEVANCY SCORE 2.74

    DB:2.74:Centos5/Parallels Pro 10.3.0 - Php And High Security Sites 3x





    Hi folks.

    Ive been migrating sites from an older Ensim 4.1 box (Linux) to a new shiny CentOS/Parallels Pro 10.3 box.

    Alls well with the exception of high security sites that use php. I followed the thread at:
    http://forum.swsoft.com/showthread.php?t=50484highlight=high+security+sites+php
    with interest as it is exactly my problem, but the solution seems to be different.

    Regardless of commenting the zend line in /etc/php.ini:



    ; Enable the PHP scripting language engine under Apache.
    engine = On

    ; Enable compatibility mode with Zend Engine 1 (PHP 4.x)
    zend.ze1_compatibility_mode = Off

    DB:2.74:Centos5/Parallels Pro 10.3.0 - Php And High Security Sites 3x




    SOLVED: Imported sites in high-security mode give Error 500 for php pages

    The issue was resolved by applying the KB fix as described here:

    http://kb.odin.com/en/2916

    For the benefit of others, this script must be run after importing sites from previous version(s) of Ensim/Parallels which ran PHP4. After import, this script copies



    /etc/virtualhosting/templates/apache/var/www/interpreters/php-script

  • RELEVANCY SCORE 2.74

    DB:2.74:Zend Optimizer Plesk 9.0 Problem 3x





    I`m need to use Zend Optimizer on Ubuntu 8.04 with Plesk 9.0.
    After the installation was the next errors:

    In apache log:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1096179541 bytes) in /var/www/vhosts/joblibrary.ru/httpdocs/dev/umitest.php on line 1

    Fatal error: Call to undefined function (null)() in /var/www/vhosts/joblibrary.ru/httpdocs/dev/umitest.php on line 1
    [Tue Jan 13 10:19:02 2009] [notice] child pid 25915 exit signal Segmentation fault (11)
    [Tue Jan 13 10:19:05 2009] [notice] child pid 25909 exit signal Segmentation fault (11)
    [Tue Jan 13 10:19:07 2009] [notice] child pid 25906 exit signal Segmentation fault (11)

    # php -v
    PHP 5.2.4-2ubuntu5.4 with Suhosin-Patch 0.9.6.2 (cli) (built: Nov 25 2008 22:10:31)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with the ionCube PHP Loader v3.1.29, Copyright (c) 2002-2007, by ionCube Ltd., and
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies
    Segmentation fault

    DB:2.74:Zend Optimizer Plesk 9.0 Problem 3x




    The post above just disabled ioncube. I later realized that there was one site out of 200 that needed it for one page so it had to go back in.

    I moved the stuff for zend out of the php.ini file into the file that I renamed /etc/php.d/ioncube-loader.ini to /etc/php.d/ioncube-and-zend.ini. Then I undid the symbolic link for the php.ini file that the zend installer made and put the php.ini file where it belonged.

    I have no idea why the zend installed put the thread safety files in there along with the non-TS files. I just commented out the TS ones. Each line under the [Zend] section is what the installer put in there. Here is what my ioncube-and-zend.ini says:

    zend_extension=/usr/lib/php4/ioncube_loader_lin_4.3.so

    [Zend]
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3
    ;zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3
    zend_optimizer.version=3.3.3
    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    ;zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

  • RELEVANCY SCORE 2.74

    DB:2.74:Php Mail Not Working 91



    Hello,

    I recently setup a new LAMP server and moved a forum to it. However PHP Mail doesnt seem to be working, at least not with vBulletin. Any ideas?

    Thanks.

    DB:2.74:Php Mail Not Working 91


    sendmail binary is just /usr/sbin/sendmail here; it does not have to be sendmail from sendmail.org itself, just standard sendmail-compatible interface that can be - and usually is - provided by other MTA. Including postfix, with no additional setup needed.

  • RELEVANCY SCORE 2.74

    DB:2.74:Php Modules, Undefined Symbol: Php_Pcre_Exec In Unknown On Line 0 cm





    I keep getting the following error message on one of my Plesk machines running 10.4.4:



    server#php -v
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php/modules/fileinfo.so - /usr/lib/php/modules/fileinfo.so: undefined symbol: php_pcre_exec in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library /usr/lib/php/modules/zip.so - /usr/lib/php/modules/zip.so: undefined symbol: php_pcre_exec in Unknown on line 0
    PHP 5.3.3 (cli) (built: Feb 22 2012 19:37:49)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.7, Copyright (c) 2002-2011, by ionCube Ltd.

    DB:2.74:Php Modules, Undefined Symbol: Php_Pcre_Exec In Unknown On Line 0 cm




    Oh I have the same issue but with Plesk 11.0.9 in Centos 5.6 64bit. Could anybody send to me those files for replace my bad ones please? Thanks in advance.

  • RELEVANCY SCORE 2.74

    DB:2.74:Zend Problem After Upgrade cd





    hello,

    after my upgrade to 8.0 Zend Optmizer no longer works on my server. Ive found a couple threads on the forum, but nothing really seemed to answer my problem.

    [root@sv01 ~]# php -v
    PHP: Error parsing /etc/php.ini on line 2
    PHP 4.3.9 (cgi) (built: Nov 4 2005 11:49:35)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.0.10, Copyright (c) 2002-2005, by ionCube Ltd.

    Ive tried to reinstall zend but it didnt fix the problem. Anyone know a solution?

    Thanks

    DB:2.74:Zend Problem After Upgrade cd




    You didnt type in the # did you? That was just showing that I ran the command as root.

    Did you look at your php.ini file in the Zend etc directory to see what version it had listed?

  • RELEVANCY SCORE 2.73

    DB:2.73:Php-4.4.0 + Zendoptimizer-2.5.10a - Help! cc





    Could someone please help on getting them to work?

    Ive tried installing and here is what I got:



    # php -v
    PHP Warning: Zend Optimizer for PHP 4.4.x cannot be found (expected at /usr/lo
    cal/Zend/lib/Optimizer-2.5.0/php-4.4.x/ZendOptimizer.so) - try reinstalling the
    Zend Optimizer in Unknown on line 0
    PHP 4.4.0 (cli) (built: Aug 9 2005 05:33:29)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v2.4, Copyright (c) 2002-2003, by ionCube Ltd.,
    and
    with Zend Extension Manager v1.0.8, Copyright (c) 2003-2005, by Zend Technol
    ogies

    DB:2.73:Php-4.4.0 + Zendoptimizer-2.5.10a - Help! cc




    Nevermind, uninstalled it and re-installed.

    Worked this time.

  • RELEVANCY SCORE 2.73

    DB:2.73:Php/Modernbill Question 9z





    I have setup one server with RH9, Plesk 7.5.3 and Modernbill and everything works well. But I tried to setup another one and have run into a problem.

    When I try to run the install script using the browser I get this error:

    Parse error: parse error in /home/httpd/vhosts/secure.domain.com/httpsdocs/modernbill/install_v4/index.php on line 89

    I have Zend installed and I think thats where my problem is. I inserted a info.php page and noticed a difference in the configuration file path.

    On the server that works its /etc/php.ini

    On the one that doesnt its /usr/local/Zend/etc/php.ini

    What would cause this and how do I fix it?

    Thanks,

    Sonny

  • RELEVANCY SCORE 2.72

    DB:2.72:Php Fatal Error: Call To Undefined Function Dbconnect() dc





    Running into error when moving ModernBill from PHP4 to PHP5. Upgrading servers and new servers have PHP5. We are receiving this error PHP Fatal error: Call to undefined function dbconnect().

    Our new ModernBill version (doesnt work):
    Downloaded modernbill-v4-stable-zend5.tar.gz and untared it, supposed to be for PHP5.

    Our new PHP version:
    5.2.9 with Suhosin-Patch 0.9.7 (cli) (built: Mar 16 2009 18:29:43)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

    Our old ModernBill Version (which works great):
    MB:4.4.2:B-3:K:001:41

    Our old PHP Version:
    PHP 4.4.9 with Suhosin-Patch 0.9.6 (cli) (built: Aug 20 2008 19:33:03)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with Zend Extension Manager v1.0.9, Copyright (c) 2003-2005, by Zend Technologies
    with Zend Optimizer v2.6.0, Copyright (c) 1998-2005, by Zend Technologies

    Any suggestions would be helpful.

    DB:2.72:Php Fatal Error: Call To Undefined Function Dbconnect() dc




    Figured it out. Thought Zend was installed, when its listed as Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies however, OPTIMIZER needs to be installed too. Such a simple fix.

  • RELEVANCY SCORE 2.72

    DB:2.72:Zend Optimizer 3 And Plesk 8.3 a1





    I need to update the current zend optimizer from 2.2 to latest 3.x

    Do you have some ideas?

    Can I try the script in Zend distribution?

    Thankyou in advance

    this is my php info:
    [root@www ~]# php -v
    PHP 5.2.5 (cli) (built: Nov 20 2007 17:51:47)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with the ionCube PHP Loader v3.1.29, Copyright (c) 2002-2007, by ionCube Ltd.
    [root@www ~]#

    DB:2.72:Zend Optimizer 3 And Plesk 8.3 a1




    If you are using the rpms from [atomic]:

    yum remove php-zend-optimizer

  • RELEVANCY SCORE 2.72

    DB:2.72:Suncc And Php Compatibility fj


    it seems that suncc have some trouble when working with PHP,hope you can imporve it:

    luoyi@4Email:~/src/lylib/trunk/topbuild$ cat do.sh
    #!/bin/sh
    echo "**************** first gcc *****************"
    make -B lib/xarray_php5.do
    echo "**************** then icc *****************"
    make -B lib/xarray_php5.do INTEL=1
    echo "**************** then pgroup *****************"
    make -B lib/xarray_php5.do PGROUP=1
    echo "**************** then pathscale *****************"
    make -B lib/xarray_php5.do PATHSCALE=1
    echo "**************** then suncc *****************"
    make -B lib/xarray_php5.do SUN=1

    luoyi@4Email:~/src/lylib/trunk/topbuild$ ./do.sh
    **************** first gcc *****************
    g++ -c -shared -fpic -fPIC -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -march=i686 -O2 -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    [DEP] ./build/dep/xarray.d
    **************** then icc *****************
    icpc -c -shared -fpic -fPIC -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -O3 -parallel -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    [DEP] ./build/dep/xarray.d
    **************** then pgroup *****************
    pgCC -c -shared -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -fastsse -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    [DEP] ./build/dep/xarray.d
    **************** then pathscale *****************
    pathCC -c -shared -fpic -fPIC -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -march=i686 -O2 -ipa -ffast-stdlib -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    [DEP] ./build/dep/xarray.d
    **************** then suncc *****************
    sunCC -library=stlport4 -c -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -fast -Bdynamic -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    "/usr/local/include/php/Zend/zend_alloc.h", line 34: Error: Type name expected instead of "uint".
    "/usr/local/include/php/Zend/zend_alloc.h", line 36: Error: Type name expected instead of "uint".
    "/usr/local/include/php/Zend/zend_hash.h", line 39: Error: "," expected instead of "(".
    "/usr/local/include/php/Zend/zend_hash.h", line 50: Error: Type name expected instead of "uint".
    "/usr/local/include/php/Zend/zend_hash.h", line 61: Error: Type name expected instead of "uint".
    "/usr/local/include/php/Zend/zend_hash.h", line 62: Error: Type name expected instead of "uint".
    "/usr/local/include/php/Zend/zend_hash.h", line 63: Error: Type name expected instead of "uint".
    "/usr/local/include/php/Zend/zend_hash.h", line 81: Error: Type name expected instead of "uint".
    "/usr/local/include/php/Zend/zend_hash.h", line 93: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 94: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 101: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 107: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 113: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 119: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 147: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 153: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 156: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 157: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 161: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 162: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 172: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 177: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 207: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 208: Error: uint is not defined.
    "/usr/local/include/php/Zend/zend_hash.h", line 209: Error: uint is not defined.
    Compilation aborted, too many Error messages.
    make: *** [lib/xarray_php5.do] Error 1

    luoyi@4Email:~/src/lylib/trunk/topbuild$ head ../cnqp/xarray/source/xarray.cpp
    // xarray = xml array
    // usage: php -r '$xml=file_get_contents("./data.xml");
    // $xml=iconv("GBK", "UTF-8", $xml);
    // $xml=str_replace("encoding=\"GBK\"", "encoding=\"UTF-8\"", $xml);
    // print_r(xmlarray($xml));'

    #include "php.h"
    #include "zend_API.h"
    #include "expat.h"
    #include "cnqp_log.h"

    Message was edited by:
    luoyi82

    DB:2.72:Suncc And Php Compatibility fj

    oh, yes, thx for your reply. I can get it compile now:

    luoyi@4Email:~/src/lylib/trunk/topbuild$ ./do.sh
    **************** first gcc *****************
    g++ -c -shared -fpic -fPIC -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -march=i686 -O2 -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    [DEP] ./build/dep/xarray.d
    **************** then icc *****************
    icpc -c -shared -fpic -fPIC -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -O3 -parallel -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    [DEP] ./build/dep/xarray.d
    **************** then pgroup *****************
    pgCC -c -shared -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -fastsse -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    [DEP] ./build/dep/xarray.d
    **************** then pathscale *****************
    pathCC -c -shared -fpic -fPIC -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -march=i686 -O2 -ipa -ffast-stdlib -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    [DEP] ./build/dep/xarray.d
    **************** then suncc *****************
    sunCC -library=stlport4 -c -KPIC -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/local/include -fast -DLINUX -D_GNU_SOURCE -Bdynamic -o lib/xarray_php5.do ../cnqp/xarray/source/xarray.cpp
    "/usr/local/include/php/main/streams/php_stream_filter_api.h", line 66: Warning: Identifier expected instead of "}".
    "../cnqp/xarray/source/xarray.cpp", line 20: Warning: String literal converted to char* in initialization.
    "../cnqp/xarray/source/xarray.cpp", line 23: Warning: String literal converted to char* in initialization.
    "../cnqp/xarray/source/xarray.cpp", line 45: Warning: String literal converted to char* in initialization.
    "../cnqp/xarray/source/xarray.cpp", line 45: Warning (Anachronism): Using void(*)(int,_zval_struct*,_zval_struct**,_zval_struct*,int) to initialize extern "C" void(*)(int,_zval_struct*,_zval_struct**,_zval_struct*,int).
    "../cnqp/xarray/source/xarray.cpp", line 53: Warning: String literal converted to char* in initialization.
    "../cnqp/xarray/source/xarray.cpp", line 61: Warning: String literal converted to char* in initialization.
    "../cnqp/xarray/source/xarray.cpp", line 223: Warning: String literal converted to char* in formal argument type_spec in call to zend_parse_parameters(int, char*, ...).
    8 Warning(s) detected.
    [DEP] ./build/dep/xarray.d

    BTW: do you have any option that can make string literal not "const" ? so it'll not throw so many warnings.

  • RELEVANCY SCORE 2.72

    DB:2.72:Zend Error After Update sx





    Hi

    I have searched and come across several postings and have tried everything without success.

    server is plesk 7.5.4 rhel3 and all I did was update sitebuilder using the updater. Apache failed to start after it installed and I found this error:
    PHP Fatal error: [ionCube Loader] The Loader must appear in the php.ini file before other extensions in Unknown on line 0

    I looked at the php.ini and found:
    [Zend]
    ;zend_optimizer.optimization_level=15
    ;zend_extension = /usr/lib/ioncube/Ioncube_loader_lin_4.3.so
    ;zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-2.5.7
    ;zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-2.5.7
    ;zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    ;zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

    I commented out the lines to get apache up.

    I added the second line per a post, no help..
    I checked and php.d/ioncube.ini already was commented out.

    php -v displays
    PHP 4.3.10 (cgi) (built: Dec 16 2004 13:42:39)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.0.10, Copyright (c) 2002-2005, by ionCube Ltd.

    So is it working even though it looks commented out?

    Thanks in advance for your help

    Chuck

    DB:2.72:Zend Error After Update sx




    Hi

    I have searched and come across several postings and have tried everything without success.

    server is plesk 7.5.4 rhel3 and all I did was update sitebuilder using the updater. Apache failed to start after it installed and I found this error:
    PHP Fatal error: [ionCube Loader] The Loader must appear in the php.ini file before other extensions in Unknown on line 0

    I looked at the php.ini and found:
    [Zend]
    ;zend_optimizer.optimization_level=15
    ;zend_extension = /usr/lib/ioncube/Ioncube_loader_lin_4.3.so
    ;zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-2.5.7
    ;zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-2.5.7
    ;zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    ;zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

    I commented out the lines to get apache up.

    I added the second line per a post, no help..
    I checked and php.d/ioncube.ini already was commented out.

    php -v displays
    PHP 4.3.10 (cgi) (built: Dec 16 2004 13:42:39)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.0.10, Copyright (c) 2002-2005, by ionCube Ltd.

    So is it working even though it looks commented out?

    Thanks in advance for your help

    Chuck

  • RELEVANCY SCORE 2.72

    DB:2.72:Linker Problem Compiling Oci8 On Php 5.2.5 8s


    System:

    Red Hat Enterprise Linux Server release 5.1 (Tikanga)
    GNU ld version 2.17.50.0.6-5.el5 20061020
    gcc version 4.1.2 20070626 (Red Hat 4.1.2-14)

    Problem:

    I've downloaded and extracted the basic and sdk into:

    /opt/oracle/instantclient_11_1

    Configure works fine:

    ./configure build=i686-redhat-linux-gnu host=i686-redhat-linux-gnu target=i386-redhat-linux-gnu program-prefix= prefix=/usr exec-prefix=/usr bindir=/usr/bin sbindir=/usr/sbin sysconfdir=/etc datadir=/usr/share includedir=/usr/include libdir=/usr/lib libexecdir=/usr/libexec localstatedir=/var sharedstatedir=/usr/com mandir=/usr/share/man infodir=/usr/share/info cache-file=../config.cache with-libdir=lib with-config-file-path=/etc with-config-file-scan-dir=/etc/php.d disable-debug with-pic disable-rpath without-pear with-bz2 with-curl with-exec-dir=/usr/bin with-freetype-dir=/usr with-png-dir=/usr enable-gd-native-ttf without-gdbm with-gettext with-gmp with-iconv with-jpeg-dir=/usr with-openssl with-png with-pspell with-expat-dir=/usr with-pcre-regex=/usr with-zlib with-layout=GNU enable-exif enable-ftp enable-magic-quotes enable-sockets enable-sysvsem enable-sysvshm enable-sysvmsg enable-track-vars enable-trans-sid enable-yp enable-wddx with-kerberos enable-ucd-snmp-hack with-unixODBC=shared,/usr enable-memory-limit enable-shmop enable-calendar enable-dbx enable-dio with-mime-magic=/etc/httpd/conf/magic without-sqlite with-libxml-dir=/usr with-xml with-apxs2=/usr/sbin/apxs with-mysql=/usr/lib/mysql without-gd without-odbc disable-dom disable-dba without-unixODBC disable-pdo disable-xmlreader disable-xmlwriter --with-oci8=instantclient,/opt/oracle/instantclient_11_1

    Bellow is the error that comes up when i try to compile:

    # make
    /bin/sh /root/sources/php-5.2.5/libtool silent preserve-dup-deps --mode=link gcc -export-dynamic -I/usr/include -g -O2 -L/usr/kerberos/lib -L/usr/lib/mysql -L/opt/oracle/instantclient_11_1 ext/libxml/libxml.lo ext/openssl/openssl.lo ext/openssl/xp_ssl.lo ext/pcre/php_pcre.lo ext/zlib/zlib.lo ext/zlib/zlib_fopen_wrapper.lo ext/zlib/zlib_filter.lo ext/bz2/bz2.lo ext/bz2/bz2_filter.lo ext/calendar/calendar.lo ext/calendar/dow.lo ext/calendar/french.lo ext/calendar/gregor.lo ext/calendar/jewish.lo ext/calendar/julian.lo ext/calendar/easter.lo ext/calendar/cal_unix.lo ext/ctype/ctype.lo ext/curl/interface.lo ext/curl/multi.lo ext/curl/streams.lo ext/date/php_date.lo ext/date/lib/astro.lo ext/date/lib/dow.lo ext/date/lib/parse_date.lo ext/date/lib/parse_tz.lo ext/date/lib/timelib.lo ext/date/lib/tm2unixtime.lo ext/date/lib/unixtime2tm.lo ext/exif/exif.lo ext/filter/filter.lo ext/filter/sanitizing_filters.lo ext/filter/logical_filters.lo ext/filter/callback_filter.lo ext/ftp/php_ftp.lo ext/ftp/ftp.lo ext/gettext/gettext.lo ext/gmp/gmp.lo ext/hash/hash.lo ext/hash/hash_md.lo ext/hash/hash_sha.lo ext/hash/hash_ripemd.lo ext/hash/hash_haval.lo ext/hash/hash_tiger.lo ext/hash/hash_gost.lo ext/hash/hash_snefru.lo ext/hash/hash_whirlpool.lo ext/hash/hash_adler32.lo ext/hash/hash_crc32.lo ext/iconv/iconv.lo ext/json/json.lo ext/json/utf8_to_utf16.lo ext/json/utf8_decode.lo ext/json/JSON_parser.lo ext/mime_magic/mime_magic.lo ext/mysql/php_mysql.lo ext/oci8/oci8.lo ext/oci8/oci8_lob.lo ext/oci8/oci8_statement.lo ext/oci8/oci8_collection.lo ext/oci8/oci8_interface.lo ext/posix/posix.lo ext/pspell/pspell.lo ext/reflection/php_reflection.lo ext/session/session.lo ext/session/mod_files.lo ext/session/mod_mm.lo ext/session/mod_user.lo ext/shmop/shmop.lo ext/simplexml/simplexml.lo ext/sockets/sockets.lo ext/spl/php_spl.lo ext/spl/spl_functions.lo ext/spl/spl_engine.lo ext/spl/spl_iterators.lo ext/spl/spl_array.lo ext/spl/spl_directory.lo ext/spl/spl_sxe.lo ext/spl/spl_exceptions.lo ext/spl/spl_observer.lo regex/regcomp.lo regex/regexec.lo regex/regerror.lo regex/regfree.lo ext/standard/array.lo ext/standard/base64.lo ext/standard/basic_functions.lo ext/standard/browscap.lo ext/standard/crc32.lo ext/standard/crypt.lo ext/standard/cyr_convert.lo ext/standard/datetime.lo ext/standard/dir.lo ext/standard/dl.lo ext/standard/dns.lo ext/standard/exec.lo ext/standard/file.lo ext/standard/filestat.lo ext/standard/flock_compat.lo ext/standard/formatted_print.lo ext/standard/fsock.lo ext/standard/head.lo ext/standard/html.lo ext/standard/image.lo ext/standard/info.lo ext/standard/iptc.lo ext/standard/lcg.lo ext/standard/link.lo ext/standard/mail.lo ext/standard/math.lo ext/standard/md5.lo ext/standard/metaphone.lo ext/standard/microtime.lo ext/standard/pack.lo ext/standard/pageinfo.lo ext/standard/quot_print.lo ext/standard/rand.lo ext/standard/reg.lo ext/standard/soundex.lo ext/standard/string.lo ext/standard/scanf.lo ext/standard/syslog.lo ext/standard/type.lo ext/standard/uniqid.lo ext/standard/url.lo ext/standard/url_scanner.lo ext/standard/var.lo ext/standard/versioning.lo ext/standard/assert.lo ext/standard/strnatcmp.lo ext/standard/levenshtein.lo ext/standard/incomplete_class.lo ext/standard/url_scanner_ex.lo ext/standard/ftp_fopen_wrapper.lo ext/standard/http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo ext/standard/credits.lo ext/standard/css.lo ext/standard/var_unserializer.lo ext/standard/ftok.lo ext/standard/sha1.lo ext/standard/user_filters.lo ext/standard/uuencode.lo ext/standard/filters.lo ext/standard/proc_open.lo ext/standard/streamsfuncs.lo ext/standard/http.lo ext/sysvmsg/sysvmsg.lo ext/sysvsem/sysvsem.lo ext/sysvshm/sysvshm.lo ext/tokenizer/tokenizer.lo ext/tokenizer/tokenizer_data.lo ext/wddx/wddx.lo ext/xml/xml.lo ext/xml/compat.lo TSRM/TSRM.lo TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/safe_mode.lo main/fopen_wrappers.lo main/alloca.lo main/php_scandir.lo main/php_ini.lo main/SAPI.lo main/rfc1867.lo main/php_content_types.lo main/strlcpy.lo main/strlcat.lo main/mergesort.lo main/reentrancy.lo main/php_variables.lo main/php_ticks.lo main/network.lo main/php_open_temporary_file.lo main/php_logos.lo main/output.lo main/streams/streams.lo main/streams/cast.lo main/streams/memory.lo main/streams/filter.lo main/streams/plain_wrapper.lo main/streams/userspace.lo main/streams/transports.lo main/streams/xp_socket.lo main/streams/mmap.lo Zend/zend_language_parser.lo Zend/zend_language_scanner.lo Zend/zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/zend_alloc.lo Zend/zend_compile.lo Zend/zend_constants.lo Zend/zend_dynamic_array.lo Zend/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_strtod.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/php_cli_readline.lo sapi/cli/getopt.lo main/internal_functions_cli.lo -laspell -lpspell -lmysqlclient -lgmp -lcurl -lbz2 -lz -lpcre -lresolv -lm -ldl -lnsl -lxml2 -lz -lm -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lssl -lcrypto -ldl -lz -lcurl -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv -ldl -lidn -lssl -lcrypto -lz -lssl -lcrypto -ldl -lz -lclntsh -lxml2 -lz -lm -lxml2 -lz -lm -lxml2 -lz -lm -o sapi/cli/php
    /usr/bin/ld: warning: libnnz11.so, needed by /opt/oracle/instantclient_11_1/libclntsh.so, not found (try using -rpath or -rpath-link)
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_ModifyCipherSuites'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosCipherSpecToStr'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Initialize'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosgpc_GetProtocolVer'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztwOpenWallet'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `A_X931RandomInit'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_SetSqlnetFunc'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosGetSupportedCipher'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_ServiceWriteQueue'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_DisableClientAuthentication'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztiGetSecInfo'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Write'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzduui2_destroy_ui'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztGetSubjectName'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzgbllsm_location_shared_memory'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_setThrUse'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzteMyCert'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzteDestroyPersona'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_RetrievePersonaCopy'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosSCCS_SetCRLCacheSize'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztnGCL_Get_Certificate_List'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzumfree'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_setCRLFile'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `A_X931RandomContextDestroy'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_OToolkitContext'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_setOIDConnInfo'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosaccrb_aysnCheckRecbuf'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzhdcgldn_getldapdn'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_SetFuncvec'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzustralloc'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzstrfc_free_content'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Read'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Destroy_Ctx'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzssGEBV_GetEntryByValue'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `snzdafn_assemble_filename'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Configure'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosSetCredential'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzdst_terminate'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosSetCipherSuite'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzumalloc'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztiGCC_Get_CertCtx'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztiFIL_Free_Identity_List'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Handshake'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztwRetrievePersonaCopy'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosGetPeerCredential'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzdcgui_get_userinfo'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Deinitialize'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `A_X931RandomGenerateBytes'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzuexid_initdl'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_setCRLPath'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztwCloseWallet'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzteOpenPersona'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_OpenWallet'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Close'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzstr_alloc'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_enableHWAcc'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzssGSL_GetSecretLength'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosgnc_GetNegotiatedCipher'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_setCertValProtocol'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzssGS_GetSecret'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Create_Ctx'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztiee_IsEncrEnabled'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `A_X931RandomUpdate'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzdsi_initialize'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzosDestroyCredential'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_setCertValPolicy'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_CompareDN'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztSetAppDefaultLocation'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzos_Get_Ctx'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzdcfcx_free_cert_ctx'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nzduui6_get_name'
    /opt/oracle/instantclient_11_1/libclntsh.so: undefined reference to `nztSearchNZDefault'
    collect2: ld returned 1 exit status
    make: *** [sapi/cli/php] Error 1

    I see that library in there, it is there, but something is not linking right!

    Message was edited by:
    user619189

    Message was edited by:
    user619189

    DB:2.72:Linker Problem Compiling Oci8 On Php 5.2.5 8s

    /app/devtools/gcc-4.2.3-64/bin/g++ -L/home/john/sdc/lib/Linux_2.6.5-7.308.PTF.352368.0-smp.gcc-4.2.3-64 -L/home/john/oracle/lib -L/app/gcc-3.3.4/lib -L/app/gcc-3.2.3/lib -ldl -lpthread -lnsl -lrt -lstdc++ -lvs -lclntsh -L/home/cdev/pkgs/oas/Linux64/oaslinux64_2_4_05_03/lib -loas Linux_2.6.5-7.308.PTF.352368.0-smp.gcc-4.2.3-64-R/db.o Linux_2.6.5-7.308.PTF.352368.0-smp.gcc-4.2.3-64-R/owl.o Linux_2.6.5-7.308.PTF.352368.0-smp.gcc-4.2.3-64-R/queue.o Linux_2.6.5-7.308.PTF.352368.0-smp.gcc-4.2.3-64-R/log.o Linux_2.6.5-7.308.PTF.352368.0-smp.gcc-4.2.3-64-R/titan.o -o /home/amehta17/sdc/bin/Linux_2.6.5-7.308.PTF.352368.0-smp.gcc-4.2.3-64/titan
    /usr/bin/ld: warning: libnnz10.so, needed by /home/john/oracle/lib/libclntsh.so, not found (try using -rpath or -rpath-link)
    /home/amehta17/oracle/lib/libclntsh.so: undefined reference to `nzos_ServiceWriteQueue'
    /home/amehta17/oracle/lib/libclntsh.so: undefined reference to `nzosCipherSpecToStr'
    /home/amehta17/oracle/lib/libclntsh.so: undefined reference to `nzos_setCRLPath'
    /home/amehta17/oracle/lib/libclntsh.so: undefined reference to `nzteOpenPersona'
    /home/amehta17/oracle/lib/libclntsh.so: undefined reference to `nzdsi_initialize'
    .. .. . ..
    .. . . ..

    All these symbols are not defined in libclntsh.so and also does not exist in libnnz10.so.
    I checked 32bit version of libnnz10.so has all above undefined symbols. This looks really weird to me why 64 bit version of libnnz10.so doesn't define these symbols.

    Let me know if you have any idea.

  • RELEVANCY SCORE 2.71

    DB:2.71:Installation Problems, Possible Bug cm





    Hello!

    I installed sitebuilder to one of our servers today.

    OS: CentOs
    Apache: 1.3.37
    WHM 10.8.0 cPanel 10.9.0-S119
    PHP version: 4.4.4
    Zend optimizer + eaccelerator

    OK...So I installed all rpm packs just as described in installation instructions. No errors etc. so it went fine. The problem is that there is no admin, wizard nor install directory in /usr/local/sitebuilder/htdocs.

    Also, this line is displayed durin sb_config:

    Code:

    DB:2.71:Installation Problems, Possible Bug cm







    Originally posted by fernando.cws
    Hi sinimarttonen!

    How you it made to install to sitebuilder with cpanel?
    I tried but of the error of dependences of packages.

    thanks

  • RELEVANCY SCORE 2.71

    DB:2.71:Solution For Php 4.3.10 Upgrade xm





    When upgracing to php 4.3.10 the foreach function and several others seem to be broken. This is not an issue of php but of the Zend optimizer. Upgrading to the latest version (2.5.7) will fix these problems.

    http://bugs.php.net/bug.php?id=31108

    regards
    Jan

    DB:2.71:Solution For Php 4.3.10 Upgrade xm




    When upgracing to php 4.3.10 the foreach function and several others seem to be broken. This is not an issue of php but of the Zend optimizer. Upgrading to the latest version (2.5.7) will fix these problems.

    http://bugs.php.net/bug.php?id=31108

    regards
    Jan

  • RELEVANCY SCORE 2.70

    DB:2.70:Gd Image Save Works In Pure Php But Not In Zend Php? dc



    I produce an imagepng imagepng($img); that readily displays on the screen. When I try to save is as a file imagepng($img, 'save.png'); it does not save the image. When using the same program under ordinary PHP in Windows is saves the file to the folder where the program is saved under htdocs, so it must have something to do with the ZEND installation on MAC. Permissions for the ZEND folder are set to readwrite. Will really appreciate cues to come around this hurdle.

    DB:2.70:Gd Image Save Works In Pure Php But Not In Zend Php? dc


    I produce an imagepng imagepng($img); that readily displays on the screen. When I try to save is as a file imagepng($img, 'save.png'); it does not save the image. When using the same program under ordinary PHP in Windows is saves the file to the folder where the program is saved under htdocs, so it must have something to do with the ZEND installation on MAC. Permissions for the ZEND folder are set to readwrite. Will really appreciate cues to come around this hurdle.

  • RELEVANCY SCORE 2.70

    DB:2.70:Php Not Installed j1





    I installed plesk 9.5.3. with the included php

    # /usr/local/psa/admin/bin/php -v
    PHP 5.2.6 (cli) (built: Jun 9 2010 10:13:49)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies

    # /usr/bin/php -v
    PHP Warning: Directive safe_mode is deprecated in PHP 5.3 and greater in Unknown on line 0
    PHP 5.3.2 (cli) (built: Mar 5 2010 15:31:46)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

    When I try to create a domain displays the following message:

    PHP support (The component was not installed)

    I modified the php field of the database to psa to 5.2.6 (the value is not installed ) but when I restart the service, the value returns to not installed

    Any Idea??

    Thanks!!!

  • RELEVANCY SCORE 2.70

    DB:2.70:Zend Amf Error On Server a9



    Hi,

    I am new to Zend Framework, i have created an application in Flex and PHP with Zend Framework.

    When i uploaded it on the server, following error is displayed:

    Send failedChannel.Connect.Failed error NetConnection.Call.BadVersion: : url: 'http://www.mydomain.com/app/gateway.php'

    How can i find more details about this error, so that i can sovle the issue?

    Best Regards,

    Alok Jain

    DB:2.70:Zend Amf Error On Server a9


    I have resolved previous error, path to zend Framework was incorrect

    Now i am facing a new error:

    "Channel disconnected before an acknowledgement was received"

    Any Help Please.

    Best Regards,

    Alok Jain

  • RELEVANCY SCORE 2.70

    DB:2.70:Running Php Script With Zend Frmwrk In Windows Task Scheduler k9



    I have a PHP script which includes the Zend framework Mail.php for sending mails.

    I am running a WAMP server and i used DW to create it.

    I want to run my script in every 5 mins, How i can schedule it in Windows task scheduler.

    I tried running a bat which contains the php.exe path and arguments as php file but it gives an error that zend/mail.php not found.

    Please help its really urgent.

    DB:2.70:Running Php Script With Zend Frmwrk In Windows Task Scheduler k9


    Thanks for your response.

    bat file has:

    path of the php.exe -f path of php file.

    But when it runs it gives an error that the zend framework file not found.

    I have a seperate PHP includes folder under which zend FW is stored.

    That folder is marked in includes_paths in php.ini.

  • RELEVANCY SCORE 2.69

    DB:2.69:Failed Loading /Usr/Local/Zend/Lib/Zendextensionmanager.So 8s





    Hi folks,

    Ive imported a site from Ensim 4.1 (on FC1) to Parallels Pro 10.3.0 (on CentOS5.2). Ive updated the virtuals php.ini file to re-point the extensions folder from /usr/lib/php4 (old) to /usr/lib/php/modules, run the update script from http://kb.odin.com/en/2916 to enable php on high-security sites (though this one is medium) and some php pages are failing to load.

    What I see in the virtuals /var/log/httpd/error_log is this, for each page which fails to display(shows blank page in browser)

    Failed loading /usr/local/Zend/lib/ZendExtensionManager.so: /usr/local/Zend/lib/ZendExtensionManager.so: cannot open shared object file: No such file or directory

    Ive looked up and down the box for ZendExtensionManager.so, hoping a symlink would fix the issue, but its just not there.

    I think the site needing this is running vbulletin

    Any ideas, pointers or suggestions would be greatly appreciated.

    Thanks,
    -Ray

    DB:2.69:Failed Loading /Usr/Local/Zend/Lib/Zendextensionmanager.So 8s




    SOLVED: Failed loading /usr/local/Zend/lib/ZendExtensionManager.so

    Well, it is what it is

    I installed the zend optimizer from Zend, following the KB article (http://kb.odin.com/en/2800) relating to FC4 and Ensim 4.1. Alls well, though the instructions on the KB indicate to write a custom install script which was not entirely correct for my particular implementaion.

    Alls said and done, and things are working.

    -Ray

  • RELEVANCY SCORE 2.68

    DB:2.68:Zend Optimizer Or Eaccelerator With Plesk Panel? 3p





    Since the Plesk control panel is all PHP code I was wondering if there would be a performance gain by using Zend Optimizer or Eaccelerator with it.

    Anyone ever try to enable those for the Apache instance that PSA runs under?

    I made a quick attempt with Zend Optimizer but I got load errors.

    Dan

  • RELEVANCY SCORE 2.68

    DB:2.68:Sjsws 7 Sp5 On Fedora Core 10 Compile Error On Php 5.2.9 88


    I am trying to compile php 5.2.9 and get the following error during make: sapi/nsapi/nsapi.c:62:19: error: nsapi.h: No such file or directory

    There was a post (http://developers.sun.com/webtier/reference/techart/php2.html) which seemed to address this problem, but it didn't fix the issue. Also, I have searched for nsapi.h and it is not on the system anywhere... Has anyone come across this problem or have suggestions on how to resolve it?

    OS: fedora core 10
    SJSWS: 7.0 sp5

    ./configure with-mysql with-nsapi=/opt/iplanet/current enable-libgcc with-gd=/usr --enable-sockets
    ....
    ....
    ....
    /bin/sh /root/installs/php/php-5.2.9/libtool silent preserve-dup-deps --mode=compile /root/installs/php/php-5.2.9/meta_ccld -IZend/ -I/root/installs/php/php-5.2.9/Zend/ -DPHP_ATOM_INC -I/rootinstalls/php/php-5.2.9/include -I/root/installs/php/php-5.2.9/main -I/root/installs/php/php-5.2.9 -I/opt/iplanet/current/include -I/opt/iplanet/current/plugins/include -I/usr/include/libxml2 -I/rot/installs/php/php-5.2.9/ext/date/lib -I/usr/include/mysql -I/root/installs/php/php-5.2.9/TSRM -I/root/installs/php/php-5.2.9/Zend -D_REENTRANT -DTHREAD=1 -I/usr/include -g -O2 -pthread -DZTS -refer-non-pic -c /root/installs/php/php-5.2.9/Zend/zend_objects_API.c -o Zend/zend_objects_API.lo
    /bin/sh /root/installs/php/php-5.2.9/libtool silent preserve-dup-deps --mode=compile /root/installs/php/php-5.2.9/meta_ccld -IZend/ -I/root/installs/php/php-5.2.9/Zend/ -DPHP_ATOM_INC -I/rootinstalls/php/php-5.2.9/include -I/root/installs/php/php-5.2.9/main -I/root/installs/php/php-5.2.9 -I/opt/iplanet/current/include -I/opt/iplanet/current/plugins/include -I/usr/include/libxml2 -I/rot/installs/php/php-5.2.9/ext/date/lib -I/usr/include/mysql -I/root/installs/php/php-5.2.9/TSRM -I/root/installs/php/php-5.2.9/Zend -D_REENTRANT -DTHREAD=1 -I/usr/include -g -O2 -pthread -DZTS -refer-non-pic -c /root/installs/php/php-5.2.9/Zend/zend_default_classes.c -o Zend/zend_default_classes.lo
    /bin/sh /root/installs/php/php-5.2.9/libtool silent preserve-dup-deps --mode=compile /root/installs/php/php-5.2.9/meta_ccld -IZend/ -I/root/installs/php/php-5.2.9/Zend/ -DPHP_ATOM_INC -I/rootinstalls/php/php-5.2.9/include -I/root/installs/php/php-5.2.9/main -I/root/installs/php/php-5.2.9 -I/opt/iplanet/current/include -I/opt/iplanet/current/plugins/include -I/usr/include/libxml2 -I/rot/installs/php/php-5.2.9/ext/date/lib -I/usr/include/mysql -I/root/installs/php/php-5.2.9/TSRM -I/root/installs/php/php-5.2.9/Zend -D_REENTRANT -DTHREAD=1 -I/usr/include -g -O2 -pthread -DZTS -refer-non-pic -c /root/installs/php/php-5.2.9/Zend/zend_execute.c -o Zend/zend_execute.lo
    /bin/sh /root/installs/php/php-5.2.9/libtool silent preserve-dup-deps --mode=compile /root/installs/php/php-5.2.9/meta_ccld -Isapi/nsapi/ -I/root/installs/php/php-5.2.9/sapi/nsapi/ -DPHP_ATOMINC -I/root/installs/php/php-5.2.9/include -I/root/installs/php/php-5.2.9/main -I/root/installs/php/php-5.2.9 -I/opt/iplanet/current/include -I/opt/iplanet/current/plugins/include -I/usr/include/lbxml2 -I/root/installs/php/php-5.2.9/ext/date/lib -I/usr/include/mysql -I/root/installs/php/php-5.2.9/TSRM -I/root/installs/php/php-5.2.9/Zend -D_REENTRANT -DTHREAD=1 -I/usr/include -g -O2 -pthrad -DZTS -prefer-non-pic -c /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c -o sapi/nsapi/nsapi.lo
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:62:19: error: nsapi.h: No such file or directory
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:81: error: expected specifier-qualifier-list before 'pblock'
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c: In function 'nsapi_strdup':
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:130: warning: return makes pointer from integer without a cast
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c: At top level:
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:206: error: expected ')' before '*' token
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:207: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'nsapi_servact_uri2path'
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:208: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'nsapi_servact_pathchecks'
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:209: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'nsapi_servact_fileinfo'
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:210: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'nsapi_servact_service'
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c: In function 'php_nsapi_init_dynamic_symbols':
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:250: error: 'nsapi_servact_uri2path' undeclared (first use in this function)
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:250: error: (Each undeclared identifier is reported only once
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:250: error: for each function it appears in.)
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:250: error: 'nsapi_servact_prototype' undeclared (first use in this function)
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:250: error: expected ';' before 'dlsym'
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:251: error: 'nsapi_servact_pathchecks' undeclared (first use in this function)
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:251: error: expected ';' before 'dlsym'
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:252: error: 'nsapi_servact_fileinfo' undeclared (first use in this function)
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:252: error: expected ';' before 'dlsym'
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:253: error: 'nsapi_servact_service' undeclared (first use in this function)
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:253: error: expected ';' before 'dlsym'
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c: In function 'zm_info_nsapi':
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:300: error: 'nsapi_servact_service' undeclared (first use in this function)
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c: In function 'zif_nsapi_virtual':
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:318: error: 'Request' undeclared (first use in this function)
    /root/installs/php/php-5.2.9/sapi/nsapi/nsapi.c:318: error: 'rq' undeclared (first use in this function)
    make: *** [sapi/nsapi/nsapi.lo] Error 1

    DB:2.68:Sjsws 7 Sp5 On Fedora Core 10 Compile Error On Php 5.2.9 88

    Rather than re-install I just unzipped WebServer/devsupport.zip
    Then tar up everything inside the include directory and extract the contents here: ws7.0-install-dir/include/

    php 5.2.9 compiled with no problem then...

    Thanks for the responses!

  • RELEVANCY SCORE 2.68

    DB:2.68:Centos5 Or Rhel5 Upgrade To Php5.2.17 How-To aj





    This is unofficial how-to upgrade Parallels Pro for Linux (formerly Ensim) to latest PHP 5.2.x
    If you have not OS based php version (php 5.1.6) and for now older php than 5.2.17 you may use this,
    becouse all older than 5.2.17 php versions has serciurity or other bugs...
    Use it on yout own risk, but if will get any problems or notices i will be glad to help.
    This how-to will work on CentOS5 or RHEL5 with 10.3.x Parallels Pro for Linux (formerly Ensim)

    Ok, to start ugrade we must go thru maintance mode and check does all sites are ok and so on:
    set_pre_maintenance
    set_maintenance
    set_post_maintenance
    exit_post_maintenance

    It there is no skiped sites, you may begin to upgrade, otherwise you must fix them at first.

    To get newer php version we must use some repo like atomic that has new php rpms.
    So we must install atomic repo:
    wget -q -O - http://www.atomicorp.com/installers/atomic | sh

    After install it dont run yum upgrade, it will update not required packages and may brake Ensim!

    Atomic repo has PHP5.3.x becouse we dont need it we will ask yum not use 5.3.x rpms.

    Edit /etc/yum.conf
    vim /etc/yum.conf

    and in end of file add:

    exclude=*5.3.*

    No we need to update php (before pressin Yes check php version, does it 5.2.17)
    yum upgrade php

    Ok, php is update, now we need more php modules:
    For 32bit system run:
    yum install php-bcmath php-mcrypt php-mhash php-soap php-tidy php-xml php-xmlrpc

    For 64bit system run:
    yum install php-bcmath.x86_64 php-mcrypt.x86_64 php-mhash.x86_64 php-soap.x86_64 php-tidy.x86_64 php-xml.x86_64 php-xmlrpc.x86_64

    Ok, now we have latest php 5.2.x, so it it is time to update Ensim FST.
    We must add aditional RPMs to FST. To do that we must create file: /etc/virtualhosting/filelists/apache.custom.sh

    vim /etc/virtualhosting/filelists/apache.custom.sh

    and add to it:
    See attached

    Now change atributes for it:

    chmod 750 /etc/virtualhosting/filelists/apache.custom.sh

    Now we need update FST and go thru maintance mode:

    set_pre_maintenance
    set_maintenance
    set_post_maintenance
    exit_post_maintenance

    After it finish you may check does php works ok:

    chroot /home/virtual/sitename/

    You must get something like that:
    php -v
    PHP 5.2.17 (cli) (built: Jan 7 2011 10:39:29)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

    Now disable atomic repo:
    vim vim /etc/yum.repos.d/atomic.repo
    and change:
    #mirrorlist = http://www.atomicorp.com/channels/atomic/centos/5/mirrors-atomic
    enabled = 1

    To:
    #mirrorlist = http://www.atomicorp.com/channels/atomic/centos/5/mirrors-atomic
    enabled = 0

    Thats all
    If somebody noticed mistakes or some troubles with it, please PM me i will try to add some fixes or addons to this post.

    DeepM

    DB:2.68:Centos5 Or Rhel5 Upgrade To Php5.2.17 How-To aj




    To upgrade to PHP5.3.x look at http://forum.parallels.com/showthread.php?p=564954#post564954

  • RELEVANCY SCORE 2.67

    DB:2.67:Zend Server With Plesk cc





    I am using Zend server because a couple of websites require it. After installing however, plesk thinks PHP is no longer installed. I have read elsewhere that Plesk / Zend have been working on this. What is the status? Is their a workaround to get plesk to realize PHP is indeed installed? Currently, I have to manutally edit vhost.conf files for each site I want to enable php for--- its annoying.

    DB:2.67:Zend Server With Plesk cc




    I am using Zend server because a couple of websites require it. After installing however, plesk thinks PHP is no longer installed. I have read elsewhere that Plesk / Zend have been working on this. What is the status? Is their a workaround to get plesk to realize PHP is indeed installed? Currently, I have to manutally edit vhost.conf files for each site I want to enable php for--- its annoying.

  • RELEVANCY SCORE 2.67

    DB:2.67:Zend On Rhel3 With Php4.3.2 78





    I installed Zend Optimizer 3.2.0 on my RHEL3 box. Installation was OK, according to the Zend installer script.
    However, it is not OK. Because the Zend Optimizer is not running.

    Googling around brought me to the Zend forum: http://www.zend.com/forums/index.php?t=rviewth=393goto=2091

    So there seems to be a problem with Zend Optimizer on PHP 4.3.2
    Here is the result when i run /usr/bin/php -v

    Failed loading /usr/local/Zend/lib/Optimizer-3.2.0/php-4.3.x/ZendOptimizer.so: /usr/local/Zend/lib/Optimizer-3.2.0/php-4.3.x/ZendOptimizer.so: undefined symbol: zend_open
    PHP 4.3.2 (cgi), Copyright (c) 1997-2003 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies
    with the ionCube PHP Loader v2.5, Copyright (c) 2002-2004, by ionCube Ltd., and
    with Zend Extension Manager v1.0.11, Copyright (c) 2003-2006, by Zend Technologies

    As you can see some symbol from shared library cannot be resolved, I think the reason why mod_php does not load Zend_optimiser is the same.

    Has anyone experiences with this?
    How can I safely upgrade mod_php to 4.3.10 version?

    DB:2.67:Zend On Rhel3 With Php4.3.2 78




    Hello,

    No, it was never resolved.
    We just picked another server with RHEL4 install to install the Zend.

  • RELEVANCY SCORE 2.67

    DB:2.67:Php.Ini Path Changed By Zend Upgrade 8c





    Hi,

    Updgrade zend and it sym linked my /etc/php.ini file to /usr/local/Zend/etc/php.ini which is fine . . . everything works.

    However, I want to make changes to the php.ini file to the include_path. When I uses vi editor to look at the file I discover theres no setting for the inlcude_path, yet phpinfo() lists it as being .:/usr/share/pear.

    Is their a default setting for include_path if it isnt set? Is it set elsewhere? Or am I just looking at the wrong php.ini file?

    Thanks!

    DB:2.67:Php.Ini Path Changed By Zend Upgrade 8c




    you can find or add this directive to php.ini as serverwide setting. You probably can also add it to a .htaccess file to enable it on a specific subdir.

    check the manual to see how you can use this directive: http://nl3.php.net/ini

  • RELEVANCY SCORE 2.67

    DB:2.67:Zend Core For Oracle Php-Cli Error j8


    I need to execute a php script thru php-cli in a linux RH environment with Zend Core for Oracle installed. This script connects to an Oracle db (using the oci extension, of course) and then tries to oci_parse and oci_execute a query. What i get is a memory fault error. Is there a way to debug the php-cli version ? The ZendCoreforOracle-one included is compiled with the '--disable -debug' option.
    The execution pipe is : ksh --php-cli --php script with the query.
    Anyone ? please ?

    DB:2.67:Zend Core For Oracle Php-Cli Error j8

    Sorry, wrong alarm. Using the oci_internal_debug(true) i have found where the problem was : i was using a function called my_oci_parse() which should call oci_parse and eventually handle error reporting. I was missing to see that in the function definition i was using the my_oci_parse() instead of the oci_parse, which is the classic recursion error ;-)
    A note : while searching on google, i noticed that few people know the existence of the oci_internal_debug function.

  • RELEVANCY SCORE 2.67

    DB:2.67:Zend Php Enabler For Sun Web Server 3j


    Hi! I'm running Solaris 10 x86 and Sun Webserver 6.1. Compiled PHP 4.3.10 using the gcc from sunfreeware, and installed the Zend php-enabler. PHP is running fine and is compiled with the cgi-option.

    When I try to access a .php page, I get:

    failure (16537): send-zend-enabler reports: Can not connect() to '/usr/local/bin/php' (80.80) - No such file or directory

    This php-binary IS indeed in /usr/local/bin/php. My config in magnus.conf and in the Zend enabler config file seems fine. Why can't the webserver execute PHP?

    Permissions are:

    rwxr-xr-x 1 root root 4044464 Feb 10 14:54 /usr/local/bin/php

    DB:2.67:Zend Php Enabler For Sun Web Server 3j

    Excellent guide! Thanks for sending this link.

    -Manish

  • RELEVANCY SCORE 2.67

    DB:2.67:Modernbill, Command Line Php And Zend Installation Question 3k





    In order to set up cron jobs for some of the scripts provided with Modernbill I have had to install a seperate command line PHP.

    Any idea how I install Zend just for this new command line PHP without affecting the Zend install already in place?

    DB:2.67:Modernbill, Command Line Php And Zend Installation Question 3k




    Well.... hardly the response I was hoping for and its so long since my original post I have upgraded to a newer version of PSA, so I guess its in the wrong forum now?!?

    Can anyone help me out on this one? Ive still not been able to find a solution. Heres where I am so far:

    PSA6
    Apache
    PHP 4.3.2
    FreeBSD 4.9
    Zend Optimizer 2.1.0

    Zend Optimizer is installed for the PHP used by PSA and working perfectly. Files are decoded without a problem.

    Ive successfully installed CLI PHP 4.3.2 using a binary from php.net, but Im not 100% sure that I did the installation correctly. When Im installing it should I be configuring it with my existing pnp.ini file i.e. /usr/local/Zend/etc/php.ini or creating a fresh one?

    I have no idea what the correct procedure is for getting ZO loaded by CLI PHP. Ive tried reinstalling ZO numerous times but no matter what I do it makes no difference.

    What I really need is a step-by-step guide on the correct method for doing this from someone with prior experience (Im sure many others would find this useful too). Ive tried to get help in the Zend forums, Modernbill, Kayako and here... no joy so far.

    Any help greatly appreciated. Surely it cant be that hard?

  • RELEVANCY SCORE 2.67

    DB:2.67:10.1.1 Adding Subdomain Problem And Patch Fails jj





    I have installed plesk 10.1.1 but today i realize that adding subdomains break apache and also newly released PHP5 patch fails too.

    [root@xxxxxxx ~]# php -v
    PHP 5.2.17 (cli) (built: Jan 7 2011 08:49:48)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.5, Copyright (c) 2002-2011, by ionCube Ltd., and
    with XCache v1.3.1, Copyright (c) 2005-2010, by mOo
    with Zend Optimizer v3.3.9, Copyright (c) 1998-2009, by Zend Technologies
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH

    ***
    The requested package php5-ioncube-loader could not be installed: dependency php 5.2.0 is unresolved
    Searching problems for the php5-ioncube-loader package.
    php5-ioncube-loader-3.2-11012014.i386: No suitable solutions were found
    for the php 5.2.0 dependency.
    The php-5.1.6-27.el5_5.3.i386 package resolves php 5.2.0.
    Searching problems for the php package.
    Unable to downgrade php package to version 5.1.6-27.el5_5.3:
    version 5.2.17-1.el5.art is currently installed.
    Could not add package php-5.1.6-27.el5_5.3.i386to the list of required packages.
    Problem occured during searching directly resolved dependencies for php 5.2.0 of package php5-ioncube-loader-3.2-11012014.i386

    The following could cause the installation failure:
    1)php5-ioncube-loader-3.2-11012014.i386: No suitable solutions were found
    for the php 5.2.0 dependency.

    2)Unable to downgrade php package to version 5.1.6-27.el5_5.3:
    version 5.2.17-1.el5.art is currently installed.

    DB:2.67:10.1.1 Adding Subdomain Problem And Patch Fails jj




    Hi guys,

    I think thats the same problem (your posted error message) as described in this thread:
    http://forum.parallels.com/showthread.php?t=108052

    Regards

  • RELEVANCY SCORE 2.67

    DB:2.67:Solution Upgrading To Php 4.3.10 9d





    When upgrading to php 4.3.10 the foreach function and several others seem to be broken. This is not an issue of php but of the Zend optimizer. Upgrading to the latest version (2.5.7) will fix these problems.

    http://bugs.php.net/bug.php?id=31108

    regards
    Jan

    DB:2.67:Solution Upgrading To Php 4.3.10 9d




    no, that is not needed. If zend optimizer is not installed then php works fine. If it is installed then you need to upgrade to the latest version.

    regards
    Jan

  • RELEVANCY SCORE 2.67

    DB:2.67:Archlinux Nginx Php With Fastcgi Help cs



    Hello,I decided to swith my server from Ubuntu to Arch a few days ago due in part from the great reviews of Arch.However I have not been able to get php working yet.

    what I did first was to install Nginx via pacmanno problems with that and works finenext I installed php and xcache via pacmanrunning php -v from my terminal I get:
    PHP 5.2.5 with Suhosin-Patch 0.9.6.2 (cgi-fcgi) (built: Nov 13 2007 20:03:00)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with XCache v1.2.1, Copyright (c) 2005-2007, by mOo

    DB:2.67:Archlinux Nginx Php With Fastcgi Help cs


    When I use a init script, can I use the user nginx and group nginx? This is so I can copy some premade script available throughout the internet.

    Birger

  • RELEVANCY SCORE 2.66

    DB:2.66:Zend Guard Loader And Plesk 11 p8





    I have Plesk 11.x installed on my CentOS 6.2 x86_64. I configured my PHP to load Zend Guard Loader. But know when I check php configuration by php -v the output is:

    PHP 5.3.3 (cli) (built: Jul 3 2012 16:53:21)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.14, Copyright (c) 2002-2011, by ionCube Ltd., and
    with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

    But in output of phpinfo() is:

    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.14, Copyright (c) 2002-2011, by ionCube Ltd.

    In phpinfo() information the config file I used to configure Zend Loader is listed.

    Any solution?

  • RELEVANCY SCORE 2.66

    DB:2.66:Updating Php And Installing Zend Optimizer 9x





    Hi Everyone,

    So I know it comes with PHP 5.2.5 but I want to update it to 5.2.6 and install ZEND Optimizer, when I do it if I tell PHP installer to install to PLESK/ADDITIONAL/PHP5 it causes errors across the entire system. FastCGI errors on Plesk itself... where is the proper location to install PHP and Zend so that all my users have the ability to use it or show it enabled... Is there a proper location or way that I should install add ons so that they are available to everyone...

    Thanks!

    Sergio

    DB:2.66:Updating Php And Installing Zend Optimizer 9x




    http://download1.swsoft.com/Plesk/P...4-win-advanced-administration-guide/51563.htm
    http://kb.odin.com/en/975

  • RELEVANCY SCORE 2.66

    DB:2.66:Zend Studio And Dreamweaver - Together? 8p



    This is probably a good question for David Powers.

    Will Zend Studio mix well with DW in a development environment (say the way BBEdit, etc. does)?

    I'm hoping to enhance the PHP side of things, learn a bit about the Zend Framework but continue with DW as my primary tool. In other words utilize a number of these tools on the same project. At the least I would think the Zend editor would be helpful for even simple bits of PHP code edits?

    Thanks for any feedback.

    DB:2.66:Zend Studio And Dreamweaver - Together? 8p


    It's interesting to me that, not only (IMO) are your books some of the most

    helpful out there, you also possess an even-handed attitude toward these

    things that seems to come from actual experience and not some preconceived

    ideas you want everyone else to adopt. Thanks for your feedback and all the

    good work you do.

  • RELEVANCY SCORE 2.66

    DB:2.66:How To Create A Custom Template For Nginx Php-Fpm For Special Websites? 3j





    I manly use Symfony 2 as PHP framework. It works without problems with Apache/FastCGI. Id like to use it with nginx/PHP-FM for low memory usage and high performance (Zend OPCache).

    However, Plesk-generated default nginx configuraton is not suitable for Symfony 2. This is a minimal working configuration:

    Code:

    DB:2.66:How To Create A Custom Template For Nginx Php-Fpm For Special Websites? 3j




    I manly use Symfony 2 as PHP framework. It works without problems with Apache/FastCGI. Id like to use it with nginx/PHP-FM for low memory usage and high performance (Zend OPCache).

    However, Plesk-generated default nginx configuraton is not suitable for Symfony 2. This is a minimal working configuration:

    Code: