• RELEVANCY SCORE 4.67

    DB:4.67:Php Upgrade 5.1.2 To Php 5.1.4 Or Higher df







    Hello,

    can any one provide any way for upgrading php 5.1.2 to 5.1.4 or higher on Suse 10.1 with plesk 9.0 without breaking plesk. Any suggestion would be appreciated.

    Thanks,

    DB:4.67:Php Upgrade 5.1.2 To Php 5.1.4 Or Higher df




    Hello,

    can any one provide any way for upgrading php 5.1.2 to 5.1.4 or higher on Suse 10.1 with plesk 9.0 without breaking plesk. Any suggestion would be appreciated.

    Thanks,

  • RELEVANCY SCORE 4.48

    DB:4.48:Upgrading To Php 5.2 Or Higher p3







    Please help me! how can I upgrade to php 5.2 or higher?

    Now I have PHP 5.1.2 on suse 10.1

    THX

    DB:4.48:Upgrading To Php 5.2 Or Higher p3




    Please help me! how can I upgrade to php 5.2 or higher?

    Now I have PHP 5.1.2 on suse 10.1

    THX

  • RELEVANCY SCORE 4.48

    DB:4.48:Upgrading Php 4.3.9 To Php 5.2.6 Plesk 9 7z







    Finally upgraded successfully Plesk 8.6 to Plesk 9.

    How easy to upgrade PHP 4.3.9 to PHP 5.2.6 now on this Plesk 9? Will be any issues? how to do the upgrade safely?

    The same question to upgrade mysql server from mysql 4 to latest mysql 5?

    Please details as possible

    Thank you all

    DB:4.48:Upgrading Php 4.3.9 To Php 5.2.6 Plesk 9 7z




    Ok so the first thing you should know about PCI testing is that the methods that the QSAs are using are very very inaccurate if they do network based checking. It absolutely *will* indicate problems that dont exist on PHP, apache, ssh, bind, ssl, etc.

    If you are running the latest updates from CentOS you are fine on all counts because RHEL/CentOS operate off of a back-porting of fixes model. In fact this will even be indicated on the PCI vulnerability report, if the QSA has not redacted the information from their vulnerability scanner (usually Nessus, which you can download from www.nessus.org).

    So first go through the vulnerabilities indicated, and verify that you are running the latest revs of those packages from centos. Submitting that information to your QSA should be enough to certify those vulnerabilities are closed.

  • RELEVANCY SCORE 4.25

    DB:4.25:How To Upgrade Php 4.3.2 To 5.0.3 To Patch Vulnerabilites? 3p





    Due to the recent discovered high risk vulnerabilities at PHP 4.3.2, or earlier we would like to upgrade to 5.03.
    Is there an automatic way of doing it at plesk?
    I cant find the option at UPGRADE options.
    Maybe with up2date?

    If I do it manually, will I damage Plesk control panel?

    Thanks in advance

    DB:4.25:How To Upgrade Php 4.3.2 To 5.0.3 To Patch Vulnerabilites? 3p




    I tried it with that (and the latest squirrelmail) , but it still didnt work. Im still looking into it, its possible that its something in the way Im building php, or perhaps one of the libraries Im linking to

  • RELEVANCY SCORE 4.09

    DB:4.09:Fixing Horde On Plesk 7.5.6 After Php 5 Upgrade jk





    Hi all,

    I dont know if there is a fix to this already - but after I upgraded to PHP 5.1.2 using the instructions at :
    http://faq.sw-soft.com/article_149_1048_en.html
    I was not able to run Horde. It crashed, cried and gave me a headache. Finally, I thought of a worst case scenario and did something totally wierd.
    The following assumes you have already installed PHP 5 using the FAQs instructions.

    1. Make a copy of /vhosts/webmail/horde folder or just rename it.
    2. Make a copy of plesks HORDE database (not this can be found in Plesks MySQL instance running on 8306).
    3. Goto horde.org and downloaded their latest horde, imp and turba packages

    4. Assuming that now /vhosts/webmail/horde is empty, untar all horde files in this directory and upgrade your database as per their UPGRADE instructions

    5. Copy all the config files from your old /horde/config directory and upload it to the ne hordes config directory

    6. Untrar IMP in /horde/imp and TURBA in /horde/turba. Copy old configs to the new one

    7. Check the webmail URL and make sure that you install the appripriate PHP/Pear packages as notified in /horde/test.php

    8. Copy the php.ini file form old horde and make sure that the extension_dir points to the NEW PHP 5 extensions directory

    9. Open IIS-Websites-Webmail and make sure that PHP5 is used instead of what the FAQ says.

    Thats about it - everything should work. I might have missed more details but if any of you runs across a problem, then let me know.

    NOTE: Couple of pointers
    If you follow PHP 5 upgrade as per
    SW-soft FAQ article you probably will run into some errors.
    - Firstly, copy all files in /Additional/php/ext to /Additional/php/extensions
    - Run /Additional/php/go-pear.bat and choose system wide installation
    - Install appropirate pear packages by using pear.bat in that same directory

    (hope this works for you guys)

    DB:4.09:Fixing Horde On Plesk 7.5.6 After Php 5 Upgrade jk




    Running php 5.1.2 and php4 for horde works fine.

    Though upgrading horde and use php 5 only seems a nice solution

  • RELEVANCY SCORE 3.71

    DB:3.71:Help Me Decide On Openbsd Or Solaris As My Web And File Server Please jm


    Hi

    5 questions

    i have been using OpenBSD as my Web and file server for a while now
    and FreeBSD as my Desktop

    i decided on OpenBSD as my Server because of its Security

    1) But now i hear Solaris is the most Secure OS pn the Planet? is this true
    And which is real Unix?

    i seem to always have trouble with things such as PHP on OpenBSD
    Most of my pages run as *.html but i also have a forum which uses PHP 4
    But all my PHP pages come up blank..
    i am always encountering errors using PHP

    2) If i Switch to Solaris will it b even harder to use or
    is it precompiled with PHP 4 and higher when i install Apache

    3) Also what about cgi and the ability to use *.htaccess files should i use them

    4) Also i i still would like to generate SSH keys ssh-keygen
    is that possible?Forcing the user to login using only a key and
    not a password on SSH

    5) Does Solaris have any Linux compatibility as well?as FreeBSD has

    Concider me a newbie even though i use to post on this forum once before
    i am always experimenting trying new things out

    Message was edited by:
    heatherval

  • RELEVANCY SCORE 3.63

    DB:3.63:Upgrade Php 4.3.9 To 4.3.10 sc





    Hi

    What is the best way to simply upgrade php 4.3.9 to 4.3.10 for plesk 8.1.1 RHET 4, I am getting ready to
    set up a new server and just need a short term fix for an app. I have looked at atomic and it will install to 5.x php
    will I need to update mysql as well?

    Chuck

    DB:3.63:Upgrade Php 4.3.9 To 4.3.10 sc




    Hi

    What is the best way to simply upgrade php 4.3.9 to 4.3.10 for plesk 8.1.1 RHET 4, I am getting ready to
    set up a new server and just need a short term fix for an app. I have looked at atomic and it will install to 5.x php
    will I need to update mysql as well?

    Chuck

  • RELEVANCY SCORE 3.59

    DB:3.59:Upgrade To Php 5.3 In Plesk 10.4.4#19 za





    I am trying since ever to upgrade to Php 5.3 in Plesk 10.x branch. I saw once the option to upgrade PHP 5.3 and I did not upgrade. Since then I keep looking for that option and it does not show up in the autoinstaller.

    Is there any more generic way of upgrade Php 5.3 with psa packages?
    (Debian )

  • RELEVANCY SCORE 3.58

    DB:3.58:Php 5 mm





    plesk comes with PHP Version 4.3.2

    with atomicturtles yum archives Ive yum upgrade php to version PHP 4.4.1

    I need PHP 5.1.2

    any tips on getting that w/o breaking plesk?

    ideas?

    pg

    DB:3.58:Php 5 mm




    plesk comes with PHP Version 4.3.2

    with atomicturtles yum archives Ive yum upgrade php to version PHP 4.4.1

    I need PHP 5.1.2

    any tips on getting that w/o breaking plesk?

    ideas?

    pg

  • RELEVANCY SCORE 3.47

    DB:3.47:10.2 With Wrong Php Version 1d





    Product
    CentOS 5.6 (Final), 10.2, x86_64

    Problem:
    Hello,

    i tried to install typo3 for a domain on this server with application vault.
    But the installer in Application vault told me, that there was a wrong php version: 5.1.6
    after looking on the typo3 site, php 5.2.x and higher is recommended.
    iam wondering why plesk 10.2 has that old php version.
    How and can i upgrade the php version with any problem on next Plesk updates or other issues.

    Thanks in advance for yor help

    vasili

    DB:3.47:10.2 With Wrong Php Version 1d




    I had a similar problem running vBulletin, which requires php 5.2 or newer. The problem is that Cent OS 5.6 ships with php 5.1.6. I updated to php 5.2 using the atomic repository, see http://www.atomicorp.com/wiki/index.php/PHP. This has worked well for me.

  • RELEVANCY SCORE 3.43

    DB:3.43:Should I Upgrade Apache To 2.4 And Php 5.4? 8m





    Hi everyone,
    Im using Apache 2.2 and PHP 5.3 but many users say that Apache 2.4 is faster and lighter.
    Now I wonder if Plesk 11 works well with Apache 2.4?
    many thanks

    DB:3.43:Should I Upgrade Apache To 2.4 And Php 5.4? 8m




    As you can see:

    # rpm -qi httpd | grep Vendor
    Version : 2.2.3 Vendor: Red Hat, Inc.

    Plesk doesn’t ship client’s PHP and Apache, it only downloads it from original OS vendor repo and it is quite likely it may be outdated there (especially for older OS). If your OS comes with PHP 5.4 and Apache 2.4, then Plesk would run PHP 5.4 and Apache 2.4 for clients.

  • RELEVANCY SCORE 3.40

    DB:3.40:Php Update - Plesk 8.6.0, Centos 5 jz





    Hello,

    I need to update the php version of the plesk to 5.2.4 (today, 5.1.6) and I have found that the plesk have not an official upgrade to make it possible. What can I do? Is there any plesk version (9.x.x or 10) with php 5.2.4 or higher? Must I try to do it by my own? Is there any risks? They are so much questions but I have too much clients asking me for upgrade the php version (the new Joomla 1.6 require this feature).

    In the case that upgrade was possible, what are the SSH commands? Thank You so much.

    DB:3.40:Php Update - Plesk 8.6.0, Centos 5 jz




    Aside from atomic which is lovely you can also use the the CentOS testing repo to just get the 5.2.x installed.

    Here is the link: http://wiki.centos.org/HowTos/PHP_5.1_To_5.2

  • RELEVANCY SCORE 3.39

    DB:3.39:Upgrade From Php 5.1.6 To 5.2.6 Fails p3





    [SOLVED] Upgrade from PHP 5.1.6 to 5.2.6 fails

    Hi,

    Im having trouble upgrading PHP using yum (Plesk 8.6.0 - just updated via control panel - on 64-bit FC6).

    Ive followed the instructions here:

    http://www.atomicorp.com/wiki/index.php/PHP

    But I get the following error when I run yum update php or yum update:

    Error: Missing Dependency: php 5.2.0 is needed by package php-sqlite

    Help!

    This is very frustrating, because I really need to run 5.2.x - and I dont even need sqlite...

    Any ideas?

    thanks in advance,

    Matt

    DB:3.39:Upgrade From Php 5.1.6 To 5.2.6 Fails p3




    Almost simultaneous posts!

    Thanks breun.

    Matt

  • RELEVANCY SCORE 3.35

    DB:3.35:Plesk Fails To Reslove In Browser After Php 5.3 Upgrade 3k





    Hi everyone,

    I upgraded my php installation to 5.3 using these instructions http://chrisjean.com/2011/06/24/upgrade-php-5-1-or-5-2-to-5-3-on-centos/

    Unfortunately Plesk now fails to resolve in the browser now.

    Can anyone help?

    Thanks,

    Charlie

    DB:3.35:Plesk Fails To Reslove In Browser After Php 5.3 Upgrade 3k




    Thanks for your help Paul. I ended up having to roll the server back to before the upgrade.

    Again thanks for your help Paul.

  • RELEVANCY SCORE 3.34

    DB:3.34:Upgrade Plesk 10.4.4 Php Version 9a





    Hi,

    Im trying to update Plesk 10.4.4 from PHP 5.2.17 to PHP 5.3 and when I run the Update, I get the following error message:

    Error: Unable to proceed with the installation until the package php-ioncube-loader-1:4.2.2-2.el5.art.x86_64 is removed from the system.

    If I SSH into the server and try to remove the php-ioncube-loader - using:
    yum remove php-ioncube-loader

    it asks me if I want to remove 29 other dependacies and I dont want to do that...

    Any suggestions?

    DB:3.34:Upgrade Plesk 10.4.4 Php Version 9a




    How are you trying to do the php upgrade? Via the Plesk Updater? If so, it could be trying to upgrade to the stock Centos5 php 5.3 as opposed to the Atomic (ART) 5.3 (you are using the Atomic 5.2.x).

    In fact the same thing may happen if you try to upgrade via the command line with the Atomic repo disabled.

    I suggest posting in the Atomic forum as someone there will almost certainly have encountered this issue. Im afraid Ive never tried to go from Atomic 5.x to a stock 5.x so other than removing that troublesome RPM with the nodeps option (which I suspect is the way, though I wont say it is safe to do so) Im not sure exactly what you need to do.

    When you post, be sure to say exactly how you are trying to upgrade and which version (stock or atomic) you want to upgrade to.

  • RELEVANCY SCORE 3.31

    DB:3.31:Centos 5.5: Php Update To 5.2 Or 5.3? sc





    Some CMS are now starting to require a PHP version thats newer than 5.1 (which is included with CentOS 5).

    Anyone has successfully upgraded their PHP to 5.2.x or 5.3.x on a Parallels Pro 10.3.4 system? I know theres a CentOS wiki showing how to upgrade CentOS 5 to a newer PHP release, Im mostly worried about potential impacts on Parallels Pro.

  • RELEVANCY SCORE 3.29

    DB:3.29:Upgrade To Latest Php 5.4.7 Or 5.3.17 1x





    My hosting with 1and1 running using plesk 11 uses php version 5.3.3. How can this be upgraded to the latest version(s) either 5.3.17 or 5.4.7? Im concerned about security problems.

  • RELEVANCY SCORE 3.20

    DB:3.20:Ht201210 How Do I Upgrade My Ipad2 Version To 5.1 Or Higher j8


    How can I upgrade my ipad2 version to 5.1 or higher?5

    DB:3.20:Ht201210 How Do I Upgrade My Ipad2 Version To 5.1 Or Higher j8

    I would re move all paid apps and free apps be for upgrading. All so back up with iTunes. all so you can do a restore on your iPad 2 wish will give you a nic clean start

  • RELEVANCY SCORE 3.19

    DB:3.19:Php-Pqsql-4.3.2-11.1.Ent.I386.Rpm //No Such File Or Directory xa





    Im trying to upgrade from 7.1.2 to 7.1.3 but I failed because php-pgsql-4.3.2-11.1.ent.i386.rpm has dependency problems (missing php4.3.2-11.1.ent). I tried rpm -Uvh --nodeps php-pgsql-4.3.2-11.1.ent.i386.rpm but says no such file or directory.

    Please help.

    DB:3.19:Php-Pqsql-4.3.2-11.1.Ent.I386.Rpm //No Such File Or Directory xa




    Do you need php-ldap? If not just uninstall it:
    rpm -e php-ldap

  • RELEVANCY SCORE 3.18

    DB:3.18:Howto Upgrade Php 4.3.9 Form Php 4.22 f1





    HowTo upgrade PHP 4.3.9 from PHP 4.22

    my dedicated server is Plesk v.7.0.2 (linux redhat 9) that was run by php v.4.2.2 I would like to upgrade PHP v. 4.3.9 . Could anyOne to help to show me step by step to do this upgrade

    Thanks

    DB:3.18:Howto Upgrade Php 4.3.9 Form Php 4.22 f1




    try: yum update php

    or if you want to get everything, yum update

  • RELEVANCY SCORE 3.17

    DB:3.17:How Do I Uprading Php 4.2 To 4.3.11 On Plesk 7.5 Reloaded 17





    I wish to upgrade php4.2 to 4.3 on plesk 7.5 reloaded. my operating system redhat 9 on a virtuoso virtual dedicated server.
    Can anyone please give me a step by step instructions on how I can do this upgrade.

    DB:3.17:How Do I Uprading Php 4.2 To 4.3.11 On Plesk 7.5 Reloaded 17




    Yep, yum should do it for you automatically. You might have to use yum upgrade instead of yum update on older versions.

  • RELEVANCY SCORE 3.17

    DB:3.17:Error: Unable To Open /Usr/Lib/Rpm/Rpmrc For Reading: No Such File Or Directory 9x





    Hi all,

    My problem started when I wanted to upgrade PHP 5.3.x to 5.4.x

    I followed this Parallels guide How to upgrade PHP to PHP 5.4 on CentOS 5 from remi repository found here http://kb.parallels.com/en/115833

    After executing step 4 which is:
    4. Remove all PHP 5.3 components and the PHP 5.3 configurator:

    Code:

  • RELEVANCY SCORE 3.17

    DB:3.17:Upgrade Php From 5.0.4-10.5 To 5.2.3-4.Fc4.Art 7c





    I am looking to update from php 5.0.4-10.5 to 5.2.3-4.fc4.art on FC4 64 with Plesk 8.2. Looks like a straightforward yum upgrade now I have configured the ART yum locations.

    Are there any caveats that I should be aware of?

  • RELEVANCY SCORE 3.16

    DB:3.16:How To Downgrade Php 5 To Php 4 7c





    Can someone help with the best way possible to downgrade our Plesk 8 running PHP 5 to PHP 4 about 90% of our sites has scripts that require this version of PHP.

    Please give detail steps.... thanks

    DB:3.16:How To Downgrade Php 5 To Php 4 7c




    Its maybe not as bad as it seems...

    Hi, Just my take on this for anyone thats stopping by here. I too was searching for info on this having just been forced to upgrade our server following a hack. A lot of our sites were broke following the upgrade which I blamed largely on incompatibility with PHP5.

    However, for anyone in the same position, Id first suggest doing the following and then seeing how many issues are fixed:

    1. Make sure you have PHP_SAFE_MODE OFF in plesk, at domain level (if the site is not causing you a problem, leave it on, though)

    2. Edit your php.ini, look for register_long_arrarys and set it to on. This gives you backwards compatibility with the old $HTTP_*_VARS which no longer exist in PHP5.

    Finally, if youre still getting odd stuff or just blank screens, dig into /var/www/vhosts/domain.name/statistics/logs/error_log and get some hints from there.

    This has ireoned out 90% of my problems - I hope it can do the same for you.

    Cheers,

    Simon

    UPDATE:
    After making any of the above changes, dont forget to restart apache.

    Also, other stuff I found that PHP5 doesnt like which was previously fine in PHP4:
    1. Declaring a variable name more than once in a class (sometimes just a genuine mistake by the developer - check your error logs).

    2. including and/or requiring files: seems to be a very random problem but sometimes files which are well within the open_basedir restrictions just will not include - the error logs will hint to this if it happens. Good work around if all else fails:

    PHP:

  • RELEVANCY SCORE 3.15

    DB:3.15:How To Upgrade To Php 5.3.3 Or Higher Unter Ubuntu 10.04 Lts jd





    Hi!

    I am running Plesk 11.5.30 Update #5 under Ubuntu 10.04.4 LTS.
    My current PHP version is PHP Version 5.3.2-1ubuntu4.19.

    For some SW this PHP version is not usable as it causes segfaults:
    http://community.egroupware.org/wiki?wikipage=releasenotes1.8

    How can I update from PHP 5.3.2 to PHP 5.3.3 or higher?

    Thanks.

    DB:3.15:How To Upgrade To Php 5.3.3 Or Higher Unter Ubuntu 10.04 Lts jd




    Use Multiple-PHP-Versions feature. It is discussed here - http://forum.parallels.com/showthread.php?289011

  • RELEVANCY SCORE 3.15

    DB:3.15:Plesk 9.5.4 And Php 5.3 kc





    Hello,

    Im currenty running plesk 9.5.4 and PHP 5.2.16
    and I want to upgrade it to 5.3.1 or higher.
    is there any safe way to do it ?

    DB:3.15:Plesk 9.5.4 And Php 5.3 kc




    Hello,

    Im currenty running plesk 9.5.4 and PHP 5.2.16
    and I want to upgrade it to 5.3.1 or higher.
    is there any safe way to do it ?

  • RELEVANCY SCORE 3.14

    DB:3.14:Php 5 Upgrade cc





    Hello,

    I really really could use some help...

    I rent a VPS with FC2, PLESK 7.5.4 and MySQL 4.21 installed on it.

    I wanted to upgrade PHP to version 5 (from version 4) and Ive used the ART repo for that.

    This is what I have done:

    1) yum remove php
    (I saw a lot of psa dependencies were removed too)

    2) yum install php

    After this psa didnt work anymore... so I tried to fix this...

    3) yum remove psa

    4) yum install psa

    5) yum install psa-*

    psa still doesnt want to start...

    Output:

    Also my POP3 mail accounts doesnt work anymore...

    PHP 5 is working and my sites are online and working on PHP 5.

    Output for rpm -qa | grep php:

    Code:

    DB:3.14:Php 5 Upgrade cc




    If the instructions are not working for you, you might want to let Scott know so he can maybe fix them. He has a nice forum as well.

  • RELEVANCY SCORE 3.11

    DB:3.11:Please Help: Horde/String.Php Issues After Php 5.2 Upgrade sz





    After an upgrade to PHP5.2.4RC from PHP5.1 on Suse 10.1 with Plesk 8.2 everything works fine besides Horde. Horde gives following errors on webmail page:

    Warning: require_once(Horde/String.php) [function.require-once]: failed to open stream: No such file or directory in /usr/share/psa-horde/lib/Horde/Browser.php on line 4

    Fatal error: require_once() [function.require]: Failed opening required Horde/String.php (include_path=/usr/share/psa-horde:/usr/share/psa-horde/pear:.) in /usr/share/psa-horde/lib/Horde/Browser.php on line 4

    forcing rpm reinstalls of psa-horde-3.1.4-suse10.1.build82070706.15.noarch.rpm and psa-imp-4.1.4-suse10.1.build82070706.15.noarch.rpm didnt change anything.

    Thank you for hints into the right directions!

  • RELEVANCY SCORE 3.11

    DB:3.11:Imp3.1 And Php ? 3d





    I am going to install PLESK 5.0 on a RH7.2 RPM server, and the latest PHP RPM for RH7.2 is 4.06

    from the PSA 5 Docs

    4. Install the rpms of indicated versions or higher from the RedHat 7.2 disc:
    (if you cannot find any rpm on your RedHat 7.2 disc, check ftp://updates.redhat.com/7.2/en/)
    apache-1.3.22-6.i386.rpm
    ....
    php-4.0.6-15.i386.rpm
    php-imap-4.0.6-15.i386.rpm
    php-mysql-4.0.6-15.i386.rpm

    However from the Horde website IMP 3.1 requires PHP 4.1.0 or higher, and will operate with either version 2.0 or 2.1 of the Horde Application Framework.IMP 3.1 requires PHP 4.1.0 or higher, and will operate with either version 2.0 or 2.1 of the Horde Application Framework.

    There is a mention in the PSA 5.0 release notes of

    [*] imp version changed to 3.1
    [*] horde version changed to 2.0
    [*] admins Apache php version changed to 4.2.2

    Has anyone yet installed PSA 5.0 on a RH7.2 RPM server with PHP 4.06 ? Does webmail work ?

    DB:3.11:Imp3.1 And Php ? 3d




    All versions off php below 4.2.2 have security issues. rh has imported the fix in there rpms but people do a phpinfo(); and see a version that is according to the www.php.net site not safe. They dont know about the special rh rpms and dont believe it if you try to tell them.
    So my advice is not to install anything below the version that php says is save.

    you can use the rpms of troels at http://rpms.arvin.dk/ they are a very extensive version 4.2.2 so you can install every module you will ever need. I compile my own version and it works also so i think every version of 4.2.2 is ok. horde was released before 4.2.2 so i think they used the new pear that was not yet included in 4.1.x but is included in 4.2.x

    regards

    Jan

  • RELEVANCY SCORE 3.09

    DB:3.09:Php Upgrade = 5.2 Plesk 10.1? s9





    Any official recomendation for php upgrad = 5.2 in plesk 10.1?
    Have plesk in vps CentOS 5 VZcontainer, no yum enabled only VZ package manager.

    Or any consideration to include in next releases?

    DB:3.09:Php Upgrade = 5.2 Plesk 10.1? s9




    thank for info.

    I prefer no third party solutions.

    In Vz package manager i see:
    package
    pp-php5.3
    PHP 5.3 support for Plesk for Parallels Hosting Panel for CentOS Linux version 5 (for AMD64/Intel EM64T) EZ template

    This is php 5.3 for centos or only plesk panel support for third party updates of php?
    I need php 5.3, the solution is migrate to diferent server with other OS distribution?

  • RELEVANCY SCORE 3.09

    DB:3.09:Upgrade To Php 5 9x





    I have tried searching the forums and on other websites about how to do this, but havent found anything that works in my case.

    I am running Fedora Core 2 and Plesk 8 and I want to upgrade to php 5 because I have some code that only works with php 5.

    Does somebody know how to successfully do this, either using an RPM or by compiling from source?

    I have tried running the yum upgrade command, but it doesnt list php 5...only php 4.3.11 (which I have installed).

    Im not really a guru when it comes to system admin, and unfortunately, my server host doesnt provide support due to the inexpensive cost of the server.

    Thanks

    DB:3.09:Upgrade To Php 5 9x




    You ROCK!

    That worked perfectly! I had a few errors after updating php5, but then I realised that there were 2 files that needed to be replaced with new versions, which were php.ini and php.conf. Finally, I can write some php5 compatible code.

    Thanks again!

  • RELEVANCY SCORE 3.09

    DB:3.09:[Plesk 10.4.4 On Debian 6] Php 5.3.3 - 5.3.6 Or Higher xd





    Hello all!

    I would appreciate if someone could tell me what I need to do, to upgrade my PHP from the 5.3.3 which is included to 5.3.6 or maybe even higher (if possible, but not needed)

    I run a Debian 6 Box with Plesk 10.4.4 (just updated)



    OS Linux 2.6.38.2-grsec-xxxx-grs-ipv6-64
    Panel version 10.4.4 Update #4
    psa 10.4.4-debian6.0.build1013111102.18
    php 5.3.3-7+squeeze3

  • RELEVANCY SCORE 3.09

    DB:3.09:Plesk 8.4 On Virtuozzo Php Upgrade 7m





    I currently have Plesk 8.4 running on Virtuozzo 3.x and CentOS 4.5 as the OS. Virtuozzo couldnt do CentOS at the time of install.

    How can I upgrade just PHP to at least PHP 4.4.x or even 5.2.x?

    Thanks.

    DB:3.09:Plesk 8.4 On Virtuozzo Php Upgrade 7m




    After reinstalling the node were back to the same final error that I cannot get past:

    After installing YUM to get PHP updated, we get an error:

    -- Processing Dependency: libxerces-c.so.25 for package: expand
    -- Processing Dependency: libXaw.so.7 for package: t1lib Restarting
    -- Dependency Resolution with new changes.
    -- Populating transaction set with selected packages. Please wait.
    --- Downloading header for libXaw to pack into transaction set.
    libXaw-1.0.2-8.1.i386.rpm 100% |=========================| 7.5 kB 00:00

    --- Package libXaw.i386 0:1.0.2-8.1 set to be updated
    -- Running transaction check
    -- Processing Dependency: libxerces-c.so.25 for package: expand
    -- Processing Dependency: libXmu.so.6 for package: libXaw Restarting
    -- Dependency Resolution with new changes.
    -- Populating transaction set with selected packages. Please wait.
    --- Downloading header for libXmu to pack into transaction set.
    libXmu-1.0.2-5.i386.rpm 100% |=========================| 6.4 kB 00:00

    --- Package libXmu.i386 0:1.0.2-5 set to be updated
    -- Running transaction check
    -- Processing Dependency: libxerces-c.so.25 for package: expand
    -- Finished Dependency Resolution
    Error: Missing Dependency: libxerces-c.so.25 is needed by package expand

  • RELEVANCY SCORE 3.08

    DB:3.08:Plesk 8.0.1 And Php 5.0.4 xp





    Why you dont upgrade PHP to the latest released? (i.e. PHP 5.1.6)

    Because PHP 5.0.4 have many many bugs as:
    1) Session Managment Problem
    2) GD (TrueType) Image Visualization Problem

    and many other...

    or there is a way to upgrade manually php in full compatibility with Plesk 8.0.1 ??

    DB:3.08:Plesk 8.0.1 And Php 5.0.4 xp




    Why you dont upgrade PHP to the latest released? (i.e. PHP 5.1.6)

    Because PHP 5.0.4 have many many bugs as:
    1) Session Managment Problem
    2) GD (TrueType) Image Visualization Problem

    and many other...

    or there is a way to upgrade manually php in full compatibility with Plesk 8.0.1 ??

  • RELEVANCY SCORE 3.06

    DB:3.06:Upgrading To Php 5.3 k1





    Im on a Centos dedicated server running Plesk 10.0.1. I currently have php 5.2.16 and mysql 5.1.54 installed. Is it possible to upgrade php to either 5.2.5 or 5.3 without killing the whole system? Do I need to upgrade mysql too?

  • RELEVANCY SCORE 3.05

    DB:3.05:Php 4 To Php 5 Upgrade 9x





    Hello,

    I have a question about upgrading php 4 to php 5 using yum update. I have centos 4.5 server. And i asked at their support forums as how can i upgrade to php 5 using yum update. Because i heard that php 4 support will be over at end of the year. And they give me a command like

    yum enablerepo=centosplus update php

    But i am not sure if it is a good idea to update php using centosplus repo, because i had some problems about using other repos for updating software.

    So i have 2 questions,

    Is it safe to upgrade php like the way i told above ?

    If it is safe, is there a way to mess up plesk by updating php by this method.

    Or i will be glad if anyone can tell a safe method to updating php.

    DB:3.05:Php 4 To Php 5 Upgrade 9x




    Is that a CentOS 4 VPS? You should have 2 channels by default (base and updates), and atomic would be the third. That output isnt displaying any channels.

  • RELEVANCY SCORE 3.03

    DB:3.03:Plesk Prevents Me From Upgrading Php 5.1 To 5.3 Or Higher jf





    I have CentOS 5.9 with Plesk 9.5 and it has PHP 5.1

    Now php 5.1 cant be simply upgraded to 5.3 with yum update because php starting from 5.3 is a different package, php53 (while php 5.1 is just php).

    But I cant install the package php53 without uninstalling php 5.1 because they conflict:
    php53-common conflicts with php-common

    So I should first uninstall the php package (php 5.1).
    BUT I cant because plesk depends on it, so if I uninstall php I will be forced to uninstall Plesk.

    So how do I upgrade php to 5.3 while keeping plesk?

    Thanks
    m.

    DB:3.03:Plesk Prevents Me From Upgrading Php 5.1 To 5.3 Or Higher jf




    Hi,

    You should be able to just use yum

    yum upgrade php

    and there is also the downgrade that yum can do too.

  • RELEVANCY SCORE 3.03

    DB:3.03:Strange Problem Php Upgrade 4.2.2 c9





    Hi,

    I just upgraded to php 4.2.2 I am having some problems. Some of the PHP files do not work. They do not show up on the browser.. whenever i try to access a php file from the browser, it just says page cannot be displayed. Can anyone please help.. This problem is ocurring to only some php files not all.. just few..

    Again please help..

    Best Regards,

    DB:3.03:Strange Problem Php Upgrade 4.2.2 c9




    Locate your php.ini file.

    Look for the section which sets register_globals.

    Change Off to On

    Jabba

  • RELEVANCY SCORE 3.03

    DB:3.03:Php 4.2.X Vulnerability cx





    All,
    We have received several inqueries about this already, as well as posts in the forums. Unless you have upgraded PHP to 4.2.0 or 4.2.1, you are not vulnerable to this, and there is no patch. Please read the following announcement from php.net.



    [22-Jul-2002] The PHP Group today announced the details of a serious vulnerability in PHP versions 4.2.0 and 4.2.1. A security update, PHP 4.2.2, fixes the issue. Everyone running affected versions of PHP is encouraged to upgrade immediately. The new 4.2.2 release doesnt include other changes, so upgrading from 4.2.1 is safe and painless.

    DB:3.03:Php 4.2.X Vulnerability cx




    All,
    We have received several inqueries about this already, as well as posts in the forums. Unless you have upgraded PHP to 4.2.0 or 4.2.1, you are not vulnerable to this, and there is no patch. Please read the following announcement from php.net.



    [22-Jul-2002] The PHP Group today announced the details of a serious vulnerability in PHP versions 4.2.0 and 4.2.1. A security update, PHP 4.2.2, fixes the issue. Everyone running affected versions of PHP is encouraged to upgrade immediately. The new 4.2.2 release doesnt include other changes, so upgrading from 4.2.1 is safe and painless.

  • RELEVANCY SCORE 3.01

    DB:3.01:How Do I Upgrade Php 5.0.4-10 To Php 5.2.1 c7





    Guys, i´m needing to Upgrade my PHP version from 5.0.4 to 5.2.1 because many off Php scripts aren´t working, what i have to do to upgrade my PHP without problems, Plesk will continuous working fine?? I´m using fedora.

    Thanks

    DB:3.01:How Do I Upgrade Php 5.0.4-10 To Php 5.2.1 c7




    probably better to take this thread up on my site, since I only check in here every other day. Thats a curious problem though, something between the 2 rpms are keeping them from recognizing its an update.

  • RELEVANCY SCORE 2.99

    DB:2.99:Bad Gateway - Php Upgrade Install? 38





    Hi,

    I get bad gateway php error quite a bit. I checked under plesk 7.6 for windows on our server and we are running php 4.4.2

    I read somewhere that php 4.4.3 corrects this error. Should i upgrade to 4.4.3 or a higher version?

    Also I have never done this before. I see a download for windows installed php 4.4.3. Do i download this to our webserver and run it?

    Please advise.

    Thank you,

    Gibs

    DB:2.99:Bad Gateway - Php Upgrade Install? 38




    still bad gateway and no help

    i still get bad gateway after the upgrade and my php scripts cannot send email. Can anyone give a response?

    Thanks,

    Gibs

  • RELEVANCY SCORE 2.99

    DB:2.99:Can The First Iphone Upgrade To Ios 5 Or Higher pc


    can i upgrade my original iphone 4.2.1 verson to ios 5 or 6

    DB:2.99:Can The First Iphone Upgrade To Ios 5 Or Higher pc

    The original iPhone will not update past 3.1.3.The 3G is end of lifed at 4.2.1.

  • RELEVANCY SCORE 2.99

    DB:2.99:Update To Php 5.2.X Or 5.3.X zx





    Hi,

    What is the steps to upgrade php 5.1.6 on PPCP 10.3.3 on centos 5 to php 5.2.x or 5.3.x ?

    Thank you for your help
    Best regards

  • RELEVANCY SCORE 2.99

    DB:2.99:How Can I Upgrade Php 4 To Php 5 cj





    I m using plesk 8.2 how can I upgrade php 4 to 5 ?

    DB:2.99:How Can I Upgrade Php 4 To Php 5 cj




    how you solved the problem

    I am facing the same problem I upgraded my php from 5.1 to 5.2 and plesk is showing the same error. Please reply soon
    Thankls in advance

  • RELEVANCY SCORE 2.99

    DB:2.99:Removal Of Php 4.X And Add Php 5.3 7c





    The only issue I have found with plesk 10.x and PHP 5.3 is the incompatibility with MySQL 5.5.9. In the future could you write php 5.3 into the CP to either replace 4.x (antiquated) or as an additional choice. Right now we basically remove 4.x from the PHP folder and install 5.3 into it.

    DB:2.99:Removal Of Php 4.X And Add Php 5.3 7c




    Now we have discussion about complete elimination of old PHP4 from hosting options.

  • RELEVANCY SCORE 2.99

    DB:2.99:How Do I Uprading Php 4.3.2 To 4.3.10 On Plesk 7.5 Reloaded 87





    I wish to upgrade php4.2 to 4.3.10 on plesk 7.5 reloaded.
    my operating system: Red Hat Enterprise Linux 3
    Can anyone please give me a step by step instructions on how I can do this upgrade.
    Thank you very much.

    DB:2.99:How Do I Uprading Php 4.3.2 To 4.3.10 On Plesk 7.5 Reloaded 87




    Thanks for the insturctions! Did just that (customised for RHEL) and it works just fine. Now Ive juts gotta figure out why webmail aint working - it wasnt working BEFORE the update so I dont think it was anything to do with that.

    Everything else working as it should. Thanks!

  • RELEVANCY SCORE 2.99

    DB:2.99:Upgrade Php 5.1.6 To 5.3.2 In Plesk Linux 9.5 z1





    Hi,

    We just upgraded the server from Plesk Panel Linux 8.6 to 9.5, but I noticed the PHP version in 9.5 still showing

    5.1.6-23.2.el5_3

    Can we upgrade the version to 5.3.2? Any risk for doing so as the PHP is integrated with Plesk? Please also advice the steps.

    Thanks.

    Regards,
    Hostpro2u

    DB:2.99:Upgrade Php 5.1.6 To 5.3.2 In Plesk Linux 9.5 z1




    Hi,

    Weve just upgraded the PHP version from 5.1.6 to 5.2.17-1.el5.art but weve received complaints from customer that their website having problem to connect to external MySQL DB (cause we dont use the local MySQL server)

    The error seems like : the php library version is different with the existing mysql version

    Any advice what can we do on this?

    How do we reverse back to old PHP version if still cannot fix?

    Thanks.

  • RELEVANCY SCORE 2.98

    DB:2.98:Upgrade Php To 5.2.4 Or Higher On Plesk 10.3.1 x9





    Hello, how do i upgrade php on CentOS 5.6 64bits on Plesk 10.3.1

    and on Plesk 9.6 CentOS 32 bits

    Both servers has web sites.

    Thanks
    Jc

    DB:2.98:Upgrade Php To 5.2.4 Or Higher On Plesk 10.3.1 x9




    I tryed to upgrade the PHP I got the error below

    File downloading PSA_9.5.4/update-rpm-CentOS-5-i386/php53-xml-5.3.3-1.el5_6.1.i386.rpm: was skipped because of md5 checksum match.
    File downloading PSA_9.5.4/update-rpm-CentOS-5-i386/php53-common-5.3.3-1.el5_6.1.i386.rpm: was skipped because of md5 checksum match.
    Starting installation of packages
    Installing the package psa-migration-manager-9.5.4-cos5.build95110630.11.i586, psa-backup-manager-9.5.4-cos5.build95110630.11.i586, psa-api-rpc-9.5.4-cos5.build95110630.11.noarch, psa-api-9.5.4-cos5.build95110630.11.noarch
    error: Failed dependencies:
    psa 9.5.4 conflicts with psa-api-9.5.4-cos5.build95110630.11.noarch
    ERROR: Unable to install the requested packages because either there is
    not enough free disk space left, or there are package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.
    [root@ns2 ~]#

  • RELEVANCY SCORE 2.98

    DB:2.98:Plesk 10.2 And Php 5 fx





    Although from the control panel imposed php 5, the site always works with php 4.I tried to create a new plan by giving permission to the customer but only ever seen php4. Why?

    DB:2.98:Plesk 10.2 And Php 5 fx




    Do you have PHP 5 in Server Components as Installed? Did you try to refresh Server Components?

  • RELEVANCY SCORE 2.97

    DB:2.97:Plesk 9.2 And Php 5.3 ak





    Hi

    Is it possible to install PHP 5.3.x beside 5.2.9 on our Plesk 9.2 System?

    If not, is it possible to upgrade the PHP Version to 5.3.x?

    Best regards,
    Stefan

    DB:2.97:Plesk 9.2 And Php 5.3 ak




    How do you install version 5.2.17? I did PHP info on a sample site on a Windows server that has been upgraded to 9.5.5 and its displaying version 4.4.9.

    EDIT: I found these instructions:

    [How to] upgrade custom PHP 5 for Parallels Plesk Panel 8.x and 9.x
    http://kb.parallels.com/6670

    Our problem was however that we just needed to select 5.2.17 from the Web Hosting setup dialog.

  • RELEVANCY SCORE 2.97

    DB:2.97:Security Vulnerability In Php 4.2.X 81





    You should upgrade to 4.2.2 if you have upgraded your PHP install, like I have.

    PHP website is slow so I am using a mirror: http://php.he.net/release_4_2_2.php

    stupidnic

    DB:2.97:Security Vulnerability In Php 4.2.X 81




    I found my problem.

    --with-mcrypt=/usr/local/lib \
    should be
    --with-mcrypt=/usr/local/lib/libmcrypt \

  • RELEVANCY SCORE 2.97

    DB:2.97:How Upgrade Php To Version 5.2.4? sm





    On page http://download1.swsoft.com/Plesk/Plesk8.3/Doc/plesk8.3_whatsnew.htm

    write:
    Admin PHP upgrade � Upgrade of Plesk Admin PHP to version 5.2.4 (latest release) or higher as there are security vulnerabilities in previous PHP versions.

    How upgrade php to version 5.2.4?

    DB:2.97:How Upgrade Php To Version 5.2.4? sm




    just do this:

    wget -q -O - http://www.atomicorp.com/installers/atomic.sh | sh

    and after that:

    yum update

    yes to all, wait and feel fine

  • RELEVANCY SCORE 2.97

    DB:2.97:Php 5.2 Upgrade Issue xp





    Hello, I run Parallels 9.5 on CentOS, running a webserver with PHP 5.1.6 and I would like to upgrade to 5.2. Ive tried to upgrade through yum, and it says its successful and doing php -v reports that I have 5.2.6 installed, however when I bring up phpinfo() on my webserver it still says 5.1.6. Any ideas?

    Thanks.

  • RELEVANCY SCORE 2.96

    DB:2.96:Upgrade To Php5? j8





    What is the easiest way to upgrade my machine to use PHP 5? I tried:

    yum update php

    but it just checks for latest version of PHP 4. I have CentOS 4.3 and Apache 2 running. Im obviously not a server expert. Id like to handle the installation as automatically as possible... any suggestions?

    DB:2.96:Upgrade To Php5? j8




    Thanks breun for your tips about IonCube, and the stepping back (did a server restore just because I had the script for this and it not (yet) a production server). Will post any news about this issue.

  • RELEVANCY SCORE 2.96

    DB:2.96:Php 5.2.X Installed, Phpinfo() On Clients Account States Old 5.1 Still fp





    I have recently used the atomicorp repo on Centos 5 to upgrade php 5.1 to php 5.2.17, and the admin control panel in plesk reflects this change, but when installing web scripts, or phpinfo() on any website, it still claims it is php 5.1 and i have tried restarting psa, apache, etc.. im sure im overlooking something simple, any responce would be extremely helpful! thanks

    DB:2.96:Php 5.2.X Installed, Phpinfo() On Clients Account States Old 5.1 Still fp




    Sorry, my bad.. I replaced /etc/php.ini.rpmnew with /etc/php.ini and made some personal changes, then restarted httpd again, and it seems to work.. disregard!

  • RELEVANCY SCORE 2.96

    DB:2.96:Php Version 5.3.3 5.3.10 k7





    Hallo,

    My OS is Debian 6.0.6
    Panel version: 11.0.9 Update #34

    In Hosting Settings / PHP Settings it says:
    Your current PHP version is 5.3.3

    Your release notes say PHP is upgraded to 5.3.10
    Some software we use need minimal requirements of PHP 5.3.8
    How can I upgrade to this version or higher ?

    xsaver

    DB:2.96:Php Version 5.3.3 5.3.10 k7




    It must be completely safe to upgrade PHP if the new PHP comes from your OS updates.
    In case you obtained the PHP from alternative source or compiled yourself, it would mainly depend on how much your new package is compatible with the original OS package
    (particularly - same location for logs, configs and executables).

  • RELEVANCY SCORE 2.95

    DB:2.95:Php-4.2.2 31





    How do I upgrade php 4.0.6 to 4.2.2 on Plesk 5.0. A complete detailed how to would be greatly apprectiated.

    DB:2.95:Php-4.2.2 31




    Solved!!!

    Thanks for the reply. With the help of support I could able to upgrade to PHP4.1.x. With RPM install that we have it was kinda easier way to do it. Just download the RPMs you need from plesk download site and try installing them. But this simple process might not be that simple if you dont know what RPM is needed for what . The best thing I could do is to contact support and these guys are really nice and willing to help any time. Cool!

    Thanks.

    -Srinivas

  • RELEVANCY SCORE 2.95

    DB:2.95:Php 5 Compatibility With Php 4 Script pz





    There something someone was looking for it,

    i have search like 2 hours for enable my compatibilty with php 4 for php 5

    i join my php.ini if you want to look what is like and what to change

    i have added some comment.

    There the link for look :

    http://www.axezium.com/php.txt

    Axezium
    Network Admin
    http://www.axezium.com
    glemay@axezium.com

    DB:2.95:Php 5 Compatibility With Php 4 Script pz




    There something someone was looking for it,

    i have search like 2 hours for enable my compatibilty with php 4 for php 5

    i join my php.ini if you want to look what is like and what to change

    i have added some comment.

    There the link for look :

    http://www.axezium.com/php.txt

    Axezium
    Network Admin
    http://www.axezium.com
    glemay@axezium.com

  • RELEVANCY SCORE 2.94

    DB:2.94:Upgrade To Plesk 7.0.2 And Php 4.3.9 3z





    Plesk says PHP not installed. HELP!!!

    Upgrade to plesk 7.0.2 and PHP 4.3.9

    After upgrade I noticed sites are working great, but Plesk say php is not installed anymore..

    the php.ini is still the same... no files are deleted.. path the same.. what does it use to recognize php? its not working... and the php pages are encrypted so I cant check..

    DB:2.94:Upgrade To Plesk 7.0.2 And Php 4.3.9 3z




    Plesk says PHP not installed. HELP!!!

    Upgrade to plesk 7.0.2 and PHP 4.3.9

    After upgrade I noticed sites are working great, but Plesk say php is not installed anymore..

    the php.ini is still the same... no files are deleted.. path the same.. what does it use to recognize php? its not working... and the php pages are encrypted so I cant check..

  • RELEVANCY SCORE 2.94

    DB:2.94:Can Someone Help Me Upgrade A Captivate 2 File? 81



    I have a client who has an old Captivate 2 course. We of course want to upgrade it so we can at least open it. My oldest version is Cap 5. Does someone still have cap 3 or 4 that might be willing to at least open it and save it to a higher version for me?

    DB:2.94:Can Someone Help Me Upgrade A Captivate 2 File? 81


    I have a client who has an old Captivate 2 course. We of course want to upgrade it so we can at least open it. My oldest version is Cap 5. Does someone still have cap 3 or 4 that might be willing to at least open it and save it to a higher version for me?

  • RELEVANCY SCORE 2.93

    DB:2.93:Sitebuilder 4.2 And The Php 5.2.6 With Sqlite 3.X pk





    I have the Sitebuilder 4.2 and the PHP 5.2.6 with SQLite 3.x, that I must do in order that the applications work with SQLite 3.x or to lower SQLite 2.x.

    DB:2.93:Sitebuilder 4.2 And The Php 5.2.6 With Sqlite 3.X pk




    Please check following article: http://kb.odin.com/en/5460
    and related http://kb.odin.com/en/5461, http://kb.odin.com/en/5462
    Hope it will be helpful.

  • RELEVANCY SCORE 2.93

    DB:2.93:App-Vault Packages Will Not Install Plesk 8 dk





    I moved to Plesk 8.0, fc4 and PHP 5 ( brand new box ). None of the installed application vault packages will install to individual domains. The installation is checking for PHP version ==4.x.x. How do I tell them to look for 4.x or higher?

    Thanks
    Jack

    DB:2.93:App-Vault Packages Will Not Install Plesk 8 dk




    It worked for me. I did it on all the appliations in the vault and I have installed and used at least 1/2 of them since then and they all work.

  • RELEVANCY SCORE 2.93

    DB:2.93:Upgrading Php To 5.3.6 Or Higher And Libxml2 p7





    Hi,

    Im running Plesk Panel 10.4.4 on Centos 5.7 system. Right now i have PHP 5.3.3 that is shipped with Plesk but this version is a bit outdated and it have some bugs, especially related with libxml2. My libxml2 shipped with Centos 5.7 is very old (2.6.26) and i need to update it also. So can anyone suggest any way to upgrade my PHP to a higher version (5.3.8 or may be 5.3.10) and also libxml2 on Centos? Doing this can bring any problem with Plesk 10.4.4?

    many thanks in advance,

  • RELEVANCY SCORE 2.92

    DB:2.92:Upgrading From Php5.1.6 To 5.2.4 On 10.3.5 1m





    I have recently setup a couple of servers with clean installs of 10.3.5. Id like to limit the customizations, for a smoother upgrade process to 10.3.6 when that is released, projected in December.

    Id like to know if an ensimized RPM could be released for PHP 5.2.4 (Minimum).

    As most are aware there has been a new release of WordPress. Some of our clients have already requested that we upgrade PHP so that they may upgrade WordPress.

    Version 3.2 - WordPress
    Requirements Changes -
    ■ PHP 5.2.4 or greater (old requirement - since WordPress 2.5 was PHP 4.3 or greater)
    ■ MySQL 5.0.15 or greater (old requirement - since WordPress 2.9 was MySQL 4.1.2 or greater)

    The MySQL is satisfied but the PHP is not.

    Thanks in Advance.

  • RELEVANCY SCORE 2.92

    DB:2.92:Pb Getting Record Navigation Work Within A Div sf



    Hi,

    I've been trying and trying but I am not getting anywhere ... I am trying to set up navigation to be able to move to a next or previous detail page. I just don't understand what is wrong and cannot find any clear explanation on how to do it ... any help will be appreciated:

    The dreamweaver code is as follow:

    div class="wrapper"a href="?php printf("%s?pageNum_DetailRS1=%d%s", $currentPage, min($totalPages_DetailRS1, $pageNum_DetailRS1 + 1), $queryString_DetailRS1); ?"ghjh/a total?php echo $totalRows_DetailRS1 ?/div
    div class="col-5"
    h1?php echo $row_DetailRS1['title']; ?/h1
    ?php do { ?
    div id="tabs"
    ul
    lia href="#tabs-1"?php echo $row_translations['descriviaje']; ?/a/li
    lia href="#tabs-2"?php echo $row_translations['fechareg']; ?/a/li
    lia href="#tabs-3"?php echo $row_translations['fotos']; ?/a/li
    lia href="#tabs-4"?php echo $row_translations['itincompleto']; ?/a/li
    lia href="#tabs-5"?php echo $row_translations['servicios']; ?/a/li
    /ul
    div id="tabs-1"
    table width="100%" border="0" cellpadding="0" cellspacing="5"
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['estilo_viaje']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['type']; ?/td
    /tr
    tbody
    tr
    tdstrong?php echo $row_translations['temporada']; ?/strong/td
    td?php echo $row_DetailRS1['temporada']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['inicio']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['inicio']; ?/td
    /tr
    /tbody
    tbody
    tr
    tdstrong?php echo $row_translations['salida']; ?/strong/td
    td?php echo $row_DetailRS1['salida']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['minpas']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['pasajero_minimo']; ?/td
    /tr
    tr
    tdstrong?php echo $row_translations['dificult']; ?/strong/td
    td?php echo $row_DetailRS1['dificulktad']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['comienz']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['comienza']; ?/td
    /tr
    tr
    tdstrong?php echo $row_translations['finaliz']; ?/strong/td
    td?php echo $row_DetailRS1['finaliza']; ?/td
    /tr
    /tbody
    /table
    div style="float:left; width:300px; /* [disabled]line-height: 1em; */ margin-right: 20px;"
    h3strong?php echo $row_translations['descriviaje']; ?/strong/h3
    pbr /
    ?php echo $row_DetailRS1['description']; ?/p
    /div
    div ?php echo $row_DetailRS1['itinierario']; ? /div
    /div
    div id="tabs-2"
    div id="datepicker"/div
    /div
    div id="tabs-3"Fotos/div
    div id="tabs-4" ?php echo $row_DetailRS1['itinera_completo']; ? /div
    div id="tabs-5" ?php echo $row_DetailRS1['servicios']; ? /div
    /div
    ?php } while ($row_DetailRS1 = mysql_fetch_assoc($DetailRS1)); ?

    DB:2.92:Pb Getting Record Navigation Work Within A Div sf


    Hi,

    I've been trying and trying but I am not getting anywhere ... I am trying to set up navigation to be able to move to a next or previous detail page. I just don't understand what is wrong and cannot find any clear explanation on how to do it ... any help will be appreciated:

    The dreamweaver code is as follow:

    div class="wrapper"a href="?php printf("%s?pageNum_DetailRS1=%d%s", $currentPage, min($totalPages_DetailRS1, $pageNum_DetailRS1 + 1), $queryString_DetailRS1); ?"ghjh/a total?php echo $totalRows_DetailRS1 ?/div
    div class="col-5"
    h1?php echo $row_DetailRS1['title']; ?/h1
    ?php do { ?
    div id="tabs"
    ul
    lia href="#tabs-1"?php echo $row_translations['descriviaje']; ?/a/li
    lia href="#tabs-2"?php echo $row_translations['fechareg']; ?/a/li
    lia href="#tabs-3"?php echo $row_translations['fotos']; ?/a/li
    lia href="#tabs-4"?php echo $row_translations['itincompleto']; ?/a/li
    lia href="#tabs-5"?php echo $row_translations['servicios']; ?/a/li
    /ul
    div id="tabs-1"
    table width="100%" border="0" cellpadding="0" cellspacing="5"
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['estilo_viaje']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['type']; ?/td
    /tr
    tbody
    tr
    tdstrong?php echo $row_translations['temporada']; ?/strong/td
    td?php echo $row_DetailRS1['temporada']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['inicio']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['inicio']; ?/td
    /tr
    /tbody
    tbody
    tr
    tdstrong?php echo $row_translations['salida']; ?/strong/td
    td?php echo $row_DetailRS1['salida']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['minpas']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['pasajero_minimo']; ?/td
    /tr
    tr
    tdstrong?php echo $row_translations['dificult']; ?/strong/td
    td?php echo $row_DetailRS1['dificulktad']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['comienz']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['comienza']; ?/td
    /tr
    tr
    tdstrong?php echo $row_translations['finaliz']; ?/strong/td
    td?php echo $row_DetailRS1['finaliza']; ?/td
    /tr
    /tbody
    /table
    div style="float:left; width:300px; /* [disabled]line-height: 1em; */ margin-right: 20px;"
    h3strong?php echo $row_translations['descriviaje']; ?/strong/h3
    pbr /
    ?php echo $row_DetailRS1['description']; ?/p
    /div
    div ?php echo $row_DetailRS1['itinierario']; ? /div
    /div
    div id="tabs-2"
    div id="datepicker"/div
    /div
    div id="tabs-3"Fotos/div
    div id="tabs-4" ?php echo $row_DetailRS1['itinera_completo']; ? /div
    div id="tabs-5" ?php echo $row_DetailRS1['servicios']; ? /div
    /div
    ?php } while ($row_DetailRS1 = mysql_fetch_assoc($DetailRS1)); ?

  • RELEVANCY SCORE 2.92

    DB:2.92:Upgrade Php To Php 4.3.8 Rpm ? 1s





    Hello,

    I am at present on php 4.2.2 and I wish to cross(spend) php 4.3.8, or to find package them RPM php 4.3.8 for RedHat 9?

    Thanks

    DB:2.92:Upgrade Php To Php 4.3.8 Rpm ? 1s




    I support a great many updated PSA compatible rpms for rh9, fc1, fc2, and 3es on my website, including php 4.3.9.

  • RELEVANCY SCORE 2.92

    DB:2.92:Thread: Up Grade Mysql 4.0.26 To 4.1.2 Or 5.0.67 fs


    Hi!

    I wish to upgrade the MySQL on a web server (NW6.5 sp6 - Apache 2, MySQL ver. 4.0.26, PHP 5.2.3) to 4.1.2 or 5.0.67.

    1. I found at http://dev.mysql.com/doc/refman/4.1/...tallation.html the link to

    PHP: http://forge.novell.com/modules/xfco...p/php/Modules/ there are modules for

    UCS, MySQL 4.1 or MySQL 5.0, GD, PDF, PostgreSQL, zlib, cURL.

    Shall I install all of them or only for MySQL?

    2. Is there any possibility to upgrade directly from MySQL 4.0.26 to 5.0.67, without upgrading first to the intermediate versions?

    3. Is anywhere a more easy step by step upgrade document for novell servers?

    4. Has MySQL 5.0.67 InnoDB storage engine?

    TIA

    Nanu

    DB:2.92:Thread: Up Grade Mysql 4.0.26 To 4.1.2 Or 5.0.67 fs

    Nanu,

    It appears that in the past few days you have not received a response to your

    posting. That concerns us, and has triggered this automated reply.

    Has your problem been resolved? If not, you might try one of the following options:

    - Visit http://support.novell.com and search the knowledgebase and/or check all

    the other self support options and support programs available.

    - You could also try posting your message again. Make sure it is posted in the

    correct newsgroup. (http://forums.novell.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:

    http://support.novell.com/forums/faq_general.html

    If this is a reply to a duplicate posting, please ignore and accept our apologies

    and rest assured we will issue a stern reprimand to our posting bot.

    Good luck!

    Your Novell Product Support Forums Team

    http://support.novell.com/forums/

  • RELEVANCY SCORE 2.91

    DB:2.91:Php 5.2+ Compatability ad





    Can anyone tell me whether Sitebuilder 4.0 is compatible with PHP 5.2+?
    If it is not, are there any upgrade plans to make Sitebuilder compatible with 5.2+

    DB:2.91:Php 5.2+ Compatability ad




    Can anyone tell me whether Sitebuilder 4.0 is compatible with PHP 5.2+?
    server-side SiteBuilder uses php 5.2.1 so I guest it is 5.2+ compatible . The published side runs on any 4.3+ as far as I known.

  • RELEVANCY SCORE 2.91

    DB:2.91:Php Upgrade 5.1.6 To 5.3.1 On Plesk 9.2.3 cz





    Hello,

    Ive read this thread here (http://forum.parallels.com/showthread.php?t=95806), but wondered if it would be okay to upgrade to PHP 5.3.1. Im new to Plesk and have found a quick guide here (http://www.christianmontoya.com/2008/10/01/upgrading-php-and-installing-apc-on-centos-5-with-plesk/) that mentions doing this:

    Code:

    DB:2.91:Php Upgrade 5.1.6 To 5.3.1 On Plesk 9.2.3 cz




    The post stating that yum command not found is probably using a Debian Derived OS (i.e. Debian, Ubuntu etc) which doesnt use YUM, but apt-get instead.

    Look at using the dotdeb.org source instead

  • RELEVANCY SCORE 2.91

    DB:2.91:Upgrade To Php 5.2.0 fm





    Plesk 9.5.2
    CentOS 2.6.18-194.17.1.el5

    I would like to upgrade from PHP 5.1.6 to PHP 5.2.0.

    I just need this one isolated upgrade.

    Any help much appreciated.

    thanks,
    JC

  • RELEVANCY SCORE 2.91

    DB:2.91:How To Install Php 5.4.7 In Plesk? da





    Hi there,

    it seems that plesk only supports php 5.3. is it possible to install php 5.4 into plesk?
    or does it make more sense to wait until a plesk php update comes out?

    DB:2.91:How To Install Php 5.4.7 In Plesk? da




    Had issues with setting up microupdates ##38 and 39.
    MU38 will fail to apply if IIS is started, saying that it cannot rename some files. PHP 5.4 support in components to install becomes active despite of this so in order to correctly install it you will need to remove and then re-add component (IIS should be shut down).

    MU39 also fails to install if IIS is started but also it breaks PleskControlPanel.exe with the following error:

    Execute websrvmng.exe --start-plesk-website failed with error code 1: Component php5_4 isnt supported
    at (execUtil line 142)
    at Execute C:\Program Files (x86)\Parallels\Plesk\admin\bin\websrvmng.exe --start-plesk-website(execUtil line 149)
    at Start control panel(PleskControlPanel::serviceMain line 110)
    at PleskControlPanel::serviceMain(PleskControlPanel::serviceMain line 125)
    Execute file name: C:\Program Files (x86)\Parallels\Plesk\admin\bin\PleskControlPanel.exe

    The Plesk Control Panel Service service is stopping.
    The Plesk Control Panel Service service was stopped successfully.
    ERROR: cant apply patch panel-11.0.9~patch39
    The process cannot access the file because it is being used by another process. (Error code 32) at rename file C:\Program Files (x86)\Parallels\Plesk\admin\htdocs\index.php to C:\Program Files (x86)\Parallels\Plesk\admin\htdocs\.aiupd_10896\index.php.old
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please try installing packages again later.
    Please resolve this issue and try installing the packages again.

    When I manually shut down IIS and then apply update it goes ok and then Im able to start PleskControlPanel.exe without mentioned error but since Plesk has autoupdate feature I suggest that AI.exe shuts down IIS and then starts it when update is finished so I wont be running across all the servers to make sure it did not break things again.

  • RELEVANCY SCORE 2.91

    DB:2.91:Upgrading To Php 5.2 Or Higher x1





    Please help me! how can I upgrade to php 5.2 or higher?

    Now I have PHP 5.1.2 on suse 10.1

    THX

    DB:2.91:Upgrading To Php 5.2 Or Higher x1




    Please help me! how can I upgrade to php 5.2 or higher?

    Now I have PHP 5.1.2 on suse 10.1

    THX

  • RELEVANCY SCORE 2.90

    DB:2.90:How To Upgrade Php To 5.2.4 8a





    Hi

    Is there an easy way to upgrade my PHP (linux) from 5.0.4 to 5.2.4?

    Or clear instructions that are New-to-linux friendly?

    Thanks

  • RELEVANCY SCORE 2.90

    DB:2.90:Php Fastcgi Disaster After Upgrade To 9.5.3 In Windows 2008 R2 8z





    After upgrade to 9.5.3 (in windows 2008 R2) Php stopped working well.
    Event viewer is full of 2 events:

    APPLICATION ERROR



    Faulting application name: php-cgi.exe, version: 5.2.13.13, time stamp: 0x4b853880
    Faulting module name: php-cgi.exe, version: 5.2.13.13, time stamp: 0x4b853880
    Exception code: 0xc0000005
    Fault offset: 0x0000191a
    Faulting process id: 0x147c
    Faulting application start time: 0x01cb84dbcb179d69
    Faulting application path: C:\Parallels\Plesk\Additional\PleskPHP5\php-cgi.exe
    Faulting module path: C:\Parallels\Plesk\Additional\PleskPHP5\php-cgi.exe
    Report Id: 08c8eb09-f0cf-11df-aa54-001cc0dbb27c

    DB:2.90:Php Fastcgi Disaster After Upgrade To 9.5.3 In Windows 2008 R2 8z




    upgraded from 9.5.2

    no solution found. i submitted a ticket, now at 2nd level support, still no solution found. (all sites are working with ISAPI for the moment, but theyre slower)

  • RELEVANCY SCORE 2.89

    DB:2.89:Upgrading Php 4.2.2 To 4.3.8 f3





    Not exactly sure how to handle this issue. I need to upgrade my standard RedHat 9.0 installation that has Plesk 7 Reloaded on it. It curently has php 4.2.2 and I need to upgrade to php 4.3.8, or some version that has the GD library bundled.

    Php 4.2.2 has the old GD 1.6, which does not have the functions I need for image manipulation on my clients real estate website, www.homeward-bound.com

    Last time I tried to upgrade manually, it required that I upgrade apache to =2.0.41, because of changes in php. When I did so, it screwed up Plesk, mail settings (couldnt send or recieve), and folder permissions for the whole server.

    Im looking to avoid these issues this time around. If there is someone out there who has successfully hurdled this task, please let me know.

    Luke Brookhart
    luke@lukebrookhart.com
    www.lukebrookhart.com

    DB:2.89:Upgrading Php 4.2.2 To 4.3.8 f3




    Change your yum.conf to include ARTs repositorys (found on his site)

    Dont do yum update

    Do as he states in his project info:

    yum install php

    That will only do PHP.

  • RELEVANCY SCORE 2.89

    DB:2.89:Upgrade From Php 4.1.0 To 4.2.2 11





    Does anyone have the HOWTO to upgrade from php 4.1.0 to 4.2.2? I need to upgrade asap

    Regards,

    DB:2.89:Upgrade From Php 4.1.0 To 4.2.2 11




    Hello,

    Webmail not working after PHP 4.2.2 ....

    got any fix....

    Thanks
    trivandrum@rediffmail.com

  • RELEVANCY SCORE 2.89

    DB:2.89:New Problem After 4.2 To 4.5 Upgrade 7p





    Hi

    does anyone has similar problem..

    After 4.2 to 4.5 upgrade sitebuilder doesnt work anymore.

    Internal Sitebuilder error.
    File: /usr/local/sitebuilder/include/SB/Auth.php; Line: 54
    Message: PHP Notice : Trying to get property of non-object; Code: 8

    DB:2.89:New Problem After 4.2 To 4.5 Upgrade 7p




    I have resolved the problem.
    The step to resolved was:
    1) upgrade from 4.1 to 4.5 version (after this I has the problem)
    2) make a backup of sitebuilder database (mysql) and sitebuilder directory (eg. /opt/sitebuilder or /usr/local/sitebuilder)
    3) do uninstall of sitebuilder (apt-get remove sitebuilder)
    4) re-install a new sitebuilder 4.5 via script: parallels_installer_v3.3.2_build080710..... (see documetation)
    5) once that new sitebuilder was installed e functioning, replacing the new database and sites directory with the old backup file following all instructions How to migrate sites and users to another Sitebuilder server (http://kb.odin.com/en/5512)
    in particular paragraph 4. (important: replacing only sites directory and not all sitebuilder directory)
    6) empty the session table of sitebuilder database (truncate table session)
    7) do the update to 4.5.7 via automatic update from admin sitebuilder panel.

  • RELEVANCY SCORE 2.89

    DB:2.89:Php 5.3.13 Or 5.4 aj





    With the recent vulnerabilities in php running in CGI when can we expect updates to the php version available.

    Current my server with a hosting company is running 5.3.3 and would like to upgrade that to 5.3.13 at least to stay on te most current 5.3.x

  • RELEVANCY SCORE 2.89

    DB:2.89:Need T Upgrade To Php 5.2 - Need Advice Please p8





    Hello all. I own a VDS server at Godaddy and it is running Parallels Plesk Panel v10.0.1_build109101029.17 os_CentOS 5, PHP 5.1.6. I need to upgrade to at least PHP 5.2 but to be 100% I am scared to death. I just got the command line zip working thanks to this htread: http://forum.parallels.com/showpost.php?p=316326postcount=3

    However I am an needing help moving to PHP 5.2. I really do not want to go any higher than 5.2 as I am hosting web sites that are running Wordpress and I am not sure if Wordpress will work with anything higher than 5.2. Since I have over 15 clients on my server I cant afford to take that chance.

    Now I will be the first to admit I should not have my own server if I do not know how to do this type of thing, but I was sold this server under the understanding that I would have a support team helping me. That later part turned out not to be true so I am stuck with this.

    can anyone help me here? I really need this dumbed down as well. I do not want to take anything for granted.

    I appreciate any help you can give me. Thanks! ~ Erik

    DB:2.89:Need T Upgrade To Php 5.2 - Need Advice Please p8




    Weve got a couple threads about it in the forums:

    https://atomicorp.com/forum/viewtopic.php?f=2t=5138
    https://atomicorp.com/forum/viewtopic.php?f=2t=4997

    There was an even better one in there, but I cant seem to find it

  • RELEVANCY SCORE 2.89

    DB:2.89:Install Php 5.2.4 To Support Wordpress 3.2.1 z8





    How do I upgrade the PHP on my new Small Business Panel 10.2.0 which is currently PHP v5.1.6 to v5.2.4 to support the latest version of Wordpress?

    Ive checked the Updates page on the server and it thinks Im at the current version.

    Help! I have a number of Wordpress users that want to upgrade but cannot currently due to the limitation of the Parallels Small Business Panel.

    martin.

    DB:2.89:Install Php 5.2.4 To Support Wordpress 3.2.1 z8




    Ok, think Ive got it fixed!

    found this link: http://myeasylinux.wordpress.com/2010/07/20/table-mysql-servers/

    ran .. mysql_fix_privilege_tables --user=admin --password=admin passord --verbose

    All seem to be working..

    {pat myself on the back}

  • RELEVANCY SCORE 2.89

    DB:2.89:Upgrade Ios From Version 4 To 5,6 z1


    Need to upgrade my iPod touch to a higher versionof ios software, to version, 5, 6

    DB:2.89:Upgrade Ios From Version 4 To 5,6 z1

    Please note the 2nd generation can not be upgraded beyond 4.2.1.

  • RELEVANCY SCORE 2.89

    DB:2.89:Is It Possible To Have Both Php Versions (5.2 And 5.3) After Update To Plesk 11? ad





    Hello,

    I am using Plesk 10 on a Windows dedicated server.

    I read on Parallels website that version 11 will upgrade PHP to 5.3.

    Is it possible to keep PHP 5.2 together with PHP 5.3?

    Thank you for your help.

    DB:2.89:Is It Possible To Have Both Php Versions (5.2 And 5.3) After Update To Plesk 11? ad




    Hello,

    Yes you can have multiple phps,for that you will need to go to upgrades and updates section hosting features and select the versions that you want to install on your server.

  • RELEVANCY SCORE 2.89

    DB:2.89:Php 4.3, Rh7.3 - Rpms? 3j





    I have a server running RedHat 7.3 and PHP 4.1.

    1 - I need to upgrade PHP to 4.3 but would prefer do it from RPM(s). Does anyone know if they exist? If so, where?

    2 - Does anyone know of any issues with this proposed upgrade? I.E. dependencies or PSA issues.

    Thanks.

    DB:2.89:Php 4.3, Rh7.3 - Rpms? 3j




    Atomic,
    Can you please answer my msg?
    ---------------------
    Since this server from EV1, the yum will not work. So is it possible to use following RPM command to upgrade? will it give any problem without yum? ( sorry, I do not know what yum does)

    rpm -Uvh php*.rpm
    ---------------------

  • RELEVANCY SCORE 2.89

    DB:2.89:What To Upgrade First? 8d





    Hi all,

    My server has:

    Linux 2.6.9-55.0.2.EL
    psa v8.2.1_build82070918.10 os_CentOS 4.2

    with PHP 4.3.9, MySQL 4.1.2 and apache 2.0.52, what is the better way to upgrade to PHP 5.* and MySQL 5.* ?

    I read Centos 5 has PHP 5 MySQL 5, must I upgrade Centos or step by step on packages?

  • RELEVANCY SCORE 2.88

    DB:2.88:Upgrade Plesk8.4 - Php5.1.6 To Php5.2.X 1j





    Hello,

    I have tried to update my server since one week. I cannot find any articles for updating my php!

    How can I update my php without to destroy my plesk settings?!

    Is there any article or description how to do that??

    By the way I tried to compile the php version by myself but there was no effect to the webserver (phpinfo() shows me the old version)! Further the yast dont show me any update related to php?!

    Some information:
    - Plesk8.4
    - openSuSE 10.1 - is this the problem?!
    - PHP5.1.6

    Thanks and regards,
    maTu

    DB:2.88:Upgrade Plesk8.4 - Php5.1.6 To Php5.2.X 1j




    Hello,

    I have tried to update my server since one week. I cannot find any articles for updating my php!

    How can I update my php without to destroy my plesk settings?!

    Is there any article or description how to do that??

    By the way I tried to compile the php version by myself but there was no effect to the webserver (phpinfo() shows me the old version)! Further the yast dont show me any update related to php?!

    Some information:
    - Plesk8.4
    - openSuSE 10.1 - is this the problem?!
    - PHP5.1.6

    Thanks and regards,
    maTu

  • RELEVANCY SCORE 2.88

    DB:2.88:Php 4.2.2 How To Install ? m9





    Hi,

    im in way of installing php 4.2.2

    There is some detailed or special instructions to do it ?

    Thanks !

    DB:2.88:Php 4.2.2 How To Install ? m9




    http://forum.plesk.com/showthread.php?s=threadid=1166

    Wonderful search function in top right hand cornor.

    Nothing different or new to do in PHP 4.2.2 just follow the instructions.

    I did however change --with-system-regex to --with-regex=system , I also --enable-ftp and added mCrypt and GD support. Which I found from a great post somewhere around here.

    ~matt

  • RELEVANCY SCORE 2.86

    DB:2.86:Upgrading To Php 5 az





    Hi,

    Im in the process of upgrading to php 5.0.4 (need mysqli support, which isnt available in php 4.x).

    All went well till the final stage - adding the LoadModule and AddType directives to httpd.conf. I was expecting to find something along the lines of:

    IfDefine HAVE_PHP4
    LoadModule php4_module modules/libphp4.so
    /IfDefine

    ..but there isnt. Does Apache 2 and/or Plesk do things a little different.

    Incidently, Ive seen reports that php 5 doesnt exist happily with horde and squirrelmail. Ive installed php 5 to /usr/local, and left php4 installed. Would it be possible for me to leave php 4 as the default for .php/.php4 files, and only have php 5 used for (say) .php5 files?

    Cheers

    DB:2.86:Upgrading To Php 5 az




    ah well ive managed it eventually, so in case anyone else is thinking of doing this...

    1) install php 5 into /usr/local (the default) so that it doesnt clobber the existing php 4

    2) put a line AddHandler cgi-script .php5 in your apache config or .htaccess. This forces files with the suffix .php5 to be executed as cgi scripts (rather than using the php apache modules). This has a small impact on performance.

    3) any php scripts you wish to execute via the php5 interpreter now need the .php5 extension. In addition, since were executing them as cgi--scripts, youll need to do the same things you do with a Perl cgi, namely:

    * set the script executably by the Web server (usually chmod 755 is ok)

    * put a shebang line at the top: #!/usr/local/bin/php

    * print a content-type header (eg print Content-type:text/html\n\n). This may or may not be added for you automatically by php (depending on config options?)

    Other than that, treat it as a normal php script - youll still need to mark your sections of php code with ? ? tags

    4) You may have issues with suexec. If the script executes ok at the command line, but 500s in your browser, check /var/log/httpd/suexec_log, and make sure the ownerships on the script are the same as the other files in the directory.

  • RELEVANCY SCORE 2.86

    DB:2.86:Anyone Running Php 4.2.3 Rpm ? 3f





    Anyone who can tell me how I can upgrade php to version 4.2.3 or 4.3.0 ?

    Have installed rpm version og psa 5.0.4 today!

    Need detailed instructions!

  • RELEVANCY SCORE 2.86

    DB:2.86:Windows V. 10.2.0 Upgrade Php To 5.3 19





    Hi,

    I have a fresh install of v 10.2.0 on web server 2008. The php version is 5.2, although the updater reports it as up to date.

    I need php 5.35 / 5.36 nts.

    A couple of posts ref Linux systems indicated that the system version of php is used, but this does not seem to be the case I have installed 5.36 on the system using the web platform installer, but when installing applications through sbp anything of value fails due to the outdated php version being dedected.

    I see that php 4 and 5 are installed in the folder C:\Parallels\Plesk\Additional but how safe is it to replace these? and what would be the good practice way of gaining a php upgrade without breaking sbp.

    Thanks

    DB:2.86:Windows V. 10.2.0 Upgrade Php To 5.3 19




    Hi,

    I have a fresh install of v 10.2.0 on web server 2008. The php version is 5.2, although the updater reports it as up to date.

    I need php 5.35 / 5.36 nts.

    A couple of posts ref Linux systems indicated that the system version of php is used, but this does not seem to be the case I have installed 5.36 on the system using the web platform installer, but when installing applications through sbp anything of value fails due to the outdated php version being dedected.

    I see that php 4 and 5 are installed in the folder C:\Parallels\Plesk\Additional but how safe is it to replace these? and what would be the good practice way of gaining a php upgrade without breaking sbp.

    Thanks

  • RELEVANCY SCORE 2.85

    DB:2.85:Upgrade Php From 4.4.9 To 5.2.6 zx





    hello all ,
    iam new in using this system
    iam debian 4 using
    i try to upgrade php from 4.4.4 to 5.2.6
    but all what i find the 2 command
    apt-get update
    apt-get upgrade

    and this make upgrade for my php but for 4.4.9
    and i need to upgrade for 5.2.6
    so what i should do now ?
    please help me ..
    and must i delete what i did ?
    and how ?
    tell me please ... waiting your requests
    thanks for all

    DB:2.85:Upgrade Php From 4.4.9 To 5.2.6 zx




    How to upgrate from PANEL Plesk 10.4.4 in debian from PHP 5.2.6 in Php 5.3

    Hello,

    How to upgrate from PANEL Plesk 10.4.4 in debian from PHP 5.2.6 in Php 5.3?

    It is possible to work on PLESK PANEL?

    Regards

  • RELEVANCY SCORE 2.85

    DB:2.85:Upgrade Php 5.2.13 To Php 5.3 Or Later ms





    Hello,

    im trying to upgrade the PHP version from 5.2.13 to a new 5.3 or 5.4

    But, while i replace the /Plesk/additionnal/PleskPHP5 folder with a new version (with a copy of the original php.ini) i have a 500 error on all pages.

    Ive tried 5.3/5.4 thread/no thread and reboot server on all try.

    Can i use directly a php version from php.net or do i have to use a specific version from plesk ?

    Thank you for your help.

    DB:2.85:Upgrade Php 5.2.13 To Php 5.3 Or Later ms




    ok so... i have new information. I can now lunch and use phpmyadmin and all websites BUT with a mySQL user with no password.

    It seems to be a problem of mysql users passwords. So i can use phpmyadmin with the user without password but when i try to change the password of other users, it doesnt work!
    Do you know why all mysql password are broken? I read something about hash 16 char or 41char. (i have MySQL 5)

    can you help me please?

  • RELEVANCY SCORE 2.85

    DB:2.85:Upgrade Php 5.2.3 To 5.2.5 kc





    Dear all,
    My Security team has inform that my PLESK 8.2 with PHP 5.2.3 should be update to 5.2.5, Could anyone advice the instruction to do...?

    Thank you in advance...

    Br,
    Bluetear

  • RELEVANCY SCORE 2.85

    DB:2.85:Lower Latency Or Higher Speed? Pc3200 Vs Pc4000 kd




    I'm debating if I should buy low latency memory or higher speed memory.

    PC3200 2-2-2-5 OR PC4000 3-4-4-8 ?

    Thanks!

    DB:2.85:Lower Latency Or Higher Speed? Pc3200 Vs Pc4000 kd


    The memory that is 2-2-2-5 is usualy 100% winbond bh5 chips, they will not usualy run faster than about 215-220fsb but not at 2-2-2-5.

    My opinion is 4000 is better if you plan to go 230+ fsb after this point the timings mean usualy nothing.

    Here is some good reference #s

  • RELEVANCY SCORE 2.85

    DB:2.85:Navigating Through Detail Page Records pk


    I am trying to setup a detail page with next / previous record browsing function, but it would not work and I do not know why the link always shows the same record ID. I followed a couple of tutorials but with no success and never got any response from the forum be it in the php or general forum .. have no idea why, is it my question that is so dumb ? Is there anyone kind enough to have a look at the coding and give me a clue at least ... ? That would be great ! You can have a look at the result page live here http://elhoster.com/sudamericatrails/details.php?pageNum_DetailRS1=0totalRows_DetailRS1=1 recordID=4And the dreamweaver code I am using is :div class="wrapper"a href="?php printf("%s?pageNum_DetailRS1=%d%s", $currentPage, min($totalPages_DetailRS1, $pageNum_DetailRS1 + 1), $queryString_DetailRS1); ?"ghjh/a total?php echo $totalRows_DetailRS1 ?/div
    div class="col-5"
    h1?php echo $row_DetailRS1['title']; ?/h1
    ?php do { ?
    div id="tabs"
    ul
    lia href="#tabs-1"?php echo $row_translations['descriviaje']; ?/a/li
    lia href="#tabs-2"?php echo $row_translations['fechareg']; ?/a/li
    lia href="#tabs-3"?php echo $row_translations['fotos']; ?/a/li
    lia href="#tabs-4"?php echo $row_translations['itincompleto']; ?/a/li
    lia href="#tabs-5"?php echo $row_translations['servicios']; ?/a/li
    /ul
    div id="tabs-1"
    table width="100%" border="0" cellpadding="0" cellspacing="5"
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['estilo_viaje']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['type']; ?/td
    /tr
    tbody
    tr
    tdstrong?php echo $row_translations['temporada']; ?/strong/td
    td?php echo $row_DetailRS1['temporada']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['inicio']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['inicio']; ?/td
    /tr
    /tbody
    tbody
    tr
    tdstrong?php echo $row_translations['salida']; ?/strong/td
    td?php echo $row_DetailRS1['salida']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['minpas']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['pasajero_minimo']; ?/td
    /tr
    tr
    tdstrong?php echo $row_translations['dificult']; ?/strong/td
    td?php echo $row_DetailRS1['dificulktad']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['comienz']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['comienza']; ?/td
    /tr
    tr
    tdstrong?php echo $row_translations['finaliz']; ?/strong/td
    td?php echo $row_DetailRS1['finaliza']; ?/td
    /tr
    /tbody
    /table
    div style="float:left; width:300px; /* [disabled]line-height: 1em; */ margin-right: 20px;"
    h3strong?php echo $row_translations['descriviaje']; ?/strong/h3
    pbr /
    ?php echo $row_DetailRS1['description']; ?/p
    /div
    div ?php echo $row_DetailRS1['itinierario']; ? /div
    /div
    div id="tabs-2"
    div id="datepicker"/div
    /div
    div id="tabs-3"Fotos/div
    div id="tabs-4" ?php echo $row_DetailRS1['itinera_completo']; ? /div
    div id="tabs-5" ?php echo $row_DetailRS1['servicios']; ? /div
    /div
    ?php } while ($row_DetailRS1 = mysql_fetch_assoc($DetailRS1)); ?

    DB:2.85:Navigating Through Detail Page Records pk

    I am trying to setup a detail page with next / previous record browsing function, but it would not work and I do not know why the link always shows the same record ID. I followed a couple of tutorials but with no success and never got any response from the forum be it in the php or general forum .. have no idea why, is it my question that is so dumb ? Is there anyone kind enough to have a look at the coding and give me a clue at least ... ? That would be great ! You can have a look at the result page live here http://elhoster.com/sudamericatrails/details.php?pageNum_DetailRS1=0totalRows_DetailRS1=1 recordID=4And the dreamweaver code I am using is :div class="wrapper"a href="?php printf("%s?pageNum_DetailRS1=%d%s", $currentPage, min($totalPages_DetailRS1, $pageNum_DetailRS1 + 1), $queryString_DetailRS1); ?"ghjh/a total?php echo $totalRows_DetailRS1 ?/div
    div class="col-5"
    h1?php echo $row_DetailRS1['title']; ?/h1
    ?php do { ?
    div id="tabs"
    ul
    lia href="#tabs-1"?php echo $row_translations['descriviaje']; ?/a/li
    lia href="#tabs-2"?php echo $row_translations['fechareg']; ?/a/li
    lia href="#tabs-3"?php echo $row_translations['fotos']; ?/a/li
    lia href="#tabs-4"?php echo $row_translations['itincompleto']; ?/a/li
    lia href="#tabs-5"?php echo $row_translations['servicios']; ?/a/li
    /ul
    div id="tabs-1"
    table width="100%" border="0" cellpadding="0" cellspacing="5"
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['estilo_viaje']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['type']; ?/td
    /tr
    tbody
    tr
    tdstrong?php echo $row_translations['temporada']; ?/strong/td
    td?php echo $row_DetailRS1['temporada']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['inicio']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['inicio']; ?/td
    /tr
    /tbody
    tbody
    tr
    tdstrong?php echo $row_translations['salida']; ?/strong/td
    td?php echo $row_DetailRS1['salida']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['minpas']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['pasajero_minimo']; ?/td
    /tr
    tr
    tdstrong?php echo $row_translations['dificult']; ?/strong/td
    td?php echo $row_DetailRS1['dificulktad']; ?/td
    /tr
    tr
    td bgcolor="#FAD0C5"strong?php echo $row_translations['comienz']; ?/strong/td
    td bgcolor="#FAD0C5"?php echo $row_DetailRS1['comienza']; ?/td
    /tr
    tr
    tdstrong?php echo $row_translations['finaliz']; ?/strong/td
    td?php echo $row_DetailRS1['finaliza']; ?/td
    /tr
    /tbody
    /table
    div style="float:left; width:300px; /* [disabled]line-height: 1em; */ margin-right: 20px;"
    h3strong?php echo $row_translations['descriviaje']; ?/strong/h3
    pbr /
    ?php echo $row_DetailRS1['description']; ?/p
    /div
    div ?php echo $row_DetailRS1['itinierario']; ? /div
    /div
    div id="tabs-2"
    div id="datepicker"/div
    /div
    div id="tabs-3"Fotos/div
    div id="tabs-4" ?php echo $row_DetailRS1['itinera_completo']; ? /div
    div id="tabs-5" ?php echo $row_DetailRS1['servicios']; ? /div
    /div
    ?php } while ($row_DetailRS1 = mysql_fetch_assoc($DetailRS1)); ?

  • RELEVANCY SCORE 2.84

    DB:2.84:Upgrade To Php 5 ka





    is it possible to upgrade to php 5.0?

    DB:2.84:Upgrade To Php 5 ka




    hmm. I didnt see anything for php5 on that site anyway.

  • RELEVANCY SCORE 2.84

    DB:2.84:Ht4137 Cannot Update To Ios5 Or Higher j7


    Cannot upgrade to ios5 or higher on an iPad 2. No matter what I do, nothing works. I was able to upgradeiphone 4, but not the iPad!!

    DB:2.84:Ht4137 Cannot Update To Ios5 Or Higher j7

    Cannot upgrade to ios5 or higher on an iPad 2. No matter what I do, nothing works. I was able to upgradeiphone 4, but not the iPad!!

  • RELEVANCY SCORE 2.84

    DB:2.84:Problems After Upgrade Php From 5.2.X To 5.3.X c9





    Hello guys i´m getting many problems with my client, 80% of their sites or applications stop to work, Joomla, Wordpress, PHPBB is not working, but didn´t give any error log, but many sites that use Thumbnails to create some images, get many messages like this:

    PHP Warning: strlen() expects parameter 1 to be string

    i got many messages like that.

    Anybody know if can i fix this or do i need to do a downgrade in PHP version?

    Thanks

    DB:2.84:Problems After Upgrade Php From 5.2.X To 5.3.X c9




    Take alook at php.net regarding this function: http://php.net/manual/en/function.strlen.php
    It seems that there are difference between 5.2.x and 5.3.x for this function. Here is an explaination regarding this issue:

    We just ran into what we thought was a bug but turned out to be a documented difference in behavior between PHP 5.2 5.3. Take the following code example:

    ?php

    $attributes = array(one, two, three);

    if (strlen($attributes) == 0 !is_bool($attributes)) {
    echo We are in the if\n; // PHP 5.3
    } else {
    echo We are in the else\n; // PHP 5.2
    }

    ?

    This is because in 5.2 strlen will automatically cast anything passed to it as a string, and casting an array to a string yields the string Array. In 5.3, this changed, as noted in the following point in the backward incompatible changes in 5.3 (http://www.php.net/manual/en/migration53.incompatible.php):

    The newer internal parameter parsing API has been applied across all the extensions bundled with PHP 5.3.x. This parameter parsing API causes functions to return NULL when passed incompatible parameters. There are some exceptions to this rule, such as the get_class() function, which will continue to return FALSE on error.

    So, in PHP 5.3, strlen($attributes) returns NULL, while in PHP 5.2, strlen($attributes) returns the integer 5. This likely affects other functions, so if you are getting different behaviors or new bugs suddenly, check if you have upgraded to 5.3 (which we did recently), and then check for some warnings in your logs like this:

    strlen() expects parameter 1 to be string, array given in /var/www/sis/lib/functions/advanced_search_lib.php on line 1028

    If so, then you are likely experiencing this changed behavior.

  • RELEVANCY SCORE 2.84

    DB:2.84:How Do I Upgrade To Web 4 And Php 5 From Expression Web 2? fa


    I am using Expression web 2 and have an html site. I want to upgrade the site and introduce PHP. I have installed the PHP Runtime 5.2.17 (couldnt find 5.2.5) and followed the instructions. I cannot view the php file.
    I have uploaded a trial version of EW4 and installed PHP runtime 5.3.6 and tried to configure the php.ini file to see if that works. I cant find a lot of discussion about the newphp5.3.6 and EW so need help. I run Windows XP.
    What have I got wrong?

    DB:2.84:How Do I Upgrade To Web 4 And Php 5 From Expression Web 2? fa

    And, of course, using ASP.NET will limit your hosting options to only Windows servers. For all intents and purposes, ASP.NET is a non-starter on Unix/Linux servers.
    Just in case you were trying ASP.NET solely out of frustration with PHP and without knowing the downside of that choice.If I had asked my customers what they wanted, they would have said a faster horse. Henry Ford

  • RELEVANCY SCORE 2.84

    DB:2.84:Official Support For Php 5.2.6 Or Higher 3a





    When will Plesk officially support PHP 5.2.6 or higher? From what I understand the latest version of PHP that is officially supported is 5.1.6. There are many people who now need 5.2.x or higher support. (for example, the new vBulletin 4.0 REQUIRES PHP 5.2.x or higher (recommends 5.2.6 or higher)).

    Id rather not have to migrate my site to cPanel if I dont absolutely need, but unless we can get some official support for a PHP version that is more up-to-date it may be the only option for many.

    DB:2.84:Official Support For Php 5.2.6 Or Higher 3a




    If you are not Plesk server administrator, that upgrade PHP and Plesk can perform only your provider (Plesk server administrator).

  • RELEVANCY SCORE 2.84

    DB:2.84:Plesk Doesnt See My Upgraded Php Mysql am





    Running Plesk 8.1.1 on RHEL 4.

    I was given the standard PHP 4 and MYSQL 4 setup at THE PLANET.

    After checking to make sure the Plesk 8.1.1 supports PHP 5 and MySQL 5, I paid the tech to upgrade PHP and MySQL for me.

    He did so, and the PHP test page works.

    However, when I look in Plesk Server Components it says that PHP and MYSQL are not installed. Consequently it will not allow me to install any application vault packages that use PHP or MYSQL.

    How do you get PLESK to see the new PHP and MYSQL installations?

    DB:2.84:Plesk Doesnt See My Upgraded Php Mysql am




    Heres how you install the rpms for the above if they didnt use them on your install.

    1) Set up the atomic yum channel:

    wget -q -O - http://www.atomicorp.com/installers/atomic.sh |sh

    2) Update php/mysql/etc all at once:

    yum update

  • RELEVANCY SCORE 2.84

    DB:2.84:Moodle Error ( Requires Php 4.3 5.0 ) 33





    Hello all,

    i want to install moodle from the application vault, but it seems that it requires php version 4.3 or higher or php 5.0 or lower

    I have php 5.2.6 :S whats the trick ?

    thanks

    DB:2.84:Moodle Error ( Requires Php 4.3 5.0 ) 33




    Any word on this? Has anyone found an answer! Parallels anyone!

  • RELEVANCY SCORE 2.84

    DB:2.84:Upgrade Php 4.1.1 To 4.2.0 ax





    Can someone done me dettailed istructions for upgrade PHP 4.1.1 to php 4.2.0 ?
    I have Standard Plesk 2.0
    PHP 4.1.1
    Gzip installed

    I want also install GD module ....

    thanks
    Max

    DB:2.84:Upgrade Php 4.1.1 To 4.2.0 ax




    Can someone done me dettailed istructions for upgrade PHP 4.1.1 to php 4.2.0 ?
    I have Standard Plesk 2.0
    PHP 4.1.1
    Gzip installed

    I want also install GD module ....

    thanks
    Max